The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Видеоинтервью с Линусом Торвальдсом про смену версии Linux и про грядущий 20-летний юбилей

17.06.2011 07:21

На конференции Linuxсon в начале июня Линус Торвальдс дал интервью, в котором рассказал про 20-летний юбилей ядра и про изменение нумерации версии ядра (переход на версию 3). Интервью проводил разработчик ядра Грег Кроа-Хартман (Greg Kroah-Hartman).

  1. Главная ссылка к новости (http://video.linux.com/video/2...)
  2. OpenNews: Представлен первый тестовый выпуск Linux-ядра 3.0
  3. OpenNews: Линус Торвальдс намерен выпустить вместо Linux-ядра 2.6.40 версию 3.0
Автор новости: xguru
Тип: английский / К сведению
Короткая ссылка: https://opennet.ru/30906-linux
Ключевые слова: linux, linus
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (32) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Anonus (?), 10:48, 17/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    Линус Торвальдс - наш человек!
     
     
  • 2.2, Graved (?), 11:10, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +12 +/
    Скорее мы - люди Линуса Торвальдса)
     
     
  • 3.27, Аноним (-), 18:29, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да какая нафиг разница? Главное что работает и довольно неплохо. И это нужно и нам и ему.
     
  • 3.33, Аноним (-), 04:20, 18/06/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    В смысле - холопы? :)
     

  • 1.3, pimiento (ok), 11:38, 17/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    ATTENTION:
    ATTENTION: Unknown system type: Linux 3.0.0-rc1
    ATTENTION:
    make: *** [Makefiles] Error 1
    make: *** [makefiles] Error 2
    * ERROR: mail-mta/postfix-2.8.3-r2 failed (configure phase):
    *   emake failed

    Куда задать ему вопрос "что с этим делать"?

     
     
  • 2.6, dalco (ok), 12:03, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +7 +/
    Лучше этого не делать :)
    На все подобные вопросы Линус жутко матерится (и не без причин) на тему косоруких программеров, не умеющих корректно парсить версии ядра.

    В вольном переводе один из его ответов звучал примерно так - "если захочу, то завтра будем вообще версии ядра на санскрите нумеровать и даже в этом случае нормальные скрипты не должны выпадать в осадок только потому, что версия ядра начинается не с 2.4 и 2.6"

    P.S. Кто не согласен - пишите гневные письма Линусу, а не мне :)

     
     
  • 3.7, pimiento (ok), 12:11, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Да я-то согласен, что Винеме косорукий :) только не реагирует postfix-сообщество на эту проблему. Пусть тогда Линус обратно переименовывает :)
     
     
  • 4.9, Mike Lee (?), 12:32, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +4 +/
    криворукий это ты - держать mta на анстебле это сильно. и не ужели так трудно пропатчить makedefs?

    diff -u makedefs.orig makedefs
    --- makedefs.orig 2011-03-01 21:08:11.000000000 +0200
    +++ makedefs 2011-06-17 11:26:07.000000000 +0300
    @@ -260,7 +260,7 @@
         Linux.1*) SYSTYPE=LINUX1
    SYSLIBS="-ldb"
    ;;
    -    Linux.2*) SYSTYPE=LINUX2
    +    Linux.[23]*) SYSTYPE=LINUX2
    # Postfix no longer needs DB 1.85 compatibility
    if [ -f /usr/include/db.h ]
    then

     
  • 3.15, Андрей (??), 14:54, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > "если захочу, то завтра будем вообще..."

    Вот и предводитель glibc такой же. Сказал, что изменим memcpy и баста! Линусу это тогда не понравилось, да? А сам, значит, так же любит поступать.

     
     
  • 4.22, анонимус (??), 16:25, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Они ничего не меняли. В мане было написано "эта функция не проверяет ничего и может вам повредить память". Но поскольку реализация была несколько другая - все работало, хотя по идее не должно было. Потом они реализацию изменили, и в тех местах где работать оно было не должно - оно работать и перстало. А поскольку разработчики flash тупые ебланы у них все и отвалилось. Такие дела.
     
     
  • 5.34, szh (ok), 11:00, 18/06/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    цитирую:
    > Они ничего не меняли.
    > Потом они реализацию изменили
     
     
  • 6.39, anonymous (??), 03:10, 21/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > цитирую:
    >> Они ничего не меняли.
    >> Потом они реализацию изменили

    это называется «развитие». реализация была изменена, но осталась в рамках стандарта. кто виндоват, что некоторые люди стандарты (и маны) не читают? и что некоторые конторы набирают исключительно тех, кто на библии поклялся, что стандарт в глаза не видел, а цпп выучил, работая поломойщиком в вечерней школе?

     
  • 3.20, pavlinux (ok), 16:10, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вообще-то Торвальдс на это говорит, что юзайте ядра из дистрибутива.

     
  • 3.23, Кодер (?), 17:01, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Ну надо же, как он быстро поумнел! А ведь недавно его же, как котёнка, тыкали в гов^w оптимизированную реализацию memcpy, а он кричал, что нельзя делать изменения в коде, ломающие "совместимость с прошлыми багами"!
     
     
  • 4.40, anonymous (??), 03:14, 21/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Ну надо же, как он быстро поумнел! А ведь недавно его же,
    > как котёнка, тыкали в гов^w оптимизированную реализацию memcpy, а он кричал,
    > что нельзя делать изменения в коде, ломающие «совместимость с прошлыми багами»!

    быдлу всякому — нельзя. а Великому Линусу всё можно.

     
  • 2.28, Аноним (-), 18:30, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Куда задать ему вопрос "что с этим делать"?

    Торвальдс имхо не должен отдуваться за бажные/устаревшие системы сборки софта.

     
     
  • 3.41, anonymous (??), 03:14, 21/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >> Куда задать ему вопрос "что с этим делать"?
    > Торвальдс имхо не должен отдуваться за бажные/устаревшие системы сборки софта.

    интересно, а почему он тогда считает, что Дреппер должен отдуваться за криворуких недопрограммистов, которые не читали стандарты?

     

  • 1.4, Аноним (-), 11:44, 17/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Линс появляется в конце восьмой минуты, остальное можно смело проматывать.
     
     
  • 2.5, oops (ok), 11:52, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Ага, особенно бесит этот японец, который постоянно зависает и говорит "ааааааа"
     

  • 1.8, Аноним (8), 12:24, 17/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    uname -a
    Linux os 3.0-0-generic-pae #1-Ubuntu SMP Thu Jun 9 16:51:27 UTC 2011 i686 i686 i386 GNU/Linux

    lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu oneiric (development branch)
    Release: 11.10
    Codename: oneiric

     
     
  • 2.21, pavlinux (ok), 16:12, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > uname -a
    > Linux os 3.0-0-generic-pae #1-Ubuntu SMP Thu Jun 9 16:51:27 UTC 2011 i686
    > i686 i386 GNU/Linux

    Фу, ацтой древний

    # uname -a
    Linux suse64 3.0.0-rc3+ #8 SMP PREEMPT Fri Jun 17 11:38:27 MSD 2011 x86_64 x86_64 x86_64 GNU/Linux

     
     
  • 3.37, Аноним (-), 19:01, 19/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > # uname -a
    > Linux suse64 3.0.0-rc3+ #8 SMP PREEMPT Fri Jun 17 11:38:27 MSD 2011
    > x86_64 x86_64 x86_64 GNU/Linux

    Специально для тебя, на бубунте:
    $ uname -a
    Linux u64 3.0.0-0300rc3-generic #201106140913 SMP Tue Jun 14 09:16:31 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

    P.S. а его changelog доставляет.

     

  • 1.11, iZEN (ok), 13:11, 17/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    "Missing Plug-in"
     
     
  • 2.14, z (??), 14:43, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    and that is epic win
     
  • 2.19, xguru (ok), 16:07, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > "Missing Plug-in"

    Там есть флв и огг

     
     
  • 3.29, Аноним (-), 18:33, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Там есть флв и огг

    А почему не выложить в webm, как на ютубе делают, а? Удобно же!

     

  • 1.12, Аноним (-), 14:13, 17/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    flash.. feeee
     
     
  • 2.18, xguru (ok), 16:07, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Успокойтесь, там есть флв и огг.
    Флэш не обязательно ставить, чтобы на линуса посмотреть
     
     
  • 3.26, Кодер (?), 17:03, 17/06/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Флэш не обязательно ставить, чтобы на линуса посмотреть

    А что надо ставить? LFS? :)

     
  • 3.38, Аноним (-), 19:02, 19/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Успокойтесь, там есть флв и огг.

    Почему не сделать HTML5 video в webm??


     

  • 1.16, ferux (ok), 15:03, 17/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    и что же это интервью не в WebM...
     
  • 1.35, Ян Злобин (ok), 12:57, 18/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Linux.com, а видео показывается на флэше...
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру