The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Обновление Debian 10.4

09.05.2020 20:12

Опубликовано четвёртое корректирующее обновление дистрибутива Debian 10, в которое включены накопившиеся обновления пакетов и устранены недоработки в инсталляторе. Выпуск включает 108 обновлений с устранением проблем со стабильностью и 53 обновления с устранением уязвимостей.

Из изменений в Debian 10.4 можно отметить обновление до свежих стабильных версий пакетов postfix, clamav, dav4tbsync, dpdk, nvidia-graphics-drivers, tbsync, waagent. Удалены пакеты getlive, gplaycli, kerneloops, lambda-align2, libmicrodns, libperlspeak-perl, ugene и yahoo2mbox, которые остались без сопровождения и имеют серьёзные проблемы или привязаны к изменившимся API. Из-за несовместимости с новым Thunderbird также удалены дополнения quotecolors и torbirdy.

Для загрузки и установки "с нуля" в течение нескольких часов будут подготовлены установочные сборки, а также live iso-hybrid c Debian 10.4. Системы, установленные ранее и поддерживаемые в актуальном состоянии, получают обновления, присутствующие в Debian 10.4, через штатную систему установки обновлений. Исправления проблем безопасности, включённые в новые выпуски Debian, доступны пользователям по мере выхода обновлений через сервис security.debian.org.



  1. Главная ссылка к новости (https://www.debian.org/News/20...)
  2. OpenNews: Debian тестирует Discourse как потенциальную замену спискам рассылки
  3. OpenNews: Проект Debian анонсировал сервисы Debian Social
  4. OpenNews: Второй альфа-выпуск инсталлятора Debian 11 "Bullseye"
  5. OpenNews: Debian 8 будет поддерживаться больше 5 лет
  6. OpenNews: Новые версии Debian 9.12 и 10.3
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/52920-debian
Ключевые слова: debian
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (108) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Lexa3110 (ok), 20:13, 09/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +19 +/
    Лучший дистрибутив. Спасибо.
     
     
  • 2.2, Аноним (2), 20:16, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +10 +/
    Пожалуйста.
     
     
  • 3.15, Главный Ананим (ok), 21:24, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • –3 +/
    На здоровье.
     
     
  • 4.72, Айболит (?), 16:17, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Не болейте
     
  • 2.63, anonimus (?), 08:30, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • –11 +/
    Debian это не дебиан это та самя убунту космик от которой пропали репозитории фактически пакетов нету , ну ну говори что заговоров нет далее , кто не дурак тот знает
     
     
  • 3.100, Аноним (100), 07:00, 12/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Срочно лекарства прими, заговорщик.
     
     
  • 4.103, C945 (?), 16:08, 12/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Не знаю, но я перепробовал все существующие на сегодня дистры, Debian из всех самый лучший! Особенно KDE Plasma.
     
  • 3.111, sysrise (ok), 01:10, 22/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    А Вас не смущает факт того, что Debian появился тогда, когда Ubuntu еще даже в проекте не было? Поэтому сравнивать Debian c Ubuntu, все равно что сравнивать "лапоть с ракетой"! Если уж и сравнивать эти две ОС, то за основу нужно брать Debian, но никак не Ubuntu.
     
  • 2.108, лютый жабби (?), 08:28, 14/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Лучший дистрибутив. Спасибо.

    На сервер центос/рхел. На рабочую станцию Арч.

    В бастере жабка только 11, обновы на браузеры прилетают с задержкой в 2-3 недели. Уж лучший так лучший...

     
     
  • 3.110, www2 (??), 11:27, 15/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Под виндой обновления прилетают только самой винды. Остальные программы нужно обновлять ручками. Тем не менее, 98% настольных систем - это винды. Фатальный недостаток такой фатальный.
     
  • 2.112, artenox (?), 19:41, 01/06/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > Лучший дистрибутив

    Ха ха. Знали бы вы сколько с ним траха после установки. А потом я удалил firefox, он мне какую-то ефифаню заставляет качать. Зазоры кругом, но это во всем линуксе так. Лучшим дистрибутивом был Xubuntu 16.04, но теперь уже никого не осталось. Крыса тоже скатилась, кнопка Whisker не всегда нажимается.

     

  • 1.3, Аноним (3), 20:40, 09/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • –6 +/
    >Выпуск включает 108 обновлений с устранением проблем со стабильностью и 53 обновления с устранением уязвимостей.<

    И половина это Firefox?

     
     
  • 2.6, Аноним (6), 20:45, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +6 +/
    В твоем случае с IE
     

  • 1.4, Аноним (4), 20:42, 09/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • –4 +/
    Народ, если есть кто дебианщики, помогите пожалуйста разобраться в механизме выставления приоритетов веток репозиториев и пакетов!
     
     
  • 2.5, Аноним (4), 20:44, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • –4 +/
    > Народ, если есть кто дебианщики, помогите пожалуйста разобраться в механизме выставления
    > приоритетов веток репозиториев и пакетов!

    У меня просто ситуация с ветками и пакетами непонятно как разрешаемая, из стондарной доки нубу не понять как чего накалдовать!

     
     
  • 3.7, losev (?), 20:56, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • –6 +/
    install gentoo
     
     
  • 4.27, Аноним (27), 22:09, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > install gentoo

    Обязательно попробую, как только с моей стороны появится железо на котором это всё компилять, а со стороны генты понятная для простых смертных документация, например такая как у арча, и хотя бы какой-нибудь инсталятор, хоть бы и на ncurses, подобный дебианскому netinstall.
    А в целом меня забавляют подобные вашим комментарии, в стиле, на любой вопрос
    -"как разобраться в Y?"
    Ответ - "не, лучше сделай X!"
    Ох уж этот losev, ай да потешник!

     
     
  • 5.65, псевдонимус (?), 10:53, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Калькулейт тогда поставь, инсталлятор там есть.
     
     
  • 6.74, Аноним (74), 18:14, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Пробовал уже, но во-первых речь была про gentoo, а калькулатор на базе генты, н... большой текст свёрнут, показать
     
     
  • 7.78, псевдонимус (?), 19:11, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    gt оверквотинг удален Извини, но портаж не влдшебная палочка Делать совсем чт... большой текст свёрнут, показать
     
     
  • 8.79, Аноним (79), 22:52, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Я имею представление, что такое portage, к чему вообще было это ваше высказыван... текст свёрнут, показать
     
     
  • 9.105, псевдонимус (?), 20:07, 12/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    К тому, что ты ищешь костыль, костыль, реализовав который, будешь страдать Ну ... текст свёрнут, показать
     
  • 7.94, Аноним (94), 16:31, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    gt оверквотинг удален Есть гораздо лучше варианты, если вам нужена гента с ус... большой текст свёрнут, показать
     
  • 6.86, Аноним (86), 10:56, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Калькулейт тогда поставь, инсталлятор там есть.

    calculate это тестовая халявная площадка для одной конторы, которая свои хотелки обкатывает на пользователях, в этом бы не было особо ничего страшного для пользователя, вот только в отличие от других дистров стабильный продукт получают только хозяева, если он вообще есть, этот стабильный продукт, иначе я не понимаю на кой этот цирк?
    Конторка мутноватая, в сообществе и в среде разрабов наличествуют сомнительной адекватности люди, и это главный отталкивающий фактор в купе с рандомной стабильностью, это не серьёзный продукт, а так на поиграться.


     
     
  • 7.90, псевдонимус (?), 12:10, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    >> Калькулейт тогда поставь, инсталлятор там есть.
    > calculate это тестовая халявная площадка для одной конторы, которая свои хотелки обкатывает
    > на пользователях, в этом бы не было особо ничего страшного для
    > пользователя, вот только в отличие от других дистров стабильный продукт получают
    > только хозяева, если он вообще есть, этот стабильный продукт, иначе я
    > не понимаю на кой этот цирк?
    > Конторка мутноватая, в сообществе и в среде разрабов наличествуют сомнительной адекватности
    > люди, и это главный отталкивающий фактор в купе с рандомной стабильностью,
    > это не серьёзный продукт, а так на поиграться.

    Выкидывание системдна и гома косвенно свидетельствует об адекватности разработчиков

     
     
  • 8.95, Аноним (95), 22:37, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Щито Отсутствие системды не заслуга калькулистов, они на генте паразитируют, а... текст свёрнут, показать
     
     
  • 9.96, псевдонимус (?), 23:42, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Разрабы вообще не отделяют себя от сообщества генты, умник И как можно паразити... текст свёрнут, показать
     
     
  • 10.98, Аноним (98), 03:28, 12/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Они могут считать себя кем угодно, хоть наполеонами Всё с вами ясно, после этой ... текст свёрнут, показать
     
     
  • 11.99, псевдонимус (?), 06:14, 12/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    На правду обиделся Напрасно ... текст свёрнут, показать
     
  • 9.97, псевдонимус (?), 23:45, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Не тупо взяли , клован, а был опрос пользователей Тупо взяла убунту, когда дн... текст свёрнут, показать
     
  • 3.12, Аноним (12), 21:02, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Начни со "стондартного" учебника русского языка.
     
  • 3.106, псевдонимус (?), 20:26, 12/05/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >> Народ, если есть кто дебианщики, помогите пожалуйста разобраться в механизме выставления
    >> приоритетов веток репозиториев и пакетов!
    > У меня просто ситуация с ветками и пакетами непонятно как разрешаемая, из
    > стондарной доки нубу не понять как чего накалдовать!

    Что ты хочешь на колдовать? Если юзать разные версии программ то винда самое простое. Если нужно с открытым кодом, то слака, Гента, фряха . и в умершем дебиане это можно, но сложнее.

    Вообще для того, чего тебе хочется, идеал вин 7, из никсоидных фряха (кде2 таки запустился на фрибсд 10, лiл;-) ) , ещё трушнее коммерческая соляра, но в ней для современного дрисктопа почти ничего нет. Тележек и шматриксов ты там не найдёшь, как и последних версий тулкитов.

    Мэйк и мэйк инсталл, бро.

     
  • 2.9, Аноним (9), 20:59, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +7 +/
    Package: *
    Pin: release a=stable
    Pin-Priority: 2000

    Package: *
    Pin: release a=testing
    Pin-Priority: 60

    Package: *
    Pin: release a=unstable
    Pin-Priority: 50

     
     
  • 3.25, Аноним (25), 22:03, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Package: *
    > Pin: release a=stable
    > Pin-Priority: 2000
    > Package: *
    > Pin: release a=testing
    > Pin-Priority: 60
    > Package: *
    > Pin: release a=unstable
    > Pin-Priority: 50

    Не всё так просто, мне нужно чтобы между пакетами одной и той же версии выбирался пакет из более свежей ветки, это если вкратце.

     
     
  • 4.30, Аноним (9), 22:29, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Package: *
    Pin: release a=stable
    Pin-Priority: 200

    Package: *
    Pin: release a=testing
    Pin-Priority: 2000

     
     
  • 5.31, Аноним (31), 22:35, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Package: *
    > Pin: release a=stable
    > Pin-Priority: 200
    > Package: *
    > Pin: release a=testing
    > Pin-Priority: 2000

    Нет, так тоже не пойдёт, если подключены все ветки с выставленными приоритетами, и с появлением пакета с нужной версии в любой из них, чтобы выбиралась самая свежая ветка и версия/субверсия - минорный апдейт/ секурити патч. Чтобы не нырять каждый раз в http://packages.debian.org/и руками не проверять, а не появился ли нужный пакет в определённой ветке, а то так можно и обновление прошляпить. Я не знаю, понятно ли объяснил?

     
     
  • 6.33, Аноним (9), 22:46, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Судя по описанию тебе нужно просто sid на максимальный приоритет поставить.
     
  • 6.34, Аноним (34), 22:47, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ты хочешь ставить или автообновляться всегда на самую последнюю версию, не важно в какой она ветке?

    Тогда выстави всем веткам одинаковый приоритет, самая новая версия автоматически выберется из-за её номера. Но по сути это будет тоже самое что сидеть на ветке sid, так как новые версии загружаются сначала в неё. Сидеть на sid не рекомендуется если вы не разработчик debian.

     
     
  • 7.47, Аноним (47), 23:34, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Нет, на полном сиде мне не нужно сидеть, в том-то и дело, у меня несколько машин... большой текст свёрнут, показать
     
     
  • 8.66, псевдонимус (?), 10:56, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Если у пакета много зависимостей, то с дебианом тебе будет трудно В твоем случа... текст свёрнут, показать
     
  • 7.50, Armagor (??), 23:51, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Сидеть на sid не рекомендуется если вы не разработчик debian.

    Я понимаю что не репрезентативно, но я на рабочей машине год сижу на sid. За все время один раз при обновлении сломалось что-то там в apparmor (не помню уже что), минут за 15 починил и работал дальше.
    Так что, исходя из моего сугубо личного опыта - вполне себе сносный rolling дистр.

     
     
  • 8.54, Аноним (54), 00:29, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Пробовал на sid сидеть, ломается редко но метко, особо вероятно после разморозки... большой текст свёрнут, показать
     
     
  • 9.67, Armagor (??), 10:57, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Поправьте меня пожалуйста, если я ошибаюсь, но я практически уверен, что в этом ... текст свёрнут, показать
     
     
  • 10.76, Аноним (76), 18:23, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    А вы попробуйте обновить sid сразу после разморозки и узнаете ... текст свёрнут, показать
     
     
  • 11.82, Armagor (??), 23:36, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Точно обновлялся после мартовского фулл-фриза в прошлом году Видимо, просто пов... текст свёрнут, показать
     
  • 6.35, Аноним (9), 22:52, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вообще вот такую табличку нашел:
    Значения веса приоритета могут быть следующими:

    P >= 1000 - пакет будет установлен, даже если это приведет к понижению версии уже установленного пакета
    990 <= P < 1000 - пакет будет установлен, если не установлена более новая версия
    500 <= P < 990 - пакет будет установлен, если нет пакета принадлежащего к целевому выпуску или не установлена более новая версия
    100 <= P < 500 - пакет будет установлен, если нет кандидатов из других источников или установленного пакета более новой версии
    0 < P < 100 - пакет будет установлен, если нет других кандидатов и установленных пакетов любой версии
    P < 0 - пакет не будет установлен ни при каких условиях
    P = 0 - неопределенное состояние, не используется

     
  • 6.36, Аноним (9), 22:53, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Видимо что-то вроде этого
    Package: *
    Pin: release a=stable
    Pin-Priority: 999

    Package: *
    Pin: release a=testing
    Pin-Priority: 998

    Package: *
    Pin: release a=unstable
    Pin-Priority: 997

     
     
  • 7.40, Аноним (9), 23:01, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Ну и если это не для всей системы, а только для выбранных пакетов, то вместо звездочки пишешь название пакета. Вроде даже через запятую можно, но это не точно.
     
     
  • 8.41, Аноним (9), 23:02, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Не через запятую, а через пробел ... текст свёрнут, показать
     
  • 6.42, Аноним (9), 23:04, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    И вот тут вроде расписано как тебе надо
    https://habr.com/ru/post/120943/
     
  • 6.45, Аноним (9), 23:09, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Хотя с такими запросами тебе явно роллинг дистрибутив нуже, что то типа Solus или openSUSE Tumbleweed
     
     
  • 7.48, Аноним (48), 23:40, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > Хотя с такими запросами тебе явно роллинг дистрибутив нуже, что то типа
    > Solus или openSUSE Tumbleweed

    Нет, дебиан вполне устраивает, ролинги и всякие сузи я не люблю, извиняюсь за сумбур выше описал ситуацию подробней как только мог!

     
     
  • 8.55, Аноним (9), 00:46, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Да пользуйся на здоровье Просто Debian это не просвежий софт, а про стабильност... большой текст свёрнут, показать
     
  • 8.56, Аноним (9), 00:49, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Ну и по поводу того что роллинги не любишь Тестовая ветка дебиана и есть роллин... текст свёрнут, показать
     
     
  • 9.57, Аноним (57), 01:39, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Да, я в курсе, прошу прощения за неясность выражений, я подразумевал скорее арч ... текст свёрнут, показать
     
     
  • 10.68, Аноним (68), 11:47, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Может тогда проще нужный софт на флатхабе поискать Firefox о котором ты писал, ... текст свёрнут, показать
     
     
  • 11.75, Аноним (75), 18:20, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Нет, не проще, у меня есть задача и надо её решить, а в посте выше я firefox как... текст свёрнут, показать
     
  • 4.32, Аноним (9), 22:44, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Или если надо обновлять не все пакеты, то в вики есть такой пример:

    Package: *
    Pin: release a=testing
    Pin-Priority: 450

    Package: *
    Pin: release a=unstable
    Pin-Priority: 400

    И пакеты из свежих репозиториев должны обновляться автоматически, если они уже установлены.
    Устанавливать или обновлять новые можно явно указывая репозиторий:

    apt-get -t testing install blender

    Или временно повышая приоритет репозитория и выборочно устанавливать то что нужно.

     
  • 4.102, ryoken (ok), 14:40, 12/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Backports в помощь.
     
  • 2.21, Аноним (21), 21:38, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Вы видимо ещё один не понимающий, но хотящий Нет никаких приоритетов и механизм... большой текст свёрнут, показать
     
     
  • 3.23, Аноним (23), 21:54, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Вы видимо ещё один не понимающий, но хотящий.
    > Нет никаких приоритетов и механизмов, и репозитории нельзя смешивать.

    Если бы нельзя было "смешивать", тогда бы не было механизма пининга, причём не каких-то незадокументированных экспериментальных функций, а именно что вполне рядового инструмента

     
     
  • 4.26, myhand (ok), 22:05, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Уверяю вас, возможность прострелить себе бошку - тоже штатный механизм револьверта.
     
     
  • 5.28, Аноним (28), 22:13, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > Уверяю вас, возможность прострелить себе бошку - тоже штатный механизм револьверта.

    Нет, штатный механизм револьвера это ударять по капсулю, с последующим выпуском пули из ствола, зарядный механизм, также часть общего механизма, а вот возможность прострелить себе башку, это таки возможный вариант применения!

     
     
  • 6.81, myhand (ok), 23:11, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    В общем, курок есть - значит надо стрелять себе в бошку!
     
     
  • 7.85, АНоним (?), 10:52, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > В общем, курок есть - значит надо стрелять себе в бошку!

    Это что, пропаганда и подстрекательство к самоубийству?!
    Поаккуратней с этим! ;)

     
     
  • 8.93, myhand (ok), 13:52, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Может и так Состояние дел в Debian вполне может довести до суицида, ага ... текст свёрнут, показать
     
  • 3.24, Аноним (24), 22:00, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Попробуете смешать несколько реп - получите минусы обоих, и ещё огромную кучу
    > несовместимостей и проблем сверху.

    Мне и ненужно смешивать несколько реп, мне нужны разные несистемные пакеты из разных веток, они точно ничего не сломают, это прикладной юзерософт, я не виноват, если некоторые пакеты есть только в sid или в oldstable, к тому же Pin-Priority стандартный механизм, просто я в своём случае не разобрался

     
     
  • 4.37, Аноним (34), 22:54, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > это прикладной юзерософт

    Прикладной юзерософт _зависит_ от версий системных библиотек. Обновив прикладной юзерософт вы обновите и системные библиотеки, из-за этих зависимостей.

    Если вам надо ставить только прикладной юзерософт, но со старыми системными блиблиотеками --- вам придётся пересобрать новый пакет со старыми либами установленными у вас (это называется backports).

    В принципе это не так сложно, в debian всё это автоматизировано и есть готовые штатные утилиты для пересборки, она выполняется в одну-две комманды. Если прикладной юзерософт не требует именно новой версии системных библиотек то у вас даже всё соберётся без проблем и будет работать.

     
     
  • 5.49, Аноним (49), 23:43, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >> это прикладной юзерософт
    > Прикладной юзерософт _зависит_ от версий системных библиотек. Обновив прикладной юзерософт
    > вы обновите и системные библиотеки, из-за этих зависимостей.

    нет, не всегда, есть пакеты которые трогают только свои зависимости, и если на них больше ничего в данном релизе не ссылается, то при обновлении как пакета, так и его зависимостей ничего не сломается и не заменится в системных компонентах, зависит от ситуации.

     
  • 5.51, Аноним (51), 23:55, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Кстати, самостоятельная пересборка как и сборка с нуля дебианопакетов, это ещё о... большой текст свёрнут, показать
     
  • 4.58, Аноним (21), 02:52, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > Мне и ненужно смешивать несколько реп, мне нужны разные несистемные пакеты из разных веток

    Твои "разные ветки" это и есть разные репы, есличо.

    > они точно ничего не сломают, это прикладной юзерософт

    Софт не существует в вакууме, у него есть зависимости. Зависимости из разных реп часто конфликтуют - в таком случае либо софт который тебе нужен не будет работать, потому что ты не поставишь нужную ему зависимость, либо ты её поставишь заменив родной пакет из дистрибутива и сломаешь ВСЁ что от него зависело.

    > я не виноват, если некоторые пакеты есть только в sid или в oldstable

    Нет, только ты и виноват. И ты гарантированно сам себя за это накажешь когда сломаешь систему.

     
     
  • 5.59, Аноним (59), 03:36, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Это смотря как посмотреть В обсуждаемом случае не про это, читайте внимательней ... большой текст свёрнут, показать
     
  • 3.39, Аноним (9), 22:55, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Поищи в интернете по debian pinnig
     
  • 2.43, Delpher (ok), 23:09, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    etc apt sources list deb cdrom Debian GNU Linux stratch _stable_ - Offici... большой текст свёрнут, показать
     
  • 2.44, Delpher (ok), 23:09, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    etc apt sources list deb cdrom Debian GNU Linux stratch _stable_ - Offici... большой текст свёрнут, показать
     
     
  • 3.52, Аноним (52), 00:05, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    >[оверквотинг удален]
    > deb-src http://mirror.yandex.ru/debian testing main contrib non-free
    > #Unstable
    > deb http://mirror.yandex.ru/debian unstable main contrib non-free
    > deb-src http://mirror.yandex.ru/debian unstable main contrib non-free
    > Далее сохраняем и обновляем список пакетов:
    > apt-get update
    > Установка программ идёт двумя способами:
    > apt install ProgramName/testing #использовать существующие версии зависимостей (безопасный)
    > apt install -t testing ProgramName #использовать новые версии зависимостей (опасный, принудительный)
    > man apt_preferences #info

    Огромное вам спасибо за ответ, но хотелось бы вкурить это на моём примере, который я описал выше https://www.opennet.ru/openforum/vsluhforumID3/120590.html#47, не знаю насколько понятно?!

     
  • 2.53, Catwoolfii (ok), 00:09, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    https://wiki.debian.org/ru/AptPreferences
     
  • 2.69, Суп из потрошков (?), 12:27, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Ну что, выхватил помощи "сообщества", чувак?
     
     
  • 3.77, Аноним (77), 18:30, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Ну что, выхватил помощи "сообщества", чувак?

    Я не совсем понял эмоционального окраса вашего сообщения и его смысловой нагрузки.
    На самом деле я в курсе что такое опеннет и что тут может быть в ответах, я вообще ничего не ожидал особо, однако ряд людей вполне годные советы дали, другое дело что я всё ещё не догнал как мне разрулить свою ситуацию с помощью приоритетов, зато несколько прояснений получил, за что благодарен!

     
  • 2.101, Аноним (100), 07:09, 12/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Не там ты помощи просишь, здесь тебе предложат или поставить ubuntu/gentoo/windows или взять учебник русского языка и поиздеваться ещё могут, на этом сила местного сообщества и заканчивается в силу отсутствия специалистов, вот от не знания и бессилия своего и могут только как бабки языком чесать.
     
     
  • 3.104, Аноним (104), 18:28, 12/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    А где надо просить помощи по Дебиану, как не в новости про Дебиан, на техническо... большой текст свёрнут, показать
     

  • 1.11, Sunderland93 (ok), 21:01, 09/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Когда уже Mesa обновлят? почему блоб обновляют регулярно, хотя на него никогда никаких гарантий не было и не будет, а открытые графические драйверы - раз в год?
     
     
  • 2.13, AleksK (ok), 21:15, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Переходи на testing или ставь Ubuntu
     
     
  • 3.14, анонимно (?), 21:23, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Будь мужиком,переходи на testing или ставь Ubuntu!
     
  • 2.17, Главный Ананим (ok), 21:26, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ставь минт или MXLinux. По мне так намного стабильнее и надёжнее и новее и хорошее.
     
     
  • 3.29, Аноним (29), 22:15, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Ставь минт или MXLinux. По мне так намного стабильнее и надёжнее и
    > новее и хорошее.

    -минт
    -MXLinux.
    -стабильнее и надёжнее
    Спасибо, рассмешили!

     
  • 2.22, Аноним (21), 21:41, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Зачем вам обновление Mesa? Вы же осознанно выбрали т.н. "стабильный" дистрибутив с замороженным софтом, как раз чтобы ничего не обновлялось и не ломалось, нет? Вот и сидите с тем что есть.
     
  • 2.83, BSDun (?), 00:06, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Переходи на тестинг и сиди голой жопой в интернет тому, что в тестинг апдейты безопасности приходят после sid и stable. Настоящие мужики за свою жопу не боятся!
     
     
  • 3.87, Аноним (87), 11:06, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > тому, что в  тестинг апдейты безопасности приходят после sid и stable.

    Я думаю вы, как приличный человек в приличном обществе, хотели приложить к своему этому высказыванию пруф в виде ссылки на официальный источник с такой информацией, но видимо были чем-то заняты пока составляли это сообщение, и ссылка нечаянно не вставилась в него при отправлении, ведь так?

     

  • 1.16, Аноним (16), 21:25, 09/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А Debian 9 уже все? Только критические исправления?
     
     
  • 2.18, Главный Ананим (ok), 21:26, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Эта cpaнь никогда толком не работала
     
     
  • 3.91, Аноним (91), 13:09, 11/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    Алло. Половина западных серверов все еще на 8-ку переходит, а Вы тут впереди паравоза ...
     
  • 2.20, анонимно (?), 21:33, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • +2 +/
    февраля 8 же было 9.12 https://www.debian.org/News/2020/2020020802
     

  • 1.38, быдлоюзер (?), 22:55, 09/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    нет ничего чётче дебиана
     
     
  • 2.46, анонимо (?), 23:10, 09/05/2020 [^] [^^] [^^^] [ответить]  
  • –3 +/
    да нет, ничего, чётче дебиана.
     

  • 1.60, Любитель Монеточки (?), 06:33, 10/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Как протестировать Lomiri на Debian?
     
  • 1.61, Аноним (61), 06:51, 10/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Из изменений в Debian 10.4 можно отметить обновление до свежих стабильных версий

    А на практике пакет может быть одновременно и свежим и стабильным?

     
     
  • 2.62, Аноним (62), 07:25, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    последняя стабильная версия же
     
  • 2.73, Аноним (73), 17:35, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +1 +/
    В Debian слово "свежий" имеет несколько иной смысл. Это когда только только окаменело.
     

  • 1.64, Аноним (64), 09:49, 10/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    При выборе Ru локализации оно научилось ставить только Ru пакеты или ставит в придачу с десяток сторонних локализаций?
     
     
  • 2.80, Аноним (80), 22:58, 10/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > При выборе Ru локализации оно научилось ставить только Ru пакеты или ставит
    > в придачу с десяток сторонних локализаций?

    Вы Дебиан с васяносборками типа дипинов или ещё какими не перепутали, точно?

    В Дебиане ставится только то, что пользователь попросил + зависимости, никогда переводов лишних не ставится, вы либо что-то делаете не так, либо просто выдумываете, в нашей вселенной Дебиан так себя не ведёт.

     

  • 1.70, Аноним (70), 12:58, 10/05/2020 Скрыто модератором [﹢﹢﹢] [ · · · ]
  • +1 +/
     
     
  • 2.71, зубастик (?), 16:03, 10/05/2020 Скрыто модератором
  • +1 +/
     
     
  • 3.88, Аноним (88), 11:10, 11/05/2020 Скрыто модератором
  • +/
     
  • 2.89, Аноним (88), 11:11, 11/05/2020 Скрыто модератором
  • +/
     

     ....ответы скрыты модератором (3)

  • 1.92, Аноним (91), 13:11, 11/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    В целом хотелось бы попросить у сообщества ускорить бэкпортирование инфраструктурных бибилотек и языков программирвоания. Хотя бы для начала транслируемых слабо связанных с системой вроде Ruby, Python, Golang, Rust, Node.js и так далее, а то сейчас их нужно ставить с официальных сайтов, а не через инфраструктуру Debian.
     
     
  • 2.107, Аноним (107), 22:37, 12/05/2020 [^] [^^] [^^^] [ответить]  
  • +/
    > В целом хотелось бы попросить у сообщества ускорить бэкпортирование инфраструктурных бибилотек
    > и языков программирвоания. Хотя бы для начала транслируемых слабо связанных с
    > системой вроде Ruby, Python, Golang, Rust, Node.js и так далее, а
    > то сейчас их нужно ставить с официальных сайтов, а не через
    > инфраструктуру Debian.

    А зачем это простому пользователю?
    А разработчики используют testing ветку, она довольно стабильная, ну а если вам надо прям свежак и непрерывный ролинг с постоянным бегом вперёд паравоза, то вам туда, где Грег Кро-Хартман сейчас тусует!

     

  • 1.109, LesPaul (?), 12:31, 14/05/2020 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    В Debian 8, с ядром 3.16 я добивался нулевой записи при простое на хард с ext4 и журналированием. Более новые ядра постоянно дёргают диск, кроны, логи и вот это вот всё выпилены с корнем, но нет, пишет и пишет мать его, вызываю у меня приступы ОКР. Тов. Линус, ты делаешь, что-то не то, одумайся...
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру