The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Разбор ситуации с лицензированием бинарных пакетов Ubuntu и Kubuntu для сторонних дистрибутивов

14.02.2014 22:06

В дополнение к расплывчатому заявлению управляющего совета проекта Ubuntu (Ubuntu Community Council) в отношении слухов о необходимости получения специальной лицензии при использовании бинарных пакетов из репозиториев Ubuntu в производных проектах, Джонатан Риддел (Jonathan Riddell), лидер сообщества разработчиков Kubuntu, пояснил позицию Kubuntu в этом вопросе.

Любой сторонний проект, не связанный с сообществом Ubuntu, может беспрепятственно использовать пакеты Kubuntu в качестве основы для производного дистрибутива, независимо от того собраны пакеты специально для Kubuntu или для Ubuntu. Единственным требованием является не использование в производном продукте торговой марки Kubuntu (т.е. производный продукт не должен распространяться от имени Kubuntu). Любые суждения, что компиляция пакетов даёт какие-то дополнительные права Canonical, ошибочны.

Вопрос о необходимости лицензирования возник в прошлом году после упоминания разработчиками Linux Mint запроса от представителей Canonical с просьбой получить лицензию на использование бинарных пакетов Ubuntu. Необходимость получения лицензии на использование пакетов, в которых фигурирует название Ubuntu, обусловлена желанием предотвратить появление низкокачественных производных дистрибутивов, прикрывающихся именем Ubuntu и делающих вид, что они развиваются при участии сообщества разработчиков Ubuntu. Т.е. основная задача лицензии - гарантирование качества продуктов, в которых используются пакеты, поставляемые от имени Ubuntu.

Подобная лицензия предоставлена всем развиваемым сообществом Ubuntu проектам и официальным ответвлениям. Сторонним проектам требуется дополнительное согласование, после которого нет проблем также получить данную лицензию без необходимости каких-либо выплат. При этом, лицензия необходима только для пакетов явно использующих торговую марку Ubuntu или логотип проекта в процессе работы программы, например, использующих слово Ubuntu в названии приложения. Без получения лицензии для распространения производного продукта достаточно удалить из пакетов использование торговой марки Ubuntu.

Что касается Linux Mint, то у сообщества Ubuntu и Canonical нет злого умысла в отношении данного дистрибутива и компания Canonical не намерена препятствовать продолжению его разработки, а лицензия лишь призвана помочь гарантировать успешность Linux Mint.

  1. Главная ссылка к новости (http://blogs.kde.org/2014/02/1...)
  2. OpenNews: Марк Шаттлворт извинился за действия Canonical в отношении проекта FixUbuntu
  3. OpenNews: Компания Canonical использовала нарушение торговой марки Ubuntu для борьбы с неугодным сайтом (инцидент исчерпан)
  4. OpenNews: Ричард Столлман выступил с критикой Ubuntu Linux
  5. OpenNews: Скрытая угроза для свободного ПО со стороны торговых марок
  6. OpenNews: Опубликованы правила использования торговой марки Ubuntu
Лицензия: CC-BY
Тип: Тема для размышления
Короткая ссылка: https://opennet.ru/39092-license
Ключевые слова: license, ubuntu, trademark
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (59) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, анонко (?), 23:26, 14/02/2014 [ответить] [﹢﹢﹢] [ · · · ]  
  • –4 +/
    правильно, нефиг плодить 100500 дистрибутивов на основе легкодоступной убунты с нескучными обоями и другими ДЕ. Собирайте, подписывайте пакеты сами, содержите репозитории.
    Хотя...
     
     
  • 2.3, Zenitur (ok), 23:31, 14/02/2014 [^] [^^] [^^^] [ответить]  
  • +7 +/
    правильно, нефиг плодить 100500 дистрибутивов на основе легкодоступного Debian с нескучными обоями и другими ДЕ. Собирайте, подписывайте пакеты сами, содержите репозитории.
    Хотя...
     
     
  • 3.6, anonymous (??), 23:42, 14/02/2014 [^] [^^] [^^^] [ответить]  
  • +5 +/
    >Собирайте, подписывайте пакеты сами, содержите репозитории.

    А что тебя возбудило? Они собирают, подписывают и содержат репозитории.

     
  • 3.29, Аноним (-), 07:28, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +2 +/
    внезапно бyбyнтa так и делает. А минт нет.
     
  • 3.34, Петросян (?), 09:31, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Правильно, нефиг плодить 100500 дистрибутивов на основе легкодоступного linux. Делайте ядро и  сами, портируйте пакеты сами, содержите репозитории.
     
  • 2.13, Аноним (-), 01:50, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > правильно, нефиг плодить 100500 дистрибутивов на основе легкодоступной убунты с нескучными обоями и другими ДЕ. Собирайте, подписывайте пакеты сами, содержите репозитории.

    Если эти дистрибутивы исчезнут - пользователи, скорее всего, ничего не потеряют.
    Но, то же самое можно сказать и про саму ubuntu - особенно с тех пор, как их LTS стал роллингом.

     
     
  • 3.30, Аноним (-), 07:30, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +2 +/
    >как их LTS стал роллингом.

    Если глупые анонимы исчезнут пользователям только станет лучше. Им перестанут морочить голову глупостями

     
     
  • 4.42, Аноним (-), 16:50, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Если глупые анонимы исчезнут пользователям только станет лучше. Им перестанут морочить голову глупостями

    Ну исчезни :)

     

  • 1.2, Zenitur (ok), 23:30, 14/02/2014 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Так вот зачем Canonical пересобрала весь репозиторий Debian из 30000 пакетов - чтобы "не засудили"? Бред.

    Давайте вспомним время, когда Ubuntu ещё не появилась. Alt, ASP, Mandrake, SUSE, Fedora, и у всех RPM-пакеты. Невозможно не только установить пакет с TuxKart от SUSE в Mandrake, но и установить пакет от Mandrake 9 в Mandrake 10 - никакой совместимости! Помню, скачал игру Astromenace, в архиве с игрой лежали 5 бинарников под 5 распространённых в то время дистрибутивов Linux. У всех разный размер, 890 Кб, 950 Кб, 920 Кб, 1,1 Мб... Хотя исходный код один и тот же!

    Другое дело Debian. После этого кошмара - лучший линукс! Если кто-то распространяет свою программу в DEB (репозиторий или файлом - не важно) и у тебя Debian, ты уже знаешь что программа у тебя запустится. У многих пользователей Debian в системе одновременно подключены репозитории old-stable, stable и testing - вообще классно! И тут приходит убунта и тупо всё пересобирает, ломая совместимость DEB-пакета и превращая Debian в очередной RPM.

    Наши дни. Используя Debian, я часто получал сообщение о невозможности установки DEB-пакета, потому что он для Ubuntu. Качаем мы с сайта разработчика Steam и видим что установка невозможна - в зависимостях есть пакеты, которые в принципе отсутствуют в репозитории. Для примера надо libgnutls35 из Ubuntu, а в Debian Stable версия 34, а в Testing 36. Другой пример - 5 лет назад настраивал Xandros на ноутбуке знакомого. Это такая же пересборочка, как Ubuntu, но потом "загнулась". Заявлялась полная совместимость с Debian 4.0. Соврали. Ставлю Wine - требуется samba 2:3.2.4-1debian2, а в системе samba 2:3.2.4-1xandros2. Понятное дело что пакеты одинаковы, но Wine не устанавливается.

    И при этом Canonical заявляет что "совместимости пока нет, но мы прикладываем героические усилия, чтобы её сделать". https://www.opennet.ru/opennews/art.shtml?num=25798 Нафига было пересобирать? Чтобы не засудили? Бред. Судят по себе.

     
     
  • 2.8, angra (ok), 00:22, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –4 +/
    У тебя фактологические или логические ошибки в каждом абзаце. Разбирать лень, так что просто иди в пеший эротический тур со своим хейтерством, мне как дебианщику неприятен факт наличия подобных звездунов среди нас.
     
  • 2.9, Аноним (-), 00:43, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > Alt, ASP, Mandrake, SUSE, Fedora, и у всех RPM-пакеты. Невозможно не только установить пакет с TuxKart от SUSE в Mandrake, но и установить пакет от Mandrake 9 в Mandrake 10 - никакой совместимости! Помню, скачал игру Astromenace, в архиве с игрой лежали 5 бинарников под 5 распространённых в то время дистрибутивов Linux. У всех разный размер, 890 Кб, 950 Кб, 920 Кб, 1,1 Мб... Хотя исходный код один и тот же!

    Одна особенность, названные rmp дистрибутивы совершенно самостоятельные продукты, как правило использующие разные версии этого самого rpm. В то время как deb используют фоки дебиана. И если под них ещё пакеты не пересобирать, то кроме замены обоев в них делать нечего)

     
     
  • 3.10, Zenitur (ok), 01:14, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ну хорошо, SUSE и Mandrake совсем разные. Но Mandrake 9 и 10 или SUSE 9 и 10 не совсем разные. Но кодекпак и TuxKart, который я с тогдашним интернетом долго скачивал, не устанавливаются после обновления системы. Другое дело Debian: устанавливаю в Stable некоторые пакеты из Testing, или наоборот из old-stable при появлении регрессий. Нигде больше не видел такой возможности - везде только одна версия программы в репозитории, а не три.
     
     
  • 4.12, kurokaze (ok), 01:27, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Но кодекпак

    Чиво? Ты с виндой не попутал?

    > Другое дело Debian: устанавливаю в Stable некоторые пакеты из
    > Testing, или наоборот из old-stable при появлении регрессий. Нигде больше не
    > видел такой возможности - везде только одна версия программы в репозитории,
    > а не три.

    Три? Хе-хе. Причем они не могут быть одновременно. А вот посмотри:

    dev-lang/python
         Available versions:  
         (2.6)  2.6.8-r3 ~2.6.9
         (2.7)  2.7.5-r3 ~2.7.5-r4 ~2.7.6
         (3.2)  3.2.5-r3
         (3.3)  3.3.2-r2 3.3.3

    В каждом слоте есть стабильные версии и нет. Установить можно любую коминацию слотов.

    dev-db/postgresql-server
         Available versions:  
         (8.4)  8.4.19
         (9.0)  9.0.15
         (9.1)  9.1.11
         (9.2)  9.2.6
         (9.3)  9.3.2
         (9.4)  **9999

    Аналогично. Есть даже 9999, это тебе не просто нестабильный, а замаскированный, который при установке тянет сорцы из git/svn и собирает.

     
  • 4.60, agent_007 (ok), 11:25, 18/02/2014 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >  Но Mandrake 9 и 10 или SUSE 9 и 10 не совсем разные

    Ты дурак. Это если коротко.

    Если длинно, то иди читать maximum rpm, может поймёшь как устроен пакетный менеджер. Ну или жуй вместо того, чтобы говорить, тоже будет отлично например.

     
  • 2.11, kurokaze (ok), 01:22, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +5 +/
    >когда Ubuntu ещё не появилась. Alt, ASP, Mandrake, SUSE, Fedora,

    Я помню время когда федоры не было и то что ты написал - лютый бред.
    Я знал что есть тулкитофобия, дистрофания, теперь вот столкнулся с пакетменеджерофилией

    > 34, а в Testing 36. Другой пример - 5 лет назад настраивал Xandros на ноутбуке знакомого. Это такая же пересборочка, как Ubuntu, но потом "загнулась". Заявлялась полная совместимость с Debian 4.0. Соврали. Ставлю Wine - требуется samba 2:3.2.4-1debian2, а в системе samba 2:3.2.4-1xandros2.

    Ты вообще понимаешь зачем это делается? Это называется зависимостями. Дебиан например минимум разбивает одну сущность на две - для остального софта (либа) и dev пакет для разработки с этой либой. А зачастую бывает еще несколько пакетов содержащих опциональные фичи - например работа с мускулем отдельно, с постгри  - отдельно.
    У других дистров политика может быть иной. Отсюда зависимости не совпадают.
    Ты хочешь единый стандарт разделения пакетов? Вперед и с песней, основывай, продвигай.
    Не нравится? Это бинарные дистры детка, привет. Терпи если альтернативы не нравятся.
    Я ушел с бинарников 9 лет назад и не ною. Но и не агитирую - каждому своё ("Jedem das Seine").

     
     
  • 3.15, Zenitur (ok), 01:55, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    Я хочу чтобы Ubuntu не выпендривалась и делала маленький репозиторий с новыми или изменившимися пакетами.

    1). 63% дистрибутивов Linux основаны на Debian. А именно 128. Вот: https://www.opennet.ru/opennews/art.shtml?num=29806 Но почему в интернете нет сотни не совместимых друг с другом репозиториев из 30000 пакетов? Где samba 2:3.2.4-1bolgenos2, samba 2:3.2.4-1partedmagic2, samba 2:3.2.4-1knoppix2, не совместимые друг с другом? Где 5 терабайт пересборок репозитория Debian?

    2). Все просто берут и первой строчкой в /etc/apt/sourcs.list пишут Debian, а второй - свой маленький репозиторий из 30 пакетов. Выгодно всем. Автору нового дистрибутива, которому понадобилось 20 минут для создания LiveCD с редактором разделов. Пользователям Debian, которые могут подключить этот репозиторий и получить самый новый gparted. Почему бы Ubuntu не сделать свой маленький дополнительный репозиторий? В Ubuntu не так уж много пакетов из Debian имеют хотя бы одно изменение: 83% пакетов пересобраны "как есть".

    3). Ещё раз повторяю, совместимости между Debian и Ubuntu нет. Я давал ссылку на то что Canonical синхронизировала свой Ubuntu 10.04 LTS с Debian 6.0, а вот с 12.04 и 14.04 этого не случилось. Вероятность того что пользователь хочет установить программу из DEB, а она не установится в DEBian-е, велика. Или потому что в репозитории Debian пакета-зависимости вообще нет, или пакет есть, но в репозитории Ubuntu пакет переименовали (как например Samba).

    Я смотрел на это и не понимал: ну нафига так делать? Переименовали бы что ли расширение пакета в UBU, чтобы авторы программ распространяли DEB и UBU отдельно. И им тоже головной боли меньше.

     
     
  • 4.27, Snowmean (?), 06:16, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    А тебя не смущает что RPM - это вобщем то RedHat Package Manager. Заметь RedHat! Следуя твоей логике давай тогда fedora будет использовать *.fed, Mandriva - *.mnd, SuSE - *.sus
    И каждый форк будет неприменно использовать новое трехбуквенное сочетание для одного и того-же ФОРМАТА пакетов. Вот тогда то мы офигеем до полной бессознанки!
     
     
  • 5.53, anonymous (??), 18:04, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > А тебя не смущает что RPM - это вобщем то RedHat Package
    > Manager. Заметь RedHat! Следуя твоей логике давай тогда fedora будет использовать
    > *.fed, Mandriva - *.mnd, SuSE - *.sus
    > И каждый форк будет неприменно использовать новое трехбуквенное сочетание для одного и
    > того-же ФОРМАТА пакетов. Вот тогда то мы офигеем до полной бессознанки!

    Во-первых, уже не RedHat, а RPM Package Manager.
    Во-вторых, примерно так с трёхбуквенными сочетаниями и обстоит ситуация. f[0-9]\{2\}, mga[0-9]?, mdv, mdk и т. д.

     
     
  • 6.58, arisu (ok), 05:04, 16/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > mga[0–9]?, mdv, mdk

    НДС…

     
  • 5.62, Ононимный Ононим (?), 01:40, 28/05/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Какбудто шото плахое? а типа одинаково названные, но несовместимые покеты это харашо? Зато стандарт, чо!
     
  • 4.36, Аноним (-), 10:43, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > Переименовали бы что ли

    Они так и делают, только переименовывают пакеты - см. практически весь PHP для Ubuntu.

     
  • 3.16, Аноним (-), 01:58, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    RPM-дистрибутивы делают аналогично, только вместо dev - devel Кстати, хороший п... большой текст свёрнут, показать
     
     
  • 4.24, Анонис (?), 04:53, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Если ты такой умный, что ж ты строем не ходишь?
     
     
  • 5.43, Аноним (-), 16:51, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Если ты такой умный, что ж ты строем не ходишь?

    Чего сказать-то хотел?

     
  • 4.56, kurokaze (ok), 00:13, 16/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    >Кстати, хороший подход, позволяющий в большинстве случаев заменить use-флаги в бинарных дистрах.

    Фиг там. Я в свое время походил по этим граблям 10 лет назад

    >А зря. Объективных показаний для разных политик пакетирования в дистрибутивах общего назначения я не вижу. Что оптимально для одного - оптимально и для остальных

    Критерий оптимальности в студию

    >Было бы неплохо. Общий стандарт системы инициализации уже появился, например.

    Так я не против - делайте. Меня например это не волнует, других судя по опеннету волнует. А результат волнений пока только нытьё

     
  • 2.31, Аноним (-), 07:33, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +1 +/
    вообще то собрать совместимый rpm пакет возможно.
    вообще то совместимость deb между двумя версиями одного и того же дистрибутива отсутствует.
    >У многих пользователей Debian в системе одновременно подключены репозитории old-stable, stable и testing - вообще классно

    эти ссзб. чтоб использовать пакет от другой версии его обязательно надо пересобрать.

     
  • 2.32, бедный буратино (ok), 07:40, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Сколько помню убунту, всегда были две претензии:

    1. Почему она не Debian
    2. Почему она Debian

    когда пакеты с лёгкостью ложились туда-обратно, все возмущались, зачем вообще убунту, если она несамостоятельно. когда в седьмой версии с этим стало чуть похуже, начался плач "почему стало несовместимо" (кстати, многое из юзерского софта совместимо до сих пор)

    Знаешь, что? Иди гуляй.

     
     
  • 3.44, Аноним (-), 16:52, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Сколько помню убунту, всегда были две претензии:
    > 1. Почему она не Debian
    > 2. Почему она Debian
    > когда пакеты с лёгкостью ложились туда-обратно, все возмущались, зачем вообще убунту, если
    > она несамостоятельно. когда в седьмой версии с этим стало чуть похуже,
    > начался плач "почему стало несовместимо" (кстати, многое из юзерского софта совместимо
    > до сих пор)

    Наверное, все дело в том, что убунта бессмысленна с самого начала - дебиан и так достаточно хорош.

     
  • 2.54, Куяврег (?), 23:46, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > Другое дело Debian. После этого кошмара - лучший линукс! Если кто-то распространяет свою программу в DEB (репозиторий или файлом - не важно) и у тебя Debian, ты уже знаешь что программа у тебя запустится.

    Виндовсятнеги согласно кивают, смахивают слезу и заводят хором песню про ABI.

    Да, возможность скачать с помойки инсталляху и запустить - это важное свойство венды. Неясно только зачем оно дебиану.

     

  • 1.4, Khariton (ok), 23:35, 14/02/2014 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Убунту - Это в переводе "человечность"! По-моэму очень даже человечно...
     
     
  • 2.7, A.Stahl (ok), 00:17, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Это в переводе "человечность"!
    Всё логично, учитывая, что человек это такое нелепое существо, которое выбирает себе тупых лидеров, доводит до маразма всё бесполезное и не заканчивает полезное.
     
     
  • 3.19, Аноним (-), 02:03, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Это в переводе "человечность"!
    > Всё логично, учитывая, что человек это такое нелепое существо, которое выбирает себе
    > тупых лидеров, доводит до маразма всё бесполезное и не заканчивает полезное.

    Последние события заставляют усомниться в глупости лидеров Ubuntu. Чтобы отказаться от "национального велосипеда" - нужны и воля, и разум.

     
     
  • 4.25, arisu (ok), 05:47, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –4 +/
    > Чтобы отказаться «национального велосипеда» - нужны и воля, и разум.

    вообще-то, достаточно просто наплевательского отношения к своему детищу. но марку это не впервой, он настолько в себе не уверен, что готов отказаться от любой своей идеи без проблем.

     
     
  • 5.45, Аноним (-), 16:55, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > вообще-то, достаточно просто наплевательского отношения к своему детищу.

    Наплевательское отношение - это заставлять своих разработчиков пилить автономный форк ОС, оторванный от сообщества и технологий, а пользователей - пользоваться этим форком.

     
     
  • 6.55, Куяврег (?), 23:48, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > Наплевательское отношение - это заставлять своих разработчиков пилить автономный форк
    > ОС, оторванный от сообщества и технологий, а пользователей - пользоваться этим
    > форком.

    далеко не все ставят знак равенства между дебианом и "сообществом и технологиями".

     
  • 6.57, arisu (ok), 05:02, 16/02/2014 [^] [^^] [^^^] [ответить]  
  • +2 +/
    я сейчас страшное скажу, ты приготовься. сядь покрепче, валокардина накапай… так вот: мир не крутится вокруг бебиана, и бебиан не является миром.

    я понимаю, тебе так сразу это осознать сложно, ты прочитал и даже ничего не понял поначалу. но ты ещё раз прочитай, и ещё раз, и ещё…  мне не очень приятно разрушать твои иллюзии, но рано или поздно это надо было сделать. и лучше рано.

     
  • 2.37, Аноним (-), 10:45, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > Убунту - Это в переводе "человечность"! По-моэму очень даже человечно...

    Ubuntu - это название одного из учений в философии.

     

  • 1.5, Аноним (-), 23:39, 14/02/2014 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >>Сторонним проектам требуется дополнительное согласование, после которого нет проблем также получить данную лицензию без необходимости каких-либо выплат.

    Это позор!

     
     
  • 2.14, paulus (ok), 01:55, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    "Без получения лицензии для распространения производного продукта достаточно удалить из пакетов использование торговой марки Ubuntu".

    Debian вон с Firefox из-за подобного не дружит и об этом уже никто и не кричит...

     
     
  • 3.17, Аноним (-), 02:00, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > "Без получения лицензии для распространения производного продукта достаточно удалить
    > из пакетов использование торговой марки Ubuntu".
    > Debian вон с Firefox из-за подобного не дружит и об этом уже
    > никто и не кричит...

    Да и центос тем же самым давно занимается. Что не мешает троллям кричать, какой плохой и проприетарный редхат.

     
     
  • 4.28, Аноним (-), 06:20, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    И даже после того как Редхат стал центосовикам даже деньги за это платить, крики таки не утихают.
     
  • 4.38, Аноним (-), 10:47, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    >> "Без получения лицензии для распространения производного продукта достаточно удалить
    >> из пакетов использование торговой марки Ubuntu".
    >> Debian вон с Firefox из-за подобного не дружит и об этом уже
    >> никто и не кричит...
    > Да и центос тем же самым давно занимается. Что не мешает троллям
    > кричать, какой плохой и проприетарный редхат.

    Чепуха. Никто не мешает EPEL в CentOS подключить, и все недостающие пакеты прекрасно будут доступны.

     
     
  • 5.52, fi (ok), 17:24, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > все недостающие пакеты прекрасно будут доступны.

    ну ну, и где там redhat-release? где rhs-updater???

    EPEL - это backport of fedore, а не rhel

     
  • 2.18, chinarulezzz (ok), 02:02, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –3 +/
    лучшее решение - закрыть репозитории, навроде red hat network.
     
     
  • 3.39, Аноним (-), 10:48, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > лучшее решение - закрыть репозитории, навроде red hat network.

    Еще раз. EPEL.

     
     
  • 4.40, chinarulezzz (ok), 14:51, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >> лучшее решение - закрыть репозитории, навроде red hat network.
    > Еще раз. EPEL.

    и еще два раза. EPEL. EPEL. Canonical вроде тоже есть мэйнтейнеры работающие в бедиан. Называли б эту группу EPEL, она мэйнтейнит и для дебиана, и для убунты. А доступ к обновлениям в убунте - закрыть по подписке, как в редхат, и все патчи сливать в один diff.

     
     
  • 5.47, Аноним (-), 16:57, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > и еще два раза. EPEL. EPEL. Canonical вроде тоже есть мэйнтейнеры работающие
    > в бедиан. Называли б эту группу EPEL, она мэйнтейнит и для
    > дебиана, и для убунты. А доступ к обновлениям в убунте -
    > закрыть по подписке, как в редхат, и все патчи сливать в
    > один diff.

    И еще код Mir распространять только под EULA :)

     

  • 1.20, chinarulezzz (ok), 02:22, 15/02/2014 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    посмотрим что из этого получится. А до 2017 года я не перейду.
     
     
  • 2.21, Аноним (-), 02:32, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > посмотрим что из этого получится. А до 2017 года я не перейду.

    А что, в 2017 намечается очередной конец света?

     
     
  • 3.23, chinarulezzz (ok), 02:59, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • –2 +/
    >> посмотрим что из этого получится. А до 2017 года я не перейду.
    > А что, в 2017 намечается очередной конец света?

    закончится поддержка LTS-релиза.

     
     
  • 4.46, Аноним (-), 16:57, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    2014+5=2019
    только в нем через 2 года уже половина программ не соберется.
     
     
  • 5.50, chinarulezzz (ok), 17:02, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    > 2014+5=2019
    > только в нем через 2 года уже половина программ не соберется.

    например каких?

     
  • 4.49, Аноним (-), 17:00, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    >>> посмотрим что из этого получится. А до 2017 года я не перейду.
    >> А что, в 2017 намечается очередной конец света?
    > закончится поддержка LTS-релиза.

    А что, релиз был только один?

     
     
  • 5.51, chinarulezzz (ok), 17:03, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    >>>> посмотрим что из этого получится. А до 2017 года я не перейду.
    >>> А что, в 2017 намечается очередной конец света?
    >> закончится поддержка LTS-релиза.
    > А что, релиз был только один?

    нет конечно. Тот на котором у меня крутится убунта, называется 12.04.4. Он будет до 2017.

     
     
  • 6.61, Миша Тихонов (?), 11:00, 22/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    >>>>> посмотрим что из этого получится. А до 2017 года я не перейду.
    >>>> А что, в 2017 намечается очередной конец света?
    >>> закончится поддержка LTS-релиза.
    >> А что, релиз был только один?
    > нет конечно. Тот на котором у меня крутится убунта, называется 12.04.4. Он
    > будет до 2017.

    ванокноно

     

  • 1.22, Аноним (-), 02:51, 15/02/2014 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    Да, всего-то удалить любое упоминание UBUNTU, KUBUNTU, EDUBUNTU, XUBUNTU, JUJU, LANDSCAPE и Canonical из исходников проги, потом скомпилировать и собрать пакет без упоминания этих trademarks и всё готово.
    Короче, пересобрать каждый пакет системы, предварительно покопавшись в коде и скомпилив все проги самому. Только так сейчас можно сделать дистрибутив на базе Ubuntu, без специального разрешения от Canonical.

    http://www.ubuntu.com/legal
    http://www.canonical.com/intellectual-property-rights-policy

     
  • 1.26, Аноним (26), 06:14, 15/02/2014 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    дебиановские проги дебиановскими утилитами собирают, и ляпать свою лицуху на пакеты
     
  • 1.35, Аноним (-), 10:38, 15/02/2014 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > появление низкокачественных производных дистрибутивов, прикрывающихся именем Ubuntu

    Оно? http://ualinux.com/ru/ubuntu-oem

     
     
  • 2.48, Аноним (-), 16:59, 15/02/2014 [^] [^^] [^^^] [ответить]  
  • +/
    >> появление низкокачественных производных дистрибутивов, прикрывающихся именем Ubuntu
    > Оно? http://ualinux.com/ru/ubuntu-oem

    У них партнерский договор с конониклом. С таким договором можно смело делать низкокачественные производные дистрибутивы, прикрываясь именем Ubuntu.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2021 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру