The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Сопровождение драйверов для устаревших GPU AMD и Intel в Linux оказалось лучше, чем в Windows

02.05.2019 09:25

В значительном выпуске системы 3D-моделирования Blender 2.80, который ожидается в июле, разработчики расчитывали обеспечить работу с GPU, выпущенными за последние 10 лет и имеющими рабочие драйверы OpenGL 3.3. Но в ходе подготовки нового выпуска выяснилось, что во многих OpenGL-драйверах для старых GPU имеются критические ошибки, которые не позволили обеспечить качественную поддержку всего запланированного оборудования. Отмечается, что в Linux ситуация не так критична как в Windows, так как старые драйверы в Linux продолжают обновляться, а пропритеарные драйверы в Windows остаются без сопровождения.

В частности, для Windows не удаётся добиться корректной поддержки графических чипов AMD, выпущенных за последние 10 лет, так как для старых GPU AMD всплывают проблемы при использовании движка рендеринга Eevee из-за ошибок в драйвере Terascale, который не обновлялся уже три года. Поэтому в Windows удалось официально предоставить поддержку только GPU AMD на базе архитектуры GCN 1 (HD 7000) и более новых.

Отдельные проблемы также возникают при использовании старых GPU Intel, поэтому в Blender 2.80 удалось гарантировать беспроблемную работу GPU только начиная с семейства Haswell, так как Windows-драйверы Intel для старых чипов также не обновлялись уже около 3 лет и ошибки остаются неисправленными. В Linux с драйверами для старых GPU Intel проблем не возникает, так как они продолжают обновляться. Проблем нет также с GPU NVIDIA благодаря продолжению поддержки ветки драйверов NVIDIA для устаревших устройств для всех заявленных платформ.

  1. Главная ссылка к новости (https://www.phoronix.com/scan....)
  2. OpenNews: NVIDIA прекращает разработку драйверов для 32-разрядных систем
  3. OpenNews: В Nouveau не получается обеспечить качественную поддержку GeForce GTX 900 из-за ограничений NVIDIA
  4. OpenNews: Разработчики Chromium добавили Nouveau в чёрный список проблемных драйверов
  5. OpenNews: Google в Android начинает использовать штатные DRM/KMS драйверы Linux
  6. OpenNews: Intel разрабатывает новый драйвер для своих графических адаптеров
Лицензия: CC-BY
Тип: Тема для размышления
Ключевые слова: gpu, driver, intel, amd, linux, windows
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (90) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (1), 09:43, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +11 +/
    осталось только еще и новые драйвера лучше поддерживать и вендокапец =D
     
     
  • 2.62, Канделябры (?), 00:55, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +8 +/
    > и вендокапец

    Да. Очередной. Плановый.

     

  • 1.2, 123 (??), 10:05, 02/05/2019 Скрыто модератором [﹢﹢﹢] [ · · · ]
  • –22 +/
     
     
  • 2.20, Аноним (20), 12:53, 02/05/2019 Скрыто модератором
  • +2 +/
     
     
  • 3.28, Аноним (28), 14:18, 02/05/2019 Скрыто модератором
  • +3 +/
     
  • 3.31, аллюминь (?), 15:58, 02/05/2019 Скрыто модератором
  • –2 +/
     
  • 2.36, йож (?), 17:24, 02/05/2019 Скрыто модератором
  • –10 +/
     
     
  • 3.37, Пользователь (?), 17:47, 02/05/2019 Скрыто модератором
  • +1 +/
     
  • 2.39, Аноним (-), 18:02, 02/05/2019 Скрыто модератором
  • +8 +/
     
     
  • 3.47, Аноним (47), 19:14, 02/05/2019 Скрыто модератором
  • +2 +/
     

     ....ответы скрыты модератором (7)

  • 1.3, Аноним (3), 10:08, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Ну так это OpenGL-драйверы. Майкрософт с ним борется на своей платформе. Например в Windows XP доступна библиотека OpenGL 2, а в Windows 7 уже OpenGL 1. Системную реализацию OpenGL использует например Intel. А NVIDIA с AMD используют свои реализации
     
     
  • 2.9, Аноним (9), 11:11, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • –6 +/
    > Системную реализацию OpenGL использует например Intel. А NVIDIA с AMD используют свои реализации

    Ты не поверишь, под линуксом точно так же: Intel юзает mesa, а у невидии и AMD свои велосипеды.

     
     
  • 3.21, Аноним (20), 12:57, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Во-первых, меза - это нк реализация огл, а универсальная основа. Собственная реализация, так или иначе, есть у всех вендоров.
    А во вторых amdgpu основан на gallium и mesa. На сей день отличилась только нвидия, которая продолжает использовать свой переизобретенный графический стек в драйвере (включая нк то что безмесовый огл, но и даже drm)
     
     
  • 4.29, Аноним (3), 14:35, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > А во вторых amdgpu основан на gallium и mesa. На сей день отличилась только нвидия

    С тех пор, как появился Vulkan, про Gallium все благополучно забыли.

     
     
  • 5.30, leap42 (ok), 14:50, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +5 +/
    лолшто? в mesa все драйвера на базе gallium, кроме i965 (современные встройки intel), только он один - classic. более того, intel в 2020 году выпустит дискретную графику и с этого момента вся новая графика intel (включая встройки) будет работать через gallium.
     
     
  • 6.32, аллюминь (?), 16:00, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Драйвера пукана отдельные
     
  • 5.42, Аноним (20), 18:43, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Ну конечно, ведь вулкан моментально заменил огл прямо в момент своего появления
     
  • 2.15, Иваныч (??), 11:45, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Вот сколько помню то всегда можно на всех платформах использовать только OpenGL 1.1 не опасаясь. Далее только wglGetProcAddress/glXGetProcAddress во все поля без каких либо проблем.
     

  • 1.4, Аноним (-), 10:21, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –25 +/
    У меня прям сразу рдились слоганы:
    - Лучшее устаревшее для отстающих!
    - Некрофилию - некрофилам!

    >Поэтому в Windows удалось официально предоставить поддержку только GPU AMD на базе архитектуры GCN 1 (HD 7000) и более новых.

    Эээ, то есть я не играл в Муровинд, Готику1-2-3, КБ и кучу других 3Д игор, не юзал 3Дмакс на RadeonX1600pro c дровами от амд без каких либо глюков?

    > в Blender 2.80 удалось гарантировать беспроблемную работу GPU только начиная с семейства Haswell

    Блендер на HD4400=8600GT в 2019, но... зачем? Рендеринг уровня 2012 года, но... зачем? Сейчас как бэ стоит юзать не ниже RX560(+-) или GF1050(+-).

     
     
  • 2.7, IRASoldier (?), 11:02, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +4 +/
    >Муровинд

    - это DirectX 9, а не OpenGL.

     
     
  • 3.76, Аноним (76), 19:17, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    ага щас, 8.1
     
     
  • 4.80, IRASoldier (?), 20:09, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > ага щас, 8.1

    А, точно, сейчас посмотрел, что лежит в инсталляционном сидюке. Ну и 2002 год, да.


     
  • 2.12, Аноним (12), 11:22, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    а ведь тебе явно больше 10-и лет
     
  • 2.16, Zenitur (ok), 11:52, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Ты бы ещё спросил, зачем финальный рендеринг делают на процах. Они же медленнее GPU!
     
     
  • 3.23, Аноним (20), 13:01, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Да никто не мешает финально рендерить на гпу, только не при помощи ogl
     
  • 2.66, й (?), 03:42, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +4 +/
    > юзал 3Дмакс на RadeonX1600pro

    я пользовал 3dsmax на компьютере с 20Мб оперативной памяти.
    в качестве видеоадаптера там, кажется, был какой-то sis.

    как тебе такое, илон маск?

     
  • 2.69, Annoynymous (ok), 14:47, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > но... зачем?

    Не всем мамка денег даёт.

     
  • 2.78, Аноним (76), 19:22, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Играл. Драйвера для Radeon X1600 и windows 7 были выпущены 10-15 лет назад и будут работать пока windows 7 не сдохла (и даже после этого)
    А у нас в GNU/Linux Stable API nonsense и ничего не работает :-(
     

  • 1.6, Аноним (6), 11:00, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Отсутствие подобного бардака очень воодушевляет:
    http://winitpro.ru/index.php/2017/05/17/microsoft-ogranichila-rabotu-windows-
    Психически здоровые люди радуются.
     
     
  • 2.8, IRASoldier (?), 11:10, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • –8 +/
    Ой-вэй... Неужто на каком-нибудь асуснетбуке птичкой вспорхнёт, скажем, свежая Kubuntu и явит величие вечной поддержки фекалий мамонта? Отчего-то мне думается, что психически здоровые люди станут на некрожелезо ставить что-то навроде MX Linux или какого-нибудь подобного спецдистриба.
     
     
  • 3.22, vitalif (ok), 12:58, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Таки взлетает, у меня до сих пор валяется оуе пуси старое какое то с упоротым gpu, который интел но не интел

    Другое дело конечно нах оно надо... удовольствие так себе

     
     
  • 4.24, Аноним (20), 13:03, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Интел но не интел - это, надо понимать, powervr? Открытые драйвера для них по сей день работают через пень, так что если и заводится, то с попдывшими цветами и без ускорения
     
  • 3.38, Пользователь (?), 17:52, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Для таких как ты изобрели Windows 10, Linux - для нормальных людей
     
     
  • 4.48, IRASoldier (?), 19:41, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Для таких как ты изобрели Windows 10, Linux - для нормальных людей

    "Чукча комментов не читает, чукча сам комментирует!" (tm) (#дисклаймер - мы не имели в виду унизить достоинство представителей народа чукч)


     
  • 4.49, IRASoldier (?), 19:49, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Windows 10

    UPD

    Кстати, вполне нормальная десктопная ОСь. (#trollface)

     
     
  • 5.72, Legionz (?), 17:30, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Кстати, вполне нормальная десктопная ОСь. (#trollface)

    фу-фу-фу!

     
  • 4.63, Канделябры (?), 01:01, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Linux - для нормальных людей

    Нуу.. ОК.. ?

     
  • 3.52, JL2001 (ok), 20:51, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Ой-вэй... Неужто на каком-нибудь асуснетбуке птичкой вспорхнёт, скажем, свежая Kubuntu

    на ноуте 2006 свежая убунта, amd tl-56 4gb, r200 какая-то

    резиновые и пластиковые элементы корпуса уже рассыпаются :( тртья замена вентилятора

     
     
  • 4.54, IRASoldier (?), 20:56, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Встать-то встала, а как насчёт шустроты, вот в чём вопрос. У ThinkPad'ов тех же лет выпуска с рассыпучестью проблем поменьше, но вот вкрячивать туда имеет смысл именно что MX-подобные дистры, а не майнстрим.
     
     
  • 5.57, JL2001 (ok), 22:41, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Встать-то встала, а как насчёт шустроты

    фаерфокс, фильмы 720р, тде кмейл, рсс-читалка
    но так-то больше сервером работает и удалённый запуск приложений (почтовик и рсс), а так же как гостевой ноут

     
  • 2.10, Аноним (9), 11:18, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • –4 +/
    Психически здоровые люди понимают, что M$ просто не хочет поддерживать 7 так же долго, как XP. В Linux такой проблемы не встаёт в принципе, новые драйвера в старые версии не бекпортируются. Новой железке — новое ядро. (Не, есть извращенцы типа RedHat, но это их проблемы, а я про мейнлайн.)
     
     
  • 3.53, IRASoldier (?), 20:52, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Не, есть извращенцы типа RedHat

    Ну, в корпоративном секторе замена железа может влететь в ну очень нехилую копеечку, так что RedHat как раз тут не извращенцы, а рыночно удовлетворяют спрос на ось, которая будет фурычить на этом железе. Бизнес же ж.

     
     
  • 4.73, Аноним (9), 17:30, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Ты хотя бы понял, о чём я? Шляпа бекпортирует новые дрова в своё допотопное ядро. Не для того, чтобы работать на старом железе, а для того, чтобы работать и на новом тоже. На старом-то и свежие версии ядра неплохо себя чувствуют.
     
     
  • 5.77, IRASoldier (?), 19:18, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Ты хотя бы понял, о чём я? (...) а для того, чтобы работать и на новом тоже

    Проглядел, бывает. Но я всё равно не понял, что тут прямо уж извращенского.

     
  • 2.13, segesg (?), 11:22, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Этапять!))
     

  • 1.11, Аноним (-), 11:22, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Эх, если б еще на моем ноуте с R2 графикой дровишки не зависали...
     
  • 1.19, Skullnet (?), 12:17, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Да и современные GPU AMD и Intel лучше работают.
     
  • 1.25, Аноним (25), 13:17, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –4 +/
    Da kakie AMD i Intel,ya nedavno Void Linux i686 na celeron 1400,512 mb ram  i Matrox G450 puskal,videokarta norm rabotala pod Xorg,pravda 3d nety ibo iz Mesa davno vykinuli kod dlya matrox-ov.
     
     
  • 2.50, Аноним (50), 20:11, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Это прекрасно. Но все же осиль setxkbmap.
     

  • 1.26, Аноним (26), 13:32, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    пусть раскрывают всю инфу о железе, раз не могут проприетарные дрова выкатить
     
     
  • 2.27, Аноним (20), 13:51, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Было бы что раскрывать, там уже все отреверсили
     
  • 2.64, Канделябры (?), 01:05, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    И клоунские носы пусть оденут.. И ботинки разноцветные ещё!
     

  • 1.34, Аноним (34), 16:54, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    какой Linux пойдёт под этот мобильный проц Intel Core Duo T2050
    подскажите
     
     
  • 2.44, 0ffh (??), 18:47, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    этот процик лучше выкинуть - он 32 ух битный
    а ему на замену за бутылку пива поставить 5600-7200 - эти 64 битные - можно будет юзать все современное по
    с оговоркой на легкую тормознутость
     
     
  • 3.46, 0ffh (??), 18:52, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    главное тока не нахомутать с сокетом
    у тебя сокет М
    не купи сокет Р
     
     
  • 4.65, Канделябры (?), 01:07, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Я могу выпить его новый процессор залпом за 10 сек!
     
  • 2.51, Аноним (9), 20:18, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > какой Linux пойдёт под этот мобильный проц Intel Core Duo T2050

    Любой из ныне поддерживаемых: 3.16, 4.4, 4.9, 4.14, 4.19, 5.0.

     

  • 1.35, Аноним (35), 16:56, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +16 +/
    Опеннет странный предмет:
    Недовльны, если поддержка есть,
    Недовольны, если ее нет.
     
     
  • 2.95, Аноним (95), 09:22, 06/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Вывод если ты всем доволен не пиши на опеннет.
     

  • 1.43, gfederix (ok), 18:44, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Увы лучше чем в винде, не говорит о том, что эти драйверы хорошего качества.
     
  • 1.45, 0ffh (??), 18:50, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    можно добавить
    у меня есть старый ноут самсунг р40
    видео ати 1200
    64 битных дров на винду 7 уже нет
    а fgrlx все еще работает в 64 битном линухе
    хотя от поддержки ати - амд отказалась после ее покупки
    так что можно сказать - что для старого железа линух лучше чем винда


     
     
  • 2.68, Аноним (3), 12:47, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Драйвер Catalyst 9 3, значит Чтобы он работал, надо соблюсти два условия Это я... большой текст свёрнут, показать
     
     
  • 3.83, Аноним (3), 06:36, 04/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    А почему в CentOS 6 нельзя установить X-Server 1.6 из Fedora 11? Для CentOS-то софта больше. И Firefox последний сразу в комплекте
     

  • 1.56, Аноним (56), 22:26, 02/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Но зачем сопровождать драйвера для устаревших GPU?
     
     
  • 2.58, axredneck (?), 23:45, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Допустим, я - пользователь винды (на самом деле нет, но допустим). Допустим, собрался я купить новый дорогой GPU. Смотрю я, значит, в интернетах, у кого с драйверами дела лучше. И покупаю Nvidia, потому что их GPU под виндой дольше не "устареет".
     
     
  • 3.59, axredneck (?), 23:51, 02/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    edit: речь идет о GPU верхнего ценового сегмента, который покупаешь надолго.
     
     
  • 4.70, Аноним (70), 15:06, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    GPU верхнего ценового сегмента как раз не покупаются надолго.
     
  • 3.60, Аноним (56), 00:49, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    для чего нужна дорогая GPU? чтоб тянула современные игрухи! ну вот как только она перестанет их тянуть, то нах она нужна и её поддержка?
     

  • 1.61, Канделябры (?), 00:54, 03/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А вот меня проблемы взБлендера вообще не волнуют.

    > Сопровождение драйверов для устаревших GPU AMD и Intel в Linux оказалось лучше, чем в Windows

    Чего, среди ослов закусивших удила, один я заметил явную подмену понятий?

     
     
  • 2.71, Ordu (ok), 16:48, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Чего, среди ослов закусивших удила, один я заметил явную подмену понятий?

    Совершенно ненужная самокритика. Но да, видимо ты один. Что за подмена понятий?

     
  • 2.74, Аноним (9), 17:37, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > А вот меня проблемы взБлендера вообще не волнуют.

    А вот нас очень волнует, что же тебя не волнует. Спасибо, что держишь в курсе!

     

  • 1.67, anonymous (??), 09:59, 03/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    > Проблем нет также с GPU NVIDIA благодаря продолжению поддержки ветки драйверов NVIDIA для устаревших устройств для всех заявленных платформ.

    Что за ветка? Можно ссылку? А то у меня ядро обновить не получается, ибо новые дрова не поддерживают старое оборудование, а старые дрова не работают с новым ядром.

     
  • 1.75, Аноним (76), 19:14, 03/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Очень странно. С играми на старых, не поддерживаемых драйверах в windows никаких проблем нет, а blender не работает. Хотя может быть потому что игры на direct3d, а blender на opengl.
     
     
  • 2.79, Ordu (ok), 19:25, 03/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Потому что игры тестируются, и как и блендер сейчас вносят в код своих движков воркэраунды? Вон блендер начали тестировать и выяснили, что без воркэраундов никуда.

    А может и потому что opengl.

     
     
  • 3.85, Аноним (85), 07:22, 04/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Потому что опенсорсу все должны, а он никому ничего не должен. Это ж не царское дело, воркараунды делать.
     
     
  • 4.86, Ordu (ok), 09:06, 04/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    К чему ты это сказал? Править баги в драйверах на соответствие стандартам -- это дело того, кто драйвера писал. Особенно если драйвера эти идут пропиетарным блобом. И если ты знаешь какого-нибудь пропиераста, кто думает иначе, то расскажи мне о нём, вместе посмеёмся над идиотом.
     

  • 1.81, Аноним (81), 20:57, 03/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Проблем нет также с GPU NVIDIA благодаря продолжению поддержки ветки драйверов NVIDIA для устаревших устройств для всех заявленных платформ.

    Увы, но это до поры до времени. GeForce 9500 GT скоро вообще дропнется: ядра все новее, а последний драйвер 340х, который последний раз "подрихтовали" под новые ядра где-то в мае прошлого года. Дебиан еще молодцы, у них есть nvidia-legacy. Как в других дистрах с этим не знаю. А между прочим, у меня есть еще даже GeForce 8600 GT :) Да, я могу купить новую видюху, но зачем... Как-то не хочется отправлять на свалку работающие карточки, но, чувствую, придется.

     
  • 1.82, Аноним (82), 03:04, 04/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >>Отмечается, что в Linux ситуация не так критична как в Windows, так как старые драйверы в Linux продолжают обновляться, а пропритеарные драйверы в Windows остаются без сопровождения.

    В Windows проблема с дровами всегда была проблемой номер 1. Помню, при установке Windows, чтобы поставить все драйвера, приходилось возиться с ними битый час, а если каких-то драйверов не хватало на дисках, надо было скачивать нужный драйвер из Интернета. Плюс ко всему, старый драйвер для Mustek негде было найти. Еле скачал тогда.

     
     
  • 2.84, Аноним (85), 07:20, 04/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    То ли дело линукс! Ставил подруге убунту, проблема с вайфаем решилась очень просто — заменой модуля. И хорошо, что ещё ноутбук позволил.
     
     
  • 3.87, zg_nico (ok), 12:06, 04/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Это что ж за экзотика такая стояла? Broadcom? Realtek? На модулях Intel проблемы крайне редко возникают. С Broadcom как правило достаточно дать машине интернет и
    sudo ubuntu-drivers autoinstall
    На realtek - там да, могут быть заморочки: сперва dkms в систему засунуть, после из репозиториев энтузиастов драйвера накатывать...
    Замена самого модуля в большинстве случаев не нужна, - достаточно освоить как и где именно для него надыбать драйвер.
     
  • 3.90, Аноним (81), 23:27, 04/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    >Ставил подруге убунту...

    Ну и? Самое главное не сказал же!

     
  • 3.96, Аноним (95), 09:24, 06/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    А если бы ставил виндоуз то подруга поблагодарила тебя гораздо раньше.
     

  • 1.88, Аноним (-), 15:35, 04/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Ну да навреняка поддержка вида: if эта часть /пока что ещё/ не написана then рендерить софтово.
    Никакого даже близкого сравнения проведено не было...
    Ура ура венде капец - в линуксе есть поддержка драйверами даже при отсутствии видеочипа как такового!
     
  • 1.89, Аноним (89), 22:45, 04/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Уж не знаю, что там на винде, но, товарищи коллеги, может, кто знает, есть ли возможность завести проприетарный opencl на Radeon HD 7660, на чём-нибудь более свежем, чем ubuntu 14.04?

    С месой нужный софт работать отказывается.

    Не то чтобы это была такая уж критическая задача, но странно делать процом то, что видяха должна уметь лучше.

     
     
  • 2.91, KonstantinB (ok), 06:56, 05/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    В 16.04 можно даунгрейднуть ядро до 3.19. Может, так заведется.
     

  • 1.92, Аноним (92), 09:33, 05/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    AMD болт кладут на поддержку старых видюх, очевидно, что по этой причине поддержка в линукс лучше (за счет сообщества), так как 0.00001 больше, чем 0. А интел да, молодцы
     
  • 1.93, Аноним (93), 12:02, 05/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Зато для TeraScale3 под линуксом вообще нет поддержки критически важных OpenCL API. Результат - сложить 2 массива можно, а ни одно серьёзное приложение, будь то GIMP или hashcat, не работает.
     
     
  • 2.94, anonymous (??), 12:35, 05/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Это значит лишь то, что AMD не очень хочет в HPC.
     

  • 1.97, Аноним (97), 12:56, 06/05/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Умиляют новости в стиле "мы лучше винды хоть в чем-то, хотя это все равно никому не надо"
     
     
  • 2.98, anonymous (??), 22:38, 06/05/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Скорее тут про обратное: в Linux наибольшее количество боли с драйверами (в сравнении с Windows) концентрировалось покруг именно GPU (ибо такие гиганты как AMD и NVidia вечно чихали на Linux во всём, что не касается HPC, и никаких вменяемых спец не предоставляют, чтобы можно было самому драйвер написать). Похожая проблема с некоторыми сетевыми устройствами (особенно WiFi), хотя тут обычно всё лечится тупо установкой firmware-файла (который в большинстве дистрибутивов есть из коробки). А тут, видимо, новость про то, что даже в GPU дела не так-то и плохи.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру