The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

07.04.2016 12:00  В RubyGems устранена уязвимость, позволявшая подменять файлы в репозитории

В Rubygems.org, популярном репозиторий модулей для приложений на языке Ruby, выявлена серьёзная проблема безопасности, позволявшая атакующим заменить некоторые gem-файлы на серверах проекта. Для исключения наличия в репозитории подставных файлов была проведена проверка всех файлов, загруженных после 8 февраля 2015 года. Проверка не выявила вредоносной активности.

Проблема затрагивает пакеты, в имени которых присутствует символ дефиса (например, "test-unit"). Неавторизированный пользователь мог заменить подобные gem-файлы на собственные варианты. Суть проблемы сводится к тому, что имена файлов разбирались как "имя_пакета-версия", что приводило к проблемам при наличии дефиса в имени пакета. 2 апреля разработчики RubyGems внесли исправление блокирующее работу присланного им эксплоита, после чего выявили ещё одну уязвимость, которая была устранена 4 апреля. Так как подменённые файлы не соответствуют размещённой для оригинальных пакетов контрольной сумме SHA256, разработчики смогли исключить наличие скрытой подмены. Кроме того, подменённые файлы не могли быть установлены командой "gem install".

Тем не менее, сохранение контрольной суммы SHA256 было введено в практику только 8 февраля 2015 года, т.е. автоматизированно можно проверить только целостность пакетов, размещённых после этой даты. При том, что в качестве даты появления первой узвимости, затрагивающей пакеты с дефисом в имени, называется 11 июня 2014 года. Для более старых пакетов авторам предлагается изучить их целостность самостоятельно, а пользователям применять такие пакеты с большой осторожностью.

Вторая уязвимость, проявляющаяся в пакетах с несколькими версиями объектов S3, присутствует с момента основания RubyGems.org. Разработчики провели анализ более 750 подобных пакетов и сопоставили дату их модификации на сервере c датой создания записи с БД. Для 6 пакетов даты отличались более чем на 5 секунд. Для данных пакетов была выполнена ручная проверка при помощи утилиты diff, которая не выявила проблем.

  1. Главная ссылка к новости (http://blog.rubygems.org/2016/...)
  2. OpenNews: Незащищённость NPM к атакам по внедрению вредоносных модулей-червей
  3. OpenNews: Инцидент с захватом прав на NPM-модуль привёл к сбою в работе проектов, использующих NPM
  4. OpenNews: Каталог RubyGems догнал CPAN по числу модулей
  5. OpenNews: Rubygems.org подвергся взлому
Лицензия: CC-BY
Тип: Проблемы безопасности
Ключевые слова: ruby
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение RSS
 
  • 1.8, Нанобот, 09:06, 08/04/2016 [ответить] [смотреть все]
  • +/
    а что курили новостеклепатели, когда размещали эту новость десятой степени важности в разделе "главные новости"?
     
     
  • 2.9, Аноним, 17:00, 08/04/2016 [^] [ответить] [смотреть все]
  • +1 +/
    Можбыть они хотели всем лишний раз напомнить, что собой представляет экосистема ... весь текст скрыт [показать]
     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:


      Закладки на сайте
      Проследить за страницей
    Created 1996-2017 by Maxim Chirkov  
    ДобавитьРекламаВебмастеруГИД  
    Hosting by Ihor