The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

KDE рассматривает возможность прекращения поддержки старых видеокарт

21.02.2012 21:25

Мартин Грасслин (Martin Gräßlin), ведущий разработчик оконного менеджера KWin, сообщил о намерении прекратить поддержку OpenGL 1.x и удалить соответствующий код. Поддержка устаревших видеокарт в Kwin, выпущенных более шести лет назад, связана с рядом существенных технических трудностей. Кроме того, отмечается, что в настоящее время наибольшее распространение уже получила спецификация OpenGL 2.0, которую поддерживают все более-менее современные графические карты.

К подобным мыслям Мартин пришел наблюдая за стратегией компании Apple, которая прекратит поддержку большого спектра устаревшего оборудования в своей следующей версии Mac OS X 10.8. Это первый релиз, в котором Apple специально удаляет поддержку устаревших систем, отталкиваясь от возможностей GPU, а не типа центрального процессора.

Грасслин классифицирует всё существующее графическое оборудование на две группы: всё что поддерживает хотя бы OpenGL 2.0 и всё остальное. Использование устаревшего оборудования, не поддерживающего OpenGL 2.0, требует поддержки кода во многом несовместимого с первой группой устройств, а попытки его оптимизации и учета особенностей устаревших систем - приводят к "деградации качества всей системы". Попытки сохранения дальнейшей совместимости с уже редким и устаревшим оборудованием, поддерживающим только OpenGL 1.1, заметно повышает сложность сопровождения KWin, что требует дополнительных затрат, как времени, так и материальных ресурсов. Кроме того, устаревшее оборудование уже почти невозможно купить, поэтому поддержка большинства устаревших систем остаётся непротестированной.

Так, по словам Грасслина, OpenGL 2.0 поддерживается на чипах ATI/AMD начиная с R300 (Radeon 9500) и с 2002 года, в продукции NVIDIA - начиная с модели NV40 (GeForce 6), которая вышла в 2004 году, а на картах Intel начиная с модели i965, которая была выпушена в 2006 году. Таким образом, чипы с поддержкой OpenGL 2.0 доминируют на рынке уже как минимум 6 лет.

Впрочем, в таком подходе не все так просто. Например, Мартин указывает, что проприетарный драйвер AMD Catalyst (fglrx) обеспечивает приемлемую производительность операций, используемых в композитном режиме KWin, только при задействовании непрямого (indirect) рендеринга, доступ к которому возможен только через API OpenGL 1.x. Таким образом удалив поддержку OpenGL 1.x, придется отказаться от поддержки композитного режима на базе OpenGL для всех систем, использующих драйвер fglrx, даже если GPU поддерживает OpenGL 4. При этом открытый драйвер radeon не испытывает проблем с OpenGL 2 на том же оборудовании. Тем не менее, Грасслин говорит, что он не ставит перед собой цель перестать поддерживать проприетарные драйверы, поэтому поддержка Catalyst будет сохранена.

В качестве универсального решения для всех владельцев устаревшего оборудования рассматривается использование Gallium3D-драйвера llvmpipe, входящего в последние версии Mesa и предназначенного для осуществления полностью программного 3D-рендеринга (требующие привлечения GPU операции преобразуются в промежуточное представление LLVM и затем транслируются в стандартный машинный код для архитектур x86 или x86-64). В частности, данный драйвер планируется использовать в Fedora 17 для запуска GNOME Shell на устаревших картах. Грасслин собирается протестировать производительность и возможности входящего в состав Mesa 8.0 драйвера llvmpipe применительно и к KWin. Если итоговая производительность будет на приемлемом уровне, то в KWin будет обеспечена поддержка работы через llvmpipe, что облегчит принятие трудного решения по отказу от поддержки устаревшего OpenGL 1.x.

  1. Главная ссылка к новости (http://blog.martin-graesslin.c...)
  2. OpenNews: Оболочка GNOME Shell адаптирована для работы без 3D-драйверов
  3. OpenNews: Релиз Mesa 8.0 с поддержкой OpenGL 3.0
Автор новости: Igor Savchuk
Тип: Тема для размышления
Короткая ссылка: https://opennet.ru/33158-kwin
Ключевые слова: kwin, llvmpipe, catalyst, kde, opengl
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (110) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 22:09, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +16 +/
    теперь как в windows - все что старее 5 лет, поддерживать не будем?
     
     
  • 2.2, Kels (ok), 22:14, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Новость не читаем? Там написано что ATI поддерживает 2 версию с 2002 года. Уже 10 лет.
     
  • 2.5, Аноним (-), 22:33, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +30 +/
    Учитывая сколько ресурсов кушает современный KDE, ему можно хоть сразу на OpenGL4.0 переходить. Владельцы карт только с OpenGL 1.x и так не могут толком работать с KDE 4.x.
     
     
  • 3.9, emg81 (ok), 22:38, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > Учитывая сколько ресурсов кушает современный KDE, ему можно хоть сразу на OpenGL4.0
    > переходить. Владельцы карт только с OpenGL 1.x и так не могут
    > толком работать с KDE 4.x.

    ндэ? стояла GT 6600 - ничего не тормозило.
    со всеми эффектами. какжетак?

    если у Вас тормозят кеды - то, скорее всего, Вы просто не умеете их готовить :)

     
     
  • 4.17, Михрютка (?), 23:13, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +10 +/
    > если у Вас тормозят кеды - то, скорее всего, Вы просто не
    > умеете их готовить :)

    если для готовки надо 4 гига памяти и немеряный И/О, то ну его нафиг такие кеды. съехал на LXDE, его не надо уметь готовить, он и так работает.


     
     
  • 5.24, a (??), 23:53, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Доо, расскажи это моему нетбуку с полгигом оперативы. Руки чини.
     
     
  • 6.26, arisu (ok), 23:54, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +10 +/
    > Доо, расскажи это моему нетбуку с полгигом оперативы

    на кеды хватает, да. жаль, что больше ни на что.

     
     
  • 7.32, Сергей (??), 00:12, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +1 +/
    На 384 MB нормально работает XBMC с KDE4 в фоне на GeForce MX 440
     
     
  • 8.35, Михрютка (?), 00:43, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • –1 +/
    замечательно а у меня rdesktop в 256 МВ нормально работал с KDE4 в фоне и чо ... текст свёрнут, показать
     
  • 8.105, Аноним (-), 23:38, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    У меня на пентиум 2 с 250М с чем то МБ оперативки набранных их всякого мусора ке... текст свёрнут, показать
     
  • 7.63, анонимус (??), 11:31, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    а что ещё кроме кед нужно?
     
  • 5.29, emg81 (ok), 00:02, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • –1 +/
    странно, я 2 года с KDE прожил на 1 гигабайте памяти ничего не свопилось, и i o... большой текст свёрнут, показать
     
     
  • 6.34, Михрютка (?), 00:37, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    я в курсе, что если выключить там семантический десктоп, поиск, PIM, и не пользо... большой текст свёрнут, показать
     
     
  • 7.39, anon2048 (?), 01:55, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    >семантический десктоп, поиск, PIM

    Ага, прям три четверти KDE

     
     
  • 8.55, Аноним (-), 09:56, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Три четверти, не три четверти, а по функционалу KDE становиться разнозначен XFCE... текст свёрнут, показать
     
     
  • 9.96, Аноним (-), 19:41, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Ну у меня с Nepomuk индексация выделено на задачи индексации 50 Мб и Akonadi с... текст свёрнут, показать
     
  • 7.67, terr0rist (ok), 13:40, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > если выключить там семантический десктоп, поиск, PIM

    очень хочется посмотреть на того гика, который этим пользуется

    > не пользоваться никакими плазмоидами, кроме таймера

    толку от этих плазмоидов, когда работаешь с полноэкранными приложениями

    > три четверти KDE

    да можно хоть 99/100 выкосить - думаю, визуально ничего не изменится

    И всё-таки я юзаю КДЕ. Почему?
    1. У меня XFCE и LXDE глючат (может быть, из-за того, что под фряху недопилены)
    2. Гном 3 "ниасилил"
    3. В принципе, в кедах есть все нужные мне "мелкие" приложения, и некоторые из них нечем заменить: копыта (kopete), катя (kate), таймер, гвенвью и пр. - намного лучше аналогов из других ДЕ и вообще имеющихся аналогов. (имхо)
    Я бы и дальше юзал IceWM или openbox, но для этих приложений один хрен кеды загружаются.

     
     
  • 8.103, ыфырф (?), 21:57, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    А какие есть альтернативы Gwenview желательно лёгкие ... текст свёрнут, показать
     
  • 8.113, Аноним (-), 23:53, 23/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Для меня это только дельфин В других ДЕ или ВМ нету достаточно юзабильных ФМ ... текст свёрнут, показать
     
  • 6.72, Аноним (-), 14:21, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > странно, я 2 года с KDE прожил на 1 гигабайте памяти. ничего не свопилось, и i/o не зашкаливал.

    Герой. Не тормозит KDE 4. На гигабайте памяти.

    > я тут не раз писал, что добился потребления в 130-140 мб после загрузки с KDE.

    А я добиваюсь полноценной работы Linux на 128 Мб памяти, с KDE и несколькими запущенными приложениями, включая приложения GTK. KDE версии 3, на котором мной ничего не отключалось, не урезалось, обои и виртуальные рабочие столы не выключены. Разработчики KDE 4 что-то делают не так, их обновлённое DE увеличило потребление памяти более чем в 2 раза.

     
     
  • 7.86, Аноним (-), 16:13, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    В 2003 «работу Linux на 128 Мб памяти, с KDE и несколькими запущенными приложениями, включая приложения GTK. KDE версии 3, на котором мной ничего не отключалось, не урезалось, обои и виртуальные рабочие столы не выключены», трудно было назвать полноценной из-за непрерывного своппинга.

    Кроме того, слова «добиваюсь полноценной работы» и «на котором мной ничего не отключалось, не урезалось, обои и виртуальные рабочие столы не выключены» противоречат друг другу.

     
  • 6.106, Аноним (-), 23:48, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > ставится nouveau

    Подытожил ) Только хочется хорошей работы и на блобе.
    Еще многих раздражает, что менюшки открываются не мгновенно, а ощутимые доли секунды. например, дельфин секунды 2-3 на мощной тачке. И при повторном открытии не быстрее. Анимация не совсем плавная.
    Многие элементарные действия невероятно грузят КПУ. Про непомуки уж молчу, просто поводите в дельфине мышкой над файлами - папками - проц загружен на половину (4 ведра, ага). Это нормально? Двигаю окошко туда-сюда - загрузка проца 20%
    В кедах что-то категорически не так. и хотя в последнем релизе стало немного лучше (в основном потому, что я проапгрейдился), до нормальной работы еще как до Китая...

     
     
  • 7.136, qux (ok), 15:27, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > Про непомуки уж молчу, просто поводите в дельфине мышкой над файлами - папками - проц загружен на половину (4 ведра, ага). Это нормально?

    Если у вас включено отображение информации про содержание каталогов при наведении мыши — да, это нормально.

    > Двигаю окошко туда-сюда - загрузка проца 20%

    А если включить перетаскивание контура?

    > до нормальной работы еще как до Китая...

    Только сидя на стуле ровно, в Китай почему-то не попадают.

     
     
  • 8.137, arisu (ok), 16:06, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    ага то есть, Quake I в софтварном режиме вполне могла достаточно плавно бегать ... текст свёрнут, показать
     
     
  • 9.138, qux (ok), 17:53, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Не передергивайте Даже если все ровно так, 20 8212 это не то, что тормоза ... текст свёрнут, показать
     
     
  • 10.139, arisu (ok), 18:22, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    это атомный ужас, вообще-то ну, или пусть мне пояснят, почему рендер окна жрёт ... текст свёрнут, показать
     
     
  • 11.140, qux (ok), 18:35, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    А вы свою поверхность подвигайте в процессе закраски, причем чтобы закраска не о... текст свёрнут, показать
     
     
  • 12.141, arisu (ok), 18:38, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    таки двигается внутри SDL-окна и само окно тоже подвигал, но всё равно не выжир... текст свёрнут, показать
     
     
  • 13.142, qux (ok), 18:46, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    На этом этапе появляется стойкое ощущение что с одной из черепашек что-то не так... текст свёрнут, показать
     
     
  • 14.143, arisu (ok), 18:56, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    ну да, читерство нет кед, выключен в пень всякий 171 композитинг 187 и проч... большой текст свёрнут, показать
     
     
  • 15.144, qux (ok), 19:10, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    По-моему в том числе и на это стоит обращать внимание 8212 две ну очень б... текст свёрнут, показать
     
     
  • 16.145, arisu (ok), 19:35, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    действительно, совсем ерунда эти пользователи совсем уже обнаглели сказано же ... текст свёрнут, показать
     
     
  • 17.146, qux (ok), 20:27, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Кстати, попробовал на машине 6-летней давности перемещение окна с содержимым, с... текст свёрнут, показать
     
     
  • 18.147, arisu (ok), 20:50, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    а какой именно из цифр следует быть недовольным больше пятёркой или нулём ... текст свёрнут, показать
     
     
  • 19.148, qux (ok), 21:09, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Пардон, но это ведь вы цифрами недовольны Вот и скажите Я против них как таков... текст свёрнут, показать
     
     
  • 20.149, arisu (ok), 21:24, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    я цифрами O_O тут уже даже не 171 отсыпь 187 , тут что-то тяжёло-синтетичес... текст свёрнут, показать
     
  • 21.150, qux (ok), 21:30, 25/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Вы о чем По треду была хоть одна причина обращать внимание на производительност... текст свёрнут, показать
     
  • 4.38, Аноним (-), 01:39, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > GT 6600

    Эта видеокарта поддерживает OpenGL >2.x

     
  • 4.83, GoSha (?), 15:25, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +4 +/
    если у Вас тормозят кеды - то, скорее всего, Вы просто не умеете их готовить ... большой текст свёрнут, показать
     
  • 3.56, trdm (ok), 10:13, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +4 +/
    >> Учитывая сколько ресурсов кушает современный KDE, ему можно хоть сразу на OpenGL4.0 переходить.

    +1
    У меня вообще встроенная видуха.
    нафига мне жфорс, если я в основном программингом занимаюсь?
    Все попытки поюзать КДЕ4 заканчивались кислой миной и гудбаем.

     
     
  • 4.108, Аноним (-), 23:50, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    У меня на встроенной, на слабом ноуте работает нормально. интел 4500
     
  • 2.8, emg81 (ok), 22:37, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    с другой стороны, если поддержка старого оборудования стоит много времени, то раз в несколько лет можно и обновиться.

    и да, если хотите, могу продать Вам по-дешёвке свою GT6600 (рублей за 200-300) - рабочая, неслышимая. 2004 г.в. даже с усечением поддержки карт будет поддерживаться.
    (*trollface*)

    а серьёзно: как по мне, так время разрабов на поддержку устаревшего кода уж куда более значимо, чем 20-30 долларов на новую карточку раз в несколько лет.

    да и хотеть от *волонтёров* поддерживать десятилетиями оборудование, которое давно устарело - не очень рациональный вариант.

    всё вышесказанное - имхо.

     
     
  • 3.15, Михрютка (?), 23:09, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    >да и хотеть от *волонтёров* поддерживать десятилетиями оборудование, которое давно устарело - не очень рациональный вариант.

    это вы чо-та путаете, десятилетиями (ровно одним десятилетием) пока только микрософт поддерживает с айбиэмом.

    волонтерам дай бог хоть три года осилить.

    вон редхат и на пять-то лет для своей пятеры расщедрился, только когда оказалось, что что-то на шестерку мигрировать народ не торопится.

    микрософт, кстати, для XP срок поддержки продлил ровно по той же причине. но это капиталисты, фуле, их не свобода интересует, а деньги клиентов.

     
     
  • 4.30, Аноним (-), 00:04, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > вон редхат и на пять-то лет для своей пятеры расщедрился, только когда
    > оказалось, что что-то на шестерку мигрировать народ не торопится.

    Вы явно отстали от жизни, у RHEL штатная поддержка 10 лет + 2 дополнительных года за отдельные деньги. RHEL 5 будет до 2019 года поддерживаться.

    Даже десктопные LTS-релизы Ubuntu  и то уже 5 лет поддерживаются.

     
     
  • 5.33, Михрютка (?), 00:21, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > Вы явно отстали от жизни, у RHEL штатная поддержка 10 лет +
    > 2 дополнительных года за отдельные деньги. RHEL 5 будет до 2019
    > года поддерживаться.

    а, да, правильно, на пару недель отстал :) в начале февраля продлили.

    > Даже десктопные LTS-релизы Ubuntu и то уже 5 лет поддерживаются.

    ну так денежку за суппорт получать захочешь - и не так раскорячишься. А, и да, вы явно поторопились от жизни - 5 лет саппорта получит пока только еще не зарелизенный 12.04. Остальные как жили по 3 года, так и живут.


     
  • 4.31, emg81 (ok), 00:07, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    >>да и хотеть от *волонтёров* поддерживать десятилетиями оборудование, которое давно устарело - не очень рациональный вариант.
    > это вы чо-та путаете, десятилетиями (ровно одним десятилетием) пока только микрософт поддерживает
    > с айбиэмом.

    ну почему же... недавно (конец или середина 2011 года) из nouveau код исключали древних в/карт.
    очень древних. которым по 8-10 и более лет.
    по-моему, это неплохой срок.

     
     
  • 5.37, Михрютка (?), 01:16, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > ну почему же... недавно (конец или середина 2011 года) из nouveau код
    > исключали древних в/карт.
    > очень древних. которым по 8-10 и более лет.
    > по-моему, это неплохой срок.

    ну так нвидия у себя давно так делает, два пакетика держат.

    здесь немножко не та ситуация, здесь приблизительно как тов. Кармак волевым решением решает выпилить из Rage, допустим, поддержку DirectX 9.

     
  • 4.65, fi (ok), 13:30, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > это вы чо-та путаете, десятилетиями (ровно одним десятилетием) пока только микрософт поддерживает с айбиэмом.

    Ой не надо!!! помню сам регулярно напарывался на неподдержку оборудования буквально через несколько лет. Тот же 95 пришлось заменить на пиратский 98  после установки драйверов для видяхи - система больше не грузилась.

    А как ОС/2 выпендривалась!!!

     
  • 2.11, Vkni (ok), 22:50, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > теперь как в windows - все что старее 5 лет, поддерживать не
    > будем?

    Виндоуз, сама по себе, поддерживает железо и 7-ми летней давности. Собственно, с него я сейчас и пишу - Toshiba Portege M400/4Gb ОЗУ/T7000/250Gb, Винды 7-е.

     
     
  • 3.23, ананим (?), 23:42, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    А как же свиста?
    А то есть народ который и её покупал.
     
     
  • 4.42, skybon (ok), 03:10, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    А Виста - это фейл. Фейлы не обсуждают, а сливают в помойку.
     
  • 4.47, Vkni (ok), 06:01, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > А как же свиста?
    > А то есть народ который и её покупал.

    Ну там всё просто - 3-й Service Pack к Висте называется Windows 7. И он платный. :-)

     
  • 2.25, arisu (ok), 23:53, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > теперь как в windows - все что старее 5 лет, поддерживать не
    > будем?

    а что за проблема? что жЫзнь есть только в кедах?

     

     ....большая нить свёрнута, показать (52)

  • 1.3, Аноним (-), 22:20, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    хочу эффекты в квине на ОГЛ 4.2 :)

     
  • 1.4, brzm (?), 22:23, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +7 +/
    Все верно. Взгромождать свежие кеды на старое железо уже сложно не только из-за GPU. На моем Celeron D420 всё ой как медленно ворочается, openbox и прочий легковесный софт удачно спасает положение.
     
  • 1.6, Аноним (-), 22:33, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Давно пора.
     
  • 1.10, xxx (??), 22:40, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Главное чтобы оставили пользователям возможность удалить сам KWin.
     
     
  • 2.98, megabaks hater (?), 20:13, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    megabaks detected!
     

  • 1.12, Аноним (-), 22:55, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    > Если итоговая производительность будет на приемлемом уровне

    В смысле, если проц будет загружен на 99% и 1% не будет хватать до явного проявления тормозов?! А ведь от разрабов KDE легко подобного можно ожидать, учитывая как они любят прослойки над прослойками писать, да непомуки и аконади придумывать. Тьфу.

    Внешний вид и производительность - последнее о чём думают разработчики KDE, в первую очередь они думают о кое-как ворочающихся технологиях, лишь бы были прогрессивными. От скринов с Oxygen до сих пор подташнивает.

     
     
  • 2.18, Vkni (ok), 23:22, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • –5 +/
    > Внешний вид и производительность - последнее о чём думают разработчики KDE, в
    > первую очередь они думают о кое-как ворочающихся технологиях, лишь бы были
    > прогрессивными. От скринов с Oxygen до сих пор подташнивает.

    Как вот это - http://xwinman.org/screenshots/olwm.gif ?

     
     
  • 3.64, el torito (?), 13:03, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Wow, OpenLook! :)
    Кстати, исключая всякие несовременные рамочки окон - набор контролов был задуман и исполнен весьма хорошо (в смысле Look&Feel). Даже жаль, что умер.
     

  • 1.13, Михрютка (?), 23:02, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Это еще ничего, это цветочки. Вот начнется добровольно-принудительное внедрение Вейланда, это да. Особенно владельцы всех без исключения нвидиевских карт возрадуются, когда им предложат жрать нуво или написать самим и не выё^W чирикать.

     
     
  • 2.19, Vkni (ok), 23:23, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Вот начнется добровольно-принудительное внедрение Вейланда,

    Есть надежда, что оно сдохнет, как предшественники - svgalib и DirectFB.


     
     
  • 3.27, arisu (ok), 23:56, 21/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    а я снова спрошу, когда это diretcfb умудрился сдохнуть, и каким образом «дохлый» проект умудряется даже нанимать людей на зарплату.
     
     
  • 4.41, Crazy Alex (ok), 02:33, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Тем не менее идея "вейланд место иксов"как-то совсем не радует. В том числе потому что там, судя по всему, не будут толком работать тайловые wm, на которых я сижу уже лет пять.
     
     
  • 5.48, kshetragia (ok), 06:04, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Куда ж они денутся? Напрямую не будут. Но для тайловых менеджеров разницы никакой.
     
  • 4.57, Vkni (ok), 10:16, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > а я снова спрошу, когда это diretcfb умудрился сдохнуть, и каким образом
    > «дохлый» проект умудряется даже нанимать людей на зарплату.

    Я это к тому, что ажиотаж спал. :-)

     
     
  • 5.66, arisu (ok), 13:37, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > Я это к тому, что ажиотаж спал. :-)

    ну так не дезинформируй же народ тогда. не будем уподобляться проприетарным крикунам, у которых живые проекты внезапно оказываются «дохлыми».

    а ажиотажа особого и не было, кстати. проект весьма нишевый же, никогда не стермился «захватить десктопы».

     

  • 1.14, хамелеон (?), 23:03, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Ну если это действительно упростит разработку kwin то конечно, это наверное оправданное решение. К тому же старые карты будут поддерживаться при помощи  llvmpipe.
    Сам имею GF6600, год выпуска 2004, поддерживается opengl 2. Эффекты кде не тормозят, единственное нету vdpau поэтому не все видео тянет. В связи с покупкой 24" монитора это стало актуально и компутер надо менять.
     
  • 1.16, NavDotRu (?), 23:11, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    до сих по радуюсь что ноут с 5870 купил :)
     
  • 1.20, Lenovo (?), 23:29, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    На ноуте (Intel P8400 2.2GHz, Nvidia 9300M GS) юзаю KDE, включены несколько несложных эффектов.
    Когда эти эффекты задействованы (плавное появление/исчезновение, прозрачность и тени под окнами), кулер начинает работать сильнее, и загрузка процессора несколько десятков процентов.
    Как-то это всё не очень быстро работает, товарищи.
     
  • 1.21, Аноним (-), 23:33, 21/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Насколько я понял, речь идет о композитном режиме. Без него все прекрасно работает. Мне, например, эффекты мешают работать и я их не включаю, хотя железо позволяет.
     
     
  • 2.59, Frank (ok), 11:04, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    У меня в гноме с компизом десктоп шустрее, чем на метасити. Интеграшка интеловская в corei3 первого поколения.
    Кстати, насчёт "все умеют 2.0":

    $ glxinfo | grep version
    server glx version string: 1.4
    client glx version string: 1.4
    GLX version: 1.4
    OpenGL version string: 2.1 Mesa 7.11
    OpenGL shading language version string: 1.20

    Так что КДЕ - ССЗБ, хотят выпилить себя со всех ноутов с интеловскими интеграшками. Если, конгечно, к тому времени интеловские дрова не доведут до 2.0 полностью (что очень хотелось бы, дабы поиграть в oil rush, а то сейчас нет текстур).

     
     
  • 3.61, Аноним (-), 11:21, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Вы сравниваете Гном2 с КДЕ4. Это некорректно. Может тогда сравним Гном3 с КДЕ3? Так же некорректно сравнивать производительность гнома в разных режимах и сделать вывод что КДЕ не может обойтись без композитного режима.
     
     
  • 4.71, anonimous (?), 14:07, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Вы хотите сказать что KDE4 быстрее/отзывчивее/менне_прожорливо чем Gnome3?
    P.S. За юзабилити молчу, это дело личное.
     
     
  • 5.73, Аноним (-), 14:22, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Нет. Я хочу сказать то, что я написал.
     
  • 5.76, Аноним (-), 14:40, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    >У меня в гноме с компизом десктоп шустрее, чем на метасити.
    >Так что КДЕ - ССЗБ, хотят выпилить себя со всех ноутов с интеловскими интеграшками.

    Логику прослеживаем?
    Гном2 в метасити плохо работает, поэтому КДЕ4 нужно выпилить с ноутов, т.к. композитный режим не поддерживается. Странные выводы. А может выпилить Гном3, т.к. ему тоже нужна современная видеокарта и оставить КДЕ3? Надеюсь вы меня поняли. Добавлю что КДЕ4 без проблем работает и без композитного режима. Шум пытаются поднять гномеры, которые забывают про требования к видеокарте у Гнома3.

     
     
  • 6.80, anonimous (?), 14:56, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Про требования к видеокартам в гноме3 все ясно - fallback mode есть и он работает.
    А вот будет ли  fallback mode в KDE, и будет ли он шустрее гномовского - вопрос не ясный.
     
     
  • 7.82, Аноним (-), 15:16, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    >А вот будет ли  fallback mode в KDE...

    Что значит будет? Он есть и работает, только не называется fallback mode.

     
  • 7.84, Аноним (-), 15:28, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Еще в КДЕ (вернее в Qt) есть режим QT_GRAPHICSSYSTEM=raster, который по умолчанию выключен. Включение этого режима увеличивает скорость отрисовки виджетов в ~10 раз. Это работает без композитного режима. Попробуйте. Возможно в гноме есть аналог, не знаю про это.

    Если в КДЕ удалить аконади и непомук, то он меньше жрет оперативки, примерно на ~100 Мб.

    А вообще, "забота" гномеров о КДЕ зашкаливает.

     
  • 4.95, Frank (ok), 18:43, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > Вы сравниваете Гном2 с КДЕ4. Это некорректно. Может тогда сравним Гном3 с
    > КДЕ3? Так же некорректно сравнивать производительность гнома в разных режимах и
    > сделать вывод что КДЕ не может обойтись без композитного режима.

    В каком месте я сравниваю гном с кедами, когда говорю о compiz vs metacity?

     
  • 3.74, Apple (?), 14:23, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +1 +/
    И что не так у вас? OpenGL версия у вас 2.1, в чём проблема?
     
     
  • 4.94, Frank (ok), 18:35, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > И что не так у вас? OpenGL версия у вас 2.1, в
    > чём проблема?

    Проблема в его полноценности, а точнее наоборот: http://ubuntuone.com/2QpF1QiuXFPoK3H2DCG2Kz

     

  • 1.36, Аноним (-), 01:04, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    вот кстати грамотная проработка вопроса! плюсую
     
  • 1.40, Пиу (?), 02:04, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    хныыыааа, мой ati radeon 9200!!!
    только закончил ремонтировать
     
  • 1.44, skybon (ok), 03:14, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Кеды разве работают на железе 06 года? Давно пора.
     
     
  • 2.51, Флинт (?), 07:24, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    пишу с железки 2004 года.. с интегрированной видяшкой от интел.. ежели отключить всякие красявости - вполне сносно все работает.
     

  • 1.46, ILYA INDIGO (ok), 05:27, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Все видюхи на PCIE однозначно поддерживают openGL 2.0, возможно да же некоторые AGP, ещё более 10 лет давности.
    Я только за, что бы выкинуть этот мусор!
     
     
  • 2.68, ФФ (ok), 13:48, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    С большинством AGP появятся проблемы.
     
  • 2.112, Проходящий (?), 21:38, 23/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > Все видюхи на PCIE однозначно поддерживают openGL 2.0

    И GeForce PCX? :)
    Плюс у атомных недокомпов тоже начнется попаболь, ибо их видеоядро 2.0 не умеет.

     

  • 1.50, Daemontux (ok), 06:38, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Как вариант в место kwin можно openbox использовать.
     
  • 1.52, QuAzI (ok), 08:49, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Блин... пусть сначала винду 2002-го года обгонят, оптимизаторы. Новое мы ещё не умеем нормально (дрова сырые или их нет), а старое УЖЕ не умеем. Мегалол
     
     
  • 2.85, Аноним (-), 15:38, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > Блин... пусть сначала винду 2002-го года обгонят, оптимизаторы. Новое мы ещё не умеем нормально (дрова сырые или их нет), а старое УЖЕ не умеем. Мегалол

    Не согласен. Эффекты переноса окон с 2D-ускорением, а не только её рамочки, всякие там всплывающие подсказки и масштабируемые значки KDE умеют столько же, сколько их умеет Windows. Кроме того, они умеют виртуальные рабочие столы, которые в Windows не было никогда. А 3D-эффекты Compiz и Beryl 2007 года превосходят аналогичные эффекты Aero в Windows в производительности и красивости. Compiz в KDE работает тоже.

     
     
  • 3.88, Пыщ Я Бетмен (?), 16:52, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Я за вас очень... только например теперь офисным работникам для их пишущих машинок на весьма не сегодняшнем железе придётся докупать видяхи умеющие тыщу ненужных плюшек. Стоимость которых нынче поболе чем новая материнка со встроенной видяхой... но материнку менять не рентабельно т.к. с ней вместе меняются ОЗУ и проц... а хотя они 50/50 и так меняются, т.к. AGP уже не у дел. Опупенно так соптимизировали.
    Вопеть "старьё ненужно" тут будут только те неадекваты, которым не надо штат машин поддерживать и которые только задницу в играх просиживать горазды.
     
     
  • 4.91, arisu (ok), 17:37, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    или адекваты, которые знают, что для «офисных работников» кеды со свистоперделками без нужды. а Крутые Одмины, которые умеют «дальше-дальше-финиш» — те да, будут исходить визгами «всёпропало!!!»
     
     
  • 5.92, Пыщ Я Бетмен (?), 17:54, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Ога, так и рвану с места поднимать везде OpenBox из консоли.
     
  • 3.110, анонимм (?), 02:39, 23/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > виртуальные рабочие столы, которые в Windows

    всегда были

     
     
  • 4.111, arisu (ok), 02:55, 23/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    >> виртуальные рабочие столы, которые в Windows
    > всегда были

    …в теории — как в любой оконной системе. а на практике — увы, две с половиной вменяемых программы для этого, о которых «обычный юзер» и не подозревает.

     

  • 1.54, Анон (?), 09:37, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Все правильно делают. Нельзя же вечно поддерживать все оборудование. А то приходился или отказаться от современных фич, или пилить поддержку и тестировать для всех-всех видеокарт.
     
  • 1.60, trdm (ok), 11:14, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Кстати, разве не ядро Linux апараткой занимается?
     
     
  • 2.69, openclocker (ok), 13:57, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Дело в том, что композитный менеджер, очень тесно взаимодействует с выч. машиной и системой. Поэтому немного архитектуро-зависимая.
    PS Может чуть ошибаюсь, но суть в этом.
     

  • 1.62, openclocker (ok), 11:29, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Новость мне нравиться, единственно: "...проприетарный драйвер AMD Catalyst (fglrx) обеспечивает приемлемую производительность операций, используемых в композитном режиме KWin, только при задействовании непрямого (indirect) рендеринга, доступ к которому возможен только через API OpenGL 1.x. Таким образом удалив поддержку OpenGL 1.x, придется отказаться от поддержки композитного режима на базе OpenGL для всех систем, использующих драйвер fglrx, даже если GPU поддерживает OpenGL 4...". Я себе думаю ноут (или ультрабук) купить на Тринити.

    А для старого оборудования есть Razor-Qt.

     
     
  • 2.81, openclocker (ok), 15:06, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Поддержка старого оборудования - это хорошо, но есть проблема. Для ее поддержки требуются люди, в которых нехватка. ИМХО
     
     
  • 3.89, Пыщ Я Бетмен (?), 16:54, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    > требуются люди, в которых нехватка. ИМХО

    Adobe тоже так сказал и свернул поддержку лялеха

     
     
  • 4.107, openclocker (ok), 23:49, 22/02/2012 [^] [^^] [^^^] [ответить]  
  • +/
    Adobe делает деньги, а KDE - ПО. Соответственно, первые без проблем могут брать на работу сотрудников, а у вторых волонтеры, а их, и без поддержки устаревшего оборудования, есть куда направить.
     

  • 1.78, когданепускаютонанима (ok), 14:43, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >В качестве универсального решения для всех владельцев устаревшего оборудования рассматривается использование Gallium3D-драйвера llvmpipe

    Ну дык надо к нему еще кокой-нить llvmpipeogl1 сверху прихлабучить. )

     
  • 1.79, когданепускаютонанима (ok), 14:44, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    llvmpipe | llvmpipeogl1 > профит
     
  • 1.87, DJa (?), 16:24, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > если у Вас тормозят кеды - то, скорее всего, Вы просто не умеете их готовить :)

    +100500

    Линух тем и хорош, что в отличие от оффтопика предоставляет выбор: не нравится/не осилил - не пользуй/форкни. А какашки метать, это, как говорится, малолетний долбо#б - это не возраст, это состояние мозга.

    А плазма уже давно (как минимум с 4.5) не падает! 3:-[

     
  • 1.90, Аноним (-), 17:20, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А я вообще не включаю kWin, хотя видюха - какая-то современная nvidia. Не хочу проприетарные дрова пускать, да и особой необходимости нет.
     
  • 1.93, Аноним (93), 17:56, 22/02/2012 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    В gnome 3 не будет fallback, т.к. будет поддержка llvmpipe.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру