The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

В Ubuntu рассматривается возможность ежедневного обновления версий программ

24.11.2010 04:56

В интервью изданию TheRegister Марк Шаттлворт сообщил о намерении обеспечить возможность установки самых свежих версий программ для пользователей Ubuntu. Установка новых версий приблизит функциональность Ubuntu к таким дистрибутивам, как ArchLinux и PCLinuxOS, разрабатываемым в рамках модели непрерывных обновлений (Rolling-release), при которой обновления пакетов выходят постоянно и пользователь в любой момент имеет возможность перейти на последние версии программ без ожидания формирования очередного релиза дистрибутива.

По мнению Шаттлворта, применяемый сегодня шестимесячный цикл выпуска релизов Ubuntu слишком большой срок для интернет-ориентированного мира, пользователи Ubuntu должны иметь возможность установки новых выпусков почти каждый день. Данная область является ключевым направлением развития дистрибутива в последующие пять лет. Первым шагом по направлению к поставленной цели является добавление в интерфейс Software Center возможности быстрой установки новых версий наиболее востребованных программ. В релизе Ubuntu 10.04 такая функция была реализована через упрощение подключения PPA-репозиториев.

Для будущих выпусков планируется создание специального постоянно обновляемого дополнительного репозитория и добавление функции отслеживания новых версий программ в Software Center. Пользователи будут иметь возможность выбора: какую программу обновить до последней версии, а для какой программы устанавливать только обновления критических ошибок и проблем безопасности. При этом на одной чаше весов будут стабильные и хорошо протестированные пакеты с не самыми свежими версиями программ, а на другой наиболее функциональные и новые, но ещё не достаточно проверенные, последние версии. Наиболее вероятно, что в новом репозитории будет размещена лишь небольшая коллекция новых версий наиболее популярных пакетов, поддержкой которых будут заниматься их майнтейнеры и разработчики, уже поддерживающие с аналогичной целью свой PPA-репозиторий.

Дополнение: Директор по маркетингу платформы в компании Canonical, объяснил:

"Ubuntu не становится rolling-дистрибутивом. Мы уверены, что наши пользователи, партнёры и экосистема свободного/открытого программного обеспечения прекрасно удовлетворены нашим текущим темпом обновлений и релизов. Статья, упоминавшаяся ранее, возможно относилась к возможности того, чтобы сделать самые свежие версии приложений доступными для разработчиков (ПО), пользующихся Ubuntu. Это далеко идущий проект, над которым мы активно работаем в процессе нормального процесса планирования".



  1. Главная ссылка к новости (http://www.theregister.co.uk/2...)
  2. OpenNews: Ubuntu вводит практику рецензирования новых программ
  3. OpenNews: В Ubuntu 10.10 может появиться поддержка установки новейших версий программ
  4. Ubuntu is *not* moving to a rolling release
Лицензия: CC-BY
Тип: К сведению
Короткая ссылка: https://opennet.ru/28751-ubuntu
Ключевые слова: ubuntu, linux, packet
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (139) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 05:20, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Странный мир, Mandriva перешла к выпуску релизов раз в год, а Ubuntu становится мало полгода. Мне лично с лихвой хватает PPA. По сути, программ обновления для которых хотелось бы видеть постоянно не так много, wine, web-браузеры и пожалуй все, остальное можно подождать пару месяцев.
     
     
  • 2.3, ячсячс (?), 06:08, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –18 +/
    >Мне лично с лихвой хватает PPA

    Ох лол, красноглазики соглашаются ставить левоту с потенциальными троянами и зловредами, да еще с такой в радостью, ппц.

     
     
  • 3.22, Zenitur (?), 09:39, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Не в этом дело я всегда называю одним из главных недостатков Убубна невозможнос... большой текст свёрнут, показать
     
     
  • 4.28, Имя123 (ok), 10:23, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > А PPA - костыль и не выход

    вот  странно же... сначала вы говорите, что _ТЕХНОЛОГИЯ_ PPA это "костыль"

    ...а потом обосновываете свой ответ тем что их маленькое _количество_ ("20-30 самых популярных программ")

    :-D :-D :-D :-D

    определитесь же наконец(!), что вам не нравиться? то что их _мало_ , или то как это _технически_ работает? :-)

     
     
  • 5.35, Wormik (??), 10:59, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Заливаешь исходник и спек на сервер - получаешь программу. Вы хоть сами смотрели, ЧТО туда заливают?
     
  • 4.62, Зилибоба (ok), 14:55, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Простому пользователю компилировать лениво. Ни кто не мешает скомпилить исходник последнего вайна и поставить его самому.
     
  • 4.64, Аноним (-), 15:14, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    создан extras.ubuntu.com - это что?

    РРА - мутная весчь, согласен.

     
  • 3.31, Аноним (-), 10:48, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >>Мне лично с лихвой хватает PPA
    > Ох лол, красноглазики соглашаются ставить левоту с потенциальными троянами и зловредами,
    > да еще с такой в радостью, ппц.

    В большинстве случаев PPA для популярных программ поддерживают те же  люди, что и пакеты в стандартных репозиториях. Просто нужно внимательно смотреть, что ставите.

     
     
  • 4.36, Wormik (??), 11:00, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +2 +/
    >>>Мне лично с лихвой хватает PPA
    >> Ох лол, красноглазики соглашаются ставить левоту с потенциальными троянами и зловредами,
    >> да еще с такой в радостью, ппц.
    > В большинстве случаев PPA для популярных программ поддерживают те же  люди,
    > что и пакеты в стандартных репозиториях. Просто нужно внимательно смотреть, что
    > ставите.

    В большинстве случаев сайты с программамит для винды делают интеллигентные и хорошие люди! Просто нужно внимательно следить за безопасностью.

     
  • 2.21, Zenitur (?), 09:33, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    У Мандривы, если что, одной из первых дистрибутивов появилось автоматическое обновление. И в отличие от ред хат и Убунту, которые скачивают уже имеющиеся версии программ, только с исправленными ошибками (исключение - фаерфокс, кде, ява), Мандрива скачивает новые версии программ. Так что годовой цикл здесь очень даже к месту, он проверен временем и немало способствует общей стабильности дистрибутива.
     
     
  • 3.40, Аноним (-), 11:10, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Мандрива скачивает новые версии программ

    Если Мандрива не дает пользователю возможности скачивать только обновления, то они тоже не сильно далеко ушли.

     

  • 1.2, anonymus (?), 05:51, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +9 +/
    Больше выбора - меньше гемора с рра. Я только за.
     
  • 1.4, kshetragia (ok), 06:22, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +14 +/
    Я всё больше уважаю Шаттлворта. Мужик имеет правильное понимание потребностей обычного пользователя.
     
     
  • 2.75, Pilat (ok), 17:53, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Эти потребности понимают все. Только не все понимают, что так делать можно на неответственных компьютерах. Хотя, даже если взять девочку с монитором - будет ли ей интересно, если программа будет каждый раз меняться?
     
     
  • 3.138, Svchost (?), 19:04, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Что значит "Ответственный компьютер"? Я вот хочу, чтобы как только выйдет Firefox 4 - мой Firefox третьей ветки обновился в этот же день, а не в день выпуска нового дистрибутива. А еще лучше, чтобы была возможность указать в настройках обновлений возможность обновляться до альф, бет, RC.
     
     
  • 4.139, Pilat (ok), 19:11, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Что значит "Ответственный компьютер"? Я вот хочу, чтобы как только выйдет Firefox
    > 4 - мой Firefox третьей ветки обновился в этот же день,
    > а не в день выпуска нового дистрибутива. А еще лучше, чтобы
    > была возможность указать в настройках обновлений возможность обновляться до альф, бет,
    > RC.

    конечно это хорошо, Вам нужен Debian Experimental или аналог из других дистрибутивов, там примерно это уже и есть.

    Опыт Debian показывает, что собрать большой дистрибутив с зависимостями пакетов - это дело не на один месяц или даже год, так что день - это для нестабильных систем. Как пример - может у Вас какое-то приложение встраивает FireFox в себя как часть, Вы его меняете - и приложение накрывается.

     
  • 2.106, Anixx (?), 03:08, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Я всё больше уважаю Шаттлворта. Мужик имеет правильное понимание потребностей обычного
    > пользователя.

    В Сусе есть отдельные репы для самого нового Гнома, и для самого нового КДЕ (включая разрабатываемые ветки). Что новыого Марк изобрел?

     
     
  • 3.110, kshetragia (ok), 07:32, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >> Я всё больше уважаю Шаттлворта. Мужик имеет правильное понимание потребностей обычного
    >> пользователя.
    > В Сусе есть отдельные репы для самого нового Гнома, и для самого
    > нового КДЕ (включая разрабатываемые ветки). Что новыого Марк изобрел?

    1. Не нужно лазить руками.
    2. Ответственность за то, что приезжает. А не только за релиз.

     

  • 1.5, stimpack (?), 06:39, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • –13 +/
    опять под мак косят
    там еженедельно всякую муру присылают - один и тот же айтюнс уже раз десять загрузил, все их промежуточные релизики и исправление багов, исправляющих баги, исправляющих баги.
    "А че, инет ширакапалосный, млин! Надажи чем-та забить, ни парнухай же толька!"

    при такой скорости часто бывает спешка-горячка.
    Ничего, получат один раз стопицот тыщ незагружающихся хомячков и сразу перейдут на старый стиль.

     
     
  • 2.8, Gular (ok), 08:09, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Не надо свистеть. Вы сетапите билды и беты? Флаг в руки. Стэйбл там разумный вполне.
     
  • 2.52, анон (?), 12:48, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > опять под мак косят

    Все равно подо что косят.
    Вот хотелось бы иметь последнюю версиию ООо без гемороя, ан нет. И не только ООо. Гимп и еще много программ не имеющих официального репозитория ppa.

     

  • 1.6, VolanD (ok), 07:37, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • –7 +/
    Неееет!!! Теперь очередной глюк, связанный с обновлениями, будет случаться каждый день!!!

    Да и вероятно, обновления будут типа: "Улучшен шрифт там и там... или Добавлены новые иконки туда и туда.."

     
     
  • 2.19, Аноним (-), 09:31, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Вы новость читали перед тем как писать? :)
     
     
  • 3.43, Анонимный трус (?), 12:05, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Он не читатель, он писатель.
     
  • 3.56, VolanD (ok), 13:27, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Вы новость читали перед тем как писать? :)

    Читал, и что же в моей месаге не соответствует новости?

     
     
  • 4.63, Зилибоба (ok), 14:59, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >> Вы новость читали перед тем как писать? :)
    > Читал, и что же в моей месаге не соответствует новости?

    "Для будущих выпусков планируется создание специального постоянно обновляемого дополнительного репозитория и добавление функции отслеживания новых версий программ в Software Center. Пользователи будут иметь возможность выбора: какую программу обновить до последней версии, а для какой программы устанавливать только обновления критических ошибок и проблем безопасности. При этом на одной чаше весов будут стабильные и хорошо протестированные пакеты с не совсем свежими версиями программ, а на другой наиболее функциональные и новые, но ещё не достаточно проверенные, последние версии."

    Теперь понимаете где вы не внимательно читали?

     
  • 2.23, Zenitur (?), 09:44, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Неееет!!! Теперь очередной глюк, связанный с обновлениями, будет случаться каждый день!!!
    > Да и сто вероятно, обновления будут типа: "Улучшен шрифт там и там...
    > или Добавлены новые иконки туда и туда.."

    Ну, не совсем. Я вас конечно поддерживаю, но Шаттлворт, судя по всему, уходит от практики смены шрифтов и воллпейперов. Теперь (возможно) в Убунте будет тот самый софт, который нужен пользователю, а не тот, который ему навязали. Давно пора - но чем он тогда будет выделяться среди других?

     
  • 2.60, Lain_13 (?), 14:35, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Всё зависит от авторов софта. Если они будут выпускать такие обновления, то так и будет, но ни один серьёзный проект так не поступает. Имеется в виду то, что стабильные версии программ будут всегда актуальными, а не замороженными по мажорной версии так, что FF3.5 нельзя обновиться до 3.6 без PPA (в котором пакет собран ещё тормознее, чем в основном репозитории).
    Просто теперь обычный софт можно будет обновлять выше той мажорной версии, которая была на момент выпуска дистрибутива.
     

  • 1.7, Gular (ok), 08:07, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • –5 +/
    Шаттлворт пишет как блондинка. А разве сейчас нет ну никакой возможности устанавливать самое свежее? Убунта ж превратится в один большой РРА.
     
     
  • 2.25, Zenitur (?), 10:01, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Есть, из исходников Потому что PPA - это пара десятков самых популярных програм... большой текст свёрнут, показать
     
     
  • 3.53, анон (?), 12:50, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >> С Ubuntu у вас будут устаревшие на полгода программы,

    еще хуже если по каким-то причинам не хочешь обновлять весь дистр


     
  • 3.61, Lain_13 (?), 14:41, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Например, что у компиза есть кубик

    А разве он кому-то нужен? Четырёх столов в ряд более чем достаточно, а в Unity это ещё удобнее делают. Зачем он нужен, этот кубик, кроме как для вау-эффекта у окружающих? -_-

     

  • 1.9, Аноним (-), 08:26, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Докатились, сначала забивали на серьёзные проблемы, изобретали никому ненужные свистелки, теперь сделали из дебияна арч.
     
  • 1.10, iZEN (ok), 08:27, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    Всё правильно делают. Плавные обновления и непрерывная интеграция приводит к устойчивости. Хотя всё зависит от выдержки мантейнеров и дисциплины обслуживания безрелизных репозиториев.
     
     
  • 2.29, alz (??), 10:26, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Пока дело не доходит до обновления либы, на которую завязана куча софта
     
     
  • 3.38, Wormik (??), 11:02, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Пока дело не доходит до обновления либы, на которую завязана куча софта

    Старую любу никто не убирает. Более того - часто в дистрибутивах поставляются многие старые либы, и поэтому в них запускается тупо всё.

     
     
  • 4.45, alz (??), 12:10, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Да ну? Имел дело с одним арчем. Понадобилось обновить самбу. И хотелось обновить только ее. Но сначала захотел обновиться сам pacman. И подтянул он с собой новую версию openssl. Потом обновил самбу. Потом понял, что мне таки придется дохрена чего еще обновлять =)
     
     
  • 5.48, Аноним (-), 12:19, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Марк хочет замутить нечто вроде бэкпортов Debian (обновляются только прикладные приложения, базовая система и либы остаются старые) только свежее, не из testing, а прямо из sid и experimental.
     
     
  • 6.51, alz (??), 12:45, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    В тексте новости явно упоминаются arch и rolling-release
     
  • 2.34, Аноним (-), 10:59, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Всё правильно делают. Плавные обновления и непрерывная интеграция приводит к устойчивости.
    > Хотя всё зависит от выдержки мантейнеров и дисциплины обслуживания безрелизных репозиториев.

    Здесь главное сохранить баланс. Обновления версий конечных пользовательских GUI-программ неоспоримо нужны, но вот библиотеки, низкоуровневые и серверные пакеты, а также комплексные системы типа GNOME/KDE обновлять нужно только в рамках релиза с очень тщательным предварительным тестированием, иначе можно на очень большие регрессии нарваться.

     
     
  • 3.78, iZEN (ok), 18:35, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Если какая-то команда выпускает ПО, то пусть она его сама тестирует. Задача мантейнеров собрать и запустить это ПО, а если оно не падает, то залить в репозиторий.
     
     
  • 4.79, Pilat (ok), 18:36, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Если какая-то команда выпускает ПО, то пусть она его сама тестирует. Задача
    > мантейнеров собрать и запустить это ПО, а если оно не падает,
    > то залить в репозиторий.

    а ПО, которое от него зависит, кто будет тестировать?

     
  • 4.115, vle (ok), 12:37, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Угу, угу Недавно у меня состоялся диалог с одним знатным ментейнером примерно... большой текст свёрнут, показать
     

  • 1.11, тоже Аноним (ok), 08:43, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Паникующим и кликушествующим: подсчитайте, сколько раз в статье встречается слово "возможность" и подумайте хоть немного, прежде чем писать.
     
     
  • 2.12, Аноним (-), 08:47, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –5 +/
    То есть это новость ни о чём? Очень показательно для авторов убунты. Через неделю кто-то из них будет плакать в блоге, что его никто не любит.
     
     
  • 3.20, тоже Аноним (ok), 09:32, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Вы ее тоже не читали?
    Новость о том, что для тех, кто не боится проблем с неоттестированным ПО, будет ВОЗМОЖНОСТЬ обновляться без лишнего геморроя.
    А те, кто дорожит работоспособностью, будут иметь ВЫБОР - использовать эту ВОЗМОЖНОСТЬ или нет.
    Не вижу в этой новости повода для столь тщательно изыскиваемого негатива.
     

  • 1.13, Dan (??), 08:57, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    вполне закономерное решение после того как Debian объявил о запуске non-freeze (CUT) репозитория.
     
     
  • 2.42, Аноним (-), 11:32, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > вполне закономерное решение после того как Debian объявил о запуске non-freeze (CUT)
    > репозитория.

    CUT - это шестимесячный цикл релизов тестинга, а не ежедневные обновления.

     

  • 1.14, Аноним (-), 09:05, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Марк открыл для себя репозиторий experimental Debian'а? :)
     
  • 1.15, netc (ok), 09:21, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    вот это да, по сути проблемы выбора дистрибутива для наших детей походу существовать не будет ;) :) ;) ;) ;) ;)
     
  • 1.16, AHAH (?), 09:22, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    опять таки марк не привнес ничего нового , а только выдал уже известную новость по дебиану http://raphaelhertzog.com/2010/10/04/can-debian-offer-a-constantly-usable-tes за свою идею
    хотя возможно он надоумил разработчиков деба , чтобы потом снимать сливки
     
  • 1.17, paulus (ok), 09:28, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +6 +/
    Лично мне очень не хватает официального и постоянно обновляемого дополнительного репозитория. Вам для серверов может такое и не нужно, но на десктопе не помешает. Возьмите например, Абиворд который в убунту всегда старее того же sid'a, в nted автор часто добавляет новые возможности, а в репозитории столетней давности, а некоторые РРА не всегда свежие бывают... Тем кому нужна возможность оф.обновлений выбранных программ, только приветствуют введение возможности непрерывных обновлений (Rolling-release). Те кому это не нужно, могут не подключать данный репозиторий или сидеть на стабильном дебиане. Зачем брызгать слюной на монитор с криками "убунтокапец"? IMHO
     
     
  • 2.24, Zenitur (?), 09:51, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Лично мне очень не хватает официального и постоянно обновляемого дополнительного репозитория.
    > Вам для серверов может такое и не нужно, но на десктопе
    > не помешает. Возьмите например, Абиворд который в убунту всегда старее того
    > же sid'a, в nted автор часто добавляет новые возможности, а в
    > репозитории столетней давности

    Ваш идеал packman для suse! Всегда самые новые версии программ, исключая тяжеловесы типа иксов, DE, или низкоуровенвых системных библиотек, влияющих на стабильность и скрость работы. У меня SuSE 10.2 (времён убунты 6.06), но при этом последние программы (за декабрь 2009 года - потом их обновление так прекратилось), начиная от wxWidgets и заканчивая x-moto. Теперь пришло время апдейта, но лень, поставил федору.

     
     
  • 3.26, paulus (ok), 10:02, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >Ваш идеал packman для suse!

    тут дело не в packman или apt, а в создании доп.оф.репозитория с которого будут тянуться самые свежие версии. Хорошо, хоть никто не "кричит", что нужно собирать из исходников (так и поступал с nted) :-)

     
     
  • 4.30, alz (??), 10:33, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Ну так и собирали бы в пакеты и оформляли в виде PPA. Не? Не хочется тратить свое время? Хочется, чтобы другие потратили?
     
     
  • 5.39, Wormik (??), 11:04, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Ну так и собирали бы в пакеты и оформляли в виде PPA.
    > Не? Не хочется тратить свое время? Хочется, чтобы другие потратили?

    Централизованный - ключевое слово. Официальный. Неофициальных полно, старых и новых.э И никакой аргументации, что где есть и чем отличается от таких же пакетиков у других

     
     
  • 6.46, alz (??), 12:15, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    А что дает эта самая официальность? Какие-то гарантии? Что мешает сделать один большой PPA с аргументацией, блэкджеком и прочим? Подозреваю, что мешает только нежелание что-то делать =)
     
     
  • 7.50, Аноним (-), 12:39, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > А что дает эта самая официальность?

    Ответственность разная. У официального разработчика и у анонима.

     
     
  • 8.54, alz (??), 12:51, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Думается мне, ответственность - это личное качество человека, слабо коррелирующе... текст свёрнут, показать
     
     
  • 9.59, szh (ok), 14:06, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    слово ответственность имеет разные смыслы Отвечать за поступки - несет другой с... текст свёрнут, показать
     
  • 4.33, Sergey722 (?), 10:57, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    В данном контексте packman - это и есть доп репозиторий:
    "Что делает команда Packman?
    Мы собираем пакеты с программным обеспечением, позволяя пользователям легко устанавливать и удалять ПО в ОС Linux. Конкретнее, мы делаем это для приложений, не идущих в составе дистрибутивов или поставляющихся в виде старых версий."
    http://packman.links2linux.org/
     
  • 4.108, Anixx (?), 03:13, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >>Ваш идеал packman для suse!
    > тут дело не в packman или apt, а в создании доп.оф.репозитория с
    > которого будут тянуться самые свежие версии. Хорошо, хоть никто не "кричит",
    > что нужно собирать из исходников (так и поступал с nted) :-)

    Packman - это не пакетный менеджер, это репозиторий сообщества в Сусе так называется :-)

    Хотя я бы посоветова не Пакман, а доп. репозитории в OBS. В Сусе есть отдельные репы для самого нового Гнома, и для самого нового КДЕ (включая разрабатываемые ветки). Причем, эти репозитории официальные. Что нового Марк изобрел?

    Кроме того, в репозитории updates версии программ не заморожены - я замечал, что и компоненты Гнома, и компоненты КДЕ время от времени обновляют версии.

     

  • 1.18, Zenitur (?), 09:30, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Пф. В сусе всегда так было.
     
     
  • 2.104, Anixx (?), 03:05, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Именно. И я думаю, не только в Сусе.
     

  • 1.27, Аноним (-), 10:17, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    просто у них скоро буковки заканчиваются для названий релизов
     
  • 1.32, splat_pack (ok), 10:50, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    не прошло и 10 лет как до него наконец дошло, тугой чувак этот шатлворт, тугой. Еще бы все убунтоидные репозитарии объединил в одном месте ваще цены бы бубунте не было. Ну что один геморой убрали уже хорошо.
     
  • 1.37, NGAGE13 (ok), 11:01, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Хорошая новость))
    Хорошо если бы в центр приложений добавили возможность просматривать какие репы есть и через него можно было бы их добавить,и не искать на лаунчпаде.типа того как это реализовано в убунту-твик.
    И я так понял это будет обновления только для программ,не для системы.
     
  • 1.41, Аноним (-), 11:17, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    А не проще ли emerge в убунту сделать?
     
  • 1.44, Alex (??), 12:09, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    > По мнению Шаттлворта, применяемый сегодня шестимесячный цикл выпуска релизов Ubuntu слишком большой срок...

    Кошмар!!! 6 месяцев - эт оч долго!!! А я думал, что переустанавливать ОС каждый год (1 раз в год) - это оч часто!

     
     
  • 2.58, тоже Аноним (ok), 14:01, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вы правильно думали.
    Речь не о системе, а о том, что за эти полгода активно допиливаемые программы сменят несколько версий.
    И пытаются сделать возможность сидеть на LTS, но указать, что конкретные программы нужно брать из экспериментальных веток - последние версии.
     
     
  • 3.66, Аноним (-), 15:55, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >а о том, что за эти полгода активно допиливаемые программы сменят несколько версий.

    Какие-такие программы? Чего вам не хватает? Я лично не знаю таких прог, чтоб за пол-года устаревали.

     
     
  • 4.68, animechaos (ok), 16:27, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Какие-такие программы? Чего вам не хватает? Я лично не знаю таких прог,
    > чтоб за пол-года устаревали.

    Почему речь сразу заходит об устаревании? Тупо в программе был добавлен необходимый тебе функционал (допустим взбрело тебе в голову использовать Shotwell и deadbeef), будешь собирать из исходников и потом использовать неподдерживаемую майнтейнером, да не обновляемую версию софта, или самостоятельно заниматься работой оного человека? успехов.

     
     
  • 5.69, Аноним (-), 16:40, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Шотвелл в оф.репах. А Говядина только в РРА или сорцах. Мне если не хватает, то именно невошедших программ - но это другая песня, согласитесь,не для хомячков.
     
     
  • 6.90, animechaos (ok), 19:47, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Шотвелл в оф.репах.

    меня интерисует LTS, а в офф репах лежит это https://launchpad.net/ubuntu/lucid/+source/shotwell/0.5.0+dfsg-1.1

    в то время как нужна актуальная версия, в результате надо копаться с PPA, как наиболее безболезненным решением.

     
     
  • 7.94, Аноним (-), 20:17, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Если у вас такие привередливые запросы, найдете способ поставить свежее или скомпилить. Свежее-свежее. :)
     
  • 4.71, тоже Аноним (ok), 17:07, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Я лично не знаю таких прог, чтоб за пол-года устаревали.

    Ну, зачем же хвалиться невежеством? Лучше его исправить. Вот здесь, например, найдутся такие программы: http://www.linuxgraphics.ru/

     
     
  • 5.72, Аноним (-), 17:31, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Cups и  Xsane  сами обновляются. А новый гимп - там есть киллер фичи, чтоб из-за них обновлять? Многие другие программы не знаю или не использую.
     
  • 3.105, Anixx (?), 03:07, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Вы правильно думали.
    > Речь не о системе, а о том, что за эти полгода активно
    > допиливаемые программы сменят несколько версий.
    > И пытаются сделать возможность сидеть на LTS, но указать, что конкретные программы
    > нужно брать из экспериментальных веток - последние версии.

    В Сусе есть отдельные репы для самого нового Гнома, и для самого нового КДЕ (включая разрабатываемые ветки). Что новыого Марк изобрел?

     
  • 2.77, develop7 (ok), 18:03, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > А я думал, что переустанавливать ОС каждый год (1 раз в год) - это оч часто!

    Вы эти виндовые замашки лучше оставьте, тут апгрейд работает, в отличие от.

     
     
  • 3.82, Alex (??), 19:16, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Вы эти виндовые замашки...

    Виндовые?? Кто говорит про Винду? В данном сообщении я больше на Debian stable намекал. Вот политика этих ребят в плане обнов мне очень нравится. Это как-то не корректно - бежать всё время за самым-самым-самым свежим. Зачем? Мода? Гораздо лучше иметь версии постарше, но без сюрпризов, отлаженные хоть сколько-нибудь. А то если новость сработает, то получится, что сегодня утром я обновил свою любимую прогу, а к вечеру программер накодил ещё 50 строк кода. Нужно ещё вечером обновиться. И постоянные баги, вылеты и crash'и. Вообще - кому всё это нужно? Какая польза от этих ежедневных обновлений?? Я просто не понимаю. Или по Винде соскучились? UNIX-like стабильность надоела?

     
     
  • 4.83, develop7 (ok), 19:35, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >> Вы эти виндовые замашки...
    > Виндовые?? Кто говорит про Винду?

    Вы же и говорите:

    > А я думал, что переустанавливать ОС каждый год (1 раз в год) - это оч часто!

    переустанавливать ОС после релиза начисто -- типично виндовозовское поведение. Строго говоря, другого выхода у них нет, но это уже оффтопик.

    Если вы имели в виду, что "переустанавливать" == "aptitude --dist-upgrade" -- надо было так и написать.

     
     
  • 5.84, Alex (??), 19:39, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Если вы имели в виду, что "переустанавливать" == "aptitude --dist-upgrade" -- надо было так и написать.

    Оно не во всех дистрибутивах так решается. А если и решается, то не всегда корректно. Помню, ещё разработчики Mandriva предупреждали о версиях в районе 2008-2009, что при выходе новой мажорной Мандривы лучше и надёжнее ставить новую систему с нуля. Можно и обновить --dist-upgrade'ом (или как он там в Мандриве...), но возможны нежелательные сюрпризы.

     
     
  • 6.87, develop7 (ok), 19:42, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >> Если вы имели в виду, что "переустанавливать" == "aptitude --dist-upgrade" -- надо было так и написать.
    > Оно не во всех дистрибутивах так решается. А если и решается, то
    > не всегда корректно. Помню, ещё разработчики Mandriva предупреждали о версиях в
    > районе 2008-2009, что при выходе новой мажорной Мандривы лучше и надёжнее
    > ставить новую систему с нуля. Можно и обновить --dist-upgrade'ом (или как
    > он там в Мандриве...), но возможны нежелательные сюрпризы.

    Как правило, оно работает. Лично я убунту обновляю начиная с 7.04, полёт нормальный.

     
  • 5.89, Alex (??), 19:45, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > переустанавливать ОС после релиза начисто -- типично виндовозовское поведение. Строго говоря, другого выхода у них нет, но это уже оффтопик.

    Начиная толи с XP, толи с Vista, там, по-моему, есть мастер переноса настроек, который переносит настройки на более новую Винду. Или я ошибаюсь? Таким образом новая ставится поверх старой, и самые распространённые опции переносятся и не требуют настройки с нуля.

     
     
  • 6.91, develop7 (ok), 19:50, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >> переустанавливать ОС после релиза начисто -- типично виндовозовское поведение. Строго говоря, другого выхода у них нет, но это уже оффтопик.
    > Начиная толи с XP, толи с Vista, там, по-моему, есть мастер переноса
    > настроек, который переносит настройки

    Знаю. Хоть в XP он и поддерживал буквально считанные единицы софта.

    > на более новую Винду. Или я ошибаюсь?
    > Таким образом новая ставится поверх старой, и самые распространённые опции переносятся
    > и не требуют настройки с нуля.

    Новая винда ставится поверх старой совсем не так. При установке оно вас спрашивает "ого, тут уже есть винды. Обновить их?" и если вы отвечаете "да" оно как бы обновляет и как бы переносит настройки, но глючит так, что больше месяца выдержать невозможно (я, по крайней мере, не выдержал)

     
  • 4.86, develop7 (ok), 19:41, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Вы, очевидно, удивитесь, но в свежих версиях софта не только добавляют функциона... большой текст свёрнут, показать
     
     
  • 5.92, Alex (??), 19:50, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Вы, очевидно, удивитесь, но в свежих версиях софта не только добавляют функционал, но и исправляют ошибки.

    Знаю. "Дырка на дырке" называется. Или ещё: "латаем старые дыры новыми". Старые баги надоели, обновляем и балуемся новыми. Чтобы не скучать. Стадия постоянной альфы.

    > Что за истерика? Выпустит "программер" очередной релиз -- да, будете обновляться. Но покажите мне хоть одну софтину, которая регулярно релизится дважды в день.

    Я просто утрировал.

    > Кто вылетает-то? Кто рушится от апдейтов? Покажите пальцем, наконец.

    http://bugs.ghostscript.com/show_bug.cgi?id=691733
    https://bugs.archlinux.org/?project=1&string=ghostscript

     
     
  • 6.96, develop7 (ok), 20:30, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –1 +/
    На каком основании вы заявляете намекаете , что данное поведение разработчико... большой текст свёрнут, показать
     
  • 3.98, Аноним (-), 20:59, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Видовые? А вы можете дать голову на отсечение, что апгрейд пройдет на ура и не останется кучи мусора и старых ошибок?
     
     
  • 4.100, develop7 (ok), 22:56, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Видовые? А вы можете дать голову на отсечение, что апгрейд пройдет на
    > ура и не останется кучи мусора и старых ошибок?

    Никто не может, но вероятность неуспешного апгрейда достаточно низка.

     
     
  • 5.101, Аноним (-), 23:23, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Поэтому лучше с гарантией - переустановить.
     

  • 1.49, Аноним (-), 12:29, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    отличная новость! роллинг релиз для такого дистриба как убунта будет очень кстати.
     
  • 1.55, JL2001 (ok), 13:22, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    а почему релизы программ даже доступные для убунты на сайтах программ не появляются в репах убунты ?

    почему тупо не сделать доступность в репозитории нескольких версий программ ? прошлый релиз, проверенный, и новый, последний ? и удобную систему выбора в каких случаях и как апгредить пакеты ?

    с этим ppa вобще геморрой - определение приоритета пакета который есть в нескольких ppa муторное и тёмное дело, а если есть ещё офф-репозиторий в котором ориджен для пакетов не прописали или прописали стандартный ubuntu или lucid - я вобще не знаю как поставить приоритет нужного мне репозитория

    приоритеты по нестандартизированному имени файла пакета в котором циферки "модификации версии" каждый лепит от балды, причём хорошо если циферки, а так лепят и буковки и имеем один пакет-6667svn и второй пакет-0ppamyname при актуальной версии в svn 100500 ==> ставится автоматом пакет пакет-6667svn, древний как баян

     
     
  • 2.116, я (?), 12:39, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > с этим ppa вобще геморрой - определение приоритета пакета который есть в
    > нескольких ppa муторное и тёмное дело, а если есть ещё офф-репозиторий
    > в котором ориджен для пакетов не прописали или прописали стандартный ubuntu
    > или lucid - я вобще не знаю как поставить приоритет нужного
    > мне репозитория

    про расстановку приоритетов репозиториев в deb-бэйсед дистрибутивах: http://jaqque.sbih.org/kplug/apt-pinning.html

     
     
  • 3.120, JL2001 (ok), 14:17, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >> с этим ppa вобще геморрой - определение приоритета пакета который есть в
    >> нескольких ppa муторное и тёмное дело, а если есть ещё офф-репозиторий
    >> в котором ориджен для пакетов не прописали или прописали стандартный ubuntu
    >> или lucid - я вобще не знаю как поставить приоритет нужного
    >> мне репозитория
    > про расстановку приоритетов репозиториев в deb-бэйсед дистрибутивах: http://jaqque.sbih.org/kplug/apt-pinning.html

    я не вижу там ответа на вопрос как различить вот эти два репозитория через preferences
    http://archive.ubuntu.com/ubuntu/dists/lucid/Release
    http://packages.enlightenment.org/ubuntu/dists/lucid/Release

    вот так они выглядят в сорсах
    deb http://archive.canonical.com/ubuntu lucid main
    deb http://packages.enlightenment.org/ubuntu lucid main extras #e17

     
     
  • 4.121, Аноним (-), 16:43, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Читайте ман apt_preferences
    Там есть ответ.
     
     
  • 5.123, JL2001 (ok), 18:58, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Читайте ман apt_preferences
    > Там есть ответ.

    читал, нету

     
     
  • 6.124, Аноним (-), 05:03, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Внимательней: по оригину(т.е. по названию сайта, не путайте с другим оригином) или по extras
     
     
  • 7.125, Аноним (-), 05:08, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Upd
    http://www.linux.org.ru/forum/general/5301895
    Не поленился и нашел вам. Надеюсь поймете вместе с маном. Чувак немного лишнего написал - но работает. Вот так правильнее - я про его случай. Вы по образу и подобию сделайте.


    Package: *
    Pin: o=LP-PPA-philip5-extra
    Pin-Priority: 300

     
     
  • 8.137, JL2001 (ok), 17:09, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    вот как раз его случай тут совсем не подходит так как поле Origin в Release в мо... текст свёрнут, показать
     
     
  • 9.140, Аноним (-), 21:05, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Действительно, оригин один в ваших репах И ман мутноват По нттр я никогда не н... текст свёрнут, показать
     
     
  • 10.141, Аноним (-), 21:28, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    А возможно www не нужно - от чего зависит я не понял http www ylsoftware com n... текст свёрнут, показать
     

  • 1.57, Аноним (-), 13:51, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А в сузе делается просто: либо подключаются factory репо (например KDE) либо делается поиск по home репам и остальным. OBS рулит :-)
     
  • 1.65, dimm (??), 15:30, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    вот зачем обычному пользователю обновляться каждый день? не понимаю
    тем более этот обыч. юзер не будет юзать cron, а будет раз в сутки садиться и открывать чего-то там или консоль
    зачем опытному юзеру/админу обн. каждый день? возможно и есть причины, спорить не буду.
    тем более он хотя бы в cron задачу поставит. лог можно посмотреть в случае чего...

    имхо апдейты ежедневные нужны разрабу и/или экспрементатору.
    хотя мона и виртуалке засадить такое.

    p.s.
    debian testing - дом/бук
    freebsd 7.2 - работа
    debian stable/freebsd 6.2 - серваки

     
     
  • 2.67, Floriani (?), 16:12, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > вот зачем обычному пользователю обновляться каждый день? не понимаю
    > тем более этот обыч. юзер не будет юзать cron, а будет раз
    > в сутки садиться и открывать чего-то там или консоль
    > зачем опытному юзеру/админу обн. каждый день? возможно и есть причины, спорить не
    > буду.

    На самом деле обычному пользователю это незачем. Достаточно следить за новостями и качать обновления, связанные с безопасностью. Но...

    Убунту и так уже фактически является почти настоящим rolling-release, привязка к полугодичному циклу - формальность. Выходит сырой релиз, а потом к нему нужно буквально каждый день качать исправления. Обязательно как минимум в первые пару месяцев, иначе wi-fi не заработает, тачпад не поднимется, вэб-камера не оживёт и переключение раскладки будет глючить. Очень ярко это проявилось в 10.10.

    Каноникал подсадили своих пользователей на обновления. Многие заболели апдейтоманией. Не могут ни спать, ни есть, ни жить спокойно, если у них хоть одна программа не в самой свежей версии. Пусть работает как часики, но не свежая - значит, всё ранво надо обязательно обновить. В результате что-нибудь отвалится или вся система рухнет, но зато самое новое установлено. Хомячки плачут, но продолжают качать апдейты. Да, это болезнь!

    Умные люди сформулировали золотое правило: "работает - не трогай!" Но с Убунту оно не актуально. Из коробки не заработает. Мало того, что на базе тестовой ветки Дебиана, с со свистелками, так ещё и заведомо сырое. Сырость Дебиана плюс сырость от Каноникал...

     
     
  • 3.70, Аноним (-), 16:45, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Отличный пост. :) Апдейтомания - ЛОЛ!!!!!!!
    Правда, у меня 10.10 работает без нареканий. Не все так плохо.
     
     
  • 4.73, Floriani (?), 17:31, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Отличный пост. :) Апдейтомания - ЛОЛ!!!!!!!
    > Правда, у меня 10.10 работает без нареканий. Не все так плохо.

    Да, у некоторого количества пользователей 10.10 действительно подружилась с железом. В основном, после месяца ежедневных обновлений.

     
     
  • 5.74, Аноним (-), 17:34, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    У меня на этом компе убунту с 7.04 до  10.10  работают без геморроев совершенно. Один раз помню в груб сразу не прописалось новое ядро и все.
     
  • 3.80, iZEN (ok), 18:47, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Каноникал подсадили своих пользователей на обновления. Многие заболели апдейтоманией.
    > Не могут ни спать, ни есть, ни жить спокойно, если у
    > них хоть одна программа не в самой свежей версии. Пусть работает
    > как часики, но не свежая - значит, всё ранво надо обязательно
    > обновить. В результате что-нибудь отвалится или вся система рухнет, но зато
    > самое новое установлено. Хомячки плачут, но продолжают качать апдейты. Да, это
    > болезнь!

    Они ещё не видели source-based дистрибутивов. Вот, например, пришло обновление Gtk 2.32, хочешь-не хочешь, а полвину программ нужно пересобрать, если приспичит обновиться. :) Или там глобальные библиотеки какие-нибудь типа libjpeg и libpng — это практически 85% софта нужно пересобрать.


     
     
  • 4.81, Аноним (-), 19:04, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >Они ещё не видели source-based дистрибутивов. Вот, например, пришло обновление Gtk 2.32, хочешь-не хочешь, а полвину программ нужно пересобрать, если приспичит обновиться. :) Или там глобальные библиотеки какие-нибудь типа libjpeg и libpng — это практически 85% софта нужно пересобрать.

    И затратить на это целый день. И качать придется кучу огромных размеров ебилдов, в которых все возможные варианты архитектур представлены. :(

     
  • 4.118, vle (ok), 12:50, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Они ещё не видели source-based дистрибутивов. Вот, например, пришло обновление Gtk 2.32,
    > хочешь-не хочешь, а полвину программ нужно пересобрать, если приспичит обновиться. :)
    > Или там глобальные библиотеки какие-нибудь типа libjpeg и libpng — это
    > практически 85% софта нужно пересобрать.

    Если апстрим не сломал API/ABI, ничего дополнительно
    пересобирать не нужно.

     
  • 3.95, szh (ok), 20:19, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Умные люди сформулировали золотое правило: "работает - не трогай!"

    Вы себе льстите. Не умные люди, а люди которым лень.

    > Из коробки не заработает.

    работает из коробки все версии с 8.04 (кроме 10.10 - еще не ставил), что я делаю не так ?

    > Мало того, что на базе тестовой ветки Дебиана

    на базе не слишком консервативной и устаревшей ветки дебиана.

     
     
  • 4.107, Floriani (?), 03:13, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +2 +/
    >> Умные люди сформулировали золотое правило: "работает - не трогай!"
    > Вы себе льстите. Не умные люди, а люди которым лень.

    Да, я не очень умный, и мне лень. Лень тратить время на обновления, эксперименты, постоянную загрузку чего-то нового. Лучше тратить его на работу. Зачем мне новое, если старое работает? Не понимаю (потому что не очень умный).

    А ещё есть люди, которые (о ужас!) по сей день используют релиз 9.10. А недавно я видел девушку, у которой (представьте себе, какой кошмар!) вообще 8.04. У них работает - они не трогают. Во какие глупые! И никакая истерия с апдейтами на них не действует. И за модой не гонятся. Ну дураки, что с них взять. Зато у них полно свободного времени.

     
     
  • 5.127, szh (ok), 06:52, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Люди, которым лень, могут быть как умными так и глупыми. То что вам лень заниматься конкретно этим в общем-то ни о чем глобальном с определенностью не говорит.
     
  • 3.117, я (?), 12:46, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Умные люди сформулировали золотое правило: "работает - не трогай!" Но с Убунту
    > оно не актуально. Из коробки не заработает. Мало того, что на
    > базе тестовой ветки Дебиана, с со свистелками, так ещё и заведомо
    > сырое. Сырость Дебиана плюс сырость от Каноникал...

    ололо. сижу дома на бубунте начиная с 6.10. не помню сырых релизов. всё работает как часы.
    на работе уже года 3 юзаю федору - там да, было пару неприятных косячков при апдейтах.

     
     
  • 4.122, Floriani (?), 17:05, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > ололо. сижу дома на бубунте начиная с 6.10. не помню сырых релизов.
    > всё работает как часы.
    > на работе уже года 3 юзаю федору - там да, было пару
    > неприятных косячков при апдейтах.

    Почему же на работе Убунту не поставили, если она такая стабильная, стабильнее Федоры? Эффективнее работали бы, не тратили бы время на исправление косяков. А раз уж не поставили, то "УМВР ЧЯДНТ" не кажется искренним, увы.


     
  • 2.112, kshetragia (ok), 07:56, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > freebsd 7.2 - работа

    с пивом потянет.

    > freebsd 6.2 - серваки

      Выбор сомнителен. Хотя бы 6.4 - еще куда ни шло.


     

  • 1.85, h31 (ok), 19:40, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Если они за 6 месяцев не успевают исправить все пробемы, то при rolling-release вообще будет сплошной глюкодром.
     
     
  • 2.88, develop7 (ok), 19:45, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Если они за 6 месяцев не успевают исправить все пробемы, то при
    > rolling-release вообще будет сплошной глюкодром.

    практически уверен, что rolling-release будет опцией.

     
     
  • 3.93, Аноним (-), 20:15, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Ролинга не будет. Просто для желающих сделают возможность ставить свежее-глючное через отдельный реп.
     

  • 1.97, Сергей (??), 20:50, 24/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Хорошая новость, верное и правильное решение. Жаль что только сейчас. Но как говориться, лучше поздно чем ни когда.
    Сам я лично пользуюсь PPA только при надобности, а не из за моды обновлений. Основное ПО стоит из стандартного репа. + всего три ppa.

    Gajim - который почему то стало модно собирать для основного репозитория калечно и глючно- поэтому мой выбор официальный PPA.

    DeaDBeeF - которого нет в репозитории вообще.
    VLC просто потому, что новая версия стабильней. Не люблю PPA где сразу куча разных программ, поэтому у меня для каждой программы свой PPA или стандартный реп.
    Ubuntu 10.04

     
     
  • 2.99, Аноним (-), 21:03, 24/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >Не люблю PPA где сразу куча разных программ, поэтому у меня для каждой программы свой PPA

    Почему РРА-писатели не сделают каталог для каждой программы? Набросают в кучу и либо майся с установлением приоритетов, либо после установки отключай.

     

  • 1.102, gegMOPO4 (ok), 00:53, 25/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А это что?

    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://archive.ubuntu.com/ubuntu lucid-backports main restricted universe multiverse

     
  • 1.103, pavlinux (ok), 02:11, 25/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Теперь мата на форумах убунты увеличится, ибо никто не будет знать,
    у кого какая версия.  А решение проблем сведётся к виндовскому
    - "Надо было ставить версию 5.8.23.16.135, а ты лошара поставил 5.8.23.16.137".

    Стабильные версии, стабильно никто юзать не будет.
    У всех будет самая свежая убунта без версии :)

    - У тебя убунта свежая?
    - Да!
    - Насколько свежая?
    - С утра обновился!
    - Фу, ацтой, мамонт доисторический!!!

    Компы с uptime больше 6 часов, автоматом зачисляются к морально устаревшим! :)

     
     
  • 2.109, Floriani (?), 03:19, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Компы с uptime больше 6 часов, автоматом зачисляются к морально устаревшим! :)

    А у кого-то не самая новая и уже успевшая выйти из моды версия убунту, с тем девушка на дискотеку не пойдёт! Одноклассницам нравятся только модные линуксоиды, с самой свежей системой, с самыми свежими глюками.


     
     
  • 3.128, szh (ok), 07:05, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    одноклассницам скорее понравятся те, кто, не будут их перегружать неинтересной им информацией
     
  • 2.119, Pilat (ok), 12:59, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Теперь мата на форумах убунты увеличится, ибо никто не будет знать,

    Ну и уйдут адекватные люди с таких форумов. А что там кричат красноглазики - кого волнует. Они самодостаточны, им кричать интересней всего.

     

  • 1.111, moralez (?), 07:49, 25/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Если у них получится, Убунта станет ещё круче чем сейчас, хотя она и так лучшая! :) Именно этим Убунта лучше Дебиана - релизы с новым софтом раз в полгода. После введения постоянных обновлений она станет лучше FreeBSD и Gentoo при всех остальных плюсах бинарного дистриба. Thumbs up!
     
     
  • 2.113, kshetragia (ok), 08:05, 25/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Это если не вспоминать, что Фрюша тоже поддерживает бинарный апгрейд пакетов и системы.
     

  • 1.114, moralez (?), 09:47, 25/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    "Это если не вспоминать, что Фрюша тоже поддерживает бинарный апгрейд пакетов и системы."

    Вранье. Во фрибзде package-и собираются на определенные релизы. То есть, поставил 5.2-RELEASE, можешь бинарных пакетов наставить. Ни через неделю, ни через год ни один пакет не обновится. Если world держать не 5.2-RELEASE, а например 5-STABLE, то пакеты может быть и будут обновляться, но жить на такой системе невозможно, стабильностью уже никакой не пахнет. И не надо спорить.
    Я в промежутке 4.7-6.2 все серваки на фре держал. Это не так долго, но уж не чайник и лечить меня не надо. :)

     
     
  • 2.126, kshetragia (ok), 05:45, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Откройте для себя pkg_add -r и portupgrade -P. Спорить не буду. Вам похоже неизвестно зачем нужен номер ревизии в портах и третья цифра. И почему скажем портов мускуля аж шесть штук(mysql-server).
    freebsd-update ИМХО тогда еще не было.
     

  • 1.129, moralez (?), 07:43, 26/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Вы определитесь, будете спорить или нет. :D

    Ещё раз: имеем стабильный world 5.2-RELEASE. Как нам прикрутить к ней распоследний срез пэкеджей? Они компилятся под 6-STABLE или даже CURRENT.

    С портами-то приблемы нет, они нормально собирутся с любой конфигурацией world+ports. А насчёт package-ей уверенности нифига нет.

     
     
  • 2.130, kshetragia (ok), 08:17, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Ещё раз: имеем стабильный world 5.2-RELEASE. Как нам прикрутить к ней распоследний
    > срез пэкеджей? Они компилятся под 6-STABLE или даже CURRENT.

    1. Пятая ветка не саппортится.
    2. для остальных:
       ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386
       ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64

    И соответственно пакеты, скажем для шестерки:
       ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/All/

    Очень внимательно посмотрите на даты сборки пакетов.

    > С портами-то приблемы нет, они нормально собирутся с любой конфигурацией world+ports. А
    > насчёт package-ей уверенности нифига нет.

    Гарантию вам даже госстрах не даст. На портах налететь даже проще чем с пакетами. Особенно на x64.  

    PS: пользуйтесь кнопкой "ответить" чтобы "не размазывать" разговор и приходила нотификация.

     
     
  • 3.131, moralez (?), 09:15, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Вот и вернулись к самому первому моему сообщению. Допустим world у нас 7.2. Сколько вылезет косяков, если ставить пакеты из среза 7-stable? 1%, 10%, 90%? В любом случае не ноль и не 0.1%. Или ошибаюсь?
     
     
  • 4.132, kshetragia (ok), 09:28, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Вот и вернулись к самому первому моему сообщению. Допустим world у нас
    > 7.2. Сколько вылезет косяков, если ставить пакеты из среза 7-stable? 1%,
    > 10%, 90%? В любом случае не ноль и не 0.1%. Или
    > ошибаюсь?

    Ошибаетесь. В stable ветке системный API не ломается. Более того старые библиотеки из пакета перемещаются в compat/pkg и все продолжает работать если so-name сменился у новых пакетов. Так работает portupgrade.

    сидеть на 7.2 когда есть 7.4 - не айс. совсем.

     
     
  • 5.133, moralez (?), 09:47, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Блин, за три года всё забыл. Когда сидел на Фре, мне ж наоборот, не хватало такого:

    ставим world - 7.4, ставим софт через пакеты/порты (неважно), а потом хотим, чтобы версии софта НЕ обновлялись, а лишь security-апдейты происходили. Чего разумеется, нет, только обновление когда от portaudit приходит волшебный пендель.

    Короче, всё с точностью до наоборот. А на последнюю версию-то всегда обновлялось. %-) Спасибо за потраченное на меня время. Хорошо, что в ubuntu от этой идеи отказались, ибо это нафиг не надо.

     
     
  • 6.134, kshetragia (ok), 10:00, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    > Короче, всё с точностью до наоборот. А на последнюю версию-то всегда обновлялось.
    > %-) Спасибо за потраченное на меня время. Хорошо, что в ubuntu
    > от этой идеи отказались, ибо это нафиг не надо.

    И тут я снова напоминаю про то, что основные порты разведены по первым двум цифрам. Последняя(третья) и есть security и миноры.

     
     
  • 7.135, moralez (?), 10:13, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Если разговор о, например, postfix

    что есть разные ветки,
    postfix-2.3.19,1.tbz
    postfix-2.4.13,1.tbz
    postfix-2.5.9,2.tbz

    итд, то это всё на усмотрение maintainer-а порта и очень далеко от идеала, а часто совсем никакого разделения нет, только последняя версия и баста.

     
     
  • 8.136, kshetragia (ok), 11:05, 26/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    ls -1d usr ports mail postfix2 usr ports mail postfix24 usr ports mail pos... текст свёрнут, показать
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру