The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

22.02.2017 22:38  Выпуск LEDE 17.01, форка дистрибутива OpenWrt

Представлен первый выпуск дистрибутива LEDE 17.01 (Linux Embedded Development Environment), основанного в мае прошлого года как форк проекта OpenWrt и также ориентированного на создание точек доступа и беспроводных маршрутизаторов. Сборки подготовлены для 32 целевых платформ, из которых 7 ранее не поддерживались в OpenWrt.

Форк был создан группой активных разработчиков OpenWrt, желающих поднять стабильность дистрибутива на новый уровень и избавиться от организационных проблем. В LEDE попытались реализовать предсказуемый цикл разработки, более либеральные правила приёма изменений и прозрачный процесс принятия решений с привлечением сообщества и проведением публичных обсуждений. В декабре в списках рассылки была предпринята попытка объединения OpenWrt и LEDE, но она пока не привела к конкретным действиям.

Ключевые новшества, реализованные после отделения от OpenWrt:

  • Добавлена поддержка большой порции новых плат, точек доступа и беспроводных маршрутизаторов;
  • Добавлена поддержка новых целевых платформ:
    • apm821xx (AppliedMicro APM821xx)
    • arc770 (Synopsys DesignWare ARC 770D)
    • archs38 (Synopsys DesignWare ARC HS38)
    • armvirt (QEMU ARM Virtual Machine)
    • ipq806x (Qualcomm Atheros IPQ806X
    • layerscape (NXP Layerscape)
    • zynq (Xilinx Zynq 7000 SoCs)
  • Реорганизована платформа Xen DomU, которая объединена с платформой x86/generic;
  • Удалены платформы: realview (на смену пришла платформа armvirt), ppc44x (не работоспособна) и netlogic (отсутствует оборудование);
  • Ядро Linux обновлено до версии 4.4.50 (в актуальном выпуске OpenWrt используется ядро 3.18);
  • Обновлены версии dnsmasq (c 2.73 до 2.76), busybox (с 1.23.2 до 1.25.1), mbedtls (c 1.3.14 до 2.4.0), openssl 1.0.2k, musl 1.1.16, gcc 5.4.0, binutils 2.25.1;
  • Для контроля целостности пакетов вместо MD5 задействован алгоритм хэширования SHA256;
  • Отключены небезопасные компоненты шифрования в mbedtls и OpenSSL (SSLv3, сжатие, NPN, Whirlpool и J-PAKE);
  • Включены опции для повышения защиты от уязвимостей и атак: в GCC активированы режимы "-Wformat -Wformat-security", добавлена защита от переполнения стека в пространстве пользователя и на уровне ядра, включён режим определения переполнения буферов (FORTIFY_SOURCE) и добавлена защита RELRO (RElocation Read-Only);
  • Улучшены сетевые возможности:
    • Поддержка SQM (Smart Queue Management) для минимализации негативного влияния промежуточной буферизации пакетов (Bufferbloat). Связанные с противодействием Bufferbloat изменения также реализованы для драйверов ath9k, mt76 и ath10k;
    • Для драйвера ath9k задействован планировщик Airtime, устраняющий аномалии на медленных системах;
    • Внесена большая порция исправлений, направленных на повышение стабильности работы беспроводного стека и драйвера ath9k;
    • В качестве опции добавлен альтернативный драйвер ath10k-ct от Candela-Tech;
    • Проведена работа по усилению защищённости IPv6;
  • Изменения в системе сборки:
    • Выполнено разделение базовой системы и поддерживаемых сообществом пакетов, что упростило распространение бинарных обновлений;
    • Решены проблемы с обработкой зависимостей пакетов, улучшена поддержка виртуальных пакетов;
    • Формирование отдельных образов rootfs для каждого устройства дало возможность индивидуально выбирать пакеты для профилей устройств;
    • Новый код сборки образов позволил сократить время компиляции и упростить определение профилей устройств;
    • В Makefile добавлены новые команды для запуска стандартных диагностических наборов;
    • Добавлена возможность загрузки исходных текстов при помощи Curl;
    • В коде сборки образов переработана сборка библиотек для улучшения переносимости между разными дистрибутивами Linux;
    • Добавлена поддержка сборки модулей ядра, используя SDK.


  1. Главная ссылка к новости (http://lists.infradead.org/pip...)
  2. OpenNews: Активные разработчики OpenWrt основали форк дистрибутива
  3. OpenNews: Компания Belkin обеспечит поддержку DD-WRT для маршрутизаторов Linksys
  4. OpenNews: Увидел свет дистрибутив OpenWrt 15.05
  5. OpenNews: Обновление дистрибутива OpenWrt 15.05.1
Лицензия: CC-BY
Тип: Программы
Ключевые слова: lede, openwrt
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение Ajax/Линейный | Раскрыть все сообщения | RSS
 
  • 1.1, Аноним (-), 22:47, 22/02/2017 [ответить] [показать ветку] [···]    [к модератору]
  • +2 +/
    Ставить можно или загнутся/объединятся через полгода?
     
     
  • 2.5, incker (?), 23:29, 22/02/2017 [^] [ответить]     [к модератору]
  • –5 +/
    А я думал, что они уже загнулись А они релиз выкатили Но ставить пока стремн... весь текст скрыт [показать]
     
     
  • 3.59, Аноним (-), 09:18, 27/02/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    Да там обычные кеды 5.9 стоят, чего скидывать-то?
     
  • 2.16, нонима (?), 11:46, 23/02/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    я ставил на тплинки разные билды - тож самое что openwrt по использованию, только собирается культурнее
     
  • 2.23, Аноним (-), 14:30, 23/02/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    Если они объединятся, то использоваться будет кодовая база lede.
     
     
  • 3.48, dimqua (ok), 07:59, 24/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Разработчики на IRC-канале мне тоже так сказали.
     
  • 1.2, кельвин (?), 22:48, 22/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • –1 +/
    воу прям круто реорганизовали всё.
     
  • 1.3, Аноним (-), 22:54, 22/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • –6 +/
    Форк, Форк, хоть одну бы до ума довели...
     
  • 1.4, x (?), 23:09, 22/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +6 +/
    В любой непонятной ситуации создавай свой форк.
     
     
  • 2.40, Аноним (-), 20:18, 23/02/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    Форки ffmeg явно пошли ему на пользу.
     
  • 1.6, Аноним (-), 23:42, 22/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +10 +/
    Оно живее и адекватнее openwrt, юзаю lede с самого появления на 2 роутерах.
    Какой нафиг скрин интерфейса?)) там тот же luci как в опенврт.
     
  • 1.7, crick (ok), 23:44, 22/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +2 +/
    > Кто-то видел скрин интерфейса хоть?) Если да - скиньте

    Интерфейс такой-же, как в OpenWRT. Стоит я января из trunk. Никаких аномалий. Все работает.

     
     
  • 2.8, lone_wolf (ok), 01:11, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    А пакетный менеджер cli тот же?
     
     
  • 3.12, h31 (ok), 06:57, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Да (уже поставил и попробовал).
     
  • 2.9, h31 (ok), 02:32, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Ставил с нуля или накатывал поверх? Какой чипсет?
     
  • 1.10, dimqua (ok), 03:26, 23/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +2 +/
    >в актуальном выпуске OpenWrt используется ядро 3.18

    В релизе OpenWRT вообще все старое, а trunk-билдов для моего роутера у них нет.

    >Связанные с противодействием Bufferbloat изменения также реализованы для драйверов ath9k, mt76 и ath10k;

    Похоже, поддержка остальных платформ значительно хуже в OpenWRT/LEDE:
    https://wiki.openwrt.org/toh/recommended_routers

     
     
  • 2.13, Аноним (-), 08:12, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    > вообще все старое

    не старое, а стабильное

     
     
  • 3.17, tensor (?), 12:22, 23/02/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    > не старое, а стабильное

    Прямо девиз RHEL/Oracle Linux.

     
  • 3.20, Crazy Alex (ok), 13:50, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Вот ядро 4.4 - это стабильное. А то, что в OpenWRT - мхом заросло. Вон, та же борьба с bufferbloat - хороший пример. В ядре сейчас гора толковых сетевых планировщиков - только не в 3.18 же.
     
     
  • 4.28, Нанобот (ok), 16:12, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    >Вон, та же борьба с bufferbloat - хороший пример

    что-то мне подсказывает, что результат этой борьбы невозможно заметить невооруженным глазом, по скорости будет прирост максимум ~0.5%

     
     
  • 5.29, Crazy Alex (??), 16:14, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    на wifi это гораздо более сушественно
     
  • 5.43, Anonplus (?), 21:40, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    https://habrahabr.ru/post/317548/


     
  • 1.18, Аноним (-), 12:37, 23/02/2017 [ответить] [показать ветку] [···]     [к модератору]  
  • +/
    Ставил OpenWRT, довольно долго пользовался, настроил большую часть того, что нуж... весь текст скрыт [показать]
     
  • 1.19, Аноним (-), 13:49, 23/02/2017 [ответить] [показать ветку] [···]     [к модератору]  
  • –2 +/
    А у них можно выкачать стабильный репозиторий чтобы собрать самому На офсайте п... весь текст скрыт [показать]
     
     
  • 2.22, Аноним (-), 14:29, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    git clone https://git.lede-project.org/source.git lede-17.01
     
  • 2.24, Crazy Alex (ok), 14:52, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Что за дикая постановка задачи?
     
     
  • 3.27, анон (?), 15:46, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Не линуксоид потому что. Ну вроде с -b lede-17.01 собирается с последним стабильным коммитом и ладно. Всем спасибо)
     
  • 1.21, Аноним (-), 13:58, 23/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    На 4 мб flash'а кто-нибудь ставил? LuCi туда влезет?
     
     
  • 2.25, Аноним (-), 14:58, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    В документации говорят, что не влезет.
     
  • 2.30, leap42 (ok), 16:30, 23/02/2017 [^] [ответить]    [к модератору]  
  • –2 +/
    доку читали? там в самом начале написано: "Your router has at least 8 MBytes of Flash and 64 MBytes of RAM"
     
     
  • 3.46, Аноним (-), 00:01, 24/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Надо читать полность, а не только начало.
     
  • 2.44, Jane Doe (?), 21:45, 23/02/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    При обновлении с openwrt до lede - luci остаётся. Сегодня только обновил wr941nd v3 с 15.05.1 до 17.01
     
  • 2.45, Аноним (-), 00:01, 24/02/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    Без luci точно ставится.
     
  • 1.26, Аноним (-), 15:41, 23/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • –1 +/
    842nd захожу в прошивку выбираю файл lede-17.01.0-r3205-59508e3-ar71xx-generic-tl-wr842n-v2-squashfs-factory.bin

    Жму обновить, а в ответ выберите файл.

     
     
  • 2.32, give me some glasses (?), 17:51, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Это "циклическая зависимость".
     
  • 2.33, alcoroll (?), 17:55, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    имя файла сократи, если со стандартной прошивки пытаешься это сделать
    и будет всё ок :)
     
     
  • 3.35, give me some glasses (?), 18:09, 23/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Типа их прошивка не поддерживает длину имени файла прошивки проименованного их собственным разработчиком? :)


     
  • 3.41, Аноним (-), 20:43, 23/02/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    Спасибо! Очень легкая настройка сразу после установки, интернет теперь раздаёт роутер с этой прошивкой.
     
  • 1.34, yz (?), 18:09, 23/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    с openwrt обновить до lede получится? Или лучше по новой установить?
     
     
  • 2.36, lucentcode (ok), 18:55, 23/02/2017 [^] [ответить]    [к модератору]  
  • +1 +/
    Получится. Только нужно образ sysupgrade накатывать, вместо factory. Сам так сегодня себе обновил прошивку.
     
  • 1.37, Анончик (?), 20:02, 23/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    На древнем WL500GPv2 похоже наконец починили рандомные ребуты.
    1 час, полёт нормальный.
     
  • 1.47, Аноним (-), 02:05, 24/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • –2 +/
    О, а я уж думал LXDE доделали, когда ничатать начинал.
     
  • 1.49, Аноним (-), 08:40, 24/02/2017 [ответить] [показать ветку] [···]     [к модератору]  
  • –1 +/
    Накатил вчера на TL-WR841N прямо из LuCi с сохранением параметров Все настройки... весь текст скрыт [показать]
     
     
  • 2.53, Jane Doe (?), 12:56, 24/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Не стоит обновлять с сохранением настроек. Слишком много глюков. И разворот из openwrt бекапа тоже очень плохая идея. Мне пришлось ручками перебивать все настройки. В итоге ноль проблем.
     
  • 2.54, SCHigi (ok), 23:39, 25/02/2017 [^] [ответить]     [к модератору]  
  • +/
    на SO http stackoverflow com questions 34112053 openwrt-cant-install-packages... весь текст скрыт [показать]
     
     
  • 3.56, Аноним (-), 12:13, 26/02/2017 [^] [ответить]    [к модератору]  
  • +/
    Оставил первые три строки - сработало !!!!
     
     
  • 4.57, SCHigi (ok), 15:21, 26/02/2017 [^] [ответить]    [к модератору]  
  • +/
    возможно, придется вернуть и четвертую строку для установки некоторых пакетов, мне пришлось так сделать чтобы поднять принт-сервер (p910nd)
     
  • 1.50, Аноним (-), 11:43, 24/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • –1 +/
    Написано в списке устройств есть D-Link DIR-632, но по факту нет там для него прошивки. Как всегда, для придания важности
     
  • 1.51, Vlad Ber (?), 11:46, 24/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Не нашел на сайте список поддерживаемых устройств. А какая на 942 тп-линке платформа не вкурсе. Гуглю...
    На tp-wr942n зальётся? а то позарез нужен клиент тунельный, чтобы реальзовать доступ к системе видеонаблюдения.
     
     
  • 2.52, Аноним (-), 12:56, 24/02/2017 [^] [ответить]    [к модератору]  
  • +/
    https://lede-project.org/toh/views/toh_available_864?dataflt%5BModel*%7E%5D=
     
  • 1.55, rumanzo (?), 23:50, 25/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Как не работал бродкомовский wifi ac на asus rt-56u, так и не работает.
     
  • 1.58, Аноним (-), 20:41, 26/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Работает на 842nd, но до юзабельности далеко. IPTV не пашет через wifi, интерфейс дичайше тормозит. Даже 15.01.1 годен по сравнению с этим. Перепрошился обратно на 12.09.
     
     
  • 2.61, PalachMB (ok), 04:46, 03/03/2017 [^] [ответить]    [к модератору]  
  • +/
    iptv от ростелекома?
     
     
  • 3.64, Аноним (-), 09:24, 12/03/2017 [^] [ответить]    [к модератору]  
  • +/
    не, провайдер из "районных".
     
  • 1.60, fvl (?), 10:23, 27/02/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Для владельцев TL-WDR3500/3600/4300/4310/MW4350R
    https://github.com/gwlim/mips74k-ar71xx-lede-patch
     
  • 1.62, Аноним (-), 22:06, 08/03/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    На dir-300 работает как часы
     
  • 1.63, Аноним (-), 21:20, 09/03/2017 [ответить] [показать ветку] [···]     [к модератору]  
  • +/
    mdk3 нет , пробовал с исходника закомпилить , не хочет , сама Lede работает стаб... весь текст скрыт [показать]
     
  • 1.65, Аноним (65), 04:51, 31/12/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    DIR D300 b7-поставил пока проблем не было...
     
  • 1.66, Аноним (65), 15:37, 31/12/2017 [ответить] [показать ветку] [···]    [к модератору]  
  • +/
    Поюзал-безбожные лаги-страница по минуте прогружать стало,вернулся на OpenWRT...
    Не советую ставить + на ней пинг вырос на пол миллисекунды-тоже минус!...
     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:


      Закладки на сайте
      Проследить за страницей
    Created 1996-2018 by Maxim Chirkov  
    ДобавитьПоддержатьВебмастеруГИД  
    Hosting by Ihor