The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Oracle прекратит поставку браузерного Java-плагина

28.01.2016 10:54

Компания Oracle приняла решение прекратить разработку, поддержку и поставку браузерного плагина в Java SE. Начиная с Oracle JDK 9, который ожидается 23 марта 2017 года, плагин планируют перевести в разряд устаревших технологий, а в дальнейших выпусках - удалить из состава JDK и JRE. Вместо встраивания Java-апплетов в web-страницы разработчикам сайтов рекомендуется перейти на использование технологии запуска аплетов Java Web Start, которая не требует наличия установленного в браузере Java-плагина.

Прекращение поддержки браузерного плагина обусловлено движением разработчиков браузеров в сторону отказа от поддержки интерфейса NPAPI. В частности, поддержка NPAPI-плагинов уже прекращена начиная с выпуска Chrome 45. В Firefox до конца 2016 года запланировано блокирование работы всех NPAPI-плагинов кроме Flash. Microsoft Edge изначально не поддерживает NPAPI.

Кроме Java, из остающихся в обиходе NPAPI-плагинов выделяются только Flash, Unity и Silverlight. Поддержка контента на Flash сохранена благодаря портированию Flash-плагина на PPAPI (Pepper API) и применению обходных путей для его выполнения. Silverlight уже давно не развивается компанией Microsoft и объявлен устаревшей технологией. Поддержка плагина Unity будет прекращена начиная с выпуска Unity 5.4, намеченного на март 2016 года (разработчикам браузерных игр рекомендовано перейти на WebGL и штатный Web API).

  1. Главная ссылка к новости (https://blogs.oracle.com/java-...)
  2. OpenNews: Java 9 переносится на 2017 год
  3. OpenNews: Обнародован график подготовки Java 9
  4. OpenNews: Обновление Java SE 8 Update 20. Новшества Java 9
  5. OpenNews: Google представил план окончательного прекращения поддержки NPAPI-плагинов в Chrome
  6. OpenNews: Firefox прекращает поддержку плагинов NPAPI, за исключением Adobe Flash
Лицензия: CC-BY
Тип: К сведению
Ключевые слова: java, npapi, plugin
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (102) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, A.Stahl (ok), 11:02, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +7 +/
    >Прекращение поставки браузерного плагина обусловлен движением разработчиков браузеров

    Вот. Даже Оракл шевелится, а местные аналитики говорили (при обсуждении отказа от какого-то устаревшего способа шифрования), что разработчики браузеров жалкие рабы, полностью зависят от Ынтерпрайза и те, кто попрёт поперёк, будут просто невостребованы.

     
     
  • 2.2, 1 (??), 11:09, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +11 +/
    Так ораклу - "баба с возу, кобыле легче".
     
     
  • 3.89, Анончег (?), 22:43, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Они припарились его фиксить, там код из одних фиксов состоит. Пусть они его Индейцу Апачу подарят, там его в инкубаторе обследувают со всех сторон, подлечат и положат на полку отдыхать.
     
     
  • 4.99, count0krsk (ok), 07:37, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Вы так говорите, как будто это что-то плохое )))
     
     
  • 5.111, Анончег (?), 23:03, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Вы так говорите, как будто это что-то плохое )))

    Ну елы-шалы, тут уж кому как нравиться.

     

  • 1.3, Аноним (-), 11:10, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –8 +/
    Вот и жабке конец, а кто кушал — молодец.
     
     
  • 2.4, Аноним (-), 11:22, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • –7 +/
    Или Firefox'у.
     
     
  • 3.5, Аноним (-), 11:24, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А что ему сделается? Жив, жил и будет жить.
     
     
  • 4.9, Аноним (-), 11:26, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +10 +/
    > А что ему сделается? Жив, жил и будет жить.

    Ага. Выкинет поддержку всег плагинов, закроет установку неподписанных обновлений, затем подписанных, ну а затем уже и об отказе от поддержки HTML можно будет подумать и заменить его на средство для прожига дисков, допустим.

     
     
  • 5.10, Аноним (-), 11:27, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вот ведь я криворукий
    > всех
    > дополнений
     
  • 5.66, Норсултан (?), 16:18, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    В этой сфере господствует Nero, Фирефоксу тут ловить нечего.
     
     
  • 6.73, Случайный_гость (?), 17:44, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Вы ещё используете компакт-диски???? Музей ограбили?
     
     
  • 7.114, Ананисм (?), 12:08, 31/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Да, использую. В моем лексусе, к сожалению, нет усб. Прожигаю диски, музеев не грабил.
     
  • 6.75, Lain_13_too_lazy_to_login (?), 19:18, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    А он разве ещё не превратился в самостоятельную OS?
     
     
  • 7.76, rvs2016 (ok), 19:41, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >  А он разве ещё не превратился в самостоятельную OS?

    Кто? Фирефокс? С приколом превращения браузера в ОС они уже вроде завязали. :-)

     
     
  • 8.100, count0krsk (ok), 07:39, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Неро жеж Помню установщик одной из последних версий весил около 500 пятьсот М... текст свёрнут, показать
     
  • 3.6, Аноним (-), 11:24, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ему тоже, но у него есть форки, в отличие от жабки без браузерного плугина.
     
  • 2.7, Соколов (?), 11:25, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    >Вот и жабке конец, а кто кушал — молодец.

    Отказ от браузерного плагина 99.9% пользователей никак не затронет, ибо с апплетами давно были проблемы и используются они сегодня маргинально.

     
     
  • 3.11, 1 (??), 11:31, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +11 +/
    Расскажи это писателям всяких вебморд от свитчей.
     
     
  • 4.12, Соколов (?), 11:36, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >Расскажи это писателям всяких вебморд от свитчей

    Хорошо, расскажу. А где такие водятся?

     
     
  • 5.14, evkogan (?), 11:41, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Это водится тв любой большой интра сети.
    К сожалению теперь везде манагеры, которые кроме игр в интернети ничего не знает.
     
     
  • 6.83, . (?), 21:59, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ну не знаю. Я последний раз живьём java-applet видел в районе 2005 и то в оЧЧень специфической штуке.
     
     
  • 7.101, count0krsk (ok), 07:42, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Ну не знаю. Я последний раз живьём java-applet видел в районе 2005
    > и то в оЧЧень специфической штуке.

    Да есть они в продакшене, есть ) Я в 2013 долбался с одной штукой, которой нужна была версия жабы не ниже н-ной, а она всё норовила обновиться, или кричала что старая. А новая требовала каждый раз тыкать кнопочки "Разрешить, запустить, я уверен" и это было неотключаемо. А юзеры хотели чтобы всё было как раньше. Зашёл по ярлыку - открылась "программа" в вебе.

     
  • 5.27, Аноним (-), 11:58, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +5 +/
    И идиоты пользующиеся клиент-банками, и идиоты пользующиеся системами видеонаблюдения. Все должны страдать.

    Пойду выпью смузи и поиграю в энгрибёрдз на ипаде без жабки.

     
     
  • 6.37, Аноним (-), 12:51, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > клиент-банками

    Если кто ещё не слез на простую вебморду - ССЗБ, всё верно.

    > пользующиеся системами видеонаблюдения

    Купили китайчатину, гвоздями прибитую к activex^Wжабе? ну-ну. Скупой платит дважды, тупoй - трижды, а лox - всегда.

     
     
  • 7.79, Аноним (-), 20:28, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Купи нашу камеру видеонаблюдения и получи наклейку "не лох" в подарок!
     
  • 7.80, anonymous (??), 20:33, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Есть вменяемый и относительно универсальный способ использовать смарткарты без апплетов?
     
  • 5.54, AdVv (ok), 14:24, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Иди расскажи это разработчикам KVM модулей для Intel серверов.
     
  • 4.63, КО (?), 15:44, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ноне вебморды не почете - теперь всем iOS или Andoid приложение подавай, чтоб делало все то же самое, что раньше из браузера можно было сделать. :)
     
  • 4.71, kido (?), 17:24, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    В можно поподробнее? Лично рулил коробками Cisco, Huawei, Extreme, Dlink, Raisecom - везде нормальный cli. Чтож за гуано вы покупаете, если оно конфижится через веб-морду, да еще и требует джаву?
     
     
  • 5.81, Аноним (-), 20:52, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    iDRAC, iLO,.. - альтернатив нет.

    < Лично рулил коробками
    ОМГ! Пафосно.

     
  • 5.85, Михрютка (ok), 22:03, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    "поконфижьте" мне пожалуйста через cli айбиэмовские СХД например те которые они оемили у LSI. h3c свитчи недорогие тож, они так удобно через cli "конфижатся". авоцентовские IP KVM через cli только в путь работают, аж полы загинаются.
     
     
  • 6.102, count0krsk (ok), 07:45, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > "поконфижьте" мне пожалуйста через cli
    > полы загинаются.

    Категорически несогласен! ЗагИбаются ))

     
  • 4.77, rvs2016 (ok), 19:42, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Расскажи это писателям всяких вебморд от свитчей.

    И не только разработчикам свитчей. Ещё и недоделанные банковские программисты заставляют использовать джавку в браузерах для работы их поделий...

     
  • 3.20, Admino (ok), 11:52, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Расскажи это писателям клиент-банков.

    Браузеры не умеют в нормальную криптографию.

     
     
  • 4.34, . (?), 12:48, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Расскажи это писателям клиент-банков.

    ну вот оракл им и расскажет.

    > Браузеры не умеют в нормальную криптографию.

    десять лет уже как умеют, последние два года - существенно лучше жабьей (в виду страдания последней детскими болезнями).
    Для писателей клиент-банков, возможно, есть другие преимущества (браузеронезависимый доступ к локальной файловой системе, интерфейсы с косорукими аппаратными ключами и т п), но им пора уже и вылезать из браузера - jnlp никто не отменяет, и для данной цели stand-alone жабья апликуха только лучше.

     
     
  • 5.50, ZiNk (ok), 13:38, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >> десять лет уже как умеют, последние два года - существенно лучше жабьей (в виду страдания последней детскими болезнями).

    На секундочку: браузеры уже научились работать с хардварными токенами с неизвлекаемыми ключами? Или "пароля хватит всем" ?

     
     
  • 6.52, Аноним (-), 13:51, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    https://www.cryptopro.ru/products/cades/plugin
     
     
  • 7.67, Аноним (-), 16:23, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    глючное дерьмо, работающее или не работающее в зависимости от фазы луны, апплетам в подмётки не годится
     
     
  • 8.84, . (?), 22:02, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    потому что апплеты не работяют всегда ну вернее - будут не работать ... текст свёрнут, показать
     
  • 7.97, soarin (ok), 06:10, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А в чём разница? Это же тоже NPAPI плагин?
     
  • 6.105, DFX (ok), 09:05, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Firefox: preferences -> advanced -> certificates -> security devices -> PKCS #11
    Не ? Или Вам обязательно какого-то кривого, нестандартизированного дерьмеца подложить надо ?
     
  • 6.108, . (?), 13:06, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > На секундочку: браузеры уже научились работать с хардварными токенами с неизвлекаемыми
    > ключами?

    давно уже умели (в винде по крайней мере, но в опенсофтваре все плохо с драйверами обычно, до интерфейсов с пользователем дело уже вообще не доходит).
    Если авторы ключа, разумеется, озаботились соответствием стандартам, а не наваяли кривую и косорукую поделку, несовместимую совершенно ни с чем. Впрочем, тогда там вряд ли будет жаба - скорее windows-xp-only .exe

     
  • 4.41, badmilkman (ok), 12:53, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Расскажи это писателям клиент-банков.

    Эти или осилят Java WebStart, или вымрут.
    Поддержку ГОСТа в 10 Windows до сих пор ждем

     
  • 4.45, Челодой Моловек (?), 13:02, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Я вот тоже все переживал на предмет того, как же я теперь буду клиент-банком пользоваться (у меня Приватбанк). А они, пока еще поддерживая java плагин, уже разродились альтернативным плагином (cryptoplugin называется). Я так понимаю, это их самописная штука. Что радует, ее можно установить с правами простого юзера. Теперь в Firefox можно хоть джавой, хоть этим плагином пользоваться для подписи платежек. Так что Приватбанк уже подготовил альтернативу джаве.
     
  • 4.49, Аноним (-), 13:14, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да в том то и дело, что тем, кому нужна безопасность и расширенные возможности, тому лучше браузер стороной обходить и смотреть в сторону отдельных приложений, а простым пользователям и браузеров без серьёзной(официальной) криптографии хватит.
     
  • 3.106, Gannet (ok), 11:51, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А как же тривиальные клиент-банки? Далеко не все умеют работать без Java.
     

  • 1.13, evkogan (?), 11:40, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Эти "хорошие" люди думают, что есть не только игры в интернете, но и IntrAnet, где куча старово софта, куча старово железа с управлением через Web Java?
    Кто знает есть браузер который пилят для IntrAnet'а?
    Где безопасность побоку, но все по максимуму работает.
     
     
  • 2.16, Аноним (-), 11:47, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +13 +/
    Internet Explorer 6, бугагагага !!!!
     
  • 2.18, Turbid (??), 11:48, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +9 +/
    Internet Explorer 6.

     
  • 2.19, Аноним (-), 11:49, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +9 +/
    Internet Explorer 6
     
     
  • 3.26, 1 (??), 11:56, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ничего смешного ... IE6 portable часто выручает.
     
     
  • 4.32, A.Stahl (ok), 12:15, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +5 +/
    >IE6 portable часто выручает.

    Это действительно не смешно.

     
  • 4.56, kot040188 (?), 14:34, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Тут плакать надо…
     
  • 2.23, iPony (?), 11:54, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Safari - единственный из мажорных браузеров, где не выкидывают NPAPI
     
     
  • 3.87, Led (ok), 22:22, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Safari - единственный из мажорных браузеров

    Тебя, шалун, обманули, и воспользовались:)

     
     
  • 4.115, элвис жив (?), 06:33, 01/02/2016 [^] [^^] [^^^] [ответить]  
  • +/
    а что, разве Сафари таки не для мажоров?
     
  • 2.24, A.Stahl (ok), 11:55, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Internet Explorer 6
     
  • 2.40, . (?), 12:53, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Эти "хорошие" люди думают, что есть не только игры в интернете, но
    > и IntrAnet, где куча старово софта, куча старово железа с управлением
    > через Web Java?

    jnlp и плагины - как бы две разные сущности. Первую оракл пока не отменял. Вторая используется довольно редко (у меня вот есть небольшой кусочек внутри цискиного монстра (prime), но он давно уже не работает с той версией, с которой работают нужные мне его части)
    Кроме того, прекрасный "cтарый софт" обычно требует какую-нибудь java 5.14.5-18, шаг вправо/влево - "socket error".


     
     
  • 3.88, . (?), 22:26, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    >Кроме того, прекрасный "cтарый софт" обычно требует какую-нибудь java 5.14.5-18, шаг вправо/влево - "socket error".

    Это - да, каждый раз вспоминаю "write once" в исполнении жабофонов :)
    Интересно голубые и хиппи обновят софт для мэнэджу их старыз блэйдов? Или "пепельнеца полна, замените автомобиль!" ? :-)

     
  • 2.44, Crazy Alex (ok), 13:02, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ну вот и будете под замшелую кривую хрень держать замшелый браузер с замшелой джавой, благо виртуалку поднять - невелика сложность.
     
     
  • 3.91, . (?), 23:44, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    ... а под sha1 certs ещё одну.
    ... а под md5 certs ещё одну.
    ... а под XP only SW - ещё одну.
    ... а под [ ... ] ещё одну.
    8-о Твою за ногу, уже нужен какой то окестрэйшен чтоб в них ногу не сломать. :)


    А вообще - это будет лютый вин если вдруг окажется что больая часть полезной работы делается из вм-ок с легаси софтом :))))

     
     
  • 4.94, Crazy Alex (ok), 04:38, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А что мешает в одну вм-ку с XP засунуть браузер, который всё это уметь будет?

    Ну и, понятно, если оно в масштабах окажется - это будет не лютый вин, а лютый фейл тех, кто принимал решения о выборе железа/софта, у которого поддержки приличной нет, чтобы  обновить до недырявого состояния.

     
     
  • 5.103, count0krsk (ok), 07:52, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > А что мешает в одну вм-ку с XP засунуть браузер, который всё
    > это уметь будет?

    Я тут это, признаться хочу. У меня есть виртуалка с XP :'(
    И там IE 6 и много старого софта, который не работает в вайне, но по учебе надо было.
    Она даже была SP2 до недавнего времени.  

     
  • 4.112, нонанимус (?), 17:43, 30/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Примерно так я и работаю, а что тут такого?
     
  • 2.58, longliveubuntu (?), 14:43, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Seamonkey?
     
  • 2.72, kido (?), 17:28, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ну так не обновляйтесь.
     

  • 1.17, Я (??), 11:47, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    Банки будут требовать древнюю версию браузера и жавы?
     
     
  • 2.22, Соколов (?), 11:54, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >Банки будут требовать древнюю версию браузера и жавы?

    Ну во-первых девятая Ява еще не вышла. Ява 8 какбэ пока еще не древняя. Многие прекрасно работают и на 6, и на 7. А банки пусть шевелятся, не все ж бабло стричь за ковыряние в носу.

     
  • 2.25, be_nt_all (ok), 11:55, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Банки перепишут свои безнадёжно устаревшие веб-клиенты, у них просто не останется другого выхода.
     
     
  • 3.46, Михрютка (ok), 13:04, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Банки перепишут свои безнадёжно устаревшие веб-клиенты, у них просто не останется другого
    > выхода.

    бггг. что проще переписать аппликуху или повесить на стартовой страничке предупреждение "Для работы с приложением требуется только IE6, в других браузерах функционал цифровой подписи будет недоступен"

    protip банки получают доход не с продаж веб-клиентов

     
     
  • 4.51, Ан (??), 13:45, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Ну и начнут их постепенно обходить стороной. Или вы думаете все к ним на поклон ходить будут что бы те не выкинули?
     
     
  • 5.65, Михрютка (ok), 16:04, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Ну и начнут их постепенно обходить стороной. Или вы думаете все к
    > ним на поклон ходить будут что бы те не выкинули?

    еще как будут. вы всерьез думаете что при выборе банка версия браузера на котором работает клиент банк имеет для потребителя хоть какое-то значение? подумайте еще раз.

    когда вы сами думали в каком банке открыть депозит или текущий счет или взять кредит вас это хоть как-то беспокоило?

     
  • 4.55, Сергей (??), 14:33, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    В свое время, как сейчас не знаю, но тоговая площадка сбера требовала IE8, с IE9 работать отказывалась
     

  • 1.21, be_nt_all (ok), 11:53, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Ну да, апплетам конец, флэш следующий, в общем, давно к этому шло.

    а в интранете для специфических задач, где безопасность побоку, можно и старую какую нибудь сборку браузера/java использовать, наверное. Если весь софт к старому железу без исходников и перекомпиляции не подлежит.

    Интересно, что будет с MIT-овским учебным языком программирования Scratch, для первой версии которого есть распространение написанных на нём игр и приложений в интернете через java-аплет, а вторая переписана на флэше…  Впрочем у мня давно руки чешутся первый Скрэтч форкнуть, а тут и повод хороший есть.

     
     
  • 2.38, Аноним (-), 12:51, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > что будет с MIT-овским учебным языком программирования Scratch

    умрет, с языками программирования точно нет проблем сейчас - на любой вкус, даже для любителей 50ти оттенков серого.

     
     
  • 3.78, Аноним (-), 20:00, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Можно пример?
     
  • 3.113, be_nt_all (ok), 04:15, 31/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ещё раз, это язык для обучения школьников, ориентировочно так с класса первого. Визуальный, легко интернационализируемый, ориентированный на упражнения a la «управляем черепашкой» и написание простеньких игрушек.

    ps. Впрочем современная версия форка скрэтча (там значительно более мощный и расширяемый язык), написанная в небезызвестном университете Беркли и, сейчас, называющаяся Snap! переписана на православный JS/HTML5.  

     

  • 1.29, Аноним (-), 12:01, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Webex под linux все?
     
     
  • 2.47, Аноним (-), 13:05, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Я для него и так 32-битный чрут юзал. Хоть сам "этим" пользовался, но никогда не считал ўёбекс чем-то рабочим. Ему было "всё" ещё до написания. Эта хрень пилится индусами в Бангалоре, как мне рассказали когда я работал в сиске.
     

  • 1.30, manster (ok), 12:02, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Привет крипто-токенам со своими плагинами для контейнеров
     
     
  • 2.35, Аноним (-), 12:51, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    у которых всемя от времени обнаруживают способ добычи неизвлекаемого ключа или фсб не продлевает лицензию за месяц до тотального внедрения по всей стране
     
     
  • 3.43, manster (ok), 12:59, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    ну это уже не плагин-проблемы, хотя и связано так-же с безопасностью
     

  • 1.31, manster (ok), 12:07, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Недавно в обновлениях dev-java/icedtea-bin приехал webstart по дефолту в USE

    Если icedtea оставит поддержку браузерного плагина (а скорее всего так и будет), то популярность вырастет в разы...

     
  • 1.36, Аноним (-), 12:51, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    а как быть с iLO от HP или DRAC от DELL ?
     
     
  • 2.42, Михрютка (ok), 12:57, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    firefox esr вам в руки. я 17 версию для таких случаев уже года два использую еще как только начались пидерсии с поддержкой "небэзопасного" крипто.

    ну или купить саппорт и обновить фирмварь (если есть такая возможность).

     

  • 1.39, Михрютка (ok), 12:53, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    как обычно, опеннетовский автор не умеет в английский.

    Oracle plans to deprecate the Java browser plugin in JDK 9 != Oracle прекратит поставку браузерного плагина в Java 9

    Oracle plans to deprecate the Java browser plugin in JDK 9.

    The deprecated plugin technology will be completely removed from the Oracle Java
    Development Kit (JDK) and Java Runtime Environment (JRE) in a future Java release
    TBD.

    ну в общем отказ от NPAPI был на стене ОТАКИМИ БУКВАМИ еще с момента когда гугль решил запилить свой плугин с отладчиком и сотрудницами техподдержки (и напихать в бровзер еще больше ненужного говнища).

    не проблема. предприятия которым хватает гугльдоков вообще не поймут о чем речь конторам покрупнее не проблема прибить браузер и плугин гвоздями.

    в любом случае есть время года три-четыре подумать и смигрировать.

    походу там в оракловском блоге им видимо насовали полную панамку уев потому что каменты к записи закрыты.

     
     
  • 2.74, Аноним (-), 17:58, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Подозреваю, что вначале в анонсе было "drop" вместо "deprecate" и потом поправили задним числом. Подозрительно, но многие ранние западные упоминания в новостях указывают именно "drop". И заметка точно называлась "Moving to a Plugin-Free", а сейчас "Moving to a Plugin-Free Web", явно была правка.

    Oracle To Drop Java Browser Plugin In JDK 9
    Oracle to kill off Java browser plugins with JDK 9
    Oracle Will Kill Java Browser Plugin with JDK 9 in 2017
    Für ein Plug-in-freies Web: Oracle verabschiedet sich von Java-Plug-in

     
     
  • 3.86, Михрютка (ok), 22:20, 28/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Подозреваю, что вначале в анонсе было "drop" вместо "deprecate" и потом поправили
    > задним числом. Подозрительно, но многие ранние западные упоминания в новостях указывают
    > именно "drop". И заметка точно называлась "Moving to a Plugin-Free", а
    > сейчас "Moving to a Plugin-Free Web", явно была правка.
    > Oracle To Drop Java Browser Plugin In JDK 9
    > Oracle to kill off Java browser plugins with JDK 9
    > Oracle Will Kill Java Browser Plugin with JDK 9 in 2017
    > Für ein Plug-in-freies Web: Oracle verabschiedet sich von Java-Plug-in

    вы считаете что дураки пишут новости только на опеннет? я так не уверен. дурак это интернациональное и кроссплатформенное понятие.

     
  • 3.104, iPony (?), 08:10, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Нет. Большинство этих новостей с такими заголовками, идут имеенно с цитатой "Oracle plans to DEPRECATE the Java browser plugin in JDK 9"
     

  • 1.48, Аноним (-), 13:13, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –4 +/
    Печально(HTML 5 уг,лучше бы оставались java и flash в браузере.Раньше можно было их просто не ставить, и никакого хлама  в браузере не было.
     
  • 1.53, Твоя мама (?), 14:18, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Кроме Java, из остающихся в обиходе NPAPI-плагинов выделяются только Flash, Unity и Silverlight

    Google Talk Plugin забыли. Без него в firefox видео в hangouts до сих пор не работает. В Chrome оно работает через NaCl.

     
  • 1.60, DmA (??), 14:56, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    а я думал Unity - это вирус...
    html5 похоже не только флеш убила насовсем, но джаву...
    8я джава уже в том же СУФД тормозит не по детски, представляю как 9ка будет тормозить.. Опреденно нужно казначейству уходить от джавы и опять возвращаться к  обычным приложениям и снова получить проблему обновлений на стороне клиента
     
  • 1.64, Мимино (?), 15:51, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А как насчёт JavaFX?
     
  • 1.68, Аноним (-), 16:37, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    надейтесь на корпорастов дальше, вечен только Си
     
  • 1.82, Roo2AT7d (ok), 21:19, 28/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Пусть WebAssembly используют, не нужно тащить в браузер лишние сущности.
     
  • 1.92, stalker37 (ok), 00:12, 29/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    гыгы..
    и чем же теперь IPMI серверов ковырять.. те хе hp/supermicro и так далее...
     
     
  • 2.93, wd (?), 02:45, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    на всех моих супермикрах (весьма старых) ipmi консоль таки об java web start, куда кокраз и направляют
     
     
  • 3.107, stalker37 (ok), 12:12, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    ну на супермикрах да..а вот на хп обычное браузерное поделие и соответственно без плугина в браузере не работает. аналогично и на dell
     
  • 2.95, Crazy Alex (ok), 04:48, 29/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Можно подумать, все старые версии разом перестанут работать
     

  • 1.96, Аноним (-), 05:01, 29/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    круть. у нас он для ЭЦП на гос сайтах используется.
     
  • 1.98, Аноним (-), 06:30, 29/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Кстати JavaFX умеет в браузере. Хотя ее как десктоп-приложение можно запустить.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру