The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Выпуск панели Dash to Dock 66

18.03.2019 07:40

Состоялся релиз панели Dash to Dock 66, которая выполнена в виде расширения к оболочке GNOME Shell. На основе Dash to Dock построена панель Ubuntu Dock, которая поставляется в составе Ubuntu вместо оболочки Unity. Ubuntu Dock главным образом отличается настройками по умолчанию и необходимостью использования иного имени для организации обновления с учётом специфики поставки через основной репозиторий Ubuntu, а разработка функциональных изменений производится в рамках основного проекта Dash to Dock.

В новой версии добавлена поддержка GNOME Shell 3.32 и прекращена поддержка версий 3.18 и 3.30. Выполнено портирование на использование современных возможностей языка ECMAScript 6. Для пиктограмм приложений добавлен обработчик кликов для смены фокуса или предпросмотра, который обеспечивает предпросмотр только при наличии активного фокуса на пиктограмме, а если пиктограмма не выбрана, то клик лишь переводит на неё фокус. Прекращена поддержка режима адаптивной установки прозрачности (панель теперь всегда непрозрачная). Решены проблемы с выбором неверного фонового цвета для некоторых пиктограмм (например, пиктограммы Slack).

  1. Главная ссылка к новости (https://micheleg.github.io/das...)
  2. OpenNews: Выпуск панели Dash to Dock 65
  3. OpenNews: Выпуск панели Plank 0.11
  4. OpenNews: Выпуск панели LXPanel 0.9.0
  5. OpenNews: Выпуск Latte Dock 0.8, альтернативной панели для KDE
  6. OpenNews: Выпуск панели Xfce 4.13.4, развиваемой для Xfce 4.14
Лицензия: CC-BY
Тип: Программы
Ключевые слова: dashtodock, dock, panel, gnome
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (23) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (1), 07:44, 18/03/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    "Прекращена поддержка режима адаптивной установки прозрачности"

    Всё в стиле gnome3.
    Когда сидел на гноме, пользовался этой функцией у dash to dock

     
     
  • 2.11, Аноним (11), 15:39, 18/03/2019 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Потому что фича была багованная, а фиксить было некому. Прошло 2 года и решили ломоть отрезать. Политика такая же как в линуксовом ядре.

    https://gitlab.gnome.org/GNOME/gnome-shell/issues/408

    Но нет, поливать мы будем гном - потому что гладиолус.

     
     
  • 3.19, Тот_Самый_Анонимус (?), 05:30, 19/03/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Политика такая же как в линуксовом ядре.

    Да чё там, вообще во всех дистрах: у мантейнера нет интереса, можете делать сами. А потом нытьё: «ну почемы мы как российская оппозиция, всего 2%»...

     
     
  • 4.21, нах (?), 16:01, 19/03/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > у мантейнера нет интереса, можете делать сами

    "а хотя бы не ломать без конца апи - вам никто не обещал!"

     
  • 4.24, Аноним (24), 00:05, 20/03/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Ну так опенсорс же. Хочешь длительную поддержку как розничный софт - плати как за розницу. Майкрософту платят - вот он и держит бинарную (!) совместимость с софтом. Бинарную, Карл!

    Попробуй запустить без пересборки линуксовое приложение пятилетней давности. Разве что игры в Стиме запустятся благодаря Steam Runtime.

    Но и это потому что...
    *барабанная дробь*
    Valve тоже не за бесплатно работает.

     

  • 1.2, edv (?), 08:00, 18/03/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    "...и прекращена поддержка версий 3.18 и 3.30."

    Прекращена поддержка 3.30, точно?

     
     
  • 2.3, helloworld (?), 08:06, 18/03/2019 [^] [^^] [^^^] [ответить]  
  • +/
    "As such, support for previous Gnome shell versions has been dropped. I will try to backports fixis and features (gnome-3.30 branch) as much as possible."
     
  • 2.4, edv (?), 08:06, 18/03/2019 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Если так, и не ведётся поддержка веток для прежних версий gnome-shell, то это действительно в "лучших традициях" Gnome.

    Вызываю iPony для значка facepalm.

     
     
  • 3.8, Отражение луны (ok), 11:56, 18/03/2019 [^] [^^] [^^^] [ответить]  
  • +5 +/
    В данном случае проблема в ломающем каждый релиз api (ну точнее там нет никого api) гноме. Мало кто захочет тратить свое время на поддержку расширения для софта, разработчикам которого на тебя глубоко похрену. Тем более что ты прекрасно понимаешь, что со следующей версией обратную совместимость снова убьют.
     
     
  • 4.9, MAN (??), 13:40, 18/03/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Это так. Сидел на гноме, очень нравилось кроме тормозов, но вот в очередной раз сломали совместимость, из-за чего половина расширений отвалилось, я почухал лоб, и переполз на kde + lattedock, да, пришлось повозиться, да, kde жутко перегружены настройками и настройками по-умолчанию (вроде сочетания клавиш ctrl+f4), но в итоге все работает, и о чудо, не течет память!
     
     
  • 5.18, Отражение луны (ok), 23:40, 18/03/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    У меня та же история
     
  • 5.20, namles (?), 13:37, 19/03/2019 [^] [^^] [^^^] [ответить]  
  • +/
    Про какие вы тормоза говорите? Я вообще спрашиваю, просто у меня все плавно и шустро работает, сижу на открытых драйверах амд.
     
     
  • 6.23, MAN (??), 19:55, 19/03/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    У меня intel,и практически везде чувствуются некоторые задержки в отклике интерфейса. Но том же ноуте plasma работает мгновенно.
     
  • 2.13, IRASoldier (?), 20:34, 18/03/2019 [^] [^^] [^^^] [ответить]  
  • +/
    >Прекращена поддержка 3.30

    А кто мешает использовать на 3.30 версию, предназначенную для 3.30?

     

  • 1.5, иПони (?), 08:24, 18/03/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    Значок фэйспалм
     
  • 1.7, feoktist.rassolny (?), 10:00, 18/03/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Вот кому адаптивка мешала?
     
  • 1.10, lucentcode (ok), 13:44, 18/03/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Юзал пару дней версию из git, а теперь дождался релиза! Одно из любимых расширений, по полезности только Switcher и TopIcon Plus ему не уступают. Так как обновился до Gnome 3.32 несколько дней назад, пришлось юзать версию из Git до выпуска новой версии расширения, ведь старые версии на Gnome 3.32 не заводились. Хорошо что Switcher без проблем работает в 3.32, хотя его пока специально для 3.32 не обновляли.
     
     
  • 2.17, Аноним84701 (ok), 21:52, 18/03/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > по полезности только Switcher

    ...
    > Юзал пару дней версию из git, а теперь дождался релиза! Одно из
    > любимых расширений, по полезности только Switcher и TopIcon Plus ему не уступают.
    > Хорошо что Switcher без проблем работает в 3.32, хотя его пока специально для 3.32 не обновляли.

    Млин, обломщики :(
    Я-то думал,  какая-то новая, полезная, инновационная придумка последних лет. Полез искать и смотреть … а там:
    https://extensions.gnome.org/extension/973/switcher/
    https://github.com/daniellandau/switcher
    > JavaScript 98.8% CSS 1.2%

    [...]
    > Use the configured global hotkey (Super+w by default) to open a list of current windows.
    > Type a part of the name or title of the application window you want to activate and hit enter or click on the item you wish to activate.

    Ох уж эти гномеры -- все норовят или переусложнить или выкинуть или (последние годы) переписать на модном ЖС и представить в качестве инновационной инновации :)
    Дарю.  Тоже "type name or title or ID, press enter or click on the item", но работает уже надцать лет как, хотя специально для <вставить версию чего угодно> не обновляли:

    [code]
    #!/bin/sh
    wmctrl -l |awk '{printf "%#.8lx",$1; $2=" ▏"; $1=""; $3="";print $0}' | sed "s/$(echo -ne '\u202a')//g"| dmenu -l 30 -fn "Terminus:pixelsize=18:lang=ru" -nf "#00b000" -nb "#201020"  -i | cut -d " " -f1 | xargs wmctrl -ia
    [/code]
    ну или
    [code]
    #!/bin/sh
    wmctrl -lx |awk '{printf "%#.8lx ▏%-30.30s",$1,$3; $2=" ▏"; $1=""; $3=""; $4=""; print $0}' | sed "s/$(echo -ne '\u202a')//g"| dmenu -l 30 -fn "Terminus:pixelsize=18:lang=ru" -nf "#00b000" -nb "#201020" -i | cut -d " " -f1 | xargs wmctrl -ia[/code]

     

  • 1.12, EnemyOfDemocracy (?), 19:24, 18/03/2019 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Чтобы прямо сейчас увидеть как Gnome 4 будет выглядеть в будущем, достаточно открыть терминал с sh (не bash!) и развернуть на весь экран.
     
     
  • 2.15, Аноним (15), 20:57, 18/03/2019 [^] [^^] [^^^] [ответить]  
  • +1 +/
    если бы ...
     
  • 2.16, аноним3 (?), 21:26, 18/03/2019 [^] [^^] [^^^] [ответить]  
  • +/
    в смысле до упрощаются до терминала?))) я помнится гном 2 обвинял в том что настроек нифига нет и функций слабовато, а тут 3 гном появился и ..... я просто решил даже не смотреть на эти недоподелия. самое страшное жрет как будто реально там фич милионы))
     
  • 2.22, нах (?), 16:02, 19/03/2019 [^] [^^] [^^^] [ответить]  
  • +/
    не понял, куда мои нескучные обойчики дели?!

     
  • 2.25, anonymous (??), 14:24, 21/03/2019 [^] [^^] [^^^] [ответить]  
  • +/
    > Чтобы прямо сейчас увидеть как Gnome 4 будет выглядеть в будущем, достаточно открыть терминал с sh (не bash!) и развернуть на весь экран.

    +100500

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру