The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Доступен минималистичный дистрибутив Alpine Linux 3.5

22.12.2016 21:53

Подготовлен релиз Alpine Linux 3.5, минималистичного дистрибутива, построенного на базе системной библиотеки Musl и набора утилит BusyBox. Дистрибутив сформирован с оглядкой на повышенную безопасность и собран с патчами PaX и SSP (Stack Smashing Protection). Alpine применяется для формирования официальных образов контейнеров Docker. Загрузочные iso-образы (x86_64, x86, armhf, aarch64) подготовлены в пяти вариантах: урезанном (75 Мб), с ядром без патчей (76 Мб), расширенном (245 Мб) и для виртуальных машин (24 Мб).

В новом выпуске осуществлён переход с OpenSSL на LibreSSL, началось формирование сборок для архитектуры aarch64, добавлена возможность использования файловой системы ZFS в корне, добавлена поддержка языков R, JRuby и OCaml, улучшена поддержка Python 3. Обновлён графический стек (xorg-server 1.18.4, GTK+3.0 3.22.5) и пакеты, например LibreOffice 5.2.3.3, PostgreSQL 9.6.x. Samba 4.5.3, glib 2.50.2. Пакет nodejs переименован в nodejs-current и перемещён в репозиторий community, а пакет nodejs-lts переименован в nodejs.

  1. Главная ссылка к новости (https://www.alpinelinux.org/po...)
  2. OpenNews: Вышел минималистичный дистрибутив Alpine Linux 3.4
  3. OpenNews: Выпуск Docker 1.10. Перевод официальных образов Docker с Ubuntu на Alpine
  4. OpenNews: Вышел дистрибутив Alpine Linux 3.3
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/45752-alpine
Ключевые слова: alpine, linux
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (34) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 21:58, 22/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Молодцы, что-то такое для Raspberry Pi и нужно
     
     
  • 2.13, Michael Shigorin (ok), 12:33, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • –5 +/
    Да оно не только на разбери хорошая штука, как понимаю.
     

  • 1.2, Андрей (??), 22:48, 22/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    > В новом выпуске осуществлён переход с OpenSSL на LibreSSL

    Зачем? Ведь:
    GNU> We recommend using GNUTLS instead of OpenSSL in software you write.

     
     
  • 2.3, Андрей (??), 22:52, 22/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ну хорошо, судя по https://en.wikipedia.org/wiki/LibreSSL
    там пофикшено больше багов. Но проблема с лицензией так и остаётся. Например, GPLv3 ring.cx не может использовать OpenSSL.
     
  • 2.4, Андрюха (??), 01:09, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Это дистрибутив, блджад, а не прога. И OpenSSL в нем должен быть.
     
     
  • 3.6, Vaka (?), 01:59, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Так в нем есть openssl. Никто не мешает использовать. просто по умолчанию тянет libre
     
  • 2.33, skybon (ok), 16:09, 24/12/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Столлман теперь истина в последней инстанции?
     

  • 1.5, Аноним (-), 01:19, 23/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Молодцы, но TinyCore меньше.
    Есть куда развиваться.
     
     
  • 2.7, Vaka (?), 02:03, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Молодцы, но TinyCore меньше.
    > Есть куда развиваться.

    В минималке ядро+musl+busybox+openrc.

    Куда уже меньше?

     
     
  • 3.12, Онанимус (?), 09:55, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Куда уже меньше?

    Побойтесь OpenWRT!


     
  • 2.8, бедный буратино (ok), 04:18, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    мда, тяжёлый случай
     
  • 2.9, Аноним (-), 08:32, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    У этих проектов разные задачи.

    > TinyCore
    > Our goal is the creation of a nomadic ultra small graphical desktop operating system capable of booting from cdrom, pendrive

    Никто его в здравом уме в качестве десктопа или сервера использовать не будет. Ну разве что дома побаловаться.

     
     
  • 3.17, Аноним (-), 16:53, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А Alpine изначально вообще был дистр для эмбеддовки и роутеров. Это сейчас там десктоп решили пилить. Непонятно зачем - десктопных дистров и так жoпой жуй.
     
     
  • 4.20, Аноним (-), 17:55, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Alpine применяется для формирования официальных образов контейнеров Docker.

    Он тоже нашёл свою нишу.

     
  • 3.31, Другой Аноним (?), 06:46, 24/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >Никто его в здравом уме в качестве [..] или сервера использовать не будет

    Почему? Вот мне надобно на серваке крутить одну задачу, но ресурсоемкую.
    Чем не пойдет?

     
     
  • 4.34, Аноним (-), 08:20, 25/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Неудобно. Будете каждый нужный пакет в ручную собирать? Тогда уж проще, ArchLinux, хоть я его и не люблю.
     
     
  • 5.35, Другой Аноним (?), 06:50, 26/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Неудобно. Будете каждый нужный пакет в ручную собирать? Тогда уж проще, ArchLinux,
    > хоть я его и не люблю.

    Вот я и думаю - кого выбрать - несколько одинаковых серверов, на них нужно только sshd, iptables2, да и все, пожалуй. Будет крутиться аппликуха
    без внешних зависимостей (кроме glibc). Хочется централизованное обновление и минимум лишнего. Тяготею к deb, хотя это не принципиально. Что посоветуете?

     

  • 1.10, Shichael Migorin (?), 09:28, 23/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +3 +/
    в пяти вариантах:
    1 урезанном (75 Мб),
    2 с ядром без патчей (76 Мб),
    3 расширенном (245 Мб)
    4 и для виртуальных машин (24 Мб).
    Найс
     
     
  • 2.14, alpar (?), 15:25, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >для виртуальных машин

    *virt*
    *Xen*

     

  • 1.15, chinarulezzz (ok), 15:39, 23/12/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Любителям могу рекомендовать Void: glibc/musl, hardened, libressl, runit, xbps+xbps-src+tor, rolling, i686/x86_64/armv5te/armv5tel/armv6hf/armv6l/armv7hf/armv7l/mips/mipsel/mipselhf.

    Не уговариваю. Просто к сведению.

     
     
  • 2.16, allnix (ok), 16:08, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Мята падучая там (gtk3), крыса норм...
     
     
  • 3.18, chinarulezzz (ok), 17:11, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Если бы только мята) я бы в целом выразился о дистре: навороченная пороховая бочка с парашютом. Юзерам противопоказана. Но продвинутым, апстрим-разработчикам, хакерам подойдёт. К тому же, минимальная база, которая может быть легко собрана под 12 архитектур, достаточно стабильна, и одновременно наисвежайша (спеллчекер не знает такого слова, лол).

    Да и по вкусу будут всякие ништяки, вроде гитхаб-разработки, присутствие ~всех разрабов в irc'e, билдботе, ядер на выбор (3.14, 3.18, 4.1, 4.3, 4.4-lts, 4.5, 4.6, 4.7, 4.8, 4.9,  версии для всяких микроустройств, netbsd-rump), легкой и простой кросскомпиляции под всякие архитектуры, простых шаблонов сборки пакетов.

     
     
  • 4.24, Аноним (-), 19:52, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    наисвежайшаЯ
     
     
  • 5.25, chinarulezzz (ok), 19:59, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > наисвежайшаЯ

    каковá?

     
  • 4.28, anonymous (??), 22:55, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Мне Войд показался не сложнее Арча. Вот только с документацией куда сложнее, такой вики как у последних нету и в помине.
    Впрочем, неподъемных вопросов передо мной Войд не ставил, а если их маны что-то и не охватывали, то накрайняк можно было подсмотреть в доках других дистрибутивов, например того же Арча.
     
  • 3.27, anonymous (??), 22:41, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    пользуюсь циннамоном, ничего не падает - никаких претенций к работе нет
    или вы о том, что какое-то время назад они поломали пакеты минтовые ДЕ (как раз не пережили очередной апдейт gtk3)? даже новость написали на своем сайте, когда все пофиксили
    http://www.voidlinux.eu/news/2016/11/Mate-1.16.1-and-Cinnamon-3.2.html
     
     
  • 4.30, allnix (ok), 00:23, 24/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Нет, из коробки, не уверен что последний срез, но до xbps-install Su, при первичных настройках панель становится не юзабельна вообще, то сильно раньше было.
     
  • 2.19, Андрей (??), 17:22, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А я добавлю, что дистрибутив не смотря на свою новизну выглядит устаревшим, т.к. не поддерживает multiarch. А также Debian Testing, который multiarch, является rolling и hardened, и там есть по крайней мере пакеты musl и newlib. Есть куча архитектур. Чего нет, так это LibreSSL - лучше просто использовать GnuTLS. Так, как напоминание.
     
     
  • 3.21, chinarulezzz (ok), 18:04, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    >устаревшим
    >multiarch

    контейнеросрач, так понимаю?)

     
     
  • 4.22, Андрей (??), 18:15, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Контейнерами не пользуюсь. Всё собирается кросс-компилятором, а затем запускается сразу на рабочем Debian благодаря qemu-user-static.
     
     
  • 5.23, chinarulezzz (ok), 18:19, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Контейнерами не пользуюсь. Всё собирается кросс-компилятором, а затем запускается сразу
    > на рабочем Debian благодаря qemu-user-static.

    Все это возможно и в Void.

     
     
  • 6.26, Андрей (??), 22:16, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Т.е. можно взять и установить одновременно пакеты, например libicu-dev:amd64, libicu-dev:i386, libicu-dev:armv7hf? И есть пакеты с кросс-компиляторами для всех поддерживаемых платформ, так что установил -dev пакет и больше ничего не надо делать: компилятор ищет заголовки и либы в правильных путях?
     
     
  • 7.29, chinarulezzz (ok), 23:07, 23/12/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Т.е. можно взять и установить одновременно пакеты, например libicu-dev:amd64, libicu-dev:i386,
    > libicu-dev:armv7hf? И есть пакеты с кросс-компиляторами для всех поддерживаемых платформ,
    > так что установил -dev пакет и больше ничего не надо делать:
    > компилятор ищет заголовки и либы в правильных путях?

    ./xbps-src -h

    Options:

    -a  <target>
        Cross compile packages for this target machine. Supported targets:

    aarch64-musl
    aarch64
    armv5te-musl
    armv5te
    armv5tel-musl
    armv5tel
    armv6hf-musl
    armv6hf
    armv6l-musl
    armv6l
    armv7hf-musl
    armv7hf
    armv7l-musl
    armv7l
    i686-musl
    i686
    mips-musl
    mipsel-musl
    mipselhf-musl
    x86_64-musl

     
     
  • 8.32, Андрей (??), 14:45, 24/12/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Хорошо, кросскомпилировать можно, а как ... текст свёрнут, показать
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру