The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Выход проприетарного драйвера NVIDIA 325.15 и библиотеки libvdpau 0.7

06.08.2013 09:07

Компания NVIDIA опубликовала первый стабильный выпуск новой серии проприетарного драйвера NVIDIA 325.15. Драйвер доступен для Linux, FreeBSD и Solaris.

В новой версии добавлена поддержка GPU GeForce GT 625, GRID K340, GRID K350, NVS 315 и Quadro K500M, а также прекращена поддержка ядер Linux серии 2.4. Для работы драйвера теперь требуется ядро Linux 2.6.9 или более новая версия. В прошлых LTS-сериях 319.x, 173.14.xx и 304.xx поддержка ядер 2.4.x будет сохранена. Из других изменений, не связанных с исправлением ошибок, можно отметить добавление в nvidia-settings настройки поворота экрана для каждого дисплея в отдельности. В разделе "X Server Display Configuration" конфигуратора nvidia-settings добавлена поддержка настройки режимов SLI Mosaic и Base Mosaic. Увеличена производительность сложных градиентов.

Одновременно представлен релиз libvdpau 0.7, открытой библиотеки с поддержкой API VDPAU (Video Decode and Presentation) для Unix. Библиотека позволяет обеспечить работу реализации VDPAU API на базе сторонних технологий аппаратного ускорения, например, через использование Intel VA-API. VDPAU API предназначен для задействования возможностей GPU по аппаратному ускорению обработки различных форматов видео, например, на плечи GPU могут быть вынесены функции пост-процессинга, слияния (compositing), отображения и декодирования. В новой версии устранена утечка файловых дескрипторов и добавлена поддержка переменной окружения DRI_PRIME для выбора корректного устройства DRI2 в конфигурациях с несколькими видеокартами. Также опубликован новый плагин к libvdpau, позволяющий организовать работу VDPAU API без проприетарного драйвера NVIDIA на системах, поддерживающих OpenGL и VAAPI. Например для аппаратного ускорения видео в Adobe Flash Player на видеокартах AMD и Intel.

  1. Главная ссылка к новости (https://devtalk.nvidia.com/def...)
  2. OpenNews: В проприетарном драйвере NVIDIA 325.08 прекращена поддержка ядер Linux 2.4
  3. OpenNews: Компания NVIDIA начала публикацию видеодрайверов для Linux-систем на базе ARM
  4. OpenNews: Обновление проприетарного драйвера NVIDIA 319.32
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/37605-nvidia
Ключевые слова: nvidia, vdpau
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (23) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.3, ананим (?), 09:37, 06/08/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Надеюсь 3.10 и 3.11 поддерживаются?
    А то предыдущие самописными патчами пришлось адаптировать.
     
     
  • 2.4, оНаним (?), 09:50, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Да.
     

  • 1.7, Аноним (7), 11:36, 06/08/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Ждем ебилдов...
     
  • 1.8, fi (ok), 11:37, 06/08/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    "Linux 2.6.9" рх4 ???  - надо же, еще тянут.
     
  • 1.9, анон (?), 13:00, 06/08/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    да это праздник какой-то: удалил венду, заработал оптимус, вышла дота2 под линукс, обновился драйвер
     
     
  • 2.10, ананим (?), 13:03, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >заработал оптимус

    Разве?

     
     
  • 3.11, анон (?), 13:28, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    optirun %app_name% ,запускает на нвидии, спасибо Bumblebee
     
     
  • 4.14, ананим (?), 13:44, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    ну, это не оптимус и работает с оверхедом. кстати, primusrun быстрее (но ненадёжнее).

    а оптимус работает пока вот так — http://us.download.nvidia.com/XFree86/Linux-x86/325.15/README/optimus.html сами настройки http://us.download.nvidia.com/XFree86/Linux-x86/325.15/README/randr14.html (BusID должен быть вот в таком формате "PCI:1:0:0").
    у меня не завёлся.

     
     
  • 5.16, Аноним (-), 14:36, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > ну, это не оптимус и работает с оверхедом. кстати, primusrun быстрее (но
    > ненадёжнее).
    > а оптимус работает пока вот так — http://us.download.nvidia.com/XFree86/Linux-x86/325.15/README/optimus.html
    > сами настройки http://us.download.nvidia.com/XFree86/Linux-x86/325.15/README/randr14.html
    > (BusID должен быть вот в таком формате "PCI:1:0:0").
    > у меня не завёлся.

    Плюсую! Пробовал 319.32, тоже не завелся

     

  • 1.12, frad00r4 (?), 13:34, 06/08/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    все ругают блоб nvidia, зато работает.
    Хотя в Steam щас что есть (и весь набор valve) идет и на Intel HD4000.
     
     
  • 2.13, анон (?), 13:41, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >> весь набор valve

    Взял, ука, все попробовал и написал коментарий.

    2 недели назад dota2 не шла, требовала нвидию

     
     
  • 3.15, ананим (?), 14:00, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    работает на hd4000
     
  • 2.17, Нанобот (ok), 14:39, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +3 +/
    >все ругают блоб nvidia, зато работает.

    ну не все ругают, а только наиболее радикальные фанатики

     
     
  • 3.19, ананим (?), 14:50, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Мастер вы ярлыки вешать.
    Я вот ругаю, история с оптимус (название даже издевательское. Окуенный оптимус) выше, ещё выше история с ядром >=3.10 (3 дня патчил. Нарушение гпл ошибки выдавали).
    К примеру с интелом я знаю только один параметр — тирингфри и всё. А тут блин оптимус.
     
     
  • 4.23, frad00r4 (?), 23:35, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Мастер вы ярлыки вешать.
    > Я вот ругаю, история с оптимус (название даже издевательское. Окуенный оптимус) выше,
    > ещё выше история с ядром >=3.10 (3 дня патчил. Нарушение гпл
    > ошибки выдавали).
    > К примеру с интелом я знаю только один параметр — тирингфри и
    > всё. А тут блин оптимус.

    у нас в конторе все рабочие станции ноуты. у некоторых АМД + интел аля оптимус только от ати. Так они тоже от счастья не пляшут

     
     
  • 5.26, ананим (?), 15:18, 07/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Это как-то меняет работу оптимус в нвидиа?
     
     
  • 6.28, frad00r4 (?), 11:34, 13/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Это к тому что все прославляют ati и хают nvidia, хотя самый вминяемый 3d на линухе только под nvidia. А у ati'шного оптимуса (не знаю как он правильно называется) дела не лучше
     
  • 2.18, Аноним (18), 14:48, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    ну да, на процах по 8 штук, идут игры на дряхлом движке 10 летней давности.
     
     
  • 3.22, frad00r4 (?), 23:31, 06/08/2013 [^] [^^] [^^^] [ответить]  
  • +/
    обыный ноут с core i5
     

  • 1.20, Аноним (20), 16:26, 06/08/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    libvdpau-va-gl не имеет никакого отношения к Nvidia. Но хоть как-то позволяет прикрутить аппаратное ускорение к Flash (который только VDPAU понимает). Единственный момент, он у меня в полноэкранном режиме выбивает в какое-то "левое" разрешение и потом уже не возвращается, даже переключение в консоль не работает (опробовал на AMD E-350). Но ускорение работает отлично и масштабирование (!) тоже аппаратное.

     
  • 1.21, Oinari (ok), 23:05, 06/08/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >libvdpau 0.7
    >позволяет обеспечить работу реализации VDPAU API на базе сторонних технологий аппаратного ускорения, например, через использование Intel VA-API.

    Можно подробнее?

    Обычный mplayer -vo vdpau заработает на Intel HD Graphics? Или же речь только о libvdpau-va-gl?

     
     
  • 2.24, Аноним (-), 00:16, 07/08/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Можно подробнее?

    Да там в новости сейчас полуправда написана. libvdpau -- это точка входа для VDPAU. (Исходный код libvdpau свободно доступен). C libvdpau линкуются приложения. А уже libvdpau грузит железо-специфичный usermode драйвер. Для оборудования nVidia это libvdpau_nvidia.so.1 (идёт в составе проприетарного драйвера), её код закрыт. Существуют и другие драйвера, например такие есть в составе Gallium, они открыты.

    libvdpau-va-gl -- это такой usermode драйвер VDPAU. В основном это для intel чипов с OpenGL и VA-API. С AMD пока работает нестабильно -- вылазят глюки из-за нестандартного использования.

    > Обычный mplayer -vo vdpau заработает на Intel HD Graphics?

    У меня работает на Intel HD Graphics, с драйвером libvdpau-va-gl.

     

  • 1.27, sHaggY_caT (ok), 23:12, 08/08/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А когда будет 3d под Nvidia на обычных видеокартах?
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру