The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

В ночных сборках Firefox для Linux включена поддержка декодирования H.264 через GStreamer

28.06.2013 09:47

В ночных сборках Firefox для Linux включена поддержка мультимедиа-фреймворка GStreamer, что позволяет использовать его в качестве бэкенда для проигрывания аудио/видео элементов HTML5. Работа через Gstreamer позволит воспользоваться на платформе Linux такими возможностями, как поддержка аппаратного ускорения, декодирование видео и привлечение GPU для решения вычислительных задач (например, применение фильтров, которые могут быть полностью реализованы на стороне GPU).

Наиболее заметным для конечных пользователей эффектом является обеспечение поддержки из коробки несвободных форматов H.264, AAC и MP3 для тегов video и audio, если для них в системе установлен соответствующий плагин для GStreamer. Так как кодек H.264 не встроен в браузер, а используется его внешняя реализация, проекту Mozilla не нужно лицензировать кодек и выплачивать роялти за использование технологий H.264. Аналогичная поддержка H.264, AAC и MP3 через задействование внешних системных библиотек уже реализлована ранее для платформ Windows и Android в Firefox 22 и Firefox 17.

Изначально поддержка GStreamer для Firefox была подготовлена ещё весной прошлого года, а указанный бэкенд уже активно используется в Firefox OS, но для активации в настольной версии до сих пор требовалась пересборка Firefox из исходных текстов. В качестве причины отказа от включения поддержки GStreamer по умолчанию называлась неготовность основных дистрибутивов для работы с Firefox, собранном с поддержкой GStreamer (в составе разных дистрибутивов поставлялись несовместимые между собой версии GStreamer). В текущей ночной сборке, по умолчанию Firefox собирается с поддержкой GStreamer, но для активации бэкенда необходимо активировать переменную "media.gstreamer.enabled" в about:config.

  1. Главная ссылка к новости (http://www.phoronix.com/scan.p...)
  2. OpenNews: Стабильный выпуск мультимедийного фреймворка GStreamer 1.0
  3. OpenNews: На базе GStreamer сформирован SDK для создания кросс-платформенных мультимедийных приложений
  4. OpenNews: В FireFox релизована поддержка GStreamer
  5. OpenNews: В Gstreamer добавлена возможность ускорения c задействованием OpenCL
  6. OpenNews: Mozilla рассматривает возможность поддержки H.264
Лицензия: CC-BY
Тип: К сведению
Короткая ссылка: https://opennet.ru/37300-gstreamer
Ключевые слова: gstreamer, firefox, video, h.264
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (46) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 10:22, 28/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    ждём ебилдов
     
     
  • 2.2, Аноним (-), 10:32, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +11 +/
    А самому сделать? Нахер тебе генточка, если даже ебилды делать не умеешь?
     
     
  • 3.3, Fracta1L (ok), 10:35, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Чтобы не делать ебилды, очевидно же.
     
     
  • 4.6, Аноним (-), 11:17, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Чтобы не делать ебилды, очевидно же.

    Что ж за гентушник такой, который без посторонней помощи себе программу собрать не может?

     
     
  • 5.19, Fracta1L (ok), 15:59, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >> Чтобы не делать ебилды, очевидно же.
    > Что ж за гентушник такой, который без посторонней помощи себе программу собрать
    > не может?

    Ленивый.

     
  • 5.30, ананим (?), 00:52, 29/06/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Что ж за гентушник такой, который...

    Гентушники кстати самые ленивые.
    Никаких апгрэйдов, куча версий одного и того же ПО.
    Вкалывают роботы, а не человек (ну разве что флаги проставить).
    Ну а обзяны ждут выхода убунты.
    Как-то так.

     
  • 4.29, ананим (?), 00:47, 29/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    ебилды с патчем поддержки гстример наверное год уже как.
    флаг только поставить. и сырцов же, т.е. траблы с версиями решаются на этапе компиляции и сборки.
     
  • 3.4, Аноним (-), 10:42, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Ждать ебилды намного интереснее. Каждый раз запуская eix-sync надеешься, что уж сейчас-то точно появится нужный ебилд... А потом теплая нежная компиляция.
     
     
  • 4.27, Okarin (ok), 22:20, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Жениться вам пора, барин.
     
  • 3.42, FSA (ok), 20:28, 30/06/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    А зачем делать, если есть профи, которые это сделают лучше? Я почти гарантировано получу стабильную систему не запариваясь с глюками. Ничего не глючит. Всё работает. В Ubuntu несмотря на простой обновлятор постоянно искал что и где вылетело. И сложно найти проблему. В Gentoo я запускаю обновление и смотрю что мне рекомендуют сделать после установки. Мне не нужно заниматься системой, я могу просто работать.
     
     
  • 4.43, Аноним (-), 21:25, 30/06/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > А зачем делать, если есть профи, которые это сделают лучше? Я почти
    > гарантировано получу стабильную систему не запариваясь с глюками. Ничего не глючит.
    > Всё работает. В U****u несмотря на простой обновлятор постоянно искал что
    > и где вылетело. И сложно найти проблему. В Gentoo я запускаю
    > обновление и смотрю что мне рекомендуют сделать после установки. Мне не
    > нужно заниматься системой, я могу просто работать.

    П и н г в и н о й д ы - работают?! В смысле - ждут, пока ведро к а н п е л я е т с я что-ли?

    PS. Я как-то не верю, что к р а с н о глазие является продуктивной работой, с баблом на выхлопе, м?

     
  • 2.5, commiethebeastie (ok), 11:02, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    В генте уже давным давно в ff есть h264.
     
     
  • 3.9, MAN (??), 12:19, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Как и в FreeBSD, т.к. собирается из исходного кода. И это не плюс Gentoo или FreeBSD, это минус мейнтейнерам
     
     
  • 4.31, ананим (?), 00:56, 29/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Почему не плюс?
    Как раз плюс — это твой личный выбор.
     
  • 2.15, Crazy Alex (ok), 15:11, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +2 +/
    В ебилдах это уже сто лет как включить можно - как положено, USE-флагом.
     

  • 1.7, Хрен с горы (?), 11:35, 28/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    >В качестве причины отказа от включения поддержки GStreamer по умолчанию называлась неготовность основных дистрибутивов для работы с Firefox, собранном с поддержкой GStreamer (в составе разных дистрибутивов поставлялись несовместимые между собой версии GStreamer).

    На самом деле проблема была в багах реализации. Сейчас пофиксели и работает. А то, о чем написано в новости до сих пор не решено - сейчас используется gstreamer0.10, хотя последний 1.0. Работа по переводу начата, но пока не очень активно.

     
     
  • 2.10, Аноним (-), 12:37, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > пофиксили
     
  • 2.11, Аноним (-), 12:48, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >>В качестве причины отказа от включения поддержки GStreamer по умолчанию называлась неготовность основных дистрибутивов для работы с Firefox, собранном с поддержкой GStreamer (в составе разных дистрибутивов поставлялись несовместимые между собой версии GStreamer).
    > На самом деле проблема была в багах реализации. Сейчас пофиксели и работает.
    > А то, о чем написано в новости до сих пор не
    > решено - сейчас используется gstreamer0.10, хотя последний 1.0. Работа по переводу
    > начата, но пока не очень активно.

    А у меня в дистре и то и другое, всё работает. Firefox (Iceweasel) правда пока без gstreamer собран.

     
  • 2.33, ананим (?), 01:03, 29/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >сейчас используется gstreamer0.10, хотя последний 1.0. Работа по переводу начата, но пока не очень активно.

    И что?
    Сейчас гстример 0.10 — это как кеды 3.5.10.
    А 1.0 как кеды 4.0. Т.е. им ещё до 4.8 расти и расти.

    Зыж
    Да, нумерация нифига не меркетоидная была. Вон вын8 к примеру.

     

  • 1.8, Аноним (-), 11:42, 28/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    С одной стороны хорошо, но с другой gstreamer глючный (всякие там аудио-щелчки в начале воспроизведения и прочие ощутимые гадости)
     
     
  • 2.20, Fracta1L (ok), 16:00, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > С одной стороны хорошо, но с другой gstreamer глючный (всякие там аудио-щелчки
    > в начале воспроизведения и прочие ощутимые гадости)

    Ни разу не сталкивался.

     
  • 2.23, Неуловимый Джо (?), 17:22, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > С одной стороны хорошо, но с другой gstreamer глючный (всякие там аудио-щелчки
    > в начале воспроизведения и прочие ощутимые гадости)

    Что простите? На моей памяти в Linux было только несколько приложений с треском - это старый блоб skype и старые-же блобы игр, движки которых отказались официально поддерживать под Linux. Выпиливайте уже свою alsa.

     
     
  • 3.34, ананим (?), 01:11, 29/06/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >Выпиливайте уже свою alsa.

    Не эльзу, а пульс.
    Эльза — это дрова. Все, включая пульс и гстример, работают поверх неё уровнем выше.

    Зыж
    И да, глюки с новой версией 1.0 гстример были.
    Но уже (вроде как. Т.е. у мени лично) исчезли.
    Версия 0.10 бронебойная.

     
     
  • 4.41, Xasd (ok), 00:05, 30/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Все, включая пульс и гстример, работают поверх неё уровнем выше.

    работают поверх Alsa -- даже у тех пользователей, у которых Alsa не установлена? :-)

     

  • 1.12, Аноним (-), 13:11, 28/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Наконец-то поняли, что одним WebM сыт не будешь. Либо смотри видео в H264, либо гордо утешайся "сосу лапу зато никакой проприетарщины". Очень рад, что в Mozilla выбрали адекватное решение.
     
     
  • 2.17, qwerty (ok), 15:21, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Наконец-то поняли, что одним WebM сыт не будешь. Либо смотри видео в
    > H264, либо гордо утешайся "сосу лапу зато никакой проприетарщины". Очень рад,
    > что в Mozilla выбрали адекватное решение.

    А причём здесь проприетарщина? Речь о патентах, вообще-то, а h264 имеет свободные реализации.

     
     
  • 3.25, Неуловимый Джо (?), 18:16, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > А причём здесь проприетарщина? Речь о патентах, вообще-то, а h264 имеет свободные
    > реализации.

    Да, не при чём тут кодеки. Главное чтобы кодеки поддерживали аппаратное ускорение, другими словами - меньше затрачивали энергии в единицу времени.

     

  • 1.13, BlackRaven86 (ok), 13:51, 28/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Прочитал заголовок и долго не мог понять, как же так у меня давно это работает.
    В общем, в толковых дистрах оно давно уже есть.
     
  • 1.14, iZEN (ok), 14:14, 28/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    На FreeBSD последний Firefox 22.0 падает на HTML5-видео с Ютуба. Предыдущая версия падучестью не страдала.
     
     
  • 2.32, ананим (?), 00:59, 29/06/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Скорее всего так — предыдущая версия фрибсд падучестью фф не страдала.
     
     
  • 3.39, iZEN (ok), 11:52, 29/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Скорее всего так — предыдущая версия фрибсд падучестью фф не страдала.

    Да нет. Поставил Firefox 21.0 (у меня, знаете ли, всегда есть два пути отката изменений: zfs rollback poolname/usr/local (var/db/pkg) и portmaster -e newpackage && pkg_add /path/to/pkg/All/oldpackage.tbz) из сохранённого пакета — работает и не падает.


     
  • 2.46, Minotaur (ok), 00:32, 26/07/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > На FreeBSD последний Firefox 22.0 падает на HTML5-видео с Ютуба. Предыдущая версия
    > падучестью не страдала.

    Да оно падает не только на видео с ютуба, а вообще на всех HTML5 видео.
    gdb указывает на корявый GStreamer.

     
     
  • 3.47, iZEN (ok), 00:35, 26/07/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >> На FreeBSD последний Firefox 22.0 падает на HTML5-видео с Ютуба. Предыдущая версия
    >> падучестью не страдала.
    > Да оно падает не только на видео с ютуба, а вообще на
    > всех HTML5 видео.
    > gdb указывает на корявый GStreamer.

    Но в gnash-плагине видео нормально воспроизводится! Так что от режима тестирования HTML5-видео на Ютубе в Firefox 22.0 пришлось отказаться.


     

  • 1.16, Дмитрий Задачкин (?), 15:12, 28/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    А что на этот счёт говорит почётный интернетчик (так!) товарищ Ричард Мэттью Столлман?
     
     
  • 2.18, qwerty (ok), 15:23, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > А что на этот счёт говорит почётный интернетчик (так!) товарищ Ричард Мэттью
    > Столлман?

    http://lwn.net/Articles/262570/

     
     
  • 3.21, Аноним (-), 16:27, 28/06/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >To look at page I send mail to a demon which runs wget and mails the page back to me.

    Сурово

     

  • 1.24, Аноним (-), 18:04, 28/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    как-то запускал плеер работающий через Gstreamer на слабенькой машине
    рвало зук и видео
    а вот vlc и mplayer все прекрасно показывали и даже не весь проц сожрали
    видно браузеростроителей энергоэффективность совсем не волнует...
     
     
  • 2.35, ананим (?), 01:18, 29/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    С версией 1.0 — было такое.
    С 0.10 всё железобетонно.

    Зыж
    Не знаю как в бинарных, а в генте 1.0 вроде как исправилась и работает также надёжно.
    (Но латенси хуже).

     

  • 1.26, Аноним (-), 21:51, 28/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Только по ночам декодирует?
     
     
  • 2.40, Аноним (-), 14:32, 29/06/2013 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Только когда ночь одновременно в США, Германии и Японии.
     

  • 1.28, Аноним (28), 22:30, 28/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Справедливости ради нужно добавть что там поддержка gstreamer 0.10, а не gstreamer 1.0 https://bugzilla.mozilla.org/show_bug.cgi?id=806917
     
     
  • 2.36, ананим (?), 01:20, 29/06/2013 [^] [^^] [^^^] [ответить]  
  • +/
    И это (пока) правильно.
    0.10 ну очень стабилен.
     

  • 1.37, ILYA INDIGO (ok), 01:36, 29/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    На openSUSE ещё с версии 17-ой работало и работает по дефолту, при установки плагина ffmpeg для gstreamer
     
  • 1.38, ILYA INDIGO (ok), 01:41, 29/06/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Вот только баг, похоже на который всем забить и уже давно, с тех пор как реализовали изменение скорости для video html5.
    На ютубе скорость-то изменяется, но вернуть назад нормальную скорость невозможно.
     
  • 1.44, Аноним (-), 04:53, 01/07/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Последний гвоздь в гроб теоры и webm (туда им и дорога).
     
  • 1.45, andrew000snake (?), 07:20, 06/07/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    "...реалиЗЛОвана..."-прикольная очепятка)))
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру