The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Репозиторий Backports интегрирован в основной архив пакетов Debian

18.03.2013 20:52

Разработчики сервиса backports.debian.org, в рамках которого обеспечивается формирование пакетов со свежими версиями программ для уже выпущенных релизов дистрибутива Debian, объявили о достижении новой значительной вехи развития сервиса - репозиторий backports отныне включён в состав официального архива пакетов Debian. Таким образом, репозитории wheezy-backports, squeeze-backports и squeeze-backports-sloppy теперь доступны в составе основного пула пакетов, в то время как раньше он распространялись обособленно.

Добавление бэкпортированных пакетов с новыми версиями программ теперь будет осуществляться по аналогии с добавлением обычных пакетов в рамках основной очереди загрузки с использованием единого набора ключей верификации, что упростит работу разработчиков, сопровождающих бэкпорты. Положительным моментом также является задействование для поставки бэкпортов основной сети зеркал проекта. Для пользователей Wheezy связанные с бэкпортами изменения в инфраструктуре потребуют правки файла sources.list - строку подключения wheezy-backports следует привести в вид: "deb http://ftp.debian.org/debian/ wheezy-backports main", т.е. вместо "debian-backports" теперь указывается основной архив "debian".

Напомним, что используя Backports пользователь имеет возможность, например, установить новую версию LibreOffice в Debian Wheezy без ущерба для стабильности системы и без необходимости установки библиотек из testing или unstable. При этом, пакеты с новой версией теперь поставляются бок о бок со штатными версиями пакетов, предлагаемых в дистрибутиве (для установки новых версий программ из бэкпортов по прежнему требуется добавление специального репозитория). В Backports содержится более 500 пакетов, среди которых новые версии ядра Linux, Iceweasel, Icecast, Apache, nginx, Samba, QEMU и т.д.

  1. Главная ссылка к новости (http://lists.debian.org/debian...)
Лицензия: CC BY 3.0
Короткая ссылка: https://opennet.ru/36426-backport
Ключевые слова: backport, debian
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (53) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, botman (ok), 21:24, 18/03/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +5 +/
    Лучше поздно, чем никогда. (с)
     
     
  • 2.55, pavlinux (ok), 17:57, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Это вызовет кучу новых багрепортов, не имеющих отношения к основной ветке.  
     
     
  • 3.56, колян (?), 22:12, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    На которой пилится не основная
     

  • 1.2, anonym (?), 21:29, 18/03/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +9 +/
    Неужели debian перестанут ругать за отсталость пакетной базы? Съехать что-ли с убунты на деб...
     
     
  • 2.4, Аноним (-), 21:40, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Отсталость пакетной базы? Не, не слышал... Использую Sid каждый день.
     
     
  • 3.15, Аноним (-), 22:58, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • +3 +/
    И как там КДЕ, к примеру, не попахивает уже? Или еще не окаменел?:)
     
     
  • 4.18, anonymous (??), 23:11, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > И как там КДЕ, к примеру, не попахивает уже? Или еще не
    > окаменел?:)

    4.8.4, чуть подсохло.

     
     
  • 5.32, Аноним (-), 07:25, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Я какбэ в курсах - у самого unstable&experimental на недобуке. Просто хотелось подколоть излишне оптимистичного анонимуса.
     
     
  • 6.54, anonymous (??), 14:47, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Я какбэ в курсах - у самого unstable&experimental на недобуке. Просто хотелось
    > подколоть излишне оптимистичного анонимуса.

    Sorry.

     
  • 2.6, wwwAnonim (?), 21:41, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Так что мешало поставить testing ветку дебиана и тотже unstable? Или юмор не понял...
     
     
  • 3.10, Аноним (-), 22:06, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    А обновления безопасности?

    http://www.debian.org/distrib/packages.en.html

    "Note that testing does not get the timely security updates from the security team."

     
  • 3.11, Lain_13 (ok), 22:27, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Новая система бэкпортов позволяет поставить свежие версии только конкретных приложений, оставив всю остальную систему в покое.
     
     
  • 4.24, GotF (ok), 06:10, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Новая система бэкпортов позволяет поставить свежие версии только конкретных приложений, оставив всю остальную систему в покое.

    Старая тоже позволяла. Переезд в основное дерево архива ничего принципиально не поменял, если смотреть с точки зрения пользователя.

     
  • 2.8, IMHO (?), 21:49, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • –2 +/
    сьехать может только разум, желаю обновится
     
     
  • 3.31, name (??), 07:14, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Кто обновится?
     
     
  • 4.58, Аноним (-), 22:30, 20/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Он же написал, обновится товарищ по имени Желаю.
     
  • 2.20, Аноним (-), 01:18, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >Package iceweasel 10.0.12

    Актуальная версия ~19. Ага, перестанут.

     
     
  • 3.26, www2 (??), 06:13, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Стабильной ветке дистрибутива - LTS-ветку Firefox, всё логично.
     
     
  • 4.34, Аноним (-), 09:46, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Срок поддержки этой ветки давно истек.
     
     
  • 5.38, Andrey Mitrofanov (?), 10:40, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Срок поддержки этой ветки давно истек.

    //support for Firefox 10.0esr branch ended with the release of Firefox 10.0.12esr released on January 8, 2013.

    Живи быстро, умри молодым?

    И кстати, какие претензии к Debian-у-то?? Это у мозилы синдром раздражённого релиза. **Все** дистрибутивы мучаются. Да, те, что сами более раздражённые -- меньше.

    Ну, разве что, что Debian не вынес _все_ поделки этих раздражённых в volatile, с релизами по каждому пу^Wпресс-релизу отдела маркетинга мофоко и поддержкой всех зависимостей (и их тоже !все! туда!). Не взлетело...

     
     
  • 6.39, бедный буратино (ok), 10:42, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Кстати, хромиум уже на лету обновляется - 22, 24, 25, безо всяких заморозок. Можно было бы и mozilla.debian.net интегрировать, 10->17->24 без промежуточных остановок.
     
  • 3.27, www2 (??), 06:14, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    А для крикунов есть http://mozilla.debian.net/
     
     
  • 4.41, Andrey Mitrofanov (?), 10:50, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > А для крикунов есть http://mozilla.debian.net/

    Кстати, не обращал внимания (пользуюсь seamonkey>>iceape, который на mozilla.d.o такой же, как на bpo), что они там собирают ff ещё и beta, и aurora:

    http://mozilla.debian.net/dists/experimental/
    esr iceweasel 17.0.3esr-1
    beta iceweasel 20.0~b4-1
    aurora iceweasel 21.0~a2+20130315042012-1

    Впрочем, [вот прямо сейчас, пирожок полка голова стена] крикун прав, в teting "большого" дебиана актуальный esr ещё не попал:
    wheezy (web): 10.0.12esr-1

     
  • 2.28, GotF (ok), 06:15, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Неужели debian перестанут ругать за отсталость пакетной базы? Съехать что-ли с убунты
    > на деб...

    Не стоит ожидать от backports обновлений всего-всего.

     
  • 2.37, re (?), 10:29, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Если там доступна девятая версия ядра из репов то я бы съехал
     
     
  • 3.40, бедный буратино (ok), 10:44, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Если там доступна девятая версия ядра из репов то я бы съехал

    Девятая версия КАКОГО ЯДРА? Есть девятая версия ядра freebsd.

     
  • 2.45, Аноним (-), 11:44, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Неужели debian перестанут ругать за отсталость пакетной базы?

    Учитывая что авторы софта мало парятся совместимостью с античными либами - несложно догадаться что в бэкпортсах далеко не весь софт и не всегда оперативно. Но это шаг вперед, не отнять.

    > Съехать что-ли с убунты на деб...

    Каждый человек имеет выбор. А потом выбор имеет человека.
      

     

  • 1.3, noize (ok), 21:39, 18/03/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    чёт я не пойму:

    aptitude -t wheezy-backports show libreoffice
    Пакет: libreoffice                              
    Состояние: установлен
    Автоматически установлен: да
    Версия: 1:3.5.4+dfsg-4

    где обещанные инновации?

     
     
  • 2.12, Аноним (-), 22:30, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Видимо потому, что приехали только контрольные суммы Список пактов пуст var li... большой текст свёрнут, показать
     
     
  • 3.14, noize (ok), 22:53, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Видимо, побежали впереди поезда. Надо было для начала всё доделать, а уж потом объявлять
     
     
  • 4.22, Аноним (-), 03:48, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Видимо Вы не в курсе что wheezy ещё не вышел. Какие бекпорты Вы хотите получить к ещё не вышедшему дистрибутиву?
     
  • 2.29, GotF (ok), 06:16, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > чёт я не пойму:
    > aptitude -t wheezy-backports show libreoffice
    > Пакет: libreoffice
    > Состояние: установлен
    > Автоматически установлен: да
    > Версия: 1:3.5.4+dfsg-4
    > где обещанные инновации?

    Репозитории backports не начинают работать до релиза.

     

  • 1.5, Аноним (-), 21:41, 18/03/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    squeeze нету
     
     
  • 2.13, Аноним (-), 22:43, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • –2 +/
    squeeze с недели на неделю станет old-stable.
     
     
  • 3.17, Аноним (-), 23:04, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Оптимист! Судя по озвученным на дистровотче темпам исправления блокирующих релиз ошибок wheezy до лета как минимум ждать...
     
  • 3.19, Аноним (-), 23:35, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    хостер ip-kvm не дает для обновления дистрибутива
     
  • 3.46, Аноним (-), 11:46, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > squeeze с недели на неделю станет old-stable.

    С года на год, вы хотели сказать? А то уж 2 года назад релиз обещали. С тех пор много воды утекло, много ядер выпустили...а в седьмом дебиане будет какое-то там ядро 3.2, которое с поддержки вот-вот снимут, если не сняли уже :). Авангардизм, чо.

     
     
  • 4.49, бедный буратино (ok), 11:55, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +3 +/
    >> squeeze с недели на неделю станет old-stable.
    > С года на год, вы хотели сказать? А то уж 2 года
    > назад релиз обещали.

    Через полтора месяца после выхода Squeeze? При том, что заморозка состоялась только несколько месяцев назад?

    > а в седьмом дебиане будет какое-то там ядро 3.2, которое с поддержки вот-вот снимут, если не сняли уже :). Авангардизм, чо.

    И что? Если debian обеспечивает предсказуемость и стабильность - это хороший debian. Если нет - то плохой. И какая разница, какое там ядро - главное не версия, главное - отвечать поставленным задачам.

    Пока Debian для многих типов задач - это лучший выбор, в том числе и потому, что предсказуемый, как зубная боль у некоторого контингента в новостях про Debian.

    В Debian ядро, обеспечивающее работоспособность Debian для его приложений на многих устройствах. И это главное. Детали не могут заменить целого, и самое сложное - это не набрать ядер и пакетов, а сделать так, чтобы оно вместе работало, везде и всегда. Потому и Debian.

     

  • 1.7, Sergey722 (ok), 21:45, 18/03/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Пот это от души!
    Надеюсь теперь там всё будет вовремя обновляться, а то когда я этой темой активно интересовался новые версии там появлялись от к случая к случаю. На форумах читал, что спокойно может не обновляться ядро с известными уязвимостями.
     
     
  • 2.9, noize (ok), 21:55, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Вот тут вы мимо. Насколько мне известно, в Debian номер версии ядра не обновляют, но бэкпортируют в данную версию исправления безопасности из более новых ядер. В этом случае меняется лишь минорная версия ядра, т.е. последняя циферка через дефис. Это позволяет держать на серверах безопасные версии ядер и не перекомпилировать специфические драйвера каждый раз после обновления.
     
     
  • 3.16, Аноним (-), 23:01, 18/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    В stable сейчас ядро 2.6.32, а в stable-backports - 3.2.
    Не самое новое, но всё же лучше чем ничего. После релиза wheezy могут выложить посвежее.
     
     
  • 4.30, бедный буратино (ok), 06:34, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • –2 +/
    apt-cache show linux-image-3.2.0-4-amd64

    Package: linux-image-3.2.0-4-amd64
    Source: linux
    Version: 3.2.39-2

     
  • 4.47, Аноним (-), 11:47, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Не самое новое, но всё же лучше чем ничего.

    ...вот только для нормальной работы моей видеокарты надо минимум 3.5, а чтобы usb 3.0 не глючил - вообще 3.9RC, не меньше. В каком году это все в дебиане будет сразу, по дефолту, интересно? :)

     
     
  • 5.50, бедный буратино (ok), 11:56, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > ...вот только для нормальной работы моей видеокарты надо минимум 3.5, а чтобы
    > usb 3.0 не глючил - вообще 3.9RC, не меньше. В каком
    > году это все в дебиане будет сразу, по дефолту, интересно? :)

    Debian плевать на твою видеокарту, только и всего. Лучше поддерживать меньше, да лучше, чем пытаться охватить всё, но это "всё" будет с та-а-акими оговорками....

    ps. В бэкпортах это будет, если будет всё нормально, как только это появится в testing. В testing это появится после релиза wheezy. Реальные пацаны могут хоть сейчас поставить самое модное ядро из experimental.

     
  • 3.21, skb7 (ok), 02:02, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    "последняя циферка через дефис" -- это версия debian-пакета, а не "минорная версия ядра". Т.е. в имени "linux-image-3.2.0-4-amd64" минорная версия ядра это "2", а "4" -- это версия пакета.
     
  • 3.25, GotF (ok), 06:12, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Вот тут вы мимо. Насколько мне известно, в Debian номер версии ядра
    > не обновляют, но бэкпортируют в данную версию исправления безопасности из более
    > новых ядер. В этом случае меняется лишь минорная версия ядра, т.е.
    > последняя циферка через дефис. Это позволяет держать на серверах безопасные версии
    > ядер и не перекомпилировать специфические драйвера каждый раз после обновления.

    Последняя циферка через дефис обозначает, в случае ядра, версию ABI.

     
     
  • 4.57, skb7 (ok), 00:00, 20/03/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Да, в версии ЯДРА, но не в версии пакета, о которой, очевидно, говорилось выше ... большой текст свёрнут, показать
     
  • 3.33, Sergey722 (ok), 09:30, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >Вот тут вы мимо. Насколько мне известно, в Debian номер версии ядра не обновляют, но бэкпортируют в данную версию исправления безопасности из более новых ядер.

    Я не писал, что Дебиянщики не портируют изменения в своё ядро. Я написал, что в бэкпортс эти изменения попадали от случая к случаю.

     
     
  • 4.35, бедный буратино (ok), 09:55, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Я не писал, что Дебиянщики не портируют изменения в своё ядро. Я
    > написал, что в бэкпортс эти изменения попадали от случая к случаю.

    linux-image-3.2.0-0.bpo.4-686-pae (3.2.39-2~bpo60+1)

    та же самая версия, что и в wheezy.

     

  • 1.23, бедный буратино (ok), 04:54, 19/03/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Респект. А какие у них будут pin-priority проставлены по умолчанию?
     
     
  • 2.42, Andrey Mitrofanov (?), 10:56, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Респект. А какие у них будут pin-priority проставлены по умолчанию?

    pin-priority будут у Вас. Обсудите перед зеркалом, чито у Вас по умолчанию.

     

  • 1.52, ua9oas (ok), 14:10, 19/03/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    ну вот у меня помимо других дистрибов есть также и "6.0.7". Свежее ПО туда поставить можно не все (а что вообще туда из за его такой консервативности еще не возможно ставить? (я пробовал только "Thunderbird" и "VLC". (VLC 1.1.3 у меня сейчас там- ничего свежее этого туда не поставится (и это не смотря на то, что после релиза "1.1.3" довольно прилично времени уже прошло)). И вот то событие этой новости- оно как-то устранит ли ту приведенную тут мной проблему? (и какие там еще недостатки есть?)
     
     
  • 2.53, бедный буратино (ok), 14:42, 19/03/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > И вот то событие этой новости- оно как-то устранит ли ту приведенную тут мной
    > проблему?

    Нет. Если вы раньше не могли поставить галочку в Debian Software Center, то и дальше не сможете.

    > (и какие там еще недостатки есть?)

    Кейринг не нужно будет ставить отдельно - это достоинство. И зеркало будет везде, где есть зеркало debian, а не только там, где есть зеркало бэкпортов - это тоже достоинство.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Партнёры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2024 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру