The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Продлена поддержка FreeBSD 4.8

06.04.2004 15:32

Продлили поддержку FreeBSD 4.8 еще на полгода. Т.е. будет и дальше развиваться ветка RELENG_4_8.

В дальнейшем ветки будут получать один из трех уровней поддержки: lite, standard, extended, соответственно, 3, 6 и 12 месяцев со дня выхода.

В общем-то, как мне кажется, правильно делают, что отменяют поддержку старых версий, освобождая ресурсы для новых версий, но срок уж очень короткий. MS вот 5 лет на поддержке продукты держит.

  1. Главная ссылка к новости (http://www.freebsd.org...)
Автор новости: Cyrill Malevanov
Источник: по мотивам freebsd-security
Тип: К сведению
Короткая ссылка: https://opennet.ru/3621-freebsd
Ключевые слова: freebsd, security
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (15) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Wadim (?), 20:30, 06/04/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Шоб 4 ветку поддерживали и это главное! :)
     
     
  • 2.2, .zZz. (??), 21:41, 06/04/2004 [^] [^^] [^^^] [ответить]  
  • +/
    В отличие от войн на опеннете типа "PHP - PERL" или "FreeBSD - LINUX", я полагаю, война "FreeBSD: 4 vs 5" идёт с огро-о-о-омным перевесом приверженцев 4. :)
     
     
  • 3.3, pepper (??), 00:02, 07/04/2004 [^] [^^] [^^^] [ответить]  
  • +/
    А что тут собственно воевать-то?
    Stable - это Stable, Current - это Current
    Вот когда 5 станет Stable, тогда и посмотрим.
     
     
  • 4.12, Банзай (?), 20:30, 07/04/2004 [^] [^^] [^^^] [ответить]  
  • +/
    Вот вот. Кто воюет? Когда разработчики предупреждают огромными буквами о том, что ветка 5 не рекомендуется для развертывания продакшн серверов?
     
  • 3.6, Andrew (??), 10:49, 07/04/2004 [^] [^^] [^^^] [ответить]  
  • +/
    Среди пользователей -- наверное да.
    Среди разработчиков -- наоборот.
    Да и объем почты в freebsd-current на порядок больше чем в
    freebsd-stable.
     

  • 1.4, Sergey G. Porotnikov (?), 08:28, 07/04/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А мне жалко заброшенную ветку 2.2.x (:
    На старых машинках она работала очень хорошо.
     
  • 1.5, JAM (?), 10:08, 07/04/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    И это правильно, ИМХО 4-ка самая правильная и стабильная пока.
     
     
  • 2.15, Банзай (?), 01:33, 11/04/2004 [^] [^^] [^^^] [ответить]  
  • +/
    >И это правильно, ИМХО 4-ка самая правильная и стабильная пока.

    Правильная. Но нарузки на сервисы - растут по Муру. Без тредов не обойтись. Соляра шикует на одном и том же бабле - зарубленном на безукоризненно работающих тредах и жава тредах.

    Поэтому без пятерки (без тредов) жизни не будет. Особенно имея ввиду встроенную в жаву балансировку.

     

  • 1.7, Крис (?), 13:44, 07/04/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    До сих пор пользуюсь 4.8 - 4.9, ставил 5.1, понравилось, но ядро 4 ветви ближе
     
  • 1.8, Дмитрий Ю. Карпов (?), 13:45, 07/04/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > В общем-то, как мне кажется, правильно делают,
    > что отменяют поддержку старых версий,
    > освобождая ресурсы для новых версий,
    > но срок уж очень короткий.
    > MS вот 5 лет на поддержке продукты держит.

    Автор статьи совершенно неправильно понимает жизнь операционных систем (разумеется, IMHO). По его мнению, каждая новая FreeBSD (как правило, отличающаясяот предыдущей во второй цифре) соответствует новой Windows. А я считаю, что FreeBSD'4.0 примерно соответствует W'NT'4.0, FreeBSD'4.1 - W'NT'4.0+SP1 и т.д.; а FreeBSD'5.x примерно соответствуют W'2000 (которая есть W'NT'5.0) с её сервис-паками.

    И поэтому прекращение поддержки 4.8 с выходом 4.9 - нормальное явление. Так же, как Билл Гейтс для решения сех проблем рекомендует накатить очередной SP, так и авторы FreeBSD могут рекомендовать переход на следующую версию внутри одной ветки.

    Плохо то, что при обновлении версий пакаджей на FTP-сайтах не выкладывают новых версий пакаджей, откомпилённых для старых версий FreeBSD.

    Что же касается плача по ветке 2.x, то я слабо представляю себе машину, на которой бы работала 2.x, но не работала 4.x (пусть и после доработки напильником, начиная с перекомпиляния ядра для уменьшения его размера). В кр.случае можно проапгрейдить машину до 386DX-40 с восемью мегабайтами памяти - на такой 4.x будет работать.

     
     
  • 2.9, Cyrill Malevanov (?), 15:41, 07/04/2004 [^] [^^] [^^^] [ответить]  
  • +/
    Я прекрасно понимаю, что FreeBSD 4.x - это как накатывать сервис-паки. Говоря же о короткой поддержке старых версий - я имею в виду как раз то, что весь новый софт, что в портах, что в пакаджах, в один прекрасный момент перестает устанавливаться на старую версию системы. Раз - и все, разошлись библиотеки. Надо систему апгрейдить, а не везде это возможно.
     
     
  • 3.14, Банзай (?), 01:26, 11/04/2004 [^] [^^] [^^^] [ответить]  
  • +/
    Сочувствую, но! Это опен сорс. Пэтому - объяви себя мэйнтейенром порта, раз в три месяца приводи мейкфайлы и конфиги порта и его пререквизитов в соответсвие с изменениями на сайте автора\авторов и все будет накатываться всегда и само.

    А пока - мы будем читать маны и факи вместо тебя. И править файло на месте. Ты же понимаешь, это - опен сорс. Ставится все. И потом работает годами. Нужно только компилить в соответствии. С еще непрочитанным факом.

     

  • 1.10, Wadim (?), 17:59, 07/04/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Старые рутеры-почтовики в контрах до сих пор на
    железной 2.2.8-STABLE
    А для стабильного современного сервера (с поддержкой железа нормальной) сейчас 4.9-STABLE, тут никто спорить, надеюсь, не будет.
     
     
  • 2.11, Дмитрий Ю. Карпов (?), 18:10, 07/04/2004 [^] [^^] [^^^] [ответить]  
  • +/
    > Старые рутеры-почтовики в контрах до сих пор на железной 2.2.8-STABLE
    > А для стабильного современного сервера (с поддержкой железа нормальной)
    > сейчас 4.9-STABLE, тут никто спорить, надеюсь, не будет.

    Боюсь, Вы меня не поняли. Я не призываю заменить 2.2.8 на 4.9 только потому, что 2.2.8 - старая, а 4.9 - новая; иб оработает - не трогай, а то сломаешь и будешь чинить.

    Я говорил о том, что ежели будет нужно поставить ещё один почтовик (или апгрейдить старый - например, диска не хватит), то нет никакой причины предпочитать 2.2.8 перед 4.9.

     

  • 1.13, Lamr (?), 12:18, 09/04/2004 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > я считаю, что FreeBSD'4.0 примерно соответствует
    > W'NT'4.0, FreeBSD'4.1 - W'NT'4.0+SP1 и т.д.; а
    > FreeBSD'5.x примерно соответствуют W'2000
    > (которая есть W'NT'5.0) с её сервис-паками.

    Сравнил [вырезано цензурой] с пальцем!

    Други!!!
    Мы ведь за эту поддержку не платим?!
    Спасибо за какую есть!
    Кому надо - тот должен и поддержать
    Хорошо работающее старое - это просто ПАМЯТНИК
    вечному BSD (и его разработчикам)
    Новое выросло ведь из старого, оно не исчезло,
    а изменилось. Стало (где-то) лучше.
    BSD фарева!!!!
    :-)))

     
     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2021 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру