The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Доступен Qt 5.0.1 и Qt Creator 2.6.2

31.01.2013 17:51

Представлен первый корректирующий выпуск Qt 5.0.1, в котором проведена работа по устранению ошибок и проблем, выявленных за шесть недель с момента выхода Qt 5.0. В новой версии внесено более 400 изменений, связанных с исправлением ошибок и улучшением работы уже доступных функций. В состав добавлен бинарный инсталлятор MinGW 4.7. Новых возможностей не добавлено, они ожидаются в версии 5.1.

На уровне исходных текстов (API) выпуск 5.0.1 полностью совместим с 5.0.0, но на уровне бинарного интерфейса (ABI) исправление одной из ошибок потребовало частичного нарушения совместимости в области мультимедийных функций (QtMultimedia). Для программ, использующих QtMultimedia, при переходе на Qt 5.0.1 рекомендуется произвести перекомпиляцию.

Дополнение: Одновременно представлен корректирующий релиз интегрированной среды разработки Qt Creator 2.6.2.

  1. Главная ссылка к новости (http://blog.qt.digia.com/blog/...)
  2. OpenNews: Релиз движка QtWebKit 2.3-beta
  3. OpenNews: Официально представлен релиз Qt 5.0
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/35980-qt
Ключевые слова: qt
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (33) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 19:02, 31/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    На 4.8.* уже совсем забили? Хоть бы багфиксы
     
     
  • 2.3, Аноним (-), 19:18, 31/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Ну да, они же раньше объявляли, что 4.8.4 будет последним из 4.*
     
     
  • 3.4, Аноним (-), 19:30, 31/01/2013 [^] [^^] [^^^] [ответить]  
  • –14 +/
    Отстой :( Мне не нравится этот полёт глючного творчества с ломанием API/ABI
     
  • 3.7, CPP (??), 19:52, 31/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Ну да, они же раньше объявляли, что 4.8.4 будет последним из 4.*

    Судя по багтрекеру 4.8.4 будет не последним. https://bugreports.qt-project.org/browse/QTBUG/fixforversion/12505

     

  • 1.2, Аноним (-), 19:17, 31/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    > Qt 5.0.1

    Yahoooo! Уже жду Qt 5.1 и пятые кеды %)

     
     
  • 2.20, Аноним (-), 08:14, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >> Qt 5.0.1
    > Yahoooo! Уже жду Qt 5.1 и пятые кеды %)

    Мне просто интересно, чего там такого нового, что прям сидеть и ждать.

     

  • 1.5, botman (ok), 19:30, 31/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –8 +/
    Ну и как KDEшникам заменитель Nokia? Форкать ещё не собираются Qt?
     
     
  • 2.6, Необъективный_ (ok), 19:41, 31/01/2013 [^] [^^] [^^^] [ответить]  
  • +2 +/
    https://www.opennet.ru/opennews/art.shtml?num=35910
     
     
  • 3.8, botman (ok), 19:57, 31/01/2013 [^] [^^] [^^^] [ответить]  
  • –3 +/
    хм, даже и бурлений не было... разве так бывает?
     
     
  • 4.16, Диетолог (?), 06:25, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Жироотталкивающий (вменяемый) тулкит просто.
     
  • 2.9, Аноним (-), 21:22, 31/01/2013 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Нам норм. А как вам?
     

  • 1.10, anonymous (??), 22:20, 31/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –5 +/
    >Для программ, использующих QtMultimedia, при переходе на Qt 5.0.1 рекомендуется произвести перекомпиляцию.

    Ломают api в минорном релизе. Это даже не смешно.

     
     
  • 2.11, добрый дядя (?), 22:51, 31/01/2013 [^] [^^] [^^^] [ответить]  
  • –3 +/
    что хуже не API а именно ABI, ну ладно, надеюсь это был последний такой фокус
     
     
  • 3.12, ВовкаОсиист (ok), 23:13, 31/01/2013 [^] [^^] [^^^] [ответить]  
  • +5 +/
    Я конечно понимаю, что Ъ по ссылкам не ходят, а обсирать всегда пожалуйста. Но лучьше если бы оставили как есть, при этом былиб утечки и, возможно, крахи программ? Там забыли к деструктору дописать virtual и не смотря на варнинги компилятора, это привело к тому, что один из наследуемых классов при удалении просто не деинициализировался.
     
     
  • 4.19, Аноним (-), 08:13, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >Я конечно понимаю, что Ъ по ссылкам не ходят, а обсирать всегда пожалуйста. Но лучьше если бы оставили как есть, при этом былиб утечки и, возможно, крахи программ? Там забыли к деструктору дописать virtual и не смотря на варнинги компилятора, это привело к тому, что один из наследуемых классов при удалении просто не деинициализировался.

    Лучше выпустить лишний RC, чем толкать явную недоделку в релиз.

     
  • 3.14, n (??), 02:28, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    просветите и чем же нарушение ABI так хуже чем API? Ничего не перепутали?Oo
     
     
  • 4.17, Диетолог (?), 06:28, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Тем, что своим перекомпилять приходится, не?
     
     
  • 5.18, Диетолог (?), 06:29, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    * свои поделия


     
     
  • 6.28, nib (?), 12:37, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    А то что если бы у вас изменилось API, например, больше недоступен метод, который вы дёргали и простая пересборка уже не помогла бы эт да, пустяки) О и меня даже не удивляет тот факт что у вас уже готовое приложение на фреймворке, который только вышел, на относительно новом его модуле(multimedia) и вы собираетесь больше не багфиксить/реализовывать новый функционал - не пересобирать приложение одним словом

    // убрал обратно сарказматор

     
  • 3.24, Аноним (-), 08:52, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >что хуже не API а именно ABI, ну ладно, надеюсь это был последний такой фокус

    В мире открытых исходников изменение ABI не проблема. Перекомпилять же.

     

  • 1.13, Аноним (-), 23:33, 31/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Когда уже запилят поддержку C++11 в редакторе QtCreator'а? :-(
     
     
  • 2.15, n (??), 02:29, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    сразу как отправите патчи
     
     
  • 3.22, Аноним (-), 08:17, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > сразу как отправите патчи

    Ты забыл ещё про отказ от своих прав на код.

     
     
  • 4.29, nib (?), 12:38, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    а что в этом такого?
     
     
  • 5.33, Тот_Самый_Анонимус (?), 09:10, 03/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >а что в этом такого?

    Да ничего. Просто тут много нытиков. которые пинали на Sun за такой "грешок".

     
  • 2.31, Аноним (-), 23:32, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Когда уже запилят поддержку C++11 в редакторе QtCreator'а? :-(

    Кое-что он уже поддерживает.

     

  • 1.21, Аноним (-), 08:15, 01/02/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    И что там с кроссплатформенностью? Всё кроме линукса и венды теперь официально не поддерживается?
     
     
  • 2.23, Аноным (ok), 08:29, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Наоборот, плюс ко всему Ведроид будет хорошо поддерживаться
     
     
  • 3.25, Аноним (-), 09:41, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >Наоборот, плюс ко всему Ведроид будет хорошо поддерживаться

    Ведроид на ядре линукс. Ты бы ещё про кроссдистрибутивность тут заявил.

     
     
  • 4.26, Аноным (ok), 11:35, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Что-то Кути не видать на Ведроиде, только 2ГИС какие-то там свои костыли налепил с Кути.
     
     
  • 5.27, Аноним (-), 11:39, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Отличные между прочим костыли
     
     
  • 6.30, Аноным (ok), 13:24, 01/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Не знаю, прокрутка карты тормозит сильно.
     
  • 2.32, Vkni (ok), 10:44, 02/02/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > И что там с кроссплатформенностью? Всё кроме линукса и венды теперь официально
    > не поддерживается?

    Qt 4.8.4 на OpenSolaris'е не компилируется - нужно пару мест подправить.

     
     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру