The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Обновление свободного Java-пакета IcedTea6 1.9

10.09.2010 23:56

Анонсирован выход релиза проекта IcedTea6 1.9, полностью открытой реализации Java SE 6, построенной на базе OpenJDK6 20 и виртуальной машины HotSpot 17, с использованием свободных средств сборки, интеграцией компилятора gcj (GNU Compiler for Java), реализацией некоторых дополнительных возможностей (64-разрядный плагин для LiveConnect и Java Web Start) и расширенной поддержкой платформ.

По сравнению с прошлым выпуском в IcedTea6 1.9 внесено более 1100 исправлений. Особенностью релиза является исключение из поставки инструмента VisualVM и оформления его в виде отдельного пакета, который поддерживает интеграцию с NetBeans 6.8 и NetBeans 6.9. Причина выделения VisualVM из основного состава IcedTea6 в упрощении формирования пакетов и снижении зависимости от проекта NetBeans.

  1. Главная ссылка к новости (http://mail.openjdk.java.net/p...)
Лицензия: CC-BY
Тип: Программы
Ключевые слова: java, IcedTea
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (18) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Аноним (-), 10:36, 11/09/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А русский язык оно поддерживает или все так же крякозяблики выходят?
     
     
  • 2.2, Tav (ok), 11:22, 11/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    По моему, подобные проблемы были решены уже давно, еще до открытия JDK.
     

  • 1.3, Arcturus (ok), 11:28, 11/09/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Блин, какого чёрта он всё ещё от NetBeans зависит?

    Кстати, Swing нормально у кого-нибудь работает под OpenJDK? А то у меня окна по умолчанию принимают какие-то гигантские размеры, что нельзя пользоваться, например, jftp.

     
     
  • 2.5, iZEN (ok), 16:05, 11/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >Кстати, Swing нормально у кого-нибудь работает под OpenJDK?

    % java -version
    openjdk version "1.6.0"
    OpenJDK Runtime Environment (build 1.6.0-b20)
    OpenJDK 64-Bit Server VM (build 17.0-b16, mixed mode)
    % uname -rsm
    FreeBSD 8.1-STABLE amd64

    IntelliJ IDEA 9.0 CE отлично себя ведёт с родным, и с Metal, и с Nimbus Look&Feel. В Gtk+ L&F есть небольшие погрешности, связанные с кнопками комбо-боксов, а так тоже хорошо.

     
     
  • 3.6, Arcturus (ok), 01:06, 12/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    java -version
    java version "1.6.0_18"
    OpenJDK Runtime Environment (IcedTea6 1.8.1) (Gentoo build 1.6.0_18-b18)
    OpenJDK 64-Bit Server VM (build 16.0-b13, mixed mode)


    В том-то и дело, что глючит (у меня) но не всегда. Eclipse (правда он не swing) работает отлично; но ПО вроде JFTP или mucommander в некоторых диалогах отвратительно глючит, так, что невозможно работать: размеры диалога по высоте, наверное 4000 пикселей... 8-(

    Если можно протестите, плз, через
    1. Запустить через Web Start: http://j-ftp.sourceforge.net/jftp.jnlp
    2. Нажать CTRL-L (File->Browse LAN).

    Был бы благодарен за результат. Возможно, это какой-то линуксячий/гентушный/xfce'шный баг.

     
     
  • 4.9, egaz (ok), 12:35, 12/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Раздутие явавских окон наблюдал, когда пользовался xfce еще со старой jdk, сейчас на gnome таких проблем нет. Может это проблема композитивного менеджера окон?
     
     
  • 5.10, Arcturus (ok), 13:00, 12/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >Раздутие явавских окон наблюдал, когда пользовался xfce еще со старой jdk, сейчас
    >на gnome таких проблем нет. Может это проблема композитивного менеджера окон?

    В том-то и дело, что когда переключаешься на сановскую jdk вздутия окон нет (под xfce). Да и композитного менеджера окон у меня нет.

     
  • 4.11, iZEN (ok), 15:10, 12/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Вы ничего не путаете? Java WebStart (javaws) нету в OpenJDK6.
     
     
  • 5.12, egaz (ok), 12:14, 13/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >Вы ничего не путаете? Java WebStart (javaws) нету в OpenJDK6.

    Загуглите. Она не полная, но для jftp работает точно.

     
     
  • 6.13, iZEN (ok), 20:35, 13/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >>Вы ничего не путаете? Java WebStart (javaws) нету в OpenJDK6.
    >
    >Загуглите. Она не полная, но для jftp работает точно.

    Нету. У меня в OpenJDK6 JWS нет точно.


     
  • 6.18, iZEN (ok), 16:07, 18/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >>Вы ничего не путаете? Java WebStart (javaws) нету в OpenJDK6.
    >
    >Загуглите. Она не полная, но для jftp работает точно.

    В коллекции портов обновили OpenJDK:
    > java -version

    openjdk version "1.6.0"
    OpenJDK Runtime Environment (build 1.6.0-b20)
    OpenJDK 64-Bit Server VM (build 17.0-b16, mixed mode)
    Теперь можно опционально собрать JWS, он берётся из кодовой базы IcedTea6.

    По ссылке http://j-ftp.sourceforge.net/jftp.jnlp загрузился JFTP. MDI-интерфейс оригинален, но не искажён. Собственный Look & Feel. Шрифты в норме.

     
  • 5.14, Arcturus (ok), 00:40, 14/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >Вы ничего не путаете? Java WebStart (javaws) нету в OpenJDK6.

    А, сори, не знал. Думал, как проще людям. У меня просто отключена сборка java-плагинов. Я-то по старинке java jftp.jar запукаю ;)

     
     
  • 6.15, iZEN (ok), 14:09, 15/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >>Вы ничего не путаете? Java WebStart (javaws) нету в OpenJDK6.
    >
    >А, сори, не знал. Думал, как проще людям.

    Не нужно как проще. Нужно точнее выражать свои мысли. Java WebStart не входит в OpenJDK6.

    >У меня просто отключена сборка java-плагинов. Я-то по старинке java jftp.jar запукаю ;)

    Плагин для браузера есть, но он работает только в Firefox 3.5.x и/или только на [i386].
    http://izenfire.blogspot.com/2009/07/firefox-35-java-plugin.html


     
  • 4.16, iZEN (ok), 14:12, 15/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >java -version
    >java version "1.6.0_18"
    >OpenJDK Runtime Environment (IcedTea6 1.8.1) (Gentoo build 1.6.0_18-b18)
    >OpenJDK 64-Bit Server VM (build 16.0-b13, mixed mode)
    >
    >
    >В том-то и дело, что глючит (у меня) но не всегда. Eclipse
    >(правда он не swing) работает отлично; но ПО вроде JFTP или
    >mucommander в некоторых диалогах отвратительно глючит, так, что невозможно работать: размеры
    >диалога по высоте, наверное 4000 пикселей... 8-(

    Пробую:
    > java -version

    openjdk version "1.6.0"
    OpenJDK Runtime Environment (build 1.6.0-b20)
    OpenJDK 64-Bit Server VM (build 17.0-b16, mixed mode)
    > cd /usr/home/igor/bin/jftp
    > java -jar lib/jftp.jar

    — после получения и инсталляции некоммерческой лицензии для личного использования JFTP программа запустилась нормально, ничего никуда не уехало, геометрия окон и шрифты в порядке.

     
     
  • 5.17, Arcturus (ok), 23:43, 17/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    Видимо, это из-за XFCE. Какой у Вас DE стоит?
     

  • 1.4, Аноним (-), 15:26, 11/09/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • –3 +/
    Кто нить еще этим недоразумением пользуется?
     
     
  • 2.7, Аноним (-), 03:16, 12/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    А почему Вы спрашиваете? :)
     
  • 2.8, Stax (ok), 05:08, 12/09/2010 [^] [^^] [^^^] [ответить]  
  • +/
    А в чем недразумение?

    Практически везде, где не прибита sun jdk внутри - а иногда и где прибита - полноценно заменяет и работает без проблем с совместимостью.

     
     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру