The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Стабильный релиз драйверов NVIDIA 180.22 с поддержкой множества новых GPU

08.01.2009 20:50

Компания NVIDIA выпустила новый релиз комплекта видеодрайверов - NVIDIA 180.22, доступного в сборках для Linux (IA32, AMD64/EM64T), Solaris и FreeBSD.

В NVIDIA 180.22 представлены следующие новшества:

  • Добавлена поддержка следующих GPU:
    • GeForce 9400M G
    • GeForce 9400M
    • GeForce 9800 GT
    • GeForce 8200M G
    • GeForce Go 7700
    • GeForce 9800M GTX
    • GeForce 9800M GT
    • GeForce 9800M GS
    • GeForce 9500 GT
    • GeForce 9700M GT
    • GeForce 9650M GT
    • GeForce 9500 GT
    • Quadro FX 2700M
    • Quadro NVS 450;
    • Quadro FX 370 LP;
    • Quadro FX 5800;
    • Quadro FX 4800;
    • Quadro FX 470.
  • На достаточно новых видеокартах теперь поддерживается практически полное аппаратное ускорение различных форматов видео, в т.ч. H.264, позволяет выполнять пост-процессинг, слияние (compositing), отображение и декодирование видео на стороне GPU. Аналогом в Windows является платный ускоритель PureVideo. Подробности по использованию VDPAU API (Video Decode and Presentation API можно найти в файле vdpau.h, устанавливаемом вместе с драйвером. Поддержка VDPAU уже реализована в mplayer, libxine, ffmpeg, vlc и MythTV;
  • Добавлена поддержка CUDA 2.1, что позволяет использовать GPU для выполнения вычислительных задач. Разработка приложений, использующих CUDA API и предназначенных для выполнения на GPU, ведется на языке Си;
  • Добавлена начальная поддержка функция OpenGL 3.0;
  • Улучшена OpenGL производительность некоторых видеокарт (класса workstation);
  • Кэширование глифов включено по умолчанию на всех поддерживаемых видеоадаптерах;
  • По умолчанию выключена разделяемая память X битмапов, для справки см. опцию "AllowSHMPixmaps";
  • Улучшено размещение в памяти X битмапов на видеокартах уровня GeForce 8 и выше;
  • Добавлена поддержка полного спектра цветов для SDI приложений;
  • Драйверы теперь совместимы с новым ядром 2.6.28;
  • Исправления ошибок:
    • Повышена стабильность работы на видеокартах уровня GeForce 8 и выше;
    • Исправлено ухудшение работы предыдущих выпусков драйверов, которая заключалась в неправильной работе менеджера окон Compiz на видеокартах Geforce 6 и 7;
    • Исправлено падение программы nvidia-settings в случае когда конфигурация X сервера содержит секции Device и Screen, но не имеет секции ServerLayout;
    • Исправлено чтение опций развёртки монитора;
    • Исправлено падение и ошибки работы некоторых SDI приложений (в противоположность MDI приложениям);

Комплект драйверов серии 177.x поддерживает только карты начиная с серии GeForce 6xxx. Карты GeForce4 и более старые поддерживаются релизами 96.43.xx и 71.86.xx, а GeForce FX - 173.14.xx.

  1. Главная ссылка к новости (http://www.nvnews.net/vbulleti...)
  2. OpenNews: Релиз бета-драйверов NVIDIA 180.06
  3. OpenNews: Новые бета-драйверы Nvidia 180.08, с реализации поддержки OpenGL 3.0
  4. OpenNews: Новые бета-драйверы Nvidia 180.11, с поддержкой GPU GeForce 9400M
  5. OpenNews: Новая бета-версия видеодрайверов NVIDIA 180.16
  6. OpenNews: Новая бета-версия видеодрайверов NVIDIA 180.18
Автор новости: Artem S. Tashkinov
Тип: Программы
Ключевые слова: nvidia, driver, video
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (40) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, 345673 (?), 22:41, 08/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Драйверы теперь совместимы с новым ядром 2.6.28;


    Та они как бы и до этого ставились нормально на 28-е

     
     
  • 2.16, smb (?), 01:20, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    177.82, vanilla kernel 2.6.28 - не ставились. 180.16 beta - встали душевно :)
     

  • 1.2, Аноним (2), 22:49, 08/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    интересно а кодировать видео можно средствами GPU ?
     
     
  • 2.4, noname (??), 22:57, 08/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >интересно а кодировать видео можно средствами GPU ?

    Как раз с помощью CUDA и можно :) если кодек написать соответствующий ;)

     
     
  • 3.18, gfh (??), 02:23, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Пока эффективных алгоритмов для этого не придумали.
    Badabum для CUDA и последняя Avivo для Stream выдают ужасное видео, хотя и работают очень быстро.
    Как раз из-за того что всякие технологии улучшения кодирования очень плохо поддаются распараллеливанью.

    http://forum.doom9.org/showthread.php?t=139158

     
     
  • 4.27, fix (??), 11:15, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >всякие технологии улучшения кодирования очень плохо поддаются распараллеливанью

    препроцессинг хорошо работает на gpu.

     
  • 2.22, Вася (??), 06:20, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >интересно а кодировать видео можно средствами GPU ?

    В Windows - да.

     
     
  • 3.33, Аноним (2), 16:39, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    а что это? O_O
     

  • 1.3, Аноним (2), 22:54, 08/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    180 вышла, а как насчёт 177 её еще будут выпускать или нет?
     
  • 1.5, Georges (ok), 22:59, 08/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    не написано про стабильную работу с KDE4
     
     
  • 2.15, tamerlan311 (?), 01:00, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    На пред пред последней бете 180.11-1 уже всё хорошо было..... сейчас обновимся до стабильной посмотрим.
     

  • 1.6, Аноним (2), 23:04, 08/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Я не понял! Под Linux сделано аппаратное перекодирование видео видеопроцессором бесплатным, а в Windows платным? Круто!
     
     
  • 2.23, Султан (?), 06:39, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Распаковка, а не перекодирование.
     

  • 1.7, Аноним (7), 23:08, 08/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Комплект драйверов серии 177.x поддерживает только карты начиная с серии GeForce 6xxx

    я не понял, а 180 серия драйверов поддерживает чипы начиная с каких моделей?

     
     
  • 2.13, pavlinux (ok), 00:46, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>Комплект драйверов серии 177.x поддерживает только карты начиная с серии GeForce 6xxx
    >
    >я не понял, а 180 серия драйверов поддерживает чипы начиная с каких
    >моделей?

    GeForce 6100

     

  • 1.8, yantux (??), 23:11, 08/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Operating System: Solaris x64/x86

    т.е. OpenSolaris не поддерживается? только Solaris или я чтото путаю?

     
     
  • 2.30, Kirill_AG (??), 12:23, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Поддерживаются все солярисы. Это по сути одно и то же
     

  • 1.9, Вереск (?), 23:29, 08/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    предыдущий драйвер сильно лагал с ядром 2.6.28, особенно на 3D
     
     
  • 2.14, Аноним (2), 00:57, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    да не лагало там ничего
     
     
  • 3.40, поцанчик (?), 14:50, 11/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >да не лагало там ничего

    подтверждаю

     

  • 1.10, deboon (?), 23:38, 08/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А с какой версии (или даты в SVN) Mplayer поддерживает декодирование H.264 видео?
     
     
  • 2.28, Аноним (2), 11:38, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Очень давно.
    Более того, года три уже _кодирую_ H.264 видео с помощью mencoder'а, собранного с x.264.
     

  • 1.11, Аноним (2), 23:50, 08/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > VDPAU уже реализована в mplayer, libxine, ffmpeg, vlc и MythTV

    Откуда такая информация? Я нахожу патчи только для mplayer

     
     
  • 2.12, другой Аноним (?), 00:11, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >> VDPAU уже реализована в mplayer, libxine, ffmpeg, vlc и MythTV
    >
    >Откуда такая информация? Я нахожу патчи только для mplayer

    http://www.phoronix.com/scan.php?page=news_item&px=Njk3MQ
    http://www.phoronix.com/scan.php?page=news_item&px=Njk1NA
    http://www.phoronix.com/scan.php?page=news_item&px=Njk0MA

     

  • 1.17, toogle (?), 01:23, 09/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А интересно, проблему с s2ram решили или по-прежнему useless для ноутбуков?
     
     
  • 2.19, toogle (?), 02:38, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Сам себе и отвечу - ничего не исправлено, ноутбук по-прежнему зависает после выхода из s2ram. Одним словом, 180.22 в сад, ждем следующего релиза, где вроде обещали поправить.
     
  • 2.24, Eugeni (??), 06:47, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    http://www.nvnews.net/vbulletin/showpost.php?p=1895489&postcount=80

    Sorry for the very slow response on this bug. We've reproduced the problem and are investigating it. Unfortunately, it's very unlikely that a fix is going to make it in by our official release deadline, so don't expect it to be fixed in the next release.

     

  • 1.21, barmaglot (??), 03:42, 09/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >А интересно, проблему с s2ram решили или по-прежнему useless для ноутбуков?

    У меня все время работало нормально. Notebook ASUS F3T, видяха: 7600Go; gentoo, gnome 2.24.1.

    Может не в дровах видиокарты дело ?

     
     
  • 2.37, toogle (?), 23:11, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    > У меня все время работало нормально. Notebook ASUS F3T, видяха: 7600Go; gentoo, gnome 2.24.1.
    >
    > Может не в дровах видиокарты дело ?

    Sony Vaio SZ7RXN, 8400M GS, 2.6.28-tuxonice, Gentoo, KDE4, pm-utils = зависание после выхода из suspend.
    Выше приведена ссылка на топик на nvnews, из которого можно почерпнуть, что проблема проявляется не у всех (возможно, зависит от фазы Луны), но разработчиками подтверждена. Ждем исправления.

    P.S. 177.x в моём случае suspend-ится нормально.

     
  • 2.39, vizor (ok), 11:11, 10/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Ноут ThinkPad T61 не проснулся с этими дровами ниразу, с прошлой версией такого не было
     

  • 1.25, Nazgul (??), 08:49, 09/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    А разрешилась ли проблема с повторным запуском иксов на карте 9600GT?
     
     
  • 2.26, Аноним (2), 10:12, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    У меня 9600GT и 28-е ядро, были какие-то проблемы с повторным запуском иксов?
     
     
  • 3.29, Mentis (?), 12:16, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >У меня 9600GT и 28-е ядро, были какие-то проблемы с повторным запуском
    >иксов?

    Были и есть =( Кулер после перезвпуска иксов начинает работать на максимальных оборотах.

     
     
  • 4.34, 345673 (?), 16:49, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Хм, у меня пассивное охлаждение :)
     
     
  • 5.41, поцанчик (?), 14:53, 11/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Хм, у меня пассивное охлаждение :)

    пентиум 2 процессор ?

     

  • 1.31, Аноним (2), 15:12, 09/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Интересно, какие пасы в тазик надо сделать чтобы работало аппаратное декодирование ? Есть проигрыватели, активирующие этот режим ? Или как оно происходит ? Наврядли автоматически...
     
     
  • 2.35, Аноним (2), 17:12, 09/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Интересно, какие пасы в тазик надо сделать чтобы работало аппаратное декодирование ?
    >Есть проигрыватели, активирующие этот режим ? Или как оно происходит ?
    >Наврядли автоматически...

    http://www.phoronix.com/scan.php?page=article&item=nvidia_vdpau&num=1

     
     
  • 3.38, yarodin (??), 09:28, 10/01/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>Интересно, какие пасы в тазик надо сделать чтобы работало аппаратное декодирование ?
    >>Есть проигрыватели, активирующие этот режим ? Или как оно происходит ?
    >>Наврядли автоматически...
    >
    >http://www.phoronix.com/scan.php?page=article&item=nvidia_vdpau&num=1

    Обратите внимание на секцию Limitation в патчсете для mplayer... Неюзабельно на данный момент.

     

  • 1.32, Аноним (7), 15:23, 09/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Хмм.. перманентный глюк с прорисовкой шрифтов остался с беты
    http://pic.ipicture.ru/uploads/090109/KOQS5W3J11.png
     
  • 1.36, Хмм (?), 18:42, 09/01/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    И backlight не починили под Иксами. Уже который год...
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    MIRhosting
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру