The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Проект FreeBSD переходит на новую модель поддержки релизов

03.02.2015 21:56

Объявлено о переходе на новую модель поддержки FreeBSD, которая будет привязана к веткам, а не отдельным релизам. Изменения направлены на переход к более предсказуемым срокам поддержки, сокращение времени выпуска исправлений ошибок и проблем с безопасностью, обеспечение согласованности наборов бинарных пакетов с версиями базовой системы, уменьшение времени внедрения новых возможностей в наборах бинарных пакетов. Анонсированные изменения вступят в силу начиная с выпуска FreeBSD 11.0-RELEASE, который ожидается через несколько месяцев. Прошлые ветки, до окончания своего времени жизни, будут поддерживаться в соответствии с ранее применяемой старой моделью.

Особенности новой модели поддержки:

  • Уход от расчёта времени поддержки относительно каждого нового выпуска в ветке в пользу обеспечения общего гарантированного срока поддержки для всей ветки;
  • Определение минимального срока поддержки каждой ветки FreeBSD (stable/X) в 5 лет с момента первого выпуска X.0-RELEASE. Срок поддержки ветки не будет зависеть от сроков подготовки, дат выпуска и числа промежуточных релизов. Таким образом время релизов не будет влиять на срок поддержки всей ветки, в том числе, выпущенный на поздних сроках релиз ветки stable/X не приведёт к очередному продлению поддержки всей ветки на два года;
  • Отвечающие за порты и безопасность команды смогут на своё усмотрение в исключительных случаях расширить сроки поддержки для любых отдельных выпусков или веток;
  • Новые стабильные ветки будут выпускаться не чаще, чем через два года с момента первого релиза (X.0-RELEASE) в прошлой ветке, что с учётом пятилетнего цикла поддержки позволит ограничить число одновременно поддерживаемых веток;
  • Поддержка прошлого релиза в ветке stable/X будет прекращаться через три месяца после выхода следующего промежуточного релиза (напирмер, поддержка X.0-RELEASE будет прекращена через три месяца после выхода X.1-RELEASE).

Новая модель даст возможность более оперативно выпускать новые версии бинарных пакетов для каждой ветки, в то время как старая модель вынуждала вносить ограничения для всей ветки из-за необходимости обеспечить работу пакетов в еще поддерживаемых старых релизах. Например, долгое время не получалось включить по умолчанию сборку пакетов с новым графическим стеком WITH_NEW_XORG, так как не все необходимые для его работы возможности имелись в базовых системах старых релизов FreeBSD, срок поддержки которых не истёк.

Кроме того, исчезнет путаница в сроках поддержки и появится возможность точного определения времени жизни ветки. С другой стороны, администраторам будет дано только три месяца для обновления системы после выхода нового релиза в ветке, при том, что время выпуска промежуточных релизов не станет фиксированным и его по-прежнему будет трудно предсказать при долгосрочном планировании обновлений.

  1. Главная ссылка к новости (https://lists.freebsd.org/pipe...)
Лицензия: CC-BY
Тип: К сведению
Ключевые слова: freebsd
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (49) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, AlexAT (ok), 22:06, 03/02/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –12 +/
    Fast RIP? Т.е. вышла 11.1-RELEASE, а 11.0-RELEASE через три месяца рипнулась. Для bleeding edge дистра, впрочем, нормально. Для продакшна - ад аццкий.
     
     
  • 2.4, Ivan_83 (?), 23:44, 03/02/2015 [^] [^^] [^^^] [ответить]  
  • +7 +/
    Нет никаких проблем проапгрейдится с 11.0 до 11.1, обычно это происходит не заметно.
     
     
  • 3.35, Аноним (-), 16:06, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > обычно это происходит не заметно.

    Звучит как "иногда на эту мину кто-то все-таки наступает" в переводе с бсдшного на русский.

     
  • 2.7, iZEN (ok), 00:27, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Fast RIP? Т.е. вышла 11.1-RELEASE, а 11.0-RELEASE через три месяца рипнулась. Для
    > bleeding edge дистра, впрочем, нормально. Для продакшна - ад аццкий.

    Это — не линукс, где всё меняется от версии к версии и нужно подгадывать моменты, чтобы, например, версия видеодрайверов совпадали с данной версией ядра. На линуксе кошмарят народ, почём зря: обновить ядро нельзя, потому что ещё не вышел видеодрайвер, его поддерживающий. :))


     
     
  • 3.8, Аноним (-), 00:59, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • –4 +/
    >обновить ядро нельзя, потому что ещё не вышел видеодрайвер, его поддерживающий. :))

    Если у вас нвидиа - да. Если видеокарта - нет.

     
     
  • 4.9, Аноним (-), 01:57, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Вообще-то, как раз наоборот. Блоб nvidia работает на всех ветках FreeBSD без проблем, проблемы всегда только со свободными дровами.
     
  • 3.11, Аноним (-), 01:58, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Ты никогда линукса не видел? Не неси бред.
     
     
  • 4.29, Аноним (-), 13:23, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Видимо, он сам себя закошмарил пытаясь поддерживать lfs =)
     
  • 3.14, Аноним (-), 02:17, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Это FreeBSD, где просто нет видеодрайверов для большинства карт, поэтому обновляй-не обновляй - результат один
     
     
  • 4.15, Аноним (-), 02:53, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Это FreeBSD, где просто нет видеодрайверов для большинства карт, поэтому обновляй-не обновляй
    > - результат один

    nvidia есть, ati есть, intel есть. Из каких таких видеокарт состоит ваше "большинство"?

     
     
  • 5.36, Аноним (-), 16:09, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > nvidia есть,

    ...левый сторонний блоб, где извольте ждать пока под вас его соберут. Если вообще сподобятся. А бонусом могут "лишние" мониторы отпилить или там что еще. И вообще - это не заслуга фрибздюков как команды, для начала.

    > ati есть,

    ATI давно помер. Нынче рулит AMD и поддержка GCN'ов у некоторых в полной ж! А другие уже и не продаются особо.

    > intel есть.

    Но со свежими опять затык. Судя по вашей же вике.

    > "большинство"?

    Ну вот из таких.

     
     
  • 6.39, dvg_lab (ok), 17:49, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +5 +/
    блобы под нвидию собирают ровно с той же скоростью что и под луноходы, бонусом могут и у вас гденить глюков добавить, и заслуга того что блобы исправно собираются именню бздюков ибо добавили недостающие вызовы в ядро.
    АМД собсно никогда особой поддержкой во фре не отличалось, но в принципе работало. хасвел со всеременем добавят, но там как-то особо фпсов даже в ваших лунотазиках не видать, один фиг для игроманов дискретное 3х вентиляторное пылесосное монстрило, а у меня системник в 30 дБ укладывается всегда, да не игроманю, отболел лет 20 назад на спектрумах, а некоторые луноходы без игр да, не могут, поэтому у луноходов пожизненный баттхерт, наверно потому что 2% это не то чтобы много, скорее чуть более чем джаст фофан, зато +146% к ЧСВ.
     
  • 6.40, Аноним (-), 18:01, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > ...левый сторонний блоб, где извольте ждать пока под вас его соберут. Если вообще сподобятся. А бонусом могут "лишние" мониторы отпилить или там что еще. И вообще - это не заслуга фрибздюков как команды, для начала.

    Конечно не фрибздюков, и не СПО сообщества вообще. Это исключительно заслуга nvidia, которая единственная делает качественные драйверы которые работали испокон веков, в отличие от опенсрского гoвна, которое, по вашим же словам, не поддерживает последние карты.

     
  • 5.44, Аноним (-), 20:26, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > nvidia есть, ati есть, intel есть

    …а дров под них у бздунов нет!

     
  • 4.26, Аноним (-), 11:10, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    идем и читаем https://wiki.freebsd.org/Graphics, Radeon HD 7700, 7800, 7950-Partially supported, Radeon HD 8000, Rx 200, Haswell - Not supported, и даже у тех что Works есть сноска, и это актуальные карты, которые продаются на данный момент и в том же linux работают с открытыми драйверами
     
     
  • 5.33, annonnym (?), 15:12, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Haswell - Not supported

    Примерно через полтора месяца "мержнут"  поддержку из CURRENT в STABLE.

    > идем и читаем https://wiki.freebsd.org/Graphics, Radeon HD 7700, 7800, 7950-Partially
    > supported, Radeon HD 8000, Rx 200,

    Так AMD карты или все-таки "большинство карт" ? :)

     
  • 5.37, Аноним (-), 16:11, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Partially supported,

    ... с прикольной сноской "See notes: 1, 2 - Acceleration doesn't work yet.". Ну да, работает, примерно на уровне VGA-адаптера :)

    > Radeon HD 8000, Rx 200, Haswell - Not supported,

    Всего ничего. При том у амдшников VLIW-based в ассортименте уже почти и не осталось.

     
  • 3.17, andy (??), 08:15, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Это — не линукс, где всё меняется от версии к версии и нужно подгадывать моменты, чтобы, > например, версия видеодрайверов совпадали с данной версией ядра.

    Если драйвер открытый, то он в ядре. С закрытым модулем ядро собирается
    в сборочнице, после чего приходит и модуль ядра для видео и само ядро
    при обновлении. Заканчивай гнать уже.

     
  • 3.34, Аноним (-), 16:04, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > обновить ядро нельзя, потому что ещё не вышел видеодрайвер, его поддерживающий. :))

    Наслаждайся прелестями проприетари, гули. А ты думаешь, мы хотим уйти проприетару просто так? :)

     
  • 3.51, Sw00p aka Jerom (?), 13:55, 05/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    >>Это — не линукс, где всё меняется от версии к версии и нужно подгадывать моменты,

    вчера столкнулся с такой хней - фря 10.1-p5, pkg в системе как изветсно новенький, а проблема в том, что они не додумались починить модуль snmp_hostres пакета bsnmpd - таблица установленного софта.

    https://github.com/lattera/freebsd/blob/master/usr.sbin/bsnmpd/modules/snmp_ho

    пс:
    /**
    * Read the installed packages
    */
    static int
    swins_get_packages(void)


    тупо читает листинг директорий в /var/db/pkg и снимает дату изменения, и это норм работало на 9.3.

    пс: все притензии в том, что - почему гамно которое последний раз в 2006 году писалось приходит в составе основной системы ? Такого рода проблем дофига у фришки.

     
     
  • 4.52, Kibab (ok), 17:32, 05/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Вот этот патч решает проблему: https://people.freebsd.org/~bapt/bsnmp-pkg.diff

    Пока он в состоянии review needed, должен быть замержен в 11-CURRENT и, вероятно, MFC to 10-stable

     
  • 2.13, annonnym (?), 02:00, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Т.е. вышла 11.1-RELEASE, а 11.0-RELEASE через три месяца рипнулась

    Я правильно понимаю, что, ну совсем ничего общего с минорными релизами той-же центоси нет?

    >http://wiki.centos.org/FAQ/General#head-dcca41e9a3d5ac4c6d900a991990fd1193086
    > CentOS is designed for you to be running CentOS-5, CentOS-6, CentOS-7 (major version). Any time you run a > yum update, no matter what you installed from, you will be upgraded to the latest update for that major version.

    Или дебиана:
    2013-05-04: Initial release: 7.0.0 (press release).
    2013-06-15: Updated (7.1) (press release).
    2013-10-12: Updated (7.2) (press release).
    2013-12-14: Updated (7.3) (press release).

    В чем конеретно разница?

     
     
  • 3.19, AlexAT (ok), 08:35, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > В чем конеретно разница?

    Фокус в том, что 99.9% совместимость всех версий софта в RHEL/CentOS между минорами практически гарантирована, а 0.1% (обычно несущественных) различий плюс добавившиеся фичи - описываются в relnotes. Т.е. все миноры являются снапшотами одной и той же ветки, и все они поддерживаются, как одно целое, до прекращения поддержки всей ветки. То есть там вообще нет такого понятия, как обособленность минорного релиза - фактически все миноры в RHEL/CentOS - это просто снапшоты rolling release.

    https://access.redhat.com/articles/64664

    "NOTE: Customers are not required to update their systems to the active minor release in its entirety, only the specific relevant affected packages."

     
     
  • 4.28, yorik.sar (ok), 13:05, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Т.е. все миноры являются снапшотами одной и той же ветки, и все они поддерживаются, как одно целое, до прекращения поддержки всей ветки.

    Абсолютно тоже самое в FreeBSD. Релизы делаются со -STABLE ветки, так что все релизы 10.x - "снапшоты одной и той же ветки". С новой моделью релизов и поддерживаться они будут "до прекращения поддержки всей ветки". Разве что есть трёхмесячные окна, когда поддерживаться одновременно могут два релиза одной ветки.

     
     
  • 5.30, Аноним (-), 13:28, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Разница в том, что у фряхи нет ресурсов чтоб поддерживать свои минорки, а у редхата есть.
     
     
  • 6.31, yorik.sar (ok), 13:32, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Разница в том, что у фряхи нет ресурсов чтоб поддерживать свои минорки, а у редхата есть.

    Примеры будут?

     
     
  • 7.32, pf (?), 13:53, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Абсолютная истина. Достаточно взглянуть на список зарегистрированных багов в трекере FreeBSD. Тянутся с 2000 года. В RHEL люди работают и патчи делают за зарплату. Большая часть разрабов FreeBSD делает что-то в проекте в свободное от своей основной работы время.
     
     
  • 8.55, Аноним (-), 22:16, 09/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Вот идиоты И не знают как прогрессивное человечество с 12309 поступило Закрыло... текст свёрнут, показать
     

  • 1.6, iZEN (ok), 00:13, 04/02/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Можно пойти ещё дальше.

    Почему бы не сделать одну единственную ветку (ствол), сохранив при этом -RELEASE, -STABLE и -HEAD, но изменить нумерацию релизов в соответствие с порядковым номером? Из -HEAD изменения вносились бы в -STABLE простым решением о готовности к широкому тестированию изменений. А -RELEASE выпускался бы как фиксация всех принятых и оттестированных изменений, не вызывающих явных сбоев.

    Зачем нужно поддерживать 8-STABLE, 9-STABLE, 10-STABLE и 11-CURRENT, если это фактически три ветки и один ствол?! Ну, разве что тем, кто не хочет видеть LLVM/Clang в качестве системного компилятора, а пользоваться GCC 4.2.1.


    > долгое время не получалось включить по умолчанию сборку пакетов с новым графическим стеком WITH_NEW_XORG, так как не все необходимые для его работы возможности имелись в базовых системах старых релизов FreeBSD, срок поддержки которых не истёк.

    Срок поддержки старушенции 8.4-RELEASE истекает 30.06.2015. Всем ждать пока она рипнется и можно будет портировать новый xorg-server-1.17 что ли?

     
     
  • 2.10, Аноним (-), 01:58, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Можно пойти ещё дальше.

    Нельзя. Ты понятия не имеешь о процессе подготовки FreeBSD'шных релизов и вообще её разработки, поэтому просто помалкивай.

     
  • 2.12, Аноним (-), 01:59, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Можно пойти ещё дальше.

    Можно, разрешаю.

     
     
  • 3.18, Аноним (-), 08:35, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    верной дорогой идете, товарищи!
     

  • 1.21, count0krsk (ok), 08:42, 04/02/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Интересно, а если седой одмин прохлопает момент, и поросшие мхом сервачки не обновит за 3 месяца? И за год не обновит. Он потом просто не сможет до куррента догнать, и придется переустанавливать?
     
     
  • 2.27, Каррент (?), 12:28, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Да ладно, я в эти новогодние каникулы поставив цель все серваки довести до 10-STABLE, все перевёл.
    Чуть сложностей было лишь с 7,8 веткой, потому что их приходилось сперва до 9-ки обновлять с GCC, затем уже с 9-ки в 10-ку с CLANG'ом.

    Так что седой не седой, но 7-ка до 10-ки обновляется удалённо без затычек. Ну коли грамотно к этому подходить.

     
     
  • 3.45, AlexAT (ok), 21:55, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Так что седой не седой, но 7-ка до 10-ки обновляется удалённо без
    > затычек. Ну коли грамотно к этому подходить.

    Ээээ... Что значит "удалённо без затычек"? IPMI и аналоги или гипервизор на подложке уже не спасают отцов русской демократии даже в случае затычек?

     
  • 2.38, Typhoon (ok), 17:20, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    да забить )))
     
  • 2.41, Аноним (-), 18:04, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    > Интересно, а если седой одмин прохлопает момент, и поросшие мхом сервачки не
    > обновит за 3 месяца? И за год не обновит.

    Будет то же самое что сейчас, если он (и не за 3 месяца, а за несколько часов) не обновит систему но releng ветки где вышло исправление критической уязвимости. Пойдёт улицы подметать.

    > Он потом просто не сможет до куррента догнать, и придется переустанавливать?

    Перестанавливать FreeBSD никогда не надо, если он "не смог" то он не админ. То же самое, подметать улицы.

     
     
  • 3.53, count0krsk (ok), 09:00, 07/02/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Это хорошо, что не надо.
    Не пойдёт, пока не хакнут, да и там отмажется. Мол это через роутер ваш дешевый )) Говорил же брать *****, а вы денег пожалели, вот и пожалуйста.
     

  • 1.23, Аноним (-), 09:12, 04/02/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Вообще, в том же redhat, при переходе с одного релиза на другой, рекомендуют делать claen install. Если система протухла, прыгать через голову бессмысленно.
     
     
  • 2.24, AlexAT (ok), 09:22, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > Вообще, в том же redhat, при переходе с одного релиза на другой,
    > рекомендуют делать claen install. Если система протухла, прыгать через голову бессмысленно.

    Только в случае перехода с одного major на другой major (миноры по сути - rolling release). Это в первую очередь связано с тем, что меняются версии софта, а вместе с ними - структуры конфигов.

     
  • 2.54, anonn (?), 10:14, 07/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    CLEAN INSTALL! not "claen install"!
     

  • 1.25, Сергей (??), 09:52, 04/02/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Фигню придумали, особенно когда сослались на поставку пакетов и это при наличие нового формата пакетов и менеджера pkg...
     
     
  • 2.43, Аноним (-), 18:08, 04/02/2015 [^] [^^] [^^^] [ответить]  
  • +2 +/
    >  Фигню придумали, особенно когда сослались на поставку пакетов и это при
    > наличие нового формата пакетов и менеджера pkg...

    Набор слов сказали. Раскройте мысль.

     

  • 1.42, Аноним (-), 18:08, 04/02/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    На первый взгляд для продакшена это хуже, потому что нельзя поставить релиз и забыть. Но если подумать, обновлять релиз всё равно нужно регулярно для исправления SA. Здесь просто будут прикатываться ещё и более масштабные (совместимые) улучшения из stable, так что никакой разницы. А вот то что пакеты будут собираться с последним релизом и тухлятина не будет держать внедрение новых фич, это безмерно круто.
     
  • 1.46, Сергей (??), 23:57, 04/02/2015 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    А пакеты и так собираются с последнего релиза, достаточно настроить только соответствующим образом pkg, вот только я привык собирать их из портов сам, кроме прочего, я считаю, что прикладной софт не является частью фрю. Теперь по поводу нового графического стека, то, что они его влили в 9-ую ветку, когда уже есть 9.2, в корне нарушает идеологию веток фри.
     
     
  • 2.47, iZEN (ok), 00:34, 05/02/2015 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >  А пакеты и так собираются с последнего релиза, достаточно настроить только
    > соответствующим образом pkg, вот только я привык собирать их из портов
    > сам, кроме прочего, я считаю, что прикладной софт не является частью
    > фрю. Теперь по поводу нового графического стека, то, что они его
    > влили в 9-ую ветку, когда уже есть 9.2, в корне нарушает
    > идеологию веток фри.

    Ты хотел сказать "влили в 8-ю ветку, когда уже есть 9.3"?

    На 8-й ветке поддерживается 8.4-RELEASE со сроком до 30.06.2015.
    На 9-й ветке поддерживается 9.3-RELEASE со сроком до 31.12.2016.
    https://www.freebsd.org/security/security.html#sup
    Коллекция портов одна.


     
     
  • 3.49, Аноним (-), 01:56, 05/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Да, пообщайтесь - вы друг друга стоите. Что один ничего не знает о системе и несёт чушь, что другой.
     
  • 3.50, Сергей (??), 10:56, 05/02/2015 [^] [^^] [^^^] [ответить]  
  • +/
    Да коллекция одна, а сходите на http://pkg.freebsd.org/ за пакетами...
     
  • 2.48, Аноним (-), 01:54, 05/02/2015 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > А пакеты и так собираются с последнего релиза

    Ложь. Хотите убедиться - сходите на beefy[12].isc.freebsd.org и посмоторите лог любой сборки для десятки.

    > в корне нарушает идеологию веток фри

    Тоже больные фантазии.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Слёрм
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру