The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз системы печати CUPS 1.4.5 с исправлением уязвимости

12.11.2010 16:15

Компания Apple выпустила новую версию системы печати CUPS 1.4.5 (Common Unix Printing System), в которой кроме исправления 36 ошибок устранена опасная уязвимость, которая может привести к выполнению кода злоумышленника через отправку специально сформированного IPP-пакета.

  1. Главная ссылка к новости (http://cups.org/articles.php?L...)
Лицензия: CC-BY
Тип: Проблемы безопасности
Короткая ссылка: https://opennet.ru/28633-cups
Ключевые слова: cups, print
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (7) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Zenitur (?), 18:06, 12/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Владельцам принтеров Canon посвящается! www.linux.org.ru/news/linux-general/5543897 Если ваш принтер не заработал, создаётся полностью свободный драйвер для него. Из обсуждения видно, что в мае расшифровали способ передачи данных, а несколько дней назад полноценная преальфа оказалась готова! Сразу после того как разработчики научились печатать страницу до конца (в данный момент доводится до ума поддержка нескольких страниц одновременно, ищется способ проверить бугагу в лотке, и добавляется поддержка принтеров, перечисленных по ссылке - для последнего нужна помощь владельцев!).
     
     
  • 2.6, User294 (ok), 21:25, 12/11/2010 [^] [^^] [^^^] [ответить]  
  • –5 +/
    > полноценная преальфа

    division by zero.

    > способ проверить бугагу в лотке

    Бугага в лотке? Это пять баллов, знатный отжиг :)))

    Кстати ссылки хорошо бы давать с http:// иначе они получаются некликабельными, а копировать ссылку - это изврат! Жаль у меня нет кэнона - полезное дело чуваки делают.

     
  • 2.10, letsmac (ok), 14:23, 13/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >>Владельцам принтеров Canon посвящается!

    Да я уже смирился и поставил принтер на винду по smb. Иначе сетевая печать превращается  в рулетку. Еще ни разу не подхватывало цветовой профиль по требованию. Вообще с 98 года в драйверах Canon ни одного просвета.

     

  • 1.7, Mike Lee (?), 22:31, 12/11/2010 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    cups 1.4 вообще фэйл. то что они сделали с usb вообще не поддается никакой логике.
     
     
  • 2.9, Анон (?), 07:27, 13/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    До сих пор не перелез с 1.3.11. Не печатает в новых мой хп1300. То ли из-за перемен с усб девайсами, то ли конфиг поменяли.
     
     
  • 3.11, Андрей (??), 19:58, 13/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    hplip? да! он такой...
    у canon еще хуже... не собираются под 64бита...
     
     
  • 4.12, bircoph (?), 22:43, 13/11/2010 [^] [^^] [^^^] [ответить]  
  • +/
    У hplip есть только один косяк: после обновления hplip нужно обновлять ppd-файлы cups для установленных принтеров. В остальном — всё замечательно.

    cups-1.4.4-r2 и три весёлых hp-принтера.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру