The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Настройка работы беспроводной карты на базе Broadcom BCM43xx в Ubuntu
После установки Ubuntu 8.04 по умолчанию не работают беспроводные карты на базе
чипов Broadcom BCM43xx из-за отсутствия firmware.
Начиная с Linux ядра 2.6.24 работу данных карт в Linux обеспечивает драйвер b43, 
в более ранних версиях использовался драйвер bcm43xx.

Для включения работы карты нужно установить пакет b43-fwcutter и получить firmware:

   sudo apt-get install b43-fwcutter

и активировать на ноутбуке адаптер. 
Также можно воспользоваться меню  Menu / System / Administration / Hardware Drivers.

Драйвером b43 поддерживаются чипы:

    * bcm4303 (802.11b)
    * bcm4306
    * bcm4309 (только 2.4GHz)
    * bcm4311 rev 1 / bcm4312
    * bcm4311 rev 2 / bcm4312 (с 2.6.24 ядром работает через доп. патчи)
    * bcm4318

В настоящее время нет поддержки: 
    * 802.11a для серий 4309 и 4312;
    * BCM 4328/4329
    * не реализованы возможности представленные в проекте стандарта 802.11n;

Сайт разработчиков драйвера: http://wireless.kernel.org/en/users/Drivers/b43
 
29.05.2008 , Автор: E@zyVG , Источник: http://blog.linuxoss.com/2008/05/29...
Ключи: linux, wifi, broadcom, driver, ubuntu / Лицензия: CC-BY
Раздел:    Корень / Администратору / Система / Поддержка аппаратного обеспечения

Обсуждение [ RSS ]
 
  • 1, chodorenko (?), 22:09, 29/05/2008 [ответить]    [к модератору]
  • +/
    ну и к чему ты это написал ?
    работает как b43 так и bcm43  очень криво , реально нормально можно работать только с ndiswrapper. Лучше бы рассказал о том где прошивки брать
     
     
  • 2, Chinese (??), 22:48, 29/05/2008 [^] [ответить]    [к модератору]
  • +/
    правильно сделал что написал

    у меня все прекрасно работает, compaq nx6110

    $ lspci
    <...>
    02:04.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
    <...>

    fwcutter с ubuntu 8.04 ставится сразу. да и по-любому - .deb даже в обрезаном образе 700 mb есть. и сразу же пытается подгрузить фирмваре. вот их и нету. где их брать - ссылка есть в посте, там же и все заклинания вобщем-то.

    насчет урлов, даже здесь 2,5 года назад было:
    https://www.opennet.ru/prog/info/2978.shtml

     
  • 3, Бурзум (?), 18:28, 03/06/2008 [^] [ответить]    [к модератору]
  • +/
    Обновитесь, сударь.

    2.6.25-gentoo-r4 + b43 + Broadcom Corporation BCM94311MCG wlan mini-PCI (rev 01)

    24 мегабита и очень даже стабильная работа.

     
  • 4, asipin (??), 12:47, 09/06/2008 [ответить]    [к модератору]
  • +/
    Аналогично.
    Отлично работает на ноуте с нативными дровами на генте, на серваке домашнем тоже отлично работает на слакваре 12 с ядром 2.6.24
     

    Ваш комментарий
    Имя:         
    E-Mail:      
    Заголовок:
    Текст:



      Закладки на сайте
      Проследить за страницей
    Created 1996-2019 by Maxim Chirkov  
    ДобавитьПоддержатьВебмастеруГИД  
    Hosting by Ihor