The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 20-Янв-23, 13:05 
Доброе время суток!

Есть Cisco Catalyst 4948E на которой созданы vlan 1, vlan 130, vlan 230 и ряд
других vlan. И есть cisco WS-C3750G-48TS на которой создан vlan 224. Между собой
они соединены транком. Обе cisco видят vlan-ы друг-друга в своих таблицах vlan-ов.

На cisco WS-C3750G-48TS делаю access-овский порт с vlan 130 и подключаю ПК с ip-
адресом 130 влана. Этот ПК не пингует ничего.
Если же поменять vlan на этом порту на vlan 1 или vlan 224, то ПК с ip-адресом
этих вланов пингует все как надо.

Вопрос: Как сделать, чтобы ПК подключенный к порту cisco WS-C3750G-48TS с vlan 130
(и соответственно с ip-адресом 130 влана) пинговал ip-адрес сомого vlan 130
созданного на Cisco Catalyst 4948E?

Конфиги Cisco Catalyst 4948E и cisco WS-C3750G-48TS прикрепляю ниже...

Конфиг Cisco Catalyst 4948E (10.55.222.30)

version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
service sequence-numbers
!
hostname CiscoWS4948E
!
boot-start-marker
boot-end-marker
!
!
vrf definition mgmtVrf
!
address-family ipv4
exit-address-family
address-family ipv6
exit-address-family
!
enable secret 5 $1$UI.Q$s8FXJ2d56

username adm privilege 15 secret 5 $1$fHki$j2RqYy

no aaa new-model
!
!
ip domain-name domen.local
ip dhcp snooping vlan 1-4094
ip dhcp excluded-address 10.55.230.20
ip dhcp excluded-address 10.55.230.2
!
ip dhcp pool WIFI
network 10.55.230.0 255.255.255.0
default-router 10.55.230.1
option 43 hex 0104.c0a8.fa21
dns-server 10.55.250.6
!
ip dhcp pool VL130
network 10.55.130.0 255.255.255.0
default-router 10.55.130.1
!
!
!
!
!
power redundancy-mode redundant
!
mac access-list extended BLOCK-MAC-WIFI
permit any host e006.e611.7f57
archive
log config
  hidekeys
path tftp://10.55.250.2/4948_core/$H-$T.conf
write-memory
time-period 1440
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 1,98
!
vlan internal allocation policy ascending
!
vlan 3327
name MATERIK

interface FastEthernet1
vrf forwarding mgmtVrf
no ip address
speed auto
duplex auto
!
interface GigabitEthernet1/1
description Aej@O qdek`m !!!
switchport access vlan 250
switchport mode access
!
interface GigabitEthernet1/2
switchport access vlan 240
!

!
interface GigabitEthernet1/39
description TRUNK-Cisco3750
switchport mode trunk
!
interface GigabitEthernet1/40
spanning-tree portfast
!
interface GigabitEthernet1/41
switchport access vlan 250
duplex full
spanning-tree portfast
!
interface GigabitEthernet1/42
switchport access vlan 250
duplex full
spanning-tree portfast
!
interface GigabitEthernet1/43

interface Vlan1
ip address 10.55.222.30 255.255.254.0
!
interface Vlan130
ip address 10.55.130.1 255.255.255.0
ip helper-address 10.55.130.1
!
interface Vlan230
ip address 10.55.230.1 255.255.255.0
ip helper-address 10.55.230.1
!
interface Vlan240
description MAN
ip address 10.55.240.1 255.255.255.0
!
interface Vlan250
description S
ip address 10.55.250.1 255.255.255.0
ip directed-broadcast
!
ip http server
ip http authentication local
no ip http secure-server
ip forward-protocol nd
!
ip route 0.0.0.0 0.0.0.0 10.55.200.2
ip route 10.55.0.0 255.255.255.0 10.55.222.10
ip route 10.55.224.0 255.255.255.0 10.55.222.153

ip ssh version 2
!
ip access-list extended vlan1_in
ip access-list extended vlan_in
!
!
route-map MAP_TO_ASA permit 10
match ip address TO_ASA
set ip default next-hop 10.55.200.2
!
snmp-server community pub RO
!
!
!
end

----------------------------------------------------


Конфиг Cisco3750 (10.55.222.153)

version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco3750_48
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$eFn2$6RFljpRicOI
!
username adm privilege 15 secret 5 $1$eAU9$nvuknZEjnc9
no aaa new-model
clock timezone UTC 4
switch 3 provision ws-c3750g-48ts
system mtu routing 1500
ip subnet-zero
ip routing
ip domain-name domen.local
no ip dhcp use vrf connected
ip dhcp excluded-address 10.55.224.1 10.55.224.50
!
ip dhcp pool 4_LOCAL
   network 10.55.224.0 255.255.255.0
   default-router 10.55.224.1
   domain-name domen.local
   dns-server 10.55.222.17 10.55.250.6
!
!
!
password encryption aes
!
crypto pki trustpoint TP-self-signed-3251
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3251
revocation-check none
rsakeypair TP-self-signed-3251
!
crypto pki certificate chain TP-self-signed-3251
certificate self-signed 01
  30820257 308201C0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  8B6B87C9 162072AE C4C8B5A6 BB86730F 72DD6209 31181CEA 6D8335
  quit
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
no spanning-tree vlan 1
!
vlan internal allocation policy ascending
lldp run
!
ip ssh version 2
!
!
!
interface GigabitEthernet3/0/1
description TRUNK-ciscoWS4948E
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet3/0/2
switchport access vlan 224
!
interface GigabitEthernet3/0/31
description VLAN130
switchport access vlan 130
switchport mode access
!
interface GigabitEthernet3/0/38
switchport access vlan 230
switchport mode access
!
!
interface Vlan1
ip address 10.55.222.153 255.255.255.0
!
interface Vlan224
description ***Sklad4_Internal***
ip address 10.55.224.1 255.255.255.0
!
ip classless
ip forward-protocol udp bootpc
ip forward-protocol udp bootps
ip route 0.0.0.0 0.0.0.0 10.55.222.30
ip route 10.55.70.0 255.255.255.0 10.55.222.30
ip route 10.55.231.0 255.255.255.0 10.55.224.3
ip route 10.55.238.0 255.255.255.224 10.55.224.42
ip route 10.55.250.0 255.255.255.0 10.55.222.30
ip http server
ip http authentication local
ip http secure-server
!
!
snmp-server community pub RO
!
control-plane
banner motd ^CC

!
end

Где-то чего-то в конфигах не хватает, а где и чего понять не могу.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от Andrey (??), 20-Янв-23, 13:49 
> Доброе время суток!
> Где-то чего-то в конфигах не хватает, а где и чего понять не
> могу.

Перестарались вы с обрезкой ненужного из конфигов.
В приведенных конфигах не видно что созданы все необходимые VLAN.
Показывайте show vlan и show vlan ip 130

Ответить | Правка | Наверх | Cообщить модератору

2. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 20-Янв-23, 14:01 
>> Доброе время суток!
>> Где-то чего-то в конфигах не хватает, а где и чего понять не
>> могу.
> Перестарались вы с обрезкой ненужного из конфигов.
> В приведенных конфигах не видно что созданы все необходимые VLAN.
> Показывайте show vlan и show vlan ip 130

Cisco3750_48#sh vlan id 130

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
130  TEST                             active    Gi3/0/1, Gi3/0/33, Gi3/0/42

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
130  enet  100130     1500  -      -      -        -    -        0      0

Remote SPAN VLAN
----------------
Disabled

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

Cisco3750_48#


CiscoWS4948E#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi18, Gi114, Gi115, Gi116
                                                Gi117, Gi121, Gi122, Gi123
                                                Gi124, Gi125, Gi135, Gi137
                                                Gi138, Gi140, Te149, Te150
                                                Te151, Te152
2    VLAN0002                         active
3    VLAN0003                         active
4    VLAN0004                         active
5    VLAN0005                         active
6    VLAN0006                         active
7    VLAN0007                         active
8    VLAN0008                         active
9    VLAN0009                         active
10   VLAN0010                         active
11   sc11                             active
12   sc12                             active
13   sc13                             active
14   VLAN0014                         active
15   VLAN0015                         active
16   VLAN0016                         active

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
17   VLAN0017                         active
18   VLAN0018                         active
19   VLAN0019                         active
20   VLAN0020                         active
21   VLAN0021                         active
22   VLAN0022                         active
23   VLAN0023                         active
24   VLAN0024                         active
25   VLAN0025                         active
26   VLAN0026                         active
27   VLAN0027                         active
28   VLAN0028                         active
29   VLAN0029                         active
30   VLAN0030                         active
31   VLAN0031                         active
32   VLAN0032                         active
33   VLAN0033                         active
50   SC50                             active
96   AIST_EXT_FOR_BUH                 active
97   VLAN0097                         active    Gi146, Gi147
98   VLAN0098                         active    Gi133
99   VLAN0099                         active    Gi144, Gi145
100  CLS_HVNODE_NET                   active    Gi126, Gi128, Gi129

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
120  VLAN0120                         active
130  TEST                             active
192  VLAN0192                         active
200  Interconnect               active
201  VLAN0201                         active
202  VLAN0202                         active
203  VLAN0203                         active
204  VLAN0204                         active
205  VLAN0205                         active
206  VLAN0206                         active
207  VLAN0207                         active
224  Sklad4_Internal              active
230  WIFI                       active
240  MANAGE                     active    Gi12, Gi13, Gi14, Gi16
                                                Gi19, Gi111, Gi113, Gi118
241  VLAN0241                         active
242  VLAN0242                         active
243  VLAN0243                         active
244  VLAN0244                         active
250  SERVERS                    active    Gi11, Gi15, Gi112, Gi120
                                                Gi127, Gi131, Gi132, Gi134
                                                Gi141, Gi142
251  SRV1                       active

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
301  test                             active
400  VLAN0400                         active
998  VLAN0998                         active
999  VLAN0999                         active
1000 VLAN1000                         active
1001 VLAN1001                         active
1002 fddi-default                     actunsup
1003 trcrf-default                    actunsup
1004 fddinet-default                  actunsup
1005 trbrf-default                    actunsup
3327 AIST_MATERIK               active
3328 AIST_NERPA                       active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
2    enet  100002     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
4    enet  100004     1500  -      -      -        -    -        0      0
5    enet  100005     1500  -      -      -        -    -        0      0
6    enet  100006     1500  -      -      -        -    -        0      0
7    enet  100007     1500  -      -      -        -    -        0      0
8    enet  100008     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
9    enet  100009     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
11   enet  100011     1500  -      -      -        -    -        0      0
12   enet  100012     1500  -      -      -        -    -        0      0
13   enet  100013     1500  -      -      -        -    -        0      0
14   enet  100014     1500  -      -      -        -    -        0      0
15   enet  100015     1500  -      -      -        -    -        0      0
16   enet  100016     1500  -      -      -        -    -        0      0
17   enet  100017     1500  -      -      -        -    -        0      0
18   enet  100018     1500  -      -      -        -    -        0      0
19   enet  100019     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
21   enet  100021     1500  -      -      -        -    -        0      0
22   enet  100022     1500  -      -      -        -    -        0      0
23   enet  100023     1500  -      -      -        -    -        0      0
24   enet  100024     1500  -      -      -        -    -        0      0
25   enet  100025     1500  -      -      -        -    -        0      0
26   enet  100026     1500  -      -      -        -    -        0      0
27   enet  100027     1500  -      -      -        -    -        0      0
28   enet  100028     1500  -      -      -        -    -        0      0
29   enet  100029     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
31   enet  100031     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
32   enet  100032     1500  -      -      -        -    -        0      0
33   enet  100033     1500  -      -      -        -    -        0      0
50   enet  100050     1500  -      -      -        -    -        0      0
96   enet  100096     1500  -      -      -        -    -        0      0
97   enet  100097     1500  -      -      -        -    -        0      0
98   enet  100098     1500  -      -      -        -    -        0      0
99   enet  100099     1500  -      -      -        -    -        0      0
100  enet  100100     1500  -      -      -        -    -        0      0
120  enet  100120     1500  -      -      -        -    -        0      0
130  enet  100130     1500  -      -      -        -    -        0      0
192  enet  100192     1500  -      -      -        -    -        0      0
200  enet  100200     1500  -      -      -        -    -        0      0
201  enet  100201     1500  -      -      -        -    -        0      0
202  enet  100202     1500  -      -      -        -    -        0      0
203  enet  100203     1500  -      -      -        -    -        0      0
204  enet  100204     1500  -      -      -        -    -        0      0
205  enet  100205     1500  -      -      -        -    -        0      0
206  enet  100206     1500  -      -      -        -    -        0      0
207  enet  100207     1500  -      -      -        -    -        0      0
224  enet  100224     1500  -      -      -        -    -        0      0
230  enet  100230     1500  -      -      -        -    -        0      0
240  enet  100240     1500  -      -      -        -    -        0      0
241  enet  100241     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
242  enet  100242     1500  -      -      -        -    -        0      0
243  enet  100243     1500  -      -      -        -    -        0      0
244  enet  100244     1500  -      -      -        -    -        0      0
250  enet  100250     1500  -      -      -        -    -        0      0
251  enet  100251     1500  -      -      -        -    -        0      0
301  enet  100301     1500  -      -      -        -    -        0      0
400  enet  100400     1500  -      -      -        -    -        0      0
998  enet  100998     1500  -      -      -        -    -        0      0
999  enet  100999     1500  -      -      -        -    -        0      0
1000 enet  101000     1500  -      -      -        -    -        0      0
1001 enet  101001     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 trcrf 101003     4472  1005   3276   -        -    srb      0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trbrf 101005     4472  -      -      15       ibm  -        0      0
3327 enet  103327     1500  -      -      -        -    -        0      0
3328 enet  103328     1500  -      -      -        -    -        0      0


VLAN AREHops STEHops Backup CRF
---- ------- ------- ----------
1003 7       7       off

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

CiscoWS4948E#


Влан 130 с CiscoWS4948E транком приходит на Cisco3750_48


Cisco3750_48#sh int tru

Port        Mode             Encapsulation  Status        Native vlan
Gi3/0/1     on               802.1q         trunking      1
Gi3/0/42    on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi3/0/1     1-4094
Gi3/0/42    1-4094

Port        Vlans allowed and active in management domain
Gi3/0/1     1-33,50,96-100,120,130,192,200-207,224,230,240-244,250-251,301,400,998-1001
Gi3/0/42    1-33,50,96-100,120,130,192,200-207,224,230,240-244,250-251,301,400,998-1001

Port        Vlans in spanning tree forwarding state and not pruned
Gi3/0/1     1-33,50,96-100,120,130,192,200-207,224,230,240-244,250-251,301,400,998-1001
Gi3/0/42    1-33,50,96-100,120,130,192,200-207,224,230,240-244,250-251,301,400,998-1001
Cisco3750_48#


Ответить | Правка | Наверх | Cообщить модератору

3. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 20-Янв-23, 14:14 
>> Доброе время суток!
>> Где-то чего-то в конфигах не хватает, а где и чего понять не
>> могу.
> Перестарались вы с обрезкой ненужного из конфигов.
> В приведенных конфигах не видно что созданы все необходимые VLAN.
> Показывайте show vlan и show vlan ip 130

ПК с vlan 130 подключен к порту GigabitEthernet3/0/33 cisco WS-C3750, а сам vlan создан на Cisco Catalyst 4948E


interface GigabitEthernet3/0/33
description VLAN130
switchport access vlan 130
switchport mode access

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

4. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 22-Янв-23, 09:32 
>> Доброе время суток!
>> Где-то чего-то в конфигах не хватает, а где и чего понять не
>> могу.
> Перестарались вы с обрезкой ненужного из конфигов.
> В приведенных конфигах не видно что созданы все необходимые VLAN.
> Показывайте show vlan и show vlan ip 130

Вот что на Cisco3750:

Cisco3750_48#sh ip interface vlan 130
                                     ^
% Invalid input detected at '^' marker.

Cisco3750_48#ping 10.55.130.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.55.130.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/295/1024 ms
Cisco3750_48#

----------------------------------------------------------------------------------
Вот что на CiscoWS4948:

CiscoWS4948E#sh ip int vlan 130
Vlan130 is up, line protocol is up
  Internet address is 10.55.130.1/24
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is 192.168.130.1
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is enabled
  IP Flow switching is disabled
  IP CEF switching is enabled
  IP CEF switching turbo vector
  IP Null turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast, CEF
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
  Input features: MCI Check
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
CiscoWS4948E#

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

7. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от Andrey (??), 23-Янв-23, 15:23 
> % Invalid input detected at '^' marker.
> Cisco3750_48#ping 10.55.130.1
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 10.55.130.1, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 1/295/1024 ms
> Cisco3750_48#

Зачем вы пингуете с С3750 IP в сети 10.55.130.0/24? У вас пинги бегут по дефолтному маршруту через 10.55.222.30 .
Если вы конечно опять что-то не обрезали в прилагаемых конфигах.

Ответить | Правка | Наверх | Cообщить модератору

8. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 23-Янв-23, 15:48 
>> % Invalid input detected at '^' marker.
>> Cisco3750_48#ping 10.55.130.1
>> Type escape sequence to abort.
>> Sending 5, 100-byte ICMP Echos to 10.55.130.1, timeout is 2 seconds:
>> !!!!!
>> Success rate is 100 percent (5/5), round-trip min/avg/max = 1/295/1024 ms
>> Cisco3750_48#
> Зачем вы пингуете с С3750 IP в сети 10.55.130.0/24? У вас пинги
> бегут по дефолтному маршруту через 10.55.222.30 .
> Если вы конечно опять что-то не обрезали в прилагаемых конфигах.

Да. Пинги бегут по дефолтному маршруту через 10.55.222.30. Я просто проверил доступность этого адреса с Cisco3750, так как этот адрес - адрес vlan 130 созданного на Cisco Catalyst 4948E.

  

Ответить | Правка | Наверх | Cообщить модератору

5. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от ogiss (?), 23-Янв-23, 07:56 
а vtp domain один и тот же на обоих коммутаторах?
Ответить | Правка | Наверх | Cообщить модератору

6. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 23-Янв-23, 13:43 
> а vtp domain один и тот же на обоих коммутаторах?

Да. vtp domen одинаковый. Если создать vlan на Catalyst 4948E, то он появится в таблице vlan-ов на C3750Gю

Ответить | Правка | Наверх | Cообщить модератору

9. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от ogiss (?), 24-Янв-23, 08:44 
>> а vtp domain один и тот же на обоих коммутаторах?
> Да. vtp domen одинаковый. Если создать vlan на Catalyst 4948E, то он
> появится в таблице vlan-ов на C3750Gю

Там есть настройка, обычно головной vtp mode server , а ниже стояшие vtp mode client и все vlan заводятся на головном

Ответить | Правка | Наверх | Cообщить модератору

10. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 24-Янв-23, 09:57 
>>> а vtp domain один и тот же на обоих коммутаторах?
>> Да. vtp domen одинаковый. Если создать vlan на Catalyst 4948E, то он
>> появится в таблице vlan-ов на C3750Gю
> Там есть настройка, обычно головной vtp mode server , а ниже стояшие
> vtp mode client и все vlan заводятся на головном

Обычно да, но здесь vlan 224 заведен на C3750G, а все остальные на Cisco Catalyst 4948E.
Сейчас я поставил  vtp mode server и на Cisco Catalyst 4948E и на C3750G.
Если поставить на C3750G vtp mode client, то ничего не меняется.
Я по прежнему не могу видить на порту C3750G ПК из любых других vlan кроме vlan 1 и vlan 224 (он заведен на C3750G). А причины этого понять не могу.

Ответить | Правка | Наверх | Cообщить модератору

11. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от elk_killa (ok), 24-Янв-23, 12:38 
А покажите на 4948
sh int Gi1/39 trunk

и динамические маки 130 влана на обоих

p.s. я бы на всякий случай еще pvst по 130 посмотрел на портах


> Я по прежнему не могу видить на порту C3750G ПК из любых
> других vlan кроме vlan 1 и vlan 224 (он заведен на
> C3750G). А причины этого понять не могу.

Ответить | Правка | Наверх | Cообщить модератору

12. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 24-Янв-23, 13:06 
> А покажите на 4948
> sh int Gi1/39 trunk
> и динамические маки 130 влана на обоих
> p.s. я бы на всякий случай еще pvst по 130 посмотрел на
> портах
>> Я по прежнему не могу видить на порту C3750G ПК из любых
>> других vlan кроме vlan 1 и vlan 224 (он заведен на
>> C3750G). А причины этого понять не могу.

Cisco3750_48#sh mac address-table vlan 130
          Mac Address Table
-------------------------------------------

Vlan    Mac Address       Type        Ports
----    -----------       --------    -----
All    0100.0ccc.cccc    STATIC      CPU
All    0100.0ccc.cccd    STATIC      CPU
All    0180.c200.0000    STATIC      CPU
All    0180.c200.0001    STATIC      CPU
All    0180.c200.0002    STATIC      CPU
All    0180.c200.0003    STATIC      CPU
All    0180.c200.0004    STATIC      CPU
All    0180.c200.0005    STATIC      CPU
All    0180.c200.0006    STATIC      CPU
All    0180.c200.0007    STATIC      CPU
All    0180.c200.0008    STATIC      CPU
All    0180.c200.0009    STATIC      CPU
All    0180.c200.000a    STATIC      CPU
All    0180.c200.000b    STATIC      CPU
All    0180.c200.000c    STATIC      CPU
All    0180.c200.000d    STATIC      CPU
All    0180.c200.000e    STATIC      CPU
All    0180.c200.000f    STATIC      CPU
All    0180.c200.0010    STATIC      CPU
All    ffff.ffff.ffff    STATIC      CPU
130    744d.2868.8853    DYNAMIC     Gi3/0/42
130    744d.2868.8856    DYNAMIC     Gi3/0/33
Total Mac Addresses for this criterion: 22

CiscoWS4948E#sh mac address-table vlan 130
Unicast Entries
vlan     mac address     type        protocols               port
---------+---------------+--------+---------------------+-------------------------
130      30f7.0dbf.977f    static ip,ipx,assigned,other Switch

Multicast Entries
vlan     mac address     type    ports
---------+---------------+-------+--------------------------------------------
130      ffff.ffff.ffff   system Gi1/39,Switch


CiscoWS4948E#sh int Gi1/39 trunk

Port        Mode             Encapsulation  Status        Native vlan
Gi1/39      on               802.1q         trunking      1

Port        Vlans allowed on trunk
Gi1/39      1-4094

Port        Vlans allowed and active in management domain
Gi1/39      1-33,50,96-100,120,130,192,200-207,224,230,240-244,250-251,301,400,998-1001,3327-3328

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/39      1-33,50,96-100,120,130,192,200-207,224,230,240-244,250-251,301,400,998-1001,3327-3328

CiscoWS4948E#show spanning-tree vlan 130

VLAN0130
  Spanning tree enabled protocol ieee
  Root ID    Priority    32898
             Address     30f7.0dbf.9740
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32898  (priority 32768 sys-id-ext 130)
             Address     30f7.0dbf.9740
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/39              Desg FWD 4         128.39   P2p

Cisco3750_48#sh spanning-tree vlan 130

VLAN0130
  Spanning tree enabled protocol ieee
  Root ID    Priority    32898
             Address     f4ac.c1d2.bf80
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32898  (priority 32768 sys-id-ext 130)
             Address     f4ac.c1d2.bf80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi3/0/1             Desg FWD 4         128.109  P2p
Gi3/0/33            Desg FWD 4         128.139  P2p
Gi3/0/42            Desg FWD 4         128.150  P2p


Cisco3750_48#

Ответить | Правка | Наверх | Cообщить модератору

13. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от elk_killa (ok), 24-Янв-23, 13:58 
Хмм, прохладная история:

> CiscoWS4948E#show spanning-tree vlan 130      
>            
>  This bridge is the root
>            
> Cisco3750_48#sh spanning-tree vlan 130
>            
>  This bridge is the root
>            

а между ними что?

Ответить | Правка | Наверх | Cообщить модератору

14. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 24-Янв-23, 14:30 
> Хмм, прохладная история:
>> CiscoWS4948E#show spanning-tree vlan 130
>>
>>  This bridge is the root
>>
>> Cisco3750_48#sh spanning-tree vlan 130
>>
>>  This bridge is the root
>>
> а между ними что?

Вообще ничего не должно быть. Они объединины между собой TRUNK-ом CiscoWS4948E порт Gi1/39 --> Cisco3750_48 порт Gi3/0/1.

Ответить | Правка | Наверх | Cообщить модератору

15. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от elk_killa (ok), 24-Янв-23, 18:19 
транк транком, а физически что? был бы один патчкорд, вряд-ли такое могло быть

ну или на каком-то из свичей глобально bpdufilter default включен (но не объясняет, почему маков нет на 4948)
>>>
>> а между ними что?
> Вообще ничего не должно быть. Они объединины между собой TRUNK-ом CiscoWS4948E порт
> Gi1/39 --> Cisco3750_48 порт Gi3/0/1.

Ответить | Правка | Наверх | Cообщить модератору

16. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 24-Янв-23, 18:57 
> транк транком, а физически что? был бы один патчкорд, вряд-ли такое могло
> быть
> ну или на каком-то из свичей глобально bpdufilter default включен (но не
> объясняет, почему маков нет на 4948)
>>>>
>>> а между ними что?
>> Вообще ничего не должно быть. Они объединины между собой TRUNK-ом CiscoWS4948E порт
>> Gi1/39 --> Cisco3750_48 порт Gi3/0/1.

Мне казалось, что они соединены физически на прямую, но возможно они соединены через неуправляемый HUB. Это я смогу проверить только на следующей неделе. Но если даже они соединены через HUB, то почему vlan 1 проходит без проблем, а другие vlan не проходят?

Ответить | Правка | Наверх | Cообщить модератору

17. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от Andrey (??), 24-Янв-23, 20:13 
>>>> а между ними что?
>>> Вообще ничего не должно быть. Они объединины между собой TRUNK-ом CiscoWS4948E порт
>>> Gi1/39 --> Cisco3750_48 порт Gi3/0/1.
> Мне казалось, что они соединены физически на прямую, но возможно они соединены
> через неуправляемый HUB. Это я смогу проверить только на следующей неделе.
> Но если даже они соединены через HUB, то почему vlan 1
> проходит без проблем, а другие vlan не проходят?

Если на одном свитче погасить порт, на другом тоже порт погаснет. Если между ними что-то стоит, то на втором ничего не погаснет. Потом это будет видно в логах.
Но есть пару последовательных "но": а) вы должны быть уверены что в любой момент, чтобы ни случилось,  сможете удаленно поднять порт, который погасили; б) если это какой-то большой участок сети с пользователями, то лучше предупредить о проводимых работах. "б)" возможно только при наличии "а)". Рисковать не рекомендую.
Ну и пытаться разобраться в "логике", не зная "физики" - это такое себе...

Можно еще посмотреть lldp/cdp на портах в обе стороны.

Ответить | Правка | Наверх | Cообщить модератору

18. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от rgl81 (ok), 24-Янв-23, 20:27 
>[оверквотинг удален]
> между ними что-то стоит, то на втором ничего не погаснет. Потом
> это будет видно в логах.
> Но есть пару последовательных "но": а) вы должны быть уверены что в
> любой момент, чтобы ни случилось,  сможете удаленно поднять порт, который
> погасили; б) если это какой-то большой участок сети с пользователями, то
> лучше предупредить о проводимых работах. "б)" возможно только при наличии "а)".
> Рисковать не рекомендую.
> Ну и пытаться разобраться в "логике", не зная "физики" - это такое
> себе...
> Можно еще посмотреть lldp/cdp на портах в обе стороны.

Я сужу, что они соединены напряму только по этому:
CiscoWS4948E#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
Cisco3750_48_4sklad.domen.local
                 Gig 1/39          141             R S I  WS-C3750G Gig 3/0/1

Ответить | Правка | Наверх | Cообщить модератору

19. "Проблема с VLAN на Cisco Catalyst 4948E и cisco WS-C3750G-48TS"  +/
Сообщение от elk_killa (ok), 25-Янв-23, 20:53 
Никакой гарантии, что там нет xDSL модемов, медиаконвертеров, или вообще VPLS например

> Я сужу, что они соединены напряму только по этому:

Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру