The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"huawei quidway s2300 и option82"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Оборудование Lucent, Nortell и др.)
Изначальное сообщение [ Отслеживать ]

"huawei quidway s2300 и option82"  +/
Сообщение от uncle (?), 22-Окт-20, 10:02 
Друзья, кто нибудь настраивал коммутаторы huawei на выдачу опции по дхцп. интересует именно dhcp snooping.
пробую настроить коммутатор следующим образом
vlan batch 88 100 4001
#
dhcp enable
dhcp snooping enable
dhcp option82 remote-id format extend
observe-port 1 interface Ethernet0/0/24
vlan 4001
description abon vlan
dhcp snooping enable
dhcp snooping trusted interface GigabitEthernet0/0/2
dhcp option82 rebuild enable interface GigabitEthernet0/0/2

interface Ethernet0/0/2
port link-type access
port default vlan 4001

interface GigabitEthernet0/0/2
description uplink
port link-type trunk
port trunk allow-pass vlan 2 to 4094
dhcp option82 insert enable
port-mirroring to observe-port 1 inbound
port-mirroring to observe-port 1 outbound

подключаю в 24 порт куда настроено зеркалирование машину с wireshark , во 2 порт роутер. в шарке вижу запросы discover но в нем нет опции
No.     Time           Source                Destination           Protocol Length Info
      3 12.322597      0.0.0.0               255.255.255.255       DHCP     594    DHCP Discover - Transaction ID 0x14646df5

Frame 3: 594 bytes on wire (4752 bits), 594 bytes captured (4752 bits)
Ethernet II, Src: NetcoreT_8b:00:4e (e4:be:ed:8b:00:4e), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Internet Protocol Version 4, Src: 0.0.0.0, Dst: 255.255.255.255
User Datagram Protocol, Src Port: 68, Dst Port: 67
Dynamic Host Configuration Protocol (Discover)
    Message type: Boot Request (1)
    Hardware type: Ethernet (0x01)
    Hardware address length: 6
    Hops: 0
    Transaction ID: 0x14646df5
    Seconds elapsed: 0
    Bootp flags: 0x0000 (Unicast)
    Client IP address: 0.0.0.0
    Your (client) IP address: 0.0.0.0
    Next server IP address: 0.0.0.0
    Relay agent IP address: 0.0.0.0
    Client MAC address: NetcoreT_8b:00:4e (e4:be:ed:8b:00:4e)
    Client hardware address padding: 00000000000000000000
    Server host name not given
    Boot file name not given
    Magic cookie: DHCP
    Option: (53) DHCP Message Type (Discover)
    Option: (61) Client identifier
    Option: (60) Vendor class identifier
    Option: (55) Parameter Request List
    Option: (255) End
    Padding: 000000000000000000000000000000000000000000000000…

где я что пропустил?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "huawei quidway s2300 и option82"  +/
Сообщение от fantom (??), 22-Окт-20, 13:27 
>[оверквотинг удален]
>     Server host name not given
>     Boot file name not given
>     Magic cookie: DHCP
>     Option: (53) DHCP Message Type (Discover)
>     Option: (61) Client identifier
>     Option: (60) Vendor class identifier
>     Option: (55) Parameter Request List
>     Option: (255) End
>     Padding: 000000000000000000000000000000000000000000000000…
> где я что пропустил?

А что сервер DHCP на сию тему глаголет???

Ответить | Правка | Наверх | Cообщить модератору

2. "huawei quidway s2300 и option82"  +/
Сообщение от uncle (?), 22-Окт-20, 14:21 
>[оверквотинг удален]
>>     Boot file name not given
>>     Magic cookie: DHCP
>>     Option: (53) DHCP Message Type (Discover)
>>     Option: (61) Client identifier
>>     Option: (60) Vendor class identifier
>>     Option: (55) Parameter Request List
>>     Option: (255) End
>>     Padding: 000000000000000000000000000000000000000000000000…
>> где я что пропустил?
> А что сервер DHCP на сию тему глаголет???

на dhcp сервере тспдамп показывает в разделе опция
Agent-information Option 82, lenght 19:
Circuit-ID SubOption 1, lenght6: ^@^D^OM-!^A^Q
Remote-ID SubOption 2, lenght 9: ^A^Gc3550_2

а сислог пишет  DHCPDISCOVER from e4:be:ed:8b:00:4e via 192.168.27.1: network test: no free leases

Ответить | Правка | Наверх | Cообщить модератору

3. "huawei quidway s2300 и option82"  +/
Сообщение от fantom (??), 27-Окт-20, 09:35 
>[оверквотинг удален]
>>>     Option: (255) End
>>>     Padding: 000000000000000000000000000000000000000000000000…
>>> где я что пропустил?
>> А что сервер DHCP на сию тему глаголет???
> на dhcp сервере тспдамп показывает в разделе опция
> Agent-information Option 82, lenght 19:
> Circuit-ID SubOption 1, lenght6: ^@^D^OM-!^A^Q
> Remote-ID SubOption 2, lenght 9: ^A^Gc3550_2
> а сислог пишет  DHCPDISCOVER from e4:be:ed:8b:00:4e via 192.168.27.1: network test: no
> free leases

Ну так опция 82 добавлена, прикол скорее всего в логике зеркалирования.
Фреймы, не требующие обработки ЦПУ будут клонами, а вот DHCPDISCOVER в вашем варианте требует вмешательства.

Ответить | Правка | Наверх | Cообщить модератору

4. "huawei quidway s2300 и option82"  +/
Сообщение от uncle (?), 27-Окт-20, 10:30 
>[оверквотинг удален]
>>> А что сервер DHCP на сию тему глаголет???
>> на dhcp сервере тспдамп показывает в разделе опция
>> Agent-information Option 82, lenght 19:
>> Circuit-ID SubOption 1, lenght6: ^@^D^OM-!^A^Q
>> Remote-ID SubOption 2, lenght 9: ^A^Gc3550_2
>> а сислог пишет  DHCPDISCOVER from e4:be:ed:8b:00:4e via 192.168.27.1: network test: no
>> free leases
> Ну так опция 82 добавлена, прикол скорее всего в логике зеркалирования.
> Фреймы, не требующие обработки ЦПУ будут клонами, а вот DHCPDISCOVER в вашем
> варианте требует вмешательства.

Доброго всем дня. спасибо всем. разобрался.
если кто будет интересоваться то хуавей настраивается для dhcp snooping следующим образом.
dhcp enable
dhcp snooping enable
dhcp option82 format extend
vlan 4002
dhcp snooping enable
dhcp snooping trusted interface GigabitEthernet0/0/2
interface GigabitEthernet0/0/2
description MNG
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 100 4002
dhcp snooping enable
dhcp snooping trusted

Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Ideco
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру