The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"наблюдаются потери пакетов"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"наблюдаются потери пакетов"  +/
Сообщение от Alexander (??) on 01-Авг-11, 16:42 
Здраствуйте.

Проблема в следущем. Есть каталист 6509 к нему по etherchannel подключены свитчи. В свичи хосты. На 6509 есть vlan 101. по VTP разползается по всем свичам.

interface Vlan101
description IBM
ip address 10.10.0.2 255.255.0.0 secondary
ip address 10.1.1.2 255.255.255.0
ip helper-address 10.1.1.28
no ip redirects
ip pim sparse-mode
ip pim snooping
no ip mroute-cache
standby 101 ip 10.1.1.1
standby 101 ip 10.10.0.1 secondary
standby 101 priority 110
standby 101 preempt
standby 101 authentication ********
standby 101 name IBM

Хосты в свичах сидят тоже в 101 влане. Ситуация такая: В какой то момент один хост перестает видеть другой. Например 10.1.1.190 не видит 10.1.1.124, но 10.1.1.124 спокойно пингует 10.1.1.190 и после того как запустил пинг, конект восстанавливается и какое-то время работает, может день, а может и час. Потом опять пропадает.
Пинг с 10.1.1.190 на 10.1.1.124 говоит destination host unreacheble, а с 10.1.1.124 на 10.1.1.190 все ок.

Что это может быть? ARP?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "наблюдаются потери пакетов"  +/
Сообщение от Alexander (??) on 01-Авг-11, 18:30 
Нашел проблему. Пропадают МАС-адреса из таблице. В ARP запись присутствует, а вот из МАС таблице переодически пропадает, причем на разные интервалы времени.
Терь вопрос, как решить эту проблему и из-за чего такая фигня может происходить?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "наблюдаются потери пакетов"  +/
Сообщение от sm00th1980 (ok) on 01-Авг-11, 18:45 
> Нашел проблему. Пропадают МАС-адреса из таблице. В ARP запись присутствует, а вот
> из МАС таблице переодически пропадает, причем на разные интервалы времени.
> Терь вопрос, как решить эту проблему и из-за чего такая фигня может
> происходить?

скорее всего IP-адреса одинаковые у кого-то из этой пары машин. Пересекаются с кем-то.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "наблюдаются потери пакетов"  +/
Сообщение от frob (ok) on 02-Авг-11, 06:53 
> Нашел проблему. Пропадают МАС-адреса из таблице. В ARP запись присутствует, а вот
> из МАС таблице переодически пропадает, причем на разные интервалы времени.

Запись в CAM-table выбрасывается по умолчанию через 5 минут неактивности.
При необходимости послать пакет на хост с MAC-адресом отсутствующим в CAM-table пакет отправляется во все порты в этом VLAN кроме того откуда пакет получен.
Такое поведение является нормальным.

Существенная разница в таймаутах CAM и ARP (по умолчанию) может приводить к проблемам при InterVLAN Routing, но в данном случае хосты находятся в одном VLAN-e, т.ч. ARP на коммутаторе будет появляться только если пинговать хосты с коммутатора (или наоборот).

Запустить wireshark и посмотреть. Например на Ethertype.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

4. "наблюдаются потери пакетов"  +/
Сообщение от Alexander (??) on 02-Авг-11, 09:00 

> Запись в CAM-table выбрасывается по умолчанию через 5 минут неактивности.
> При необходимости послать пакет на хост с MAC-адресом отсутствующим в CAM-table пакет
> отправляется во все порты в этом VLAN кроме того откуда пакет
> получен.
> Такое поведение является нормальным.
> Существенная разница в таймаутах CAM и ARP (по умолчанию) может приводить к
> проблемам при InterVLAN Routing, но в данном случае хосты находятся в
> одном VLAN-e, т.ч. ARP на коммутаторе будет появляться только если пинговать
> хосты с коммутатора (или наоборот).
> Запустить wireshark и посмотреть. Например на Ethertype.

Про это я читал. Но там нет неактивности. Трафик довольно существенный. МАС в таблице пропадает с различными интервалами времени. Можно конечно увеличить mac-address-table aging-time, сделать например его равным ARP, но как мне кажется это проблемы не решит. Можно статикой прописать. НО это тоже кривое решение. mac-address-table synchronize включен.

По последним наблюдениям оказалось, что пропадают МАС адреса на 6509 только хостов расположенных на одном блейдцентре который эзерчанелом подключен к 6509. Там VMWare и дистрибьютед свичи. Может быть в них проблема?


Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "наблюдаются потери пакетов"  +/
Сообщение от frob (ok) on 02-Авг-11, 09:47 
> aging-time, сделать например его равным ARP, но как мне кажется это

Хосты в одном VLAN, ARP тут не при чём.
Прочитайте ещё раз.

> mac-address-table synchronize включен.

У вас DFC-шные карты?
По-любому, если нет адреса пакет полетит во все порты, т.ч. если с пакетом всё в порядке, то можно ожидать флудинг, а не потери пакетов.

> Может быть в них проблема?

Может. Wireshark или в TAC.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "наблюдаются потери пакетов"  +/
Сообщение от Alexander (??) on 02-Авг-11, 11:58 
>> aging-time, сделать например его равным ARP, но как мне кажется это
> Хосты в одном VLAN, ARP тут не при чём.
> Прочитайте ещё раз.
>> mac-address-table synchronize включен.
> У вас DFC-шные карты?
> По-любому, если нет адреса пакет полетит во все порты, т.ч. если с
> пакетом всё в порядке, то можно ожидать флудинг, а не потери
> пакетов.
>> Может быть в них проблема?
> Может. Wireshark или в TAC.

Карты DFC-шные.


C6509-1#sh module 2
Mod Ports Card Type                              Model              Serial No.
--- ----- -------------------------------------- ------------------ -----------
  2   48  CEF720 48 port 10/100/1000mb Ethernet  WS-X6748-GE-TX     SAL1050AXT1

Mod MAC addresses                       Hw    Fw           Sw           Status
--- ---------------------------------- ------ ------------ ------------ -------
  2  0019.e8e7.1fc0 to 0019.e8e7.1fef   2.5   12.2(14r)S5  12.2(18)SXF1 Ok

Mod  Sub-Module                  Model              Serial       Hw     Status
---- --------------------------- ------------------ ----------- ------- -------
  2  Distributed Forwarding Card WS-F6700-DFC3BXL   SAL10489GM3  5.3    Ok

Mod  Online Diag Status
---- -------------------
  2  Pass


Щас попробуем сузить поиск проблемы. Перенесем VMWare хост чей мак переодически пропадает из таблицы на другой блейдцентр.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "наблюдаются потери пакетов"  +/
Сообщение от yparaH Raph email on 23-Авг-11, 09:59 
> Щас попробуем сузить поиск проблемы. Перенесем VMWare хост чей мак переодически пропадает
> из таблицы на другой блейдцентр.

Помогло?

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "наблюдаются потери пакетов"  +/
Сообщение от chaplinchaplin (ok) on 10-Июл-12, 14:14 
Расскажите как порешали, пожалуйста, у нас ситуация очень похожа.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру