The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"Прекращена поддержка LTS-ветки ядра Linux 3.18"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Прекращена поддержка LTS-ветки ядра Linux 3.18"  +/
Сообщение от opennews (??) on 09-Фев-17, 10:54 
Грег Кроа-Хартман (Greg Kroah-Hartman), отвечающий за поддержку стабильной ветки ядра Linux, представил (https://lkml.org/lkml/2017/2/8/295) последнее обновление LTS-ветки ядра 3.18.48. Релиз ядра 3.18 был выпущен (https://www.opennet.ru/opennews/art.shtml?num=41210) в декабре 2014 года и поддерживался в течение более двух лет. Отныне впуск обновлений для данной ветки ядра  прекращён и  пользователям рекомендуется перейти на актуальные LTS-ветки 4.4 или 4.9, которые будут поддерживаться до февраля 2018 и января 2019 г. Сообщается, что несмотря на окончание времени жизни ветка 3.18 продолжает использоваться в некоторых актуальных прошивках на базе платформы Android и ChromeOS, но поддерживать портирование исправлений с устранением уязвимостей для ядра Linux 3.18 теперь придётся самим производителям.


Кроме веток 4.4 и 4.9 также продолжается сопровождение longterm-веток (https://www.opennet.ru/opennews/art.shtml?num=31475)  4.1, 3.16, 3.12, 3.10, 3.4 и 3.2. Ветка 4.1  будет поддерживаться до сентября 2017 (сопровождает Sasha Levin, работающий в Oracle), ветки 3.16 и 3.2 будут поддерживаться до апреля 2020  и до мая 2018 г. (поддерживает Ben Hutchings  из Debian), ветка 3.12 будет обновляться до мая 2017 г. (поддерживает Jiri Slaby из SUSE), ветка 3.10 просуществует до октября 2017 г. (поддерживает Willy Tarreau, автор HAProxy), ветка 3.4 будет обновляться до апреля 2017 года    (поддерживает Li Zefan из компании Huawei).


URL: https://lkml.org/lkml/2017/2/8/295
Новость: https://www.opennet.ru/opennews/art.shtml?num=46005

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


3. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  –3 +/
Сообщение от Аноним (??) on 09-Фев-17, 11:12 
> но поддерживать портирование исправлений с устранением уязвимостей
> для ядра Linux 3.18 теперь придётся самим производителям

По большей части не производители будут поддерживать, а пользователи надеяться и терпеть, пока аккумулятор не сдохнет. Так оно всегда и бывает...

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  +4 +/
Сообщение от eRIC (ok) on 09-Фев-17, 12:54 
Очень много разбросанных версий LTS. Не логично:

- 3.2 - май 2018
- 3.4 - апрель 2017
- 3.10 - октябрь 2017
- 3.12 - май 2017
- 3.16 - апрель 2020
- 3.18 - EOL
- 4.1 - сентябрь 2017
- 4.4 - февраль 2018
- 4.9 - январь 2019

т.е если хочешь 3.x стабильное ядро на протяжении долгого времени то откатись до 3.16!
на 4.X не перейдешь, потому что LTS версия для нее коротковременные.

лучше по одной версии LTS сроком до 5 лет из каждой ветки достаточно было бы, всего две версии было бы из 3.X и 4.X

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  +8 +/
Сообщение от rshadow (ok) on 09-Фев-17, 13:19 
Логично. LTS поддерживают те кому это нужно, а не из альтруистических побуждений и стремлений "к прекрасному перфекционизму".
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

8. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  –1 +/
Сообщение от Andrey Mitrofanov on 09-Фев-17, 13:44 
> Очень много разбросанных версий LTS.

Кто что схватил, тот то и тащит. Корраборация!
  + https://www.opennet.ru/opennews/art.shtml?num=46005
  + после Новой Схемы Разработки от тов.Линуса(ссылки нет под рукой) релизы на k.o "зачастили как-то", поэтому каждый крутится, как может~ //Главное - Линус в порядке.

3.16 - после "короткого" цикла на kernel.org подхватили и понесли UKT @ Canonical.
  + https://www.opennet.ru/opennews/art.shtml?num=40978 //эта ссылка есть там наверху, под этой новостью
  + https://www.opennet.ru/opennews/art.shtml?num=36937 //чуть ранее -- и без Debian--

А есть ещё "LTSI" от железячников: http://ltsi.linuxfoundation.org/downloads/releases У меня в телефоне =3.0, в [только что купленном] медиа-плеере =3.10. _Они_ [как теперь оказалось]...
  + https://www.opennet.ru/opennews/art.shtml?num=37597
  + http://ltsi.linuxfoundation.org/downloads/releases //свежачокЪ!

]]]А в роутере с 4МБ флэша - так и вообще 2.4.---[[[

> Не логично:

Это просто другая, пока скрытая от Вас логика. Старайтесь лучше.

> т.е если хочешь 3.x стабильное ядро на протяжении долгого времени то откатись
> до 3.16!
> на 4.X не перейдешь, потому что LTS версия для нее коротковременные.

Про 3.16 уже _видно_, что ооооочень длинно. А вот удлиннят ли 4.9 -- сейчас/пока не видно.

Если *получится*, как с 3.16 -- что оно в очередном Debian-е, и Canonical поподдержит его плюс-сверху от kernel.org-овского LTS -- то будет "длиннееееее", если не получится, то не будет.---

> лучше по одной версии LTS сроком до 5 лет из каждой ветки
> достаточно было бы, всего две версии было бы из 3.X и
> 4.X

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

10. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  +1 +/
Сообщение от eRIC (ok) on 09-Фев-17, 14:00 
Я в курсе какие компании взялись за поддержку той или иной версии, но это инициатива самих дистрибутивов. на самом деле дистрибутивы должны на LTS версии ядер ориентироваться в своих LTS релизах, а тут как бы они формируют LTS версию ядра ;)

со стороны kernel после того как они перешли на новый формат версионности, ИМХО больше всего они гонятся за версией нежели стабильности(в нашем понимании LTS).

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

11. "Прекращена поддержка пользователей ядра"  –1 +/
Сообщение от Andrey Mitrofanov on 09-Фев-17, 14:30 
> но это инициатива самих дистрибутивов. на самом деле дистрибутивы должны на
> LTS версии ядер ориентироваться в своих LTS релизах, а тут как
> бы они формируют LTS версию ядра ;)
> со стороны kernel после того как они перешли на новый формат версионности,
> ИМХО больше всего они гонятся за версией нежели стабильности(в нашем понимании
> LTS).

Ну дак, Линус наконец избавился от пользователей-человеков и хороводит в фундейшене с корпо-пользователями за мзду. Дистрибутивам и люлям они там ничего не должны -- не уплочено. Апогей опенсорсной дружественности к бизнесам.

Всё по Плану -- а Вы ^W мы проходим в бижайший магазинчик, там есть много tivo-, eufi-, acpi-, дроидо- и проч. :((( предметов потребления. Майкрософт-налог включён в цену, и не один.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

13. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  –4 +/
Сообщение от Ilya Indigo (ok) on 09-Фев-17, 15:43 
> т.е если хочешь ... стабильное ядро на протяжении долгого времени...

Обновляйся до стабильной версии ядра и будет тебе счастье.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

5. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  –1 +/
Сообщение от Аноним (??) on 09-Фев-17, 12:59 
PuppyLinux Precise и PuppyLinux Tahr храню на всякий случай для стареньких ПК... Эти "прекращения поддержки" уже немного достали. Ядро на то и ядро чтобы быть стабильным на протяжение многих лет, а не меняться каждый год (или даже каждый месяц) следуя последней моде.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  –2 +/
Сообщение от Аноним (??) on 09-Фев-17, 13:50 
Интересно. Сижу на 3.10.101, начал переходить на 3.12.70(переписывать некоторые костыли). Но в виду новой информации, лучше костыли переписывать под 4.9 или подождать и заняться ботанированием.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

16. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  +4 +/
Сообщение от Andrey Mitrofanov on 09-Фев-17, 16:38 
> Интересно. Сижу на 3.10.101, начал переходить на 3.12.70(переписывать некоторые костыли).
> Но в виду новой информации, лучше костыли переписывать

Вы, товарищь,
      https://www.kernel.org/pub/linux/kernel/v3.0/?C=M;O=D
сядьте на пол,
      linux-3.10.104.tar.xz   21-Oct-2016 10:30   70M
Вам, товарищь,
      linux-3.10.101.tar.xz   16-Mar-2016 15:49   70M
всё равно

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

23. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  –2 +/
Сообщение от Аноним (??) on 10-Фев-17, 05:14 
А что там про 2.6.19? Ещё можно пока не обновляться?!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

24. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  –1 +/
Сообщение от Онаним on 10-Фев-17, 10:36 
Пользователям Дебиана можно.
Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

25. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  +/
Сообщение от Andrey Mitrofanov on 10-Фев-17, 10:52 
> А что там про 2.6.19? Ещё можно пока не обновляться?!

Держаться!1

kernel-2.6.18-417.el5.i686.rpm    2016-12-20 17:00     20M

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

26. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  +/
Сообщение от _KUL (ok) on 10-Фев-17, 19:03 
Это у вас на холодильник вендор не хочет свежую прошивку выпускать? Где вы такое ядро держите?
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

27. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  +/
Сообщение от Andrey Mitrofanov on 10-Фев-17, 23:38 
> Это у вас на холодильник вендор не хочет свежую прошивку выпускать? Где
> вы такое ядро держите?

Я? Нашёл в поисковике под "задачу" не обновляться на 2.6.19 выше.

http://vault.centos.org/centos/5.11/updates/SRPMS/?C=M;O=D
http://mirror.centos.org/centos/5/updates/i386/RPMS/?C=M;O=D

---Ну, и роутер, я говорил уже, с 2.4 -- работает.
https://www.dd-wrt.com/wiki/index.php/ASUS_WL-520GC
Брат, вендор, то бишь, жив:
[FILE] dd-wrt.v24_micro_generic.bin . . Feb 07 10:28   1688k [DOWNLOAD]
ftp://ftp.dd-wrt.com/betas/2017/02-07-2017-r31277/broadcom/

Выглядит примерно так (старое из архива):

\u@\h:\w\$ cat /proc/version
Linux version 2.4.37 (root@dd-wrt) (gcc version 3.4.6 (OpenWrt-2.0)) #18206 Wed Apr 13 05:51:36 CEST 2011
или
Linux version 2.4.37 (root@dd-wrt) (gcc version 3.4.6 (OpenWrt-2.0)) #22651 Tue Dec 20 05:34:02 CET 2011

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

28. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  –1 +/
Сообщение от _KUL (ok) on 11-Фев-17, 15:56 
https://s-media-cache-ak0.pinimg.com/736x/42/ca/bd/42cabd400...
Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

29. "Прекращена поддержка LTS-ветки ядра Linux 3.18"  +/
Сообщение от fi (ok) on 13-Фев-17, 14:38 
> Это у вас на холодильник вендор не хочет свежую прошивку выпускать? Где
> вы такое ядро держите?

автор честно указал где: kernel-2.6.18-417. ''el5'' .i686.rpm
и ВООБЩЕ ядра надо знать в лицо!  :)

уже лет десять ядро поддерживается, крутиться и есть не просит.  Возможно и я когда-нибудь сподвигнусь обновить образ системы для наших железок, но сейчас.

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Ideco
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру