The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Не срабатывает правило udev. Не могу понять в чём дело."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на рабочей станции (Драйверы, оборудование / Linux)
Изначальное сообщение [ Отслеживать ]

"Не срабатывает правило udev. Не могу понять в чём дело."  +/
Сообщение от camojietemail (?), 01-Ноя-19, 07:04 
Доброго вам всего на свете.

Имею на борту Linux Mint 18.3 Sylvia, включаю в него usb модем Huawei e3372 в режиме hilink
Моя задача переключить флешку в режим модема. Команда мне известна, она работает. Проблема в том, что я не могу заставить udev выполнить эту команду при подключении флешки.
lsusb:
Bus 001 Device 023: ID 12d1:1f01 Huawei Technologies Co., Ltd. E353/E3131 (Mass storage mode)

Cоздаю файл /etc/udev/rules.d/70-huawei-e3.rules:
SUBSYSTEM=="usb", ACTION=="add", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1f01", RUN+="echo helo >> /tmp/lala"

Обновляю правила:
udevadm control --reload-rules && udevadm trigger

Файл /tmp/lala при  не создается при переподключении.

Пробую udevadm monitor --environment, и подключаю устройство. Самое первое из действий udev:

UDEV  [6527.139277] add      /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2 (usb)
ACTION=add
BUSNUM=001
DEVNAME=/dev/bus/usb/001/022
DEVNUM=022
DEVPATH=/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2
DEVTYPE=usb_device
DRIVER=usb
ID_BUS=usb
ID_MODEL=HUAWEI_MOBILE
ID_MODEL_ENC=HUAWEI_MOBILE
ID_MODEL_FROM_DATABASE=E353/E3131 (Mass storage mode)
ID_MODEL_ID=1f01
ID_REVISION=0102
ID_SERIAL=HUAWEI_MOBILE_HUAWEI_MOBILE_0123456789ABCDEF
ID_SERIAL_SHORT=0123456789ABCDEF
ID_USB_INTERFACES=:080650:
ID_VENDOR=HUAWEI_MOBILE
ID_VENDOR_ENC=HUAWEI_MOBILE
ID_VENDOR_FROM_DATABASE=Huawei Technologies Co., Ltd.
ID_VENDOR_ID=12d1
MAJOR=189
MINOR=21
PRODUCT=12d1/1f01/102
SEQNUM=9278
SUBSYSTEM=usb
TYPE=0/0/0
USEC_INITIALIZED=6527124591

Ну всё же подходит. Что я делаю не так?
Спасибо.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Не срабатывает правило udev. Не могу понять в чём дело."  +/
Сообщение от camojietemail (?), 01-Ноя-19, 07:19 
Разобрался. В RUN должны быть полные пути исполняемых программ.

RUN+="/bin/sh -c 'echo HELLO ! > /tmp/lala'"

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру