The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Помогите  обновить debian 8 до 9"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Система. проблемы, диагностика / Linux)
Изначальное сообщение [ Отслеживать ]

"Помогите  обновить debian 8 до 9"  +/
Сообщение от eeeemail (??), 05-Апр-19, 11:26 
Всем добрый день!
Просьба очень сильно не бить ногами. Первый раз обновляюсь. Раньше переуставливал систему и дальше работал. Так вот. Имеется система  debian версии 8 решил ее обновить до 9 вот по этому руководству
https://serveradmin.ru/obnovlenie-debian-8-jessie-do-9-stretch/
Проблема возникла после того как я поменял список серверов обновления sources.list. То есть команда apt-get update выполняется без ошибок.
Но после того как я запускаю apt upgrade
Выдается вот такая информация
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kdepimlibs-kio-plugins : Breaks: kdepimlibs-data but 4:16.04.2-2 is to be installed
                          Breaks: kdepimlibs-data:i386
libakonadi-kde4 : Breaks: kdepimlibs-data but 4:16.04.2-2 is to be installed
                   Breaks: kdepimlibs-data:i386
libakonadi-kmime4 : Breaks: kdepimlibs-data but 4:16.04.2-2 is to be installed
                     Breaks: kdepimlibs-data:i386
libkabc4 : Breaks: kdepimlibs-data but 4:16.04.2-2 is to be installed
            Breaks: kdepimlibs-data:i386
libkcal4 : Breaks: kdepimlibs-data but 4:16.04.2-2 is to be installed
            Breaks: kdepimlibs-data:i386
libkholidays4 : Breaks: kdepimlibs-data but 4:16.04.2-2 is to be installed
                 Breaks: kdepimlibs-data:i386
libkresources4 : Breaks: kdepimlibs-data but 4:16.04.2-2 is to be installed
                  Breaks: kdepimlibs-data:i386
libmailtransport4 : Breaks: kdepimlibs-data but 4:16.04.2-2 is to be installed
                     Breaks: kdepimlibs-data:i386
E: Broken packages
Куда капать? Как преодолеть данную проблему?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Помогите  обновить debian 8 до 9"  +/
Сообщение от universite (ok), 05-Апр-19, 15:10 
> Всем добрый день!
> Просьба очень сильно не бить ногами. Первый раз обновляюсь. Раньше переуставливал систему
> и дальше работал. Так вот. Имеется система  debian версии 8
> решил ее обновить до 9 вот по этому руководству
> https://serveradmin.ru/obnovlenie-debian-8-jessie-do-9-stretch/
> E: Broken packages
> Куда капать? Как преодолеть данную проблему?

Самое то обратиться к автору руководства.
А особенно посмотреть пункт - "заказать настройку сервера от 500р."

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Помогите  обновить debian 8 до 9"  +/
Сообщение от Polter (??), 08-Апр-19, 10:26 
Грохни пакет kdepimlibs-data и все его зависимости. потом поставишь, вместе с пакетами что удалятся.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Помогите  обновить debian 8 до 9"  +/
Сообщение от Аноним (3), 08-Апр-19, 13:30 
в 9 дебиане перешли на kde5, попробуй запустить apt-get full-upgrade. Если не поможет, то да, запчасти kde4 придется почистить
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Помогите  обновить debian 8 до 9"  +/
Сообщение от Arhangel Tirael (?), 09-Апр-19, 10:57 
>[оверквотинг удален]
>            
>      Breaks: kdepimlibs-data:i386
>  libkresources4 : Breaks: kdepimlibs-data but 4:16.04.2-2 is to be installed
>            
>       Breaks: kdepimlibs-data:i386
>  libmailtransport4 : Breaks: kdepimlibs-data but 4:16.04.2-2 is to be installed
>            
>          Breaks: kdepimlibs-data:i386
> E: Broken packages
> Куда капать? Как преодолеть данную проблему?

Копать в сторону удаления KDE4 и только потом обновлять систему.
Делай вот что:
1) apt-get purge kde*
2) apt-get autoremove
# Далее команды с прописанным репозиторием Debian 8 в /etc/apt/sources.list
3) apt-get update
4) apt-get upgrade, в случае чего - apt-get -f install
# Далее команды с прописанным репозиторием Debian 9 в /etc/apt/sources.list
5) apt-get update
6) apt-get upgrade или aptitude safe-upgrade

P.S Если на что-то ещё будет ругаться - удаляй эти пакеты.

P.P.S Не забываем, что Debian 9 переехал на систему инициализации systemd и если вы хотите воспользоваться всеми его (systemd) преимуществами, то его нужно будет установить в обновлённую систему и удалить SysVinit, оставшийся от Debian 8.

P.P.P.S Для установки KDE Plasma 5 c минимальным набором программ в Debian 9 сделайте: apt install kde-plasma-desktop. доп информацию смотрите на: https://wiki.debian.org/ru/KDE

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Помогите  обновить debian 8 до 9"  +/
Сообщение от Andrey Mitrofanov (?), 09-Апр-19, 13:47 
> P.P.S Не забываем, что Debian 9 переехал на систему инициализации systemd и
> если вы хотите воспользоваться всеми его (systemd) преимуществами, то его нужно
> будет установить в обновлённую систему

Неожиданно!  Чтобы воспользоваться всеми его _недостатками_, нужно сделать то же самое...

Сурпрайз!  На s-d они "уже" переезжали таки в 8-ке.


>и удалить SysVinit, оставшийся от Debian
> 8.

В 9-ке есть свой, он обновляется при апгрейде.  ...а не, то было про 7->8...

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Помогите  обновить debian 8 до 9"  +/
Сообщение от Arhangel Tirael (?), 10-Апр-19, 19:05 
>> Неожиданно!  Чтобы воспользоваться всеми его _недостатками_, нужно сделать то же самое...

Давайте не будем разводить священные войны по поводу SysVinit vs Systemd vs Upstart. Тема не про это.

>> Сурпрайз!  На s-d они "уже" переезжали таки в 8-ке.

Это был проходной релиз. Для сравнения:

debian 8.11:

dpkg -l  | grep systemd
ii  libsystemd0:amd64              215-17+deb8u11                   amd64        systemd utility library

debian 9.8:

dpkg -l | grep systemd
ii  libpam-systemd:amd64          232-25+deb9u9                  amd64        system and service manager - PAM module
ii  libsystemd0:amd64             232-25+deb9u9                  amd64        systemd utility library
ii  systemd                       232-25+deb9u9                  amd64        system and service manager
ii  systemd-sysv                  232-25+deb9u9                  amd64        system and service manager - SysV links

Ну и на отсутствие systemd как бы намекает то, что такого инструментария, как systemctl в debian 8 нет:

root@deb8:~# systemctl
bash: systemctl: command not found
root@deb8:~# whereis systemctl
systemctl:
root@deb8:~# whereis ssh
ssh: /usr/bin/ssh /etc/ssh /usr/share/man/man1/ssh.1.gz

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Помогите  обновить debian 8 до 9"  +/
Сообщение от Andrey Mitrofanov (?), 11-Апр-19, 11:37 
>>> Сурпрайз!  На s-d они "уже" переезжали таки в 8-ке.
> Это был проходной релиз. Для сравнения:
> debian 8.11:
> dpkg -l  | grep systemd

Я, конечно!, верю, что ты не знаешь, что это -- в _установленных_ пакетах, а не в _дистрибутиве_ Debian 8.

> Ну и на отсутствие systemd как бы намекает то, что такого инструментария,
> как systemctl в debian 8 нет:

То, что его нет в твоей установке, не означает, что его нет в Debian 8:

> root@deb8:~# systemctl
> bash: systemctl: command not found

Вот же он.

File list of package systemd in jessie of architecture i386

/bin/journalctl
/bin/loginctl
/bin/machinectl
/bin/systemctl
  <<-- https://packages.debian.org/jessie/i386/systemd/filelist

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Помогите  обновить debian 8 до 9"  +/
Сообщение от QuazyMorda (ok), 12-Апр-19, 18:02 
# Правим /etc/apt/sources.list* Меняем везде jessie на stretch.
# sed -i 's/jessie/stretch/' /etc/apt/sources.list

apt-get update       # Обновление списка пакетов
apt-get upgrade      # Минимальное обновление системы
apt-get dist-upgrade # Обновление системы
reboot

cat /etc/debian_version
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема



Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру
Hosting by Ihor