The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Не могу установить gd->php на freebsd"
Вариант для распечатки  
Пред. тема | След. тема 
Форум WEB технологии (PHP)
Изначальное сообщение [ Отслеживать ]

"Не могу установить gd->php на freebsd"  +/
Сообщение от andragen (??) on 06-Апр-11, 15:50 
Установленные
# pkg_info | grep php
php5-5.2.9          PHP Scripting Language
php5-bz2-5.2.9      The bz2 shared extension for php
php5-ctype-5.2.9    The ctype shared extension for php
php5-dom-5.2.11_1   The dom shared extension for php
php5-filter-5.2.11_1 The filter shared extension for php
php5-gettext-5.2.11_1 The gettext shared extension for php
php5-hash-5.2.11_1  The hash shared extension for php
php5-iconv-5.2.11_1 The iconv shared extension for php
php5-imap-5.2.9     The imap shared extension for php
php5-json-5.2.11_1  The json shared extension for php
php5-mbstring-5.2.11_1 The mbstring shared extension for php
php5-mcrypt-5.3.3_2 The mcrypt shared extension for php
php5-mysql-5.2.9    The mysql shared extension for php
php5-mysqli-5.2.11_1 The mysqli shared extension for php
php5-openssl-5.2.11_1 The openssl shared extension for php
php5-pcre-5.2.9     The pcre shared extension for php
php5-pdo-5.2.11_1   The pdo shared extension for php
php5-pdo_sqlite-5.2.11_1 The pdo_sqlite shared extension for php
php5-posix-5.2.11_1 The posix shared extension for php
php5-session-5.2.9  The session shared extension for php
php5-simplexml-5.2.9 The simplexml shared extension for php
php5-soap-5.2.11_1  The soap shared extension for php
php5-sockets-5.2.11_1 The sockets shared extension for php
php5-spl-5.2.9      The spl shared extension for php
php5-sqlite-5.2.11_1 The sqlite shared extension for php
php5-tokenizer-5.2.11_1 The tokenizer shared extension for php
php5-xml-5.2.11_1   The xml shared extension for php
php5-xmlreader-5.2.11_1 The xmlreader shared extension for php
php5-xmlwriter-5.2.11_1 The xmlwriter shared extension for php
php5-zip-5.2.11_1   The zip shared extension for php
php5-zlib-5.2.11_1  The zlib shared extension for php

делаю
cd /usr/ports/lang/php5-extensions
make config (выбираю только GD)
make instal и получаю

checking for XEXT... configure: error: Package requirements (xproto >= 7.0.13 x11 >= 1.1.99.1 xextproto >= 7.0.99.2) were not met:

Requested 'x11 >= 1.1.99.1' but version of X11 is 1.1.3

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XEXT_CFLAGS
and XEXT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

===>  Script "configure" failed unexpectedly.
Please report the problem to x11@FreeBSD.org [maintainer] and attach the
"/usr/ports/x11/libXext/work/libXext-1.1.1/config.log" including the output
of the failure of your make command. Also, it might be a good idea to provide
an overview of all packages installed on your system (e.g. an `ls
/var/db/pkg`).
*** Error code 1

Stop in /usr/ports/x11/libXext.
*** Error code 1

Stop in /usr/ports/x11/libXpm.
*** Error code 1

Stop in /usr/ports/graphics/php5-gd.
*** Error code 1

Stop in /usr/ports/graphics/php5-gd.

как установить без x11

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Не могу установить gd->php на freebsd"  +/
Сообщение от t (??) on 06-Апр-11, 16:08 
> *** Error code 1
> Stop in /usr/ports/graphics/php5-gd.
> как установить без x11

Добавьте в /etc/make.conf строки:
WITHOUT_X11=yes
WITHOUT_GUI=yes

Хотя я не уверен, что gd можно собрать без x.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Не могу установить gd->php на freebsd"  +/
Сообщение от andragen (ok) on 06-Апр-11, 16:12 
сейчас выдает

  CCLD   wrjpgcom
===>  Installing for jpeg-8_3
===>   Generating temporary packing list
===>  Checking if graphics/jpeg already installed
===>   An older version of graphics/jpeg is already installed (jpeg-6b_7)
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of graphics/jpeg
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/graphics/jpeg.
*** Error code 1

Stop in /usr/ports/graphics/php5-gd.
*** Error code 1

Stop in /usr/ports/graphics/php5-gd.
*** Error code 1

Stop in /usr/ports/lang/php5-extensions.
*** Error code 1

Stop in /usr/ports/lang/php5-extensions.

Если пройдется удалять jpeg то он просит еще кучу портов снести

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Не могу установить gd->php на freebsd"  +/
Сообщение от t (??) on 06-Апр-11, 16:35 

> Если пройдется удалять jpeg то он просит еще кучу портов снести

нет, не попросит.
/usr/ports/graphics/jpeg && make deinstall

потом снова запустите установку php5-gd и jpeg установится как зависимость.
а в каком вообще состоянии система? все пакеты последних версий, следуете указаниям из /usr/ports/UPDATING?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Не могу установить gd->php на freebsd"  +/
Сообщение от andragen (ok) on 06-Апр-11, 16:52 
так и сделал, перезапустил апач все в норме.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Не могу установить gd->php на freebsd"  +/
Сообщение от Сергей (??) on 06-Апр-11, 17:25 
> так и сделал, перезапустил апач все в норме.

Странно это как то, я бы обновил бы все, что установлено в системе, оно явно просит более старшие версии софта из пакетов,  нежели установленного в системе...


Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру