The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Не могу установить mod_perl"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы WEB технологии (Public)
Изначальное сообщение [ Отслеживать ]

"Не могу установить mod_perl"  
Сообщение от Grizzli email on 27-Авг-08, 16:42 
у меня такая проблема.
Хочу поставить mod_perl. Уже установлен apache_2.0.63-win32-x86-no_ssl,
ActivePerl-5.10.0.1003-MSWin32-x86-285500. Всё работает, всё нормально.
Скачал mod_perl-2.0.4.tar.gz, распаковал.
забыл сказзать,стоит WinXP, MVS2005.
пробовал
1)из директории mod_perl комманду
perl Makefile.PL MP_AP_PREFIX=\Path\to\Apache2
Сначала начинает писать, что не хватает математических библиотек, но потом

что-то всё-таки начинает ставить..Затем появляется множество сообщений типа
Note (probably harmless): No library found for ole32.lib
Затем предупреждает, что в зависимости от этой установки mod_perl.so будет

или не будет находиться в /modules...как ы понимаете, его там нет.
Почти все эти библиотеки есть( за исключением 2-3) в system32, но у них

расширение dll, а не lib.
make или nmake пробовал, но эти команды "не являются внутренними и тд" ну вы

поняли...
2) из ppm.bat
ppm install http://theoryx5.uwinnipeg.ca/ppms/mod_perl.ppd
и
ppm install http://theoryx5.uwinnipeg.ca/ppms/mod_perl-2.0.ppd
Тут уже нет никаких роблем с библиотеками, но
пишет install failed:The PPD does not provide code to install for this

platform((((
Пробовал просто загрузить этот файл и установить с компа, через mpinstall-то

же самое.
Что делать-не знаю.Помогите пожалуйста.


Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Не могу установить mod_perl"  
Сообщение от Pahanivo email(ok) on 27-Авг-08, 17:03 
> скачал ... tar.gz ???

Те как я понял ты его из сырцов под винду ставишь? )))

Ходи сюда:
http://perl.apache.org/docs/2.0/os/win32/install.html#All_in...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Не могу установить mod_perl"  
Сообщение от Grizzli email on 27-Авг-08, 20:20 
>Ходи сюда:
>http://perl.apache.org/docs/2.0/os/win32/install.html#All_in...

А какой тогда пакет для Windows? Переставлять Apache как то не хочеися просто

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Не могу установить mod_perl"  
Сообщение от Pahanivo email(ok) on 28-Авг-08, 12:47 
>>Ходи сюда:
>>http://perl.apache.org/docs/2.0/os/win32/install.html#All_in...
>
>А какой тогда пакет для Windows? Переставлять Apache как то не хочеися
>просто

Те уже ссылу дал - прочитать не могешь?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Не могу установить mod_perl"  
Сообщение от Grizzli email on 28-Авг-08, 19:05 
>Те уже ссылу дал - прочитать не могешь?

Может быть у меня конечно проблемы с английским( не исключено), но эти пакеты идут вместе с апачем, а я не хочу заново всё переставлять...
Может я тебя конечно совсем не понимаю- готов взять свои слова обратно, но ведь есть способ доставить этот модуль без кардинальных мер...
Прообовал ещё просто, как там написано, скачать файл mod_perl-2.0.so и поставить-перезапустить сервер не получается, вылетает ошибка...Типа не может загрузить модуль
Я могу страшно тупить, так что объясни в таком случае по шагам...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Не могу установить mod_perl"  
Сообщение от Pahanivo email(ok) on 29-Авг-08, 07:16 
>[оверквотинг удален]
>
>Может быть у меня конечно проблемы с английским( не исключено), но эти
>пакеты идут вместе с апачем, а я не хочу заново всё
>переставлять...
>Может я тебя конечно совсем не понимаю- готов взять свои слова обратно,
>но ведь есть способ доставить этот модуль без кардинальных мер...
>Прообовал ещё просто, как там написано, скачать файл mod_perl-2.0.so и поставить-перезапустить сервер
>не получается, вылетает ошибка...Типа не может загрузить модуль
>Я могу страшно тупить, так что объясни в таком случае по шагам...
>

Ну шош, поясню в чем твой тупизм.
Во-первых, то что изначально скачал - это так называемые source пакета, те исходники.
Чтобы их скомпилить под винду нуно очень сильно поизвращатся. С твоим опытом это в принципе дохлый номер.
Во-вторых, у тябя ВИДНА (в рот мне ноги), дак качай и прикручивай уже скомпиленный пакет
(aka binary) для виндов (aka Win32, aka Windiws). Для этого иди apahce.org -> perl.
В-третих, проблемы с англицким нужно решать хотябы словарем.
Удачи.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру