The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема с CISCO 881 или что то надо отключить?"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Диагностика и решение проблем)
Изначальное сообщение [ Отслеживать ]

"Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от sidsoft (??) on 27-Май-11, 07:46 
Здравствуйте.
При включении CISCO 881 в ЛВС со многими рабоичими станциями, особенно с LINUX рабочими станциями происходят странные вещи.
У Windows-рабочих станций перестают присваиваться IP-адреса по DHCP-протоколу.
У Linux-рабочих станциях перестают так же присваиваться IP-адреса по DHCP, а у тех рабочих станциях у которых прописано "жестко" несколько IP-адресов иногда вовсе адаптер не присваивает ничего, либо только один из IP-адресов прописаных "жестко".
После отключения CISCO 881 из сети ЛВС (или вообще от электрического питания) ситуация полностью нормализуется и все рабочие станции работают нормально, всем начинается нормально присваиваться IP-адреса по DHCP-протоколу и все рабочие станции начинают работать в "штатном режиме".
Я сразу же (перед тем как подключить CISCO 881) отключил в данном маршрутизаторе:
no service dhcp
no ip route-source (на всякий случай)
Но "АНОМАЛИИ" имеют место быть.
Подскажите пожалуйста что нужно включить/выключить, чтобы не было данной проблемы.
Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от Pve1 (ok) on 27-Май-11, 09:51 
А компьютер возьмите, wireshark поставьте, и посмотрите, что у вас в сети творится.
А телепатов тут нет.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от merko (ok) on 27-Май-11, 10:05 
>[оверквотинг удален]
> После отключения CISCO 881 из сети ЛВС (или вообще от электрического питания)
> ситуация полностью нормализуется и все рабочие станции работают нормально, всем начинается
> нормально присваиваться IP-адреса по DHCP-протоколу и все рабочие станции начинают работать
> в "штатном режиме".
> Я сразу же (перед тем как подключить CISCO 881) отключил в данном
> маршрутизаторе:
> no service dhcp
> no ip route-source (на всякий случай)
> Но "АНОМАЛИИ" имеют место быть.
> Подскажите пожалуйста что нужно включить/выключить, чтобы не было данной проблемы.

властелин колец однако...

хоть конфиг покажите

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от sidsoft (??) on 27-Май-11, 10:38 
>[оверквотинг удален]
>> нормально присваиваться IP-адреса по DHCP-протоколу и все рабочие станции начинают работать
>> в "штатном режиме".
>> Я сразу же (перед тем как подключить CISCO 881) отключил в данном
>> маршрутизаторе:
>> no service dhcp
>> no ip route-source (на всякий случай)
>> Но "АНОМАЛИИ" имеют место быть.
>> Подскажите пожалуйста что нужно включить/выключить, чтобы не было данной проблемы.
> властелин колец однако...
> хоть конфиг покажите

Using 2477 out of 262136 bytes
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname CISCO-881
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
!
memory-size iomem 10
no ip source-route
!
!
!        
ip dhcp excluded-address 10.10.10.1
!
!
ip cef
no ip domain lookup
ip domain name xxx.ru
no ipv6 cef
!
!
multilink bundle-name authenticated
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-458237257
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-458237257
revocation-check none
!
!
crypto pki certificate chain TP-self-signed-458237257
certificate self-signed 01 nvram:IOS-Self-Sig#4.cer
license udi pid CISCO881-SEC-K9 sn FCZ151492SD
!
!        
username root privilege 15 secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
!
!
!
!
!
interface FastEthernet0
!
interface FastEthernet1
switchport access vlan 2
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
description $ES_WAN$
ip address xx.xxx.xxx.xxx 255.255.255.248
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 10.10.10.1 255.255.255.248 secondary
ip address 192.168.200.230 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Vlan2
description LANit
ip address 192.168.23.111 255.255.255.224
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source route-map provider interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 xx.xxx.xxx.x
ip route 172.20.200.21 255.255.255.255 Vlan2
ip route 172.20.200.25 255.255.255.255 Vlan2
!
ip access-list extended LAN_IN
permit ip any any
!
logging esm config
access-list 23 permit 192.168.200.100
access-list 23 permit 192.168.200.65
access-list 23 permit 192.168.200.68
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 23 permit 192.168.200.0 0.0.0.7
access-list 23 permit 192.168.23.0 0.0.0.127
no cdp run

!
!
!
!
route-map provider permit 10
match ip address nat-traffic LAN_IN
match interface FastEthernet4
!
!
control-plane
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
end

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от sidsoft (ok) on 27-Май-11, 13:37 
>[оверквотинг удален]
>  login local
>  no modem enable
> line aux 0
> line vty 0 4
>  access-class 23 in
>  privilege level 15
>  login local
>  transport input telnet ssh
> !
> end

Встречался кто нибудь с такой проблемой?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от Pve1 (ok) on 27-Май-11, 14:08 

> Встречался кто нибудь с такой проблемой?

Я же вам написал уже - смотреть надо снифером, что происходит в сети.
На текущи момент явно не достаточно вводных данных для определения сути проблемы.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от rakis (ok) on 28-Май-11, 10:23 
> У Windows-рабочих станций перестают присваиваться IP-адреса по DHCP-протоколу.
> У Linux-рабочих станциях перестают так же присваиваться IP-адреса по DHCP, а у
> тех рабочих станциях у которых прописано "жестко" несколько IP-адресов иногда вовсе
> адаптер не присваивает ничего, либо только один из IP-адресов прописаных "жестко".

У Вас случаем IP адрес Cisco маршрутизатора не тот же самый, что и у DHCP сервера?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от sidsoft (ok) on 30-Май-11, 07:08 
>> У Windows-рабочих станций перестают присваиваться IP-адреса по DHCP-протоколу.
>> У Linux-рабочих станциях перестают так же присваиваться IP-адреса по DHCP, а у
>> тех рабочих станциях у которых прописано "жестко" несколько IP-адресов иногда вовсе
>> адаптер не присваивает ничего, либо только один из IP-адресов прописаных "жестко".
> У Вас случаем IP адрес Cisco маршрутизатора не тот же самый, что
> и у DHCP сервера?

Нет, это первое что я проверял.
В любом случае Всем спасибо за отклики. Проблему обнаружил и устранил.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от Pve1 (ok) on 30-Май-11, 09:59 

> В любом случае Всем спасибо за отклики. Проблему обнаружил и устранил.

А что было то? Поделитесь опытом с товарищами:)

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от sidsoft (ok) on 03-Июн-11, 09:25 
>> В любом случае Всем спасибо за отклики. Проблему обнаружил и устранил.
> А что было то? Поделитесь опытом с товарищами:)

=) Просто смешно уже самому...
Сейчас попробую как смогу нарисовать как подключена кошка и линукс-машина после чего попробую еще более понятнее описать проблему.

       1
+-------------+
| CISCO 828   |
|  G.SHDSL    |
| modem/router|
| 4 Ethernet  |
|    port     |
|(switch mode)|
+-------------+
   |    |  |  
   |    |  |
   |    |  +--------------+
   |    |                 |
   | 2  +-----+           | 3
+---------+   |       +---------+
|CISCO 881|   |       |  LINUX  |
+---------+   |       +---------+
   |          |            |
   |          |            |
   +----+     |   +--------+
        |  4  |   |
    +------------------+
    |        HUB       |
    |        LAN       |
    |   192.168.200.xx |
    +------------------+

********************************************************************
1 - CISCO 828 G.SHDSL modem/router
IP1: Ethernet0 172.22.0.1 mask 255.255.255.0
IP2: Ethernet0 192.168.23.97 mask 255.255.255.224 secondary
====================================================================
2 - CISCO 881
IP1: Vlan1 192.168.200.230 mask 255.2555.255.0
IP2: Vlan2 192.168.23.111 mask 255.255.255.224
IP3: Provider Inetrnet address yyy.yyy.yyy.yyy
====================================================================
3 - LINUX
IP1: eth0 172.22.0.2 mask 255.255.255.0
IP2: eth0:1 192.168.23.110 mask 255.255.255.224
IP3: eth1 192.168.200.200 mask 255.255.255.0
====================================================================
4 - HUB
*********************************************************************
Вот при такой топологии и вышеприведенной конфигурации cisco 881 проблема не исчезла.
Так при включении CISCO 881 у Linux-машины не присваиваются IP-адреса которые прописаны "жестко" в конфигурационном файле для настройки сетевых интерфейсов.
Прилагаю на всякий случай конфигурационный файл с Linux-машины для сетевых интерфейсов:
======================================================================
# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d.  To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).
dns_domain_lo="ROUTER"
nis_domain_lo="XXXXXXX.RU"
config_eth0=( "172.22.0.2 netmask 255.255.255.0"
              "192.168.23.110 netmask 255.255.255.224" ) #цепляется в системе как eth0:1
routes_eth0=( "default gw 172.22.0.1" )
dns_servers_eth0=( "192.168.200.1
            192.168.200.11" )
config_eth1=( "192.168.200.200 netmask 255.255.255.0" )
=======================================================================

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от sidsoft (ok) on 03-Июн-11, 09:39 
Не получилось привести "схему"... все "съехало"
вот по этой ссылке http://s015.radikal.ru/i330/1106/2a/5f5f24526754.jpg доступно то что я хотел здесь "изобразить".
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от sidsoft (ok) on 03-Июн-11, 11:38 
Т.е. если выключить CISCO 881 то линукс-машина присваивает себе нормально ip-адреса из вышеприведенного конфигурационного файла, но стоит только включить CISCO 881 и после этого перезагрузить линукс-машину то ip-адреса уже не присваиваются.
Может что то там с пакетами происходит или какую то настройку нужно произвести в CISCO 881 что бы таких "конфликтов" по присваиванию ip-адресов не происходило на линукс-машине, может какие то КРИВЫЕ настройки шлет сетевым картам линукс-машине эта CISCO 881?
Но одно явно, то что ВИНОВНА CISCO 881.
ПОМОГИТЕ хоть чем нибудь... уже извелся весь, КУДА(!!!) копать и смотреть не могу даже представить.
Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от Николай_kv on 03-Июн-11, 12:55 
Разрисуйте свою топологию человечески что за псевдографика какой сейчас год на дворе!!!  (зайдите на сайты посмотрите как рисовать надо впринципе) как пример http://it.wikipedia.org/wiki/File:DHS_Network_Topology.jpg - тут не ясновидящие сидят. Что за набор цифр???!!!! Какие подсети бегают между интерфейсами? как они привязаны к топологии? какие номера портов? какие порты L2/L3?, Пока вы не научитесь грамоно описывать проблему на вас просто будут забивать сколько бы постов вы не писали.
Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

13. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от sidsoft (ok) on 03-Июн-11, 14:58 
> Разрисуйте свою топологию человечески что за псевдографика какой сейчас год на дворе!!!
>  (зайдите на сайты посмотрите как рисовать надо впринципе) как пример
> http://it.wikipedia.org/wiki/File:DHS_Network_Topology.jpg - тут не ясновидящие сидят.
> Что за набор цифр???!!!! Какие подсети бегают между интерфейсами? как они
> привязаны к топологии? какие номера портов? какие порты L2/L3?, Пока вы
> не научитесь грамоно описывать проблему на вас просто будут забивать сколько
> бы постов вы не писали.

Ну вроде попытался "разрисовать" графически. http://s14.radikal.ru/i187/1106/57/2b688760992a.jpg

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Проблема с CISCO 881 или что то надо отключить?"  +/
Сообщение от Петя Покрышкин on 22-Мрт-12, 11:16 
proxy arp?


Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру