The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"PBR"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"PBR"  +/
Сообщение от plohish email(??) on 27-Апр-10, 10:56 
Здравствуйте.
Имеется 2 маршрутизатора CISCO, соединенный 2 dot1q каналами.
На одной из сторон настройка следующая:

interface FastEthernet0/1.669
encapsulation dot1Q 669
ip address 10.30.11.90 255.255.255.248
ip policy route-map PBR

interface FastEthernet0/1.670
encapsulation dot1Q 670
ip address 10.30.11.2 255.255.255.248

access-list 152 permit ip 10.30.11.88 0.0.0.7 any

route-map PBR permit 10
match ip address 152
set ip next-hop 10.30.11.89

ip route 0.0.0.0 0.0.0.0 10.30.11.1

Хочу чтобы пакеты, пришедшие на Fa 0/1.669, уходили с него же, но уходят с Fa 0/1.670:

#traceroute 192.168.60.145 source 10.30.11.90 ttl 1 1

Type escape sequence to abort.
Tracing the route to 192.168.60.145

  1 10.30.11.1 32 msec 40 msec 40 msec

Где я неправ ?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

  • PBR, mario, 13:03 , 27-Апр-10, (1)  
    • PBR, mario, 15:21 , 27-Апр-10, (2)  
      • PBR, ShyLion, 15:46 , 27-Апр-10, (3)  
      • PBR, ShyLion, 16:07 , 27-Апр-10, (6)  
    • PBR, ShyLion, 16:03 , 27-Апр-10, (4)  
  • PBR, ShyLion, 16:06 , 27-Апр-10, (5)  

Сообщения по теме [Сортировка по времени | RSS]


1. "PBR"  +/
Сообщение от mario email(ok) on 27-Апр-10, 13:03 
>[оверквотинг удален]
>уходят с Fa 0/1.670:
>
>#traceroute 192.168.60.145 source 10.30.11.90 ttl 1 1
>
>Type escape sequence to abort.
>Tracing the route to 192.168.60.145
>
>  1 10.30.11.1 32 msec 40 msec 40 msec
>
>Где я неправ ?

PBR не работает для интерфейсов на циске
т.е. у вас интерфейс Fa 0/1.670 смотрит на дефолтный шлюз. следовательно от него он и уходит...
а PBR отрабатывает только для сетки описаной в листе кроме интерфейсам маршрутизера ...

если вам критично что бы маршрутизатор сам отправлял трафик по некст хопу то погуглите как то решается как не помню...(в смысле средствами PBR)
....
если трафа не много с сетки идет то можно deb ip poli
и вам будет сказано какие пакеты (с сорсом и дестинейшеном) отрабатываются  а какие нет


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "PBR"  +/
Сообщение от mario email(ok) on 27-Апр-10, 15:21 
>[оверквотинг удален]
>...
>
>если вам критично что бы маршрутизатор сам отправлял трафик по некст хопу
>то погуглите как то решается как не помню...(в смысле средствами PBR)
>
>....
>если трафа не много с сетки идет то можно deb ip poli
>
>и вам будет сказано какие пакеты (с сорсом и дестинейшеном) отрабатываются  
>а какие нет

если не ошибаюсь то повесьте карту на local
т.е.
ip local policy route-map тра тра та
и будет отрабатывать локально на роутере...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "PBR"  +/
Сообщение от ShyLion (ok) on 27-Апр-10, 15:46 

>если не ошибаюсь то повесьте карту на local
>т.е.
>ip local policy route-map тра тра та
>и будет отрабатывать локально на роутере...

ip local policy отрабатывает на пакетах, генерируемых самой кисой.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "PBR"  +/
Сообщение от ShyLion (ok) on 27-Апр-10, 16:07 
>[оверквотинг удален]
>>....
>>если трафа не много с сетки идет то можно deb ip poli
>>
>>и вам будет сказано какие пакеты (с сорсом и дестинейшеном) отрабатываются  
>>а какие нет
>
>если не ошибаюсь то повесьте карту на local
>т.е.
>ip local policy route-map тра тра та
>и будет отрабатывать локально на роутере...

только сейчас заметил, что он трейсит с того-же роутера где полиси настраивает

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "PBR"  +/
Сообщение от ShyLion (ok) on 27-Апр-10, 16:03 
>PBR не работает для интерфейсов на циске
>т.е. у вас интерфейс Fa 0/1.670 смотрит на дефолтный шлюз. следовательно от
>него он и уходит...
>а PBR отрабатывает только для сетки описаной в листе кроме интерфейсам маршрутизера
>...

только что проверил на стенде, все должно работать, пофиг в какую сторону некст-хоп

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "PBR"  +/
Сообщение от ShyLion (ok) on 27-Апр-10, 16:06 
>#traceroute 192.168.60.145 source 10.30.11.90 ttl 1 1
>Где я неправ ?

локально-генерируемые пакеты подчиняются ip local policy

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру