The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Проблема с добавлением vlan на роутер"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Проблема с добавлением vlan на роутер"  +/
Сообщение от Babaich (ok) on 11-Ноя-09, 10:52 
Добрый день,

Есть С2621. Fa0/0 скомутирован на С2950(fa0/11)

-- Конфиг на С2621 --

interface FastEthernet0/0                                                      
no ip address                                                                  
ip nat inside                                                                  
ip route-cache flow                                                            
speed 100                                                                      
full-duplex                                                                    
!                                                                              
interface FastEthernet0/0.136                                                  
encapsulation dot1Q 136                                                        
ip address 192.168.136.3 255.255.255.0                                        
ip nat inside                                                                  
!                                                                              
interface FastEthernet0/0.190                                                  
encapsulation dot1Q 190                                                        
ip address 192.168.190.2 255.255.255.0                                        
ip nat inside
!
!
ip route 192.168.0.0 255.255.0.0 192.168.190.1

-- Конфиг на С2950 --

interface Vlan1                                                                
ip address 192.168.0.15 255.255.255.0                                          
no ip route-cache
!
interface FastEthernet0/11                                                      
description link-to-2621 (f0/0)                                            
switchport mode trunk                                                          
no ip address                                                                  
duplex full                                                                    
speed 100


Хочу включить С2621 в native vlan 1. Добавляю:

interface FastEthernet0/0.1                                                  
  encapsulation dot1Q 1                                                    
  ip address 192.168.0.190 255.255.255.0                                        

В результате:
С С2921 сеть 192.168.0.* не пингуется хоть и становится directly connect.
На С2950:
c2950-4#sh mac-address-table int fa0/11                                    
          Mac Address Table                                                    
------------------------------------------                                      
                                                                                
Vlan    Mac Address       Type       Ports                                      
----    -----------       ----       -----                                      
   1    0009.e89d.5c40    DYNAMIC    Fa0/11                                    
136    0009.e89d.5c40    DYNAMIC    Fa0/11                                    
190    0009.e89d.5c40    DYNAMIC    Fa0/11                                    
Total Mac Addresses for this criterion: 3

iti-c2950-4#sh int fa0/11 trunk                                                
                                                                                
Port      Mode         Encapsulation  Status        Native vlan                
Fa0/11    on           802.1q         trunking      1                          
                                                                                
Port      Vlans allowed on trunk                                                
Fa0/11    1-4094                                                                
                                                                                
Port      Vlans allowed and active in management domain                        
Fa0/11    1,20,30,50,60,133,136,190,193,195,205                                
                                                                                
Port      Vlans in spanning tree forwarding state and not pruned                
Fa0/11    1,20,30,50,60,133,136,190,193,195,205

При попытке посмотреть на С2621 debug arp получаю лог забитый тысячами сообщений меньше чем за минуту
    10.11.2009 14:26    192.168.190.2    Debug    127001: 11w2d: IP ARP throttled out the ARP Request for 192.168.0.17
    ........
    10.11.2009 14:26    192.168.190.2    Debug    107391: 11w2d: IP ARP throttled out the ARP Request for 192.168.0.17
Иногда проскальзывают такие:
    10.11.2009 14:26    192.168.190.2    Debug    126779:                  dst 192.168.0.17 0000.0000.0000 FastEthernet0/0.1
    10.11.2009 14:26    192.168.190.2    Debug    126916: 11w2d: IP ARP rep filtered src 192.168.0.17 0050.da3a.c4a5, dst 192.168.0.190 0009.e89d.5c40 wrong cable, interface FastEthernet0/0

192.168.0.17 - Tacacs-сервер

Что-то я теряюсь. Что не так делаю?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с добавлением vlan на роутер"  +/
Сообщение от GolDi (??) on 11-Ноя-09, 11:21 
>[оверквотинг удален]
>Иногда проскальзывают такие:
> 10.11.2009 14:26 192.168.190.2 Debug 126779:      
>          
>dst 192.168.0.17 0000.0000.0000 FastEthernet0/0.1
> 10.11.2009 14:26 192.168.190.2 Debug 126916: 11w2d: IP ARP rep filtered src
>192.168.0.17 0050.da3a.c4a5, dst 192.168.0.190 0009.e89d.5c40 wrong cable, interface FastEthernet0/0
>
>192.168.0.17 - Tacacs-сервер
>
>Что-то я теряюсь. Что не так делаю?

Native VLAN на свиче и роутере совпадает?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проблема с добавлением vlan на роутер"  +/
Сообщение от Stell email(??) on 11-Ноя-09, 11:30 
У вас на свиче VLAN1 - Native:
>ti-c2950-4#sh int fa0/11 trunk                                                
>Port      Mode         Encapsulation  Status        Native vlan                
>Fa0/11    on           802.1q         trunking      1                          

На роутере надо:
interface FastEthernet0/0.1                                                  
  encapsulation dot1Q 1 native

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Проблема с добавлением vlan на роутер"  +/
Сообщение от littlevik on 11-Ноя-09, 11:34 
>[оверквотинг удален]
>Иногда проскальзывают такие:
> 10.11.2009 14:26 192.168.190.2 Debug 126779:      
>          
>dst 192.168.0.17 0000.0000.0000 FastEthernet0/0.1
> 10.11.2009 14:26 192.168.190.2 Debug 126916: 11w2d: IP ARP rep filtered src
>192.168.0.17 0050.da3a.c4a5, dst 192.168.0.190 0009.e89d.5c40 wrong cable, interface FastEthernet0/0
>
>192.168.0.17 - Tacacs-сервер
>
>Что-то я теряюсь. Что не так делаю?

interface FastEthernet0/0
ip address 192.168.0.190 255.255.255.0

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Проблема с добавлением vlan на роутер"  +/
Сообщение от Babaich (ok) on 11-Ноя-09, 12:14 
>У вас на свиче VLAN1 - Native:
>>ti-c2950-4#sh int fa0/11 trunk                                                
>>Port      Mode         Encapsulation  Status        Native vlan                
>>Fa0/11    on           802.1q         trunking      1                          
>
>На роутере надо:
>interface FastEthernet0/0.1
>  encapsulation dot1Q 1 native

Не дает добавлять native. Хотя на cisco.com написано, что это возможно с 12.1(3)
У меня 12.1(7)
Сделал по совету littlevik(и cisco для версий IOS ниже 12.1(3)) добавив адрес на интерфейс Fa0/0
Спасибо всем. Проблема решена.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру