The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Помогите настроить маршрутизацию"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Помогите настроить маршрутизацию"  +/
Сообщение от MakcSokolOFF email(ok) on 07-Июн-09, 17:45 
Доброго времени суток! Помогите разобраться со следующей проблемой! С циской я имею первый раз дело, это маршрутизатор cisco 1841. Задача - подключить её со статическим ИП в инет и раздать малому офису инет по NAT. Так же на ней должны быть DNS и DHCP, но эти задачи я решил. Вообщем, кое-как настроил почти все: с циски инет пингуется, DHCP работает, внутр. компы циску видят. Но вот проблема: компы не видят инет(( кучу всего перепробовал, но не помогает... Подскажите, где я накосячил с маршрутизацией!? Прилагаю конфиг:

Router#con
!

version 12.4
Configur
  
service timestamps debug datetime msecesnal]?P Echos to 195.128.48.65, timeo
service timestamps log datetime msecist access expressionne per line.  E
no service password-encryptions ra
  access-lists          
!
hostname Routerser(config)#ip
!c
boot-start-marker168.0.10 i
  acco
boot-end-marker      Accountin
!d
no logging bufferedonsdhcp pool dpool1
enable secret 5 $1$0HDA$aBYgV4wM71V6j8ChfEmeN/
  adjacency                 Adjacent nodes  
enable password csl           ^      
!
no aaa new-model         Display
!l
resource policyat '^' marker.
!v
mmi polling-interval 6095.1
                  
no mmi auto-confi                
Router(dhcp-
   import allbli
10  *  *
   network 192.168.0.0 255.255.255.0         ARP tableBootstrap, Vers
  
   domain-name cslstudio.local                 Information o
   dns-server 195.128.48.65 195.128.50.30al Support:
  bootfile             Boot f
   default-router 192.168.0.9                   interfaces
   lease 3pecify a D
!P
!l
ip name-server 195.128.48.65           Show Automation T
ip name-server 195.128.50.30rO ASIC version 0x127o the I
!

!b
!k
crypto pki trustpoint TP-self-signed-1682278439nformation    
  domain-
  default-router    
enrollment selfsigned con
  backup        
subject-name cn=IOS-Self-Signed-Certificate-1
d to: Enabledequi
                          
!
!
interface FastEthernet0/0mation about dialup conne
description $ETH-LAN$lease                A
ip address 192.168.0.9 255.255.255.0a                       CCA informati
ip nat inside(WINS) name se
ip virtual-reassemblyi                    
no ip route-caches-node-type    Net
speed autope#########
half-duplex acc########
no cdp enable access      
no mop enabled#sh access-list
!

interface FastEthernet0/1ard IP access list 1rver
description $ETH-WAN$  10 permit 192.168.0.
ip address 89.188.119.195 255.255.255.2
                                  
  
speed autoP
Extended
no cdp enable 100and conf
*
!
ip default-gateway 89.188.119.1932.168.0.0 0.0.0.255 anypooldsce F
ip classless          

ip route 0.0.0.0 0.0.0.0 89.188.119.193

Router#sh ?ion as a DH
  aaa        
ip route 0.0.0.0 255.255.255.255 dhcpar
  subnet               Subnet a
  
ip dns server
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.0.0 0.0.0.255
snmp-server community public RO
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password 1234
login
!
no process cpu extended
no process cpu autoprofile hog
end

P.S. eth0/0 смотрит в локалку,
     eth0/1 смотрит в инет

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Помогите настроить маршрутизацию"  +/
Сообщение от harrytv email on 08-Июн-09, 00:57 
Вы на будущее пароли и адреса не светите
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Помогите настроить маршрутизацию"  +/
Сообщение от harrytv email on 08-Июн-09, 01:03 
1. Можно конфиг во вменяемом виде посмотреть
2. На ПК шлюз прописали, надеюсь?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Помогите настроить маршрутизацию"  +/
Сообщение от huk on 08-Июн-09, 09:46 
Конфиг во вменяемом виде в студию - команда show run.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Помогите настроить маршрутизацию"  +/
Сообщение от MakcSokolOFF (ok) on 08-Июн-09, 12:12 
>Конфиг во вменяемом виде в студию - команда show run.

Прошу прощения, сам не заметил, что скопипастил...
Да, на ПК все задается DHCP, соответственно шлюз 192.168.0.2

Building configuration...

Current configuration : 3766 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5 <secret>
enable password <pass>
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip routing
no ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1 192.168.0.9
!
ip dhcp pool dpool1
   import all
   network 192.168.0.0 255.255.255.0
   domain-name <domain>
   dns-server 192.168.0.2
   default-router 192.168.0.2
   lease 3
!
!
ip name-server 195.128.48.65
ip name-server 195.128.50.30
!
!
!
!
interface FastEthernet0/0
description $ETH-LAN$
ip address 192.168.0.2 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
speed auto
half-duplex
no cdp enable
no mop enabled
!
interface FastEthernet0/1
description $ETH-WAN$
ip address 89.188.119.195 255.255.255.248
ip nat outside
ip virtual-reassembly
no ip route-cache
duplex auto
speed auto
no cdp enable
!
ip default-gateway 89.188.119.193
ip classless
ip route 0.0.0.0 0.0.0.0 89.188.119.193 20

!
ip http server
ip http authentication local
ip http secure-server
ip nat pool no-overload 89.188.119.192 89.188.119.199 netmask 255.255.255.248
ip nat pool ovrld 89.188.119.195 89.188.119.195 netmask 255.255.255.248
ip nat inside source list 2 pool ovrld
ip dns server
!
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.0.0 0.0.0.255
snmp-server community public RO
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password 1234
login
!
no process cpu extended
no process cpu autoprofile hog
end

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Помогите настроить маршрутизацию"  +/
Сообщение от Дмитрий (??) on 08-Июн-09, 12:37 
>[оверквотинг удален]
>!
>line con 0
>line aux 0
>line vty 0 4
> password 1234
> login
>!
>no process cpu extended
>no process cpu autoprofile hog
>end

А где list 2? (ip nat inside source list 2 pool ovrld)

добавьте:
access-list 2 permit 192.168.0.0 0.0.0.255

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Помогите настроить маршрутизацию"  +/
Сообщение от MakcSokolOFF (ok) on 08-Июн-09, 13:49 
>А где list 2? (ip nat inside source list 2 pool ovrld)
>
>
>добавьте:
> access-list 2 permit 192.168.0.0 0.0.0.255

Спасибо! Но так уже пробовал... к сожалению, не помогло. Тут просто созданы 2 пула с перегрузкой и без, эксперементировал с ними. Кстати, как лучше поступить, когда ISP дал нам пул IP (около 10), какой NAT лучше настроить?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Помогите настроить маршрутизацию"  +/
Сообщение от harrytv email on 08-Июн-09, 18:07 
Без NAT работает?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Помогите настроить маршрутизацию"  +/
Сообщение от MakcSokolOFF (ok) on 08-Июн-09, 18:09 
>Без NAT работает?

То есть без нат? как это проверить? сорри за ламерство, первый раз дело с циской имею... С роутера, как я уже писал, инет пингуется отлично. С рабочих станций IP распознаются (т.е. DNS работает), а вот пакеты не идут...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Помогите настроить маршрутизацию"  +/
Сообщение от harrytv email on 08-Июн-09, 18:18 
Судя по Вашему конфигу не повредит почитать
http://www.nsa.gov/ia/guidance/security_configuration_guides...


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Помогите настроить маршрутизацию"  +/
Сообщение от MakcSokolOFF (ok) on 08-Июн-09, 18:24 
>Судя по Вашему конфигу не повредит почитать
>http://www.nsa.gov/ia/guidance/security_configuration_guides...

Спасибо. Пригодится :) Но все-таки вопрос пока что в другом...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Помогите настроить маршрутизацию"  +/
Сообщение от harrytv email on 09-Июн-09, 10:24 
Разобрались?
Если нет - киньте ipconfig /all с ПК.
Пингуете по имени или по ip?. Если первое - попробуйте по ip.
И я бы статический ip пока присвоил на ПК на время настройки во исключение
косяков.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Помогите настроить маршрутизацию"  +/
Сообщение от MakcSokolOFF (ok) on 09-Июн-09, 17:27 
>Разобрались?
>Если нет - киньте ipconfig /all с ПК.
>Пингуете по имени или по ip?. Если первое - попробуйте по ip.
>
>И я бы статический ip пока присвоил на ПК на время настройки
>во исключение
>косяков.

Спасибо за советы! Все, я разобрался, почистив конфиг от лишних "экспериментов". Безопасность тоже включил :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Помогите настроить маршрутизацию"  +/
Сообщение от harrytv email on 09-Июн-09, 18:41 
Верный подход. Успехов.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Помогите настроить маршрутизацию"  +/
Сообщение от harrytv email on 09-Июн-09, 19:00 
В догонку. Скачайте на торрентах
Cisco Press Ccna Portable Command Guide 2Nd Edition(640-802).pdf
Там кратко все основное, что вам нужно на первое время.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Помогите настроить маршрутизацию"  +/
Сообщение от MakcSokolOFF (ok) on 15-Июн-09, 11:04 
>В догонку. Скачайте на торрентах
>Cisco Press Ccna Portable Command Guide 2Nd Edition(640-802).pdf
>Там кратко все основное, что вам нужно на первое время.

Все! Спасибо большое, хоть и с запозданием :) Скачал, читаю... С циской еще много чего предстоит судя по всему...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Помогите настроить маршрутизацию"  +/
Сообщение от harrytv email on 16-Июн-09, 16:12 
> С циской
>еще много чего предстоит судя по всему...

Желаю удачи. Рабочие конфиги на tftp сохраняйте перед очередным экспериментом :-)


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Помогите настроить маршрутизацию"  +/
Сообщение от Igor Perfilov (ok) on 15-Июн-09, 12:07 
ip nat inside source list 2 pool ovrld

Насколько вижу, здесь не хватает слова 'overload'
Без него вы не сможете транслировать все адреса сети /24 в один-единственный адрес, определенный в пуле ovrld

Так что:
no ip nat inside source list 2 pool ovrld
ip nat inside source list 2 pool ovrld overload

И да, access-list 2 тоже должен быть определн как указали выше.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру