The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco AS5350 регистрация по SIP"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (VoIP)
Изначальное сообщение [ Отслеживать ]

"Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(??) on 12-Дек-08, 23:10 
Cisco отказывается слать SIP запросы на регистрацию на asterisk, читал два мана
http://www.cisco.com/en/US/docs/ios/12_3/sip/configuration/g...
https://www.opennet.ru/tips/info/1456.shtml
Вроде бы всё понятно, немного отличаются по тому писать или не писать registrar, когда надо соединиться с asterisk.
Вот, что я написал в конфигах на cisco

voice service voip
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
h323
sip
  registrar server expires max 3600 min 3000
  no call service stop
.................................................
sip-ua
authentication username 1111 password 12121212121212121212121
registrar ipv4:192.168.11.2 expires 3600
sip-server ipv4:192.168.11.2

Пробовал и без registrar, всё равно реакций ни какой.
Вот так пытался, посмотреть есть ли трафик между astersik и cisco
tcpdump -i eth0.1 -n not port 22 | grep 192.168.11.1 - IP Cisco

Не поймал ни одного пакета связанно с регистрацией на сервере, проверил пингами,
tcpdump ловит всё, значит SIP пакетов и в правду нет.
IOS c5350-is-mz.123-14.T2.bin.
Что копать совершенно не понятно.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от APach on 13-Дек-08, 09:49 
Покажите полный конфиг.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(??) on 13-Дек-08, 10:49 
>Покажите полный конфиг.

Building configuration...

Current configuration : 7676 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname AL5350
!
boot-start-marker
boot system flash c5350-is-mz.123-14.T2.bin
no boot startup-test
boot-end-marker
!
logging count
logging rate-limit 100
enable secret 5 121212212121212121
!
!
!
resource-pool disable
aaa new-model
!
!
aaa group server radius rad02
server 87.11.11.78 auth-port 1635 acct-port 1636
!
aaa authentication login default local
aaa authentication login h304 group rad02
aaa authentication login DIALIN group rad02
aaa authentication login VTY local
aaa authentication login CONSOLE local
aaa authentication login AUX local
aaa authentication ppp default group rad02
aaa authorization exec default local if-authenticated group rad02
aaa authorization exec h304 group rad02
aaa authorization network default group rad02
aaa accounting suppress null-username
aaa accounting update periodic 1
aaa accounting network default start-stop group rad02
aaa accounting network h304 start-stop group rad02
aaa accounting connection h304 start-stop group rad02
aaa accounting resource h304 start-stop group rad02
!
aaa pod server auth-type any server-key megaparol
aaa session-id common
!
resource policy
!
clock timezone kzt 6
clock summer-time KDT recurring last Sun Mar 2:00 last Sun Oct 2:00
spe default-firmware spe-firmware-1
ip subnet-zero
no ip rcmd domain-lookup
ip rcmd rsh-enable
ip rcmd remote-host Router 87.11.11.78 cherry enable
!
!
ip cef
ip name-server 194.0.109.66
ip name-server 195.5.35.4
no ip dhcp use vrf connected
!
!
async-bootp dns-server 194.0.109.66 195.5.35.4
isdn switch-type primary-net5
isdn voice-call-failure 0
chat-script dial "" "ATDT\T" TIMEOUT 120 CONNECT \p
chat-script offhook "" "ATH1" OK
chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \T" TIMEOUT 60 CONNECT \c
!
!
voice service pots
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
!
voice service voip
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
h304
sip
  registrar server expires max 3600 min 3000
  redirect contact order best-match
  no call service stop
!
!
voice class codec 11
codec preference 1 g729r8
codec preference 2 g726r16
codec preference 3 g723r53
codec preference 4 g711ulaw
codec preference 5 g711alaw
!
voice class codec 10
codec preference 1 g723r53 bytes 60
codec preference 2 g723r63 bytes 48
codec preference 3 g729r8 bytes 60
codec preference 4 g729br8 bytes 60
codec preference 5 g726r16 bytes 60
!
!
!
voice class h304 1
  call start slow
!
!
!
!
!
!
!
!
application
service standart flash:/standart_only_ani.tcl
!
service premium flash:/premium_only_ani.tcl
!
!
!
!
username cisco password 7 000055555555
!
!
controller E1 3/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 3/1
framing NO-CRC4
pri-group timeslots 1-31
gw-accounting aaa
!
!
!
interface Tunnel0
ip address 192.168.101.1 255.255.255.252
tunnel source 91.5.1.24
tunnel destination 91.3.1.16
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
no ip address
shutdown
duplex full
speed 100
!
interface FastEthernet0/1
ip address 10.10.10.10 255.255.255.0
ip access-group signaling in
duplex full
speed 100
!
interface FastEthernet0/1.1
encapsulation dot1Q 1 native
ip address 192.168.11.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/1.111
encapsulation dot1Q 111
ip address 194.0.11.33 255.255.255.248
no snmp trap link-status
!
interface FastEthernet0/1.200
encapsulation dot1Q 200
ip address 91.5.1.24 255.255.255.248
no snmp trap link-status
!
interface Serial0/0
no ip address
shutdown
clockrate 2000000
!
interface Serial0/1
no ip address
shutdown
clockrate 2000000
!
interface Serial3/0:15
no ip address
isdn switch-type primary-net5
isdn not-end-to-end 64
isdn incoming-voice modem
isdn map address .* plan isdn type national
isdn T306 60000
isdn T310 60000
isdn sending-complete
no cdp enable
!
interface Serial3/1:15
no ip address
isdn switch-type primary-net5
isdn not-end-to-end 64
isdn incoming-voice modem
isdn map address .* plan isdn type national
isdn T306 60000
isdn T310 60000
isdn sending-complete
no cdp enable
!
interface Group-Async0
description Dial-In:3040555
ip unnumbered FastEthernet0/1.111
ip access-group Public_to_Private in
ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
ip tcp header-compression
async mode interactive
peer default ip address pool default
keepalive 10 3
ppp callback accept
ppp authentication pap
group-range 1/00 1/59
!
router ospf 55
log-adjacency-changes
network 194.0.11.0 0.0.0.255 area 2
!
ip local pool default 194.0.11.128 194.0.11.254
!
ip classless
ip route 0.0.0.0 0.0.0.0 91.5.6.78
ip route 192.168.12.0 255.255.255.0 192.168.101.2
no ip http server
!
!
!
ip access-list extended Public_to_Private
deny   ip any 10.0.0.0 0.255.255.255
deny   ip any 192.168.0.0 0.0.255.255
deny   ip any 172.16.0.0 0.15.255.255
deny   ip any 127.0.0.0 0.255.255.255
permit ip any any
access-list 22 permit 192.168.4.0 0.0.0.255
access-list 110 permit ip 212.154.188.10 0.0.0.1 any
access-list 111 permit ip 85.29.137.34 0.0.0.1 any
snmp-server community voip.alm.mn RO
snmp-server trap link ietf
snmp-server trap-source FastEthernet0/0
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps isdn ietf
snmp-server enable traps voice poor-qov
snmp-server host 192.168.11.1 version 2c voip.alm.mn
!
!
radius-server attribute 44 include-in-access-req
radius-server attribute nas-port format d
radius-server host 87.11.11.78 auth-port 1635 acct-port 1636
radius-server timeout 15
radius-server key 7 1212121212112
radius-server vsa send accounting
radius-server vsa send authentication
!
control-plane
!
!
!
voice-port 3/0:D
input gain -3
output attenuation -4
echo-cancel coverage 64
cptone RU
bearer-cap 3100Hz
!
voice-port 3/1:D
input gain -3
output attenuation -4
echo-cancel coverage 64
cptone RU
bearer-cap 3100Hz
!
!
dial-peer cor custom
!
!
!
dial-peer voice 3040173 pots
service standart
incoming called-number 3040173
!
dial-peer voice 3333810 voip
description Standart_Tariff
huntstop
preference 2
max-conn 30
destination-pattern 33338T
voice-class codec 10
session target ipv4:192.168.11.2
no vad
!
dial-peer voice 3040321 pots
service premium
incoming called-number 3040321
!
dial-peer voice 5555810 voip
description Standart_Tariff
huntstop
preference 2
max-conn 30
destination-pattern 55558T
voice-class codec 10
session target ipv4:192.168.11.2
no vad
!
dial-peer voice 3040000 pots
preference 1
incoming called-number 3040000
no digit-strip
direct-inward-dial
!
dial-peer voice 30400000 voip
huntstop
preference 1
destination-pattern 3040000
session protocol sipv2
session target ipv4:192.168.11.2
codec g711alaw
fax protocol pass-through g711alaw
no vad
!
!
sip-ua
authentication username 1111 password 12121212121212121212121
registrar ipv4:192.168.11.2 expires 3600
sip-server ipv4:192.168.11.2:5060
!
ss7 mtp2-variant Bellcore 0
ss7 mtp2-variant Bellcore 1
ss7 mtp2-variant Bellcore 2
ss7 mtp2-variant Bellcore 3
!
line con 0
line aux 0
line vty 0 4
exec-timeout 30 0
password 7 12121212121
terminal-type cons25r
length 25
line 1/00 1/59
no flush-at-activation
script modem-off-hook offhook
script callback callback
modem InOut
international
transport preferred none
transport input all
transport output none
escape-character BREAK
autoselect during-login
autoselect ppp
!
scheduler allocate 10000 400
ntp clock-period 17180055
ntp server 194.226.199.50 prefer
end

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от APach on 13-Дек-08, 12:15 
А где:

voice rtp send-recv

voice service voip
allow-connections sip to sip

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 13-Дек-08, 12:31 
Спасибо за помощь, по наивности своей я думал, что allow-connections sip to sip - даёт возможность работы как софт свитч, а не для регистрации. Сейчас всё попробую.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 13-Дек-08, 12:49 
Не пытается зарегаться
!
voice rtp send-recv
!
voice service pots
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
!
voice service voip
allow-connections sip to sip
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
h323
sip
  registrar server expires max 3600 min 3000
  redirect contact order best-match
  no call service stop
!
...............................................
sip-ua
authentication username 1111 password 121212121211212121212121212121212
registrar ipv4:192.168.11.2 expires 3600
sip-server ipv4:192.168.11.2:5060
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 13-Дек-08, 17:36 
>voice service voip
> allow-connections sip to sip

Такой вопрос, он очень обязательный параметр я так понимаю, без него регистрация пойдёт?
Если нет, то IOS должен поддерживать это
SIP to SIP Supplementary Services for Session Border Controller(SBC)
а это судя по фьючесам на cisco.com, данную штуку поддерживают IOS 12.4T, а эти IOS держат только AS5350XM, а не как моя AS5350. Тогда получается, что Cisco AS5350 не может регаться на asterisk, что вериться с трудом. Так что не так может быть?

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от APach on 14-Дек-08, 02:48 
А что говорит дебаг по этому поводу, тоисть где или на каком этапе за тык получается.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 14-Дек-08, 06:38 
>А что говорит дебаг по этому поводу, тоисть где или на каком
>этапе за тык получается.

debug ccsip all запусти я и тишина, ну я жду просто начнёт ли он пытаться регаться или ещё надь звонок на cisco пустить или он не регается пока не звонит?

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(??) on 15-Дек-08, 15:01 
Люди добрые поделитесь конфигом своим и названием IOS, я уж как-нибудь поищу грабли. На AS5400 шлёт разные запрос, но нет Try для самой регистрации. Напихал в конфиги всё чё можно, что бы посмотреть, что пойдёт в конце концов.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 18-Дек-08, 19:44 
Добрый челове посоветовал, покрутить другую настройку на cisco, а именно
credentials, именно попробовал на AS5400, для появления данной фичи, залил ИОС
c5400-jk9s-mz.124-15.T8.bin
Такой вот конфиг получился

!
sip-ua
credentials username 3230000 password 121212121211 realm 19.0.19.1
keepalive target ipv4:19.0.11.2
authentication username 3230000 password 7 1212121212121 realm 19.0.19.1
no remote-party-id
set sip-status 400 pstn-cause 1
set sip-status 404 pstn-cause 3
set sip-status 480 pstn-cause 19
set sip-status 502 pstn-cause 1
set sip-status 503 pstn-cause 27
registrar ipv4:19.0.11.2 expires 3600
sip-server ipv4:19.0.11.2
  host-registrar
!

Тепрь в данном ИОСе нет фичи,
voice service voip
allow-connections sip to sip
Вообще нет ни какого allow-connections, просто нет ни в хелпе ни строку
не есть Cisco.
Так и Cisco не регается нормально на SIP сервере. Читая ман на dial-peer pots,
делается такое authentication username, но в примерах только на исходящую связь, кстати все исходящие pots диалпиры пытаются прорегаться на Sip сервере. Данные примеры поведения тоже видел в мане. Так что мне надо ИОС менять опять? что бы были в настройках allow-connections или стоит ещё что-то покрутить?.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

11. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 19-Дек-08, 18:40 
Смотрю, что происходит в дебаге, когда регается циска, она один раз отправляет запрос на регистрацию, получает отказ и ждёт следующего запроса.
Когда регаю софтофон ebeam, то при первой регистрации получаю отказ, а дальше он опять шлёт запрос на авторизацию, потом получает несколько пакетов и авторизуется. Хм так как же циску зарегать и может ли идти регистрация после первого  же запроса на авторизацию?
Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от chuvy email(??) on 20-Дек-08, 05:24 
>Смотрю, что происходит в дебаге, когда регается циска, она один раз отправляет
>запрос на регистрацию, получает отказ и ждёт следующего запроса.
>Когда регаю софтофон ebeam, то при первой регистрации получаю отказ, а дальше
>он опять шлёт запрос на авторизацию, потом получает несколько пакетов и
>авторизуется. Хм так как же циску зарегать и может ли идти
>регистрация после первого  же запроса на авторизацию?

Думаю стоит смотреть в астериске проблему, а не в циске.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от chuvy email(??) on 20-Дек-08, 06:11 
>>Смотрю, что происходит в дебаге, когда регается циска, она один раз отправляет
>>запрос на регистрацию, получает отказ и ждёт следующего запроса.
>>Когда регаю софтофон ebeam, то при первой регистрации получаю отказ, а дальше
>>он опять шлёт запрос на авторизацию, потом получает несколько пакетов и
>>авторизуется. Хм так как же циску зарегать и может ли идти
>>регистрация после первого  же запроса на авторизацию?
>
>Думаю стоит смотреть в астериске проблему, а не в циске.

Взято от сюда - http://www.voip-info.org/wiki-Asterisk+cisco+FXO
REGISTER: Cisco gateway doesn't usually REGISTER with SIP servers, but later versions of IOS can (in order to register FXS ports, for instance)

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от chuvy email(??) on 20-Дек-08, 06:17 
>[оверквотинг удален]
>>>он опять шлёт запрос на авторизацию, потом получает несколько пакетов и
>>>авторизуется. Хм так как же циску зарегать и может ли идти
>>>регистрация после первого  же запроса на авторизацию?
>>
>>Думаю стоит смотреть в астериске проблему, а не в циске.
>
>Взято от сюда - http://www.voip-info.org/wiki-Asterisk+cisco+FXO
>REGISTER: Cisco gateway doesn't usually REGISTER with SIP servers, but later versions
>of IOS can (in order to register FXS ports, for instance)
>

Попробуй еще так:

dial-peer voice 30400000 voip
huntstop
preference 1
destination-pattern 3040000
session protocol sipv2
session target ipv4:192.168.11.2
session transport udp
dtmf-relay sip-notify rtp-nte
codec g711alaw
fax protocol pass-through g711alaw
no vad

sip-ua
authentication username *** password ***
retry invite 2

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 20-Дек-08, 06:29 
>[оверквотинг удален]
>session target ipv4:192.168.11.2
>session transport udp
>dtmf-relay sip-notify rtp-nte
>codec g711alaw
>fax protocol pass-through g711alaw
>no vad
>
>sip-ua
>authentication username *** password ***
>retry invite 2

У меня сейчас конфиг такой (сейчас из локалке с астериском воюю, IP другие и логин другой пробую)
dial-peer voice 3040000 voip
preference 1
destination-pattern 3040000
redirect ip2ip
b2bua
voice-class sip transport switch udp tcp
session protocol sipv2
session target ipv4:192.168.18.12
acc-qos guaranteed-delay
codec g711alaw

!
sip-ua
credentials username 902401 password 1212121212 realm 192.168.18.5
authentication username 902401 password 7 1212121212121 realm 192.168.18.5
no remote-party-id
set sip-status 400 pstn-cause 1
set sip-status 404 pstn-cause 3
set sip-status 480 pstn-cause 19
set sip-status 502 pstn-cause 1
set sip-status 503 pstn-cause 27
retry invite 3
retry response 3
retry bye 3
retry cancel 3
retry register 10
timers connect 100
timers connection aging 30
timers register 100
registrar ipv4:192.168.18.12:5060 expires 3600
sip-server ipv4:192.168.18.12:5060
notify telephone-event max-duration 3000
  host-registrar
!
Так что глобальных отличий не вижу, только побольше всего. Или чо-то в конфе не так?
А что могёт с asterisk быть не так, Linksys регается, ebeam тоже, а если что не так, что править то в нём, тама логика работы SIP, мною не менялась, потому что я да же не знаю, возможно ли это.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

17. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от chuvy email(??) on 20-Дек-08, 06:40 
>[оверквотинг удален]
> sip-server ipv4:192.168.18.12:5060
> notify telephone-event max-duration 3000
>  host-registrar
>!
>Так что глобальных отличий не вижу, только побольше всего. Или чо-то в
>конфе не так?
>А что могёт с asterisk быть не так, Linksys регается, ebeam тоже,
>а если что не так, что править то в нём, тама
>логика работы SIP, мною не менялась, потому что я да же
>не знаю, возможно ли это.

Это попробуй добавить в диал пир.
session transport udp
dtmf-relay sip-notify rtp-nte

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

16. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 20-Дек-08, 06:39 
>Взято от сюда - http://www.voip-info.org/wiki-Asterisk+cisco+FXO
>REGISTER: Cisco gateway doesn't usually REGISTER with SIP servers, but later versions
>of IOS can (in order to register FXS ports, for instance)
>

НУ ИОС новый довольно у меня, должно регаться по любому, описалово я читал, там не совсем то кажись или не целиком, в сущности нет FXS или FXO у меня нет, я пытаюсь звонок из Е1 и обязательно прорегатся на asterisk, что бы маршрутизацию номано настроить.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

18. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 22-Дек-08, 06:40 
Дебаг в астериске, такой, приходит сообщение register, формируется ответ trying, а потом 401, второй раз циска не посылает register.
В дебаге cisco, два раза подрят register, ну а потом ответ от астериска получается trying и register. Как выправить сию штуку, кто-нибудь знает?
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

19. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 23-Дек-08, 10:54 
>Дебаг в астериске, такой, приходит сообщение register, формируется ответ trying, а потом
>401, второй раз циска не посылает register.
>В дебаге cisco, два раза подрят register, ну а потом ответ от
>астериска получается trying и register. Как выправить сию штуку, кто-нибудь знает?
>

На новом ИОС c5400-js-mz.124-23.bin, два раза не валится, просто нет повторного register после сообщения 401.

Конфиг AS5400
!
dial-peer voice 3030000 voip
preference 1
destination-pattern 3030000
redirect ip2ip
voice-class sip transport switch udp tcp
session protocol sipv2
session target ipv4:192.168.18.120
acc-qos guaranteed-delay
codec g711alaw
!
!
sip-ua
credentials username 902401 password 12122121212121 realm 192.168.18.120
authentication username 902401 password 121212121212121 realm 192.168.18.120
no remote-party-id
set sip-status 400 pstn-cause 1
set sip-status 404 pstn-cause 3
set sip-status 480 pstn-cause 19
set sip-status 502 pstn-cause 1
set sip-status 503 pstn-cause 27
retry invite 3
retry response 3
retry bye 3
retry cancel 3
retry register 10
timers connect 100
timers connection aging 30
timers register 100
registrar ipv4:192.168.18.120:5060 expires 3600
sip-server ipv4:192.168.18.120:5060
notify telephone-event max-duration 3000
!

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

20. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от Cyrill Malevanov email on 25-Дек-08, 10:32 
>Cisco отказывается слать SIP запросы на регистрацию на asterisk, читал два мана
>
>http://www.cisco.com/en/US/docs/ios/12_3/sip/configuration/g...
>https://www.opennet.ru/tips/info/1456.shtml
>Вроде бы всё понятно, немного отличаются по тому писать или не писать
>registrar, когда надо соединиться с asterisk.
>Вот, что я написал в конфигах на cisco
>

А не проще регистрацию по юзернейму отменить, и связать их просто как пиры, по ип-адресам?
Благо, как я понимаю, циска на статическом ипе, астериск тоже.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

21. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от pbxware email(ok) on 25-Дек-08, 11:47 
А cisco вообще зачем тут?
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

23. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(??) on 25-Дек-08, 15:40 
>А cisco вообще зачем тут?

Не понял вопроса???

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

24. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от pbxware email(ok) on 25-Дек-08, 19:30 
>>А cisco вообще зачем тут?
>
>Не понял вопроса???

ну мне интересно, что делаете на cisco, и вижу, что уже есть Asteirsk. Вот и интересно, зачем циска, так как не могу понять, чего нельзя сделать на asterisk.

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

25. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(ok) on 26-Дек-08, 06:22 
>>>А cisco вообще зачем тут?
>>
>>Не понял вопроса???
>
>ну мне интересно, что делаете на cisco, и вижу, что уже есть
>Asteirsk. Вот и интересно, зачем циска, так как не могу понять,
>чего нельзя сделать на asterisk.

Ну что звонки принемает из сети по DSS1 и льёт немножко звоночков на asterisk.

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

26. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от pbxware email(ok) on 26-Дек-08, 13:42 
>>>>А cisco вообще зачем тут?
>Ну что звонки принемает из сети по DSS1 и льёт немножко звоночков
>на asterisk.

Ну вот и я про это. Втыкайте в Asterisk плату Digium TE120P, настраивайте E1/PRI, и выкиньте циску.

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

27. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(??) on 26-Дек-08, 21:08 
>>>>>А cisco вообще зачем тут?
>>Ну что звонки принемает из сети по DSS1 и льёт немножко звоночков
>>на asterisk.
>
>Ну вот и я про это. Втыкайте в Asterisk плату Digium TE120P,
>настраивайте E1/PRI, и выкиньте циску.

Да же спорить не буду. Но циска есть циска, вообщем я такой вариант расматривать не собираюсь. В гробу я видел праблы с этими картами. Да и бегает весь траф по h323 у меня и маршрутизация всякая разрулена тама да и привычно, работа более стабильная, да и вообще енто cisco.

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

22. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от EXA email(??) on 25-Дек-08, 15:40 
>А не проще регистрацию по юзернейму отменить, и связать их просто как
>пиры, по ип-адресам?
>Благо, как я понимаю, циска на статическом ипе, астериск тоже.

Ну вообщем так и сделал то в конце концов, ну думаю, но иногда бывает, что на чужие сервера, надо будет по паролю и логину, хоть и можно только на один-то сервак зарегаться.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

28. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от Алексей (??) on 07-Фев-11, 10:57 
>>А не проще регистрацию по юзернейму отменить, и связать их просто как
>>пиры, по ип-адресам?
>>Благо, как я понимаю, циска на статическом ипе, астериск тоже.
> Ну вообщем так и сделал то в конце концов, ну думаю, но
> иногда бывает, что на чужие сервера, надо будет по паролю и
> логину, хоть и можно только на один-то сервак зарегаться.

дописать в sip-ua:
username user1 password pass1  realm 192.168.10.3

и должно работать

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

29. "Cisco AS5350 регистрация по SIP"  +/
Сообщение от TrEK email(ok) on 11-Апр-13, 12:03 
>[оверквотинг удален]
>>
>>http://www.cisco.com/en/US/docs/ios/12_3/sip/configuration/g...
>>https://www.opennet.ru/tips/info/1456.shtml
>>Вроде бы всё понятно, немного отличаются по тому писать или не писать
>>registrar, когда надо соединиться с asterisk.
>>Вот, что я написал в конфигах на cisco
>>
> А не проще регистрацию по юзернейму отменить, и связать их просто как
> пиры, по ип-адресам?
> Благо, как я понимаю, циска на статическом ипе, астериск тоже.

Подскажите как ?
Что надо на Циске ,и что надо в Астере прописать ??
в sip-ua
ip-server ipv4:192.168.180.44 (192.168.180.44 айпи астера?)
а далее:

authentication username test password 111D1C1603
retry invite 3
retry response 3
retry bye 3
retry cancel 3
retry options 0
timers trying 1000
registrar ipv4:192.168.180.44 expires 3600
sip-server ipv4:192.168.180.44

или authentication  убрать? И чем это чревато?


Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру