The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Policy Based Routing и Tracking"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"Policy Based Routing и Tracking"  
Сообщение от Nec (??) on 05-Ноя-08, 15:47 
Помогите разобраться!

У меня настроен Policy Routing с функцией слежения (tracking).
Но вот такая возникла проблема!

ip sla monitor 1
type echo protocol ipIcmpEcho 100.100.100.100 source-interface Dialer1
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho 20.20.20.2 source-interface FastEthernet0/1
ip sla monitor schedule 2 life forever start-time now

track 123 rtr 1 reachability
!
track 124 rtr 2 reachability

interface FastEthernet0/0
description <<<ISP2>>>
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 20
!
interface FastEthernet0/1
description <<<ISP1>>>
ip address 20.20.20.1
ip inspect firewall in
ip ips myips in
ip nat outside
ip virtual-reassembly
duplex auto
speed auto

interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 500
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username nnnn password 7 xxxxxxxxx


ip route 0.0.0.0 0.0.0.0 ISP1

interface Vlan20
description <<<LAN>>>
ip address 192.168.1.1 255.255.255.0
ip pim dense-mode
ip nat inside
ip virtual-reassembly
ip policy route-map POLICY

route-map POLICY permit 10
match ip address ACCESS_LIST
set ip next-hop verify-availability 10.10.10.2 10 track 124
set ip next-hop verify-availability 100.100.100.100 20 track 123
set ip next-hop 100.100.100.100

ip access-list extended ACCESS_LIST
deny ip 192.168.1.0 0.0.0.255 DMZ1
deny ip DMZ1 192.168.1.0 0.0.0.255
deny ip 192.168.1.0 0.0.255.255 192.168.1.0 0.0.255.255
permit ip any any

Не пойму! Изначально все работает через ISP1(debug ip policy показывает что policy routed через ISP1). Делаю F0/1 shut - связь вообще проподает(debug ip policy показывает normal forwarding). Нет переключения. Перед этим смотрел sh track br - оба up, после shut F0/1 оба down.
Можно ли использовать в set ip next-hop verify-availability 100.100.100.100 20 track 123 чтобы 100.100.100.100 какой-то хост в интернете на который включен тракинг?



Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Policy Based Routing и Tracking"  
Сообщение от sh_ email(??) on 05-Ноя-08, 18:30 
А вы не shut делайте, а провод вынимайте...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Policy Based Routing и Tracking"  
Сообщение от Nec (??) on 06-Ноя-08, 10:19 

Вынимал, включается normal forwarding, преключения не происходит. А должно быть policy routed на другого провайдера...

>А вы не shut делайте, а провод вынимайте...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру