The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"как организовать NAT "
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"как организовать NAT "  
Сообщение от Protector email(ok) on 30-Окт-08, 12:59 
Имею следующую схему
                  
               GE0/0          GE0/1  
| local lan       |-----------| 195.*.*.1/28
|10.0.0.0/24 ---- | cisco nat |-------------
|                 |-----------|

на цыске настроен nat

interface GigabitEthernet0/0
  ip address 10.0.0.1 255.255.255.240
  ip nat inside

interface GigabitEthernet0/1
description TO INTERNET
ip address 195.*.*.1 255.255.255.240
ip nat outside

ip nat inside source list 5 interface GigabitEthernet0/1 overload
ip nat inside source static 10.0.0.1 195.*.*.2
ip nat inside source static 10.0.0.2 195.*.*.3
ip nat inside source static 10.0.0.3 195.*.*.4


Далее модернизирую схему
               GE0/0          GE0/1  
| local lan       |-----------| 195.*.*.1/28
|10.0.0.0/24 ---- | cisco nat |-------------
|                 |-----------|
                        |FE 1/0
                        |192.168.0.0/24
                        |

теперь мне нужно, чтобы машины из локальной сетки попадали в сеть 192.168.0.0 натируясь интерфейсом FE 1/0

что-то не допру как это сделать.

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "как организовать NAT "  
Сообщение от mic (ok) on 30-Окт-08, 13:15 
а если просто сети промаршрутизировать? зачем нат-то
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "как организовать NAT "  
Сообщение от Protector email(ok) on 30-Окт-08, 13:21 
>а если просто сети промаршрутизировать? зачем нат-то

нет. не подойдет.
два разных предприятия со своей адресацией....
нужен именно нат

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "как организовать NAT "  
Сообщение от Protector email(ok) on 30-Окт-08, 13:31 
прошу прощения.. не совем верно описал схему которую хочу получить

на интерфейсе FE1/0 опорная сеть - дальше еще один рутер

т.е. FE0/1 192.168.0.1/30 ------ 192.168.0.2./30  ----- сеть 192.168.0.5/30

вот в эту сеть 192.168.0.5/30 мне и нужно пройти....
и просто роутинг здесь не пройдет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "как организовать NAT "  
Сообщение от Square (ok) on 30-Окт-08, 15:13 
>прошу прощения.. не совем верно описал схему которую хочу получить
>
>на интерфейсе FE1/0 опорная сеть - дальше еще один рутер
>
>т.е. FE0/1 192.168.0.1/30 ------ 192.168.0.2./30  ----- сеть 192.168.0.5/30
>
>вот в эту сеть 192.168.0.5/30 мне и нужно пройти....
>и просто роутинг здесь не пройдет.

кинуть тоннель в ту сеть и просто маршрутизировать? нат то зачем?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "как организовать NAT "  
Сообщение от Protector email(ok) on 30-Окт-08, 16:09 
>>прошу прощения.. не совем верно описал схему которую хочу получить
>>
>>на интерфейсе FE1/0 опорная сеть - дальше еще один рутер
>>
>>т.е. FE0/1 192.168.0.1/30 ------ 192.168.0.2./30  ----- сеть 192.168.0.5/30
>>
>>вот в эту сеть 192.168.0.5/30 мне и нужно пройти....
>>и просто роутинг здесь не пройдет.
>
>кинуть тоннель в ту сеть и просто маршрутизировать? нат то зачем?

просто сеть назначения не принадлежит мне.
для меня выставлен просто фтп сервер, к которому должны конектиться юзеры моей локальной сети. А в сети 192.168.0.5/30 маршрута на мою локальную сеть нет и быть не должно

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "как организовать NAT "  
Сообщение от GolDi (??) on 30-Окт-08, 18:20 
>[оверквотинг удален]
>>>
>>>вот в эту сеть 192.168.0.5/30 мне и нужно пройти....
>>>и просто роутинг здесь не пройдет.
>>
>>кинуть тоннель в ту сеть и просто маршрутизировать? нат то зачем?
>
>просто сеть назначения не принадлежит мне.
>для меня выставлен просто фтп сервер, к которому должны конектиться юзеры моей
>локальной сети. А в сети 192.168.0.5/30 маршрута на мою локальную сеть
>нет и быть не должно

ну так напишите nat outside на FA0/1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "как организовать NAT "  
Сообщение от Protector email(ok) on 30-Окт-08, 18:23 
>[оверквотинг удален]
>>>>и просто роутинг здесь не пройдет.
>>>
>>>кинуть тоннель в ту сеть и просто маршрутизировать? нат то зачем?
>>
>>просто сеть назначения не принадлежит мне.
>>для меня выставлен просто фтп сервер, к которому должны конектиться юзеры моей
>>локальной сети. А в сети 192.168.0.5/30 маршрута на мою локальную сеть
>>нет и быть не должно
>
> ну так напишите nat outside на FA0/1

и писал... все начинает идти через FE1/0 ...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "как организовать NAT "  
Сообщение от Grid (ok) on 30-Окт-08, 19:46 
>> ну так напишите nat outside на FA0/1
>
>и писал... все начинает идти через FE1/0 ...

route-map используйте в конструкции "ip nat inside source...",
либо два разных ACL, на интернетовский вешаете:
deny ip 10.0.0.0 0.0.0.15 192.168.0.0 0.0.0.255
premit ip 10.0.0.0 0.0.0.15 any
на тот который в чужую сеть:
permit ip 10.0.0.0 0.0.0.15 192.168.0.0 0.0.0.255

вроде должно заработать, попробуйте.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "как организовать NAT "  
Сообщение от Protector email(ok) on 31-Окт-08, 11:08 
спасибо за совет.
сделал при помощи route-map

route-map mymap permit 10
match ip address 110

access-list 110 permit ip 10.0.0.0 0.0.0.255 192.168.0.4 0.0.0.3

ip nat inside source route-map mymap interface FastEthernet1/0 overload

заработало, кроме тех кто прокидывается в инет по статик нату

(ip nat inside source static 10.0.0.1 195.*.*.2
ip nat inside source static 10.0.0.2 195.*.*.3
ip nat inside source static 10.0.0.3 195.*.*.4)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру