The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"не хочет работать callback"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [ Отслеживать ]

"не хочет работать callback"  
Сообщение от xeno email(ok) on 15-Авг-08, 14:01 
Помогите !

я в cisco IOS практически не работал, тут понадобилось

есть роутер cisco 3725 с 16-ти портовым модемом NM-16AM
по экзамплам дайлап настроил для доступа в локальную сеть, заработал сразу

а вот callback не хочет работать.

как только прописываю ppp callback accept звонки принимает, аутентификация проходит,
но на компьютере с которых звонил окно проверка имени и пароля висит и не закрывается,
телефонная линия остаеться включенной

долго гуглил, нашел описание точно такой же проблемы, но решения нет.
и лог дебага заканчиваеться точно так же:
http://www.lslnet.com/linux/edosc/31/linux-31243896.htm

мой дебаг:

*Mar  1 03:08:21.911: As34 PAP: I AUTH-REQ id 33 len 20 from "ppp"
*Mar  1 03:08:21.911: As34 PAP: Authenticating peer ppp
*Mar  1 03:08:21.911: As34 PPP: Phase is FORWARDING, Attempting Forward
*Mar  1 03:08:21.911: As34 PPP: Phase is AUTHENTICATING, Unauthenticated User
*Mar  1 03:08:21.915: As34 PPP: Phase is FORWARDING, Attempting Forward
*Mar  1 03:08:21.915: As34 PPP: Phase is AUTHENTICATING, Authenticated User
*Mar  1 03:08:21.915: As34 PAP: O AUTH-ACK id 33 len 5
*Mar  1 03:08:21.915: As34 PPP: Phase is UP
*Mar  1 03:08:21.915: As34 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar  1 03:08:21.915: As34 IPCP:    Address 1.1.1.1 (0x030601010101)
*Mar  1 03:08:21.915: As34 PPP: Process pending ncp packets
*Mar  1 03:08:22.915: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async34, changed state to up
*Mar  1 03:08:23.907: As34 IPCP: TIMEout: State REQsent
*Mar  1 03:08:23.907: As34 IPCP: O CONFREQ [REQsent] id 2 len 10
*Mar  1 03:08:23.907: As34 IPCP:    Address 1.1.1.1 (0x030601010101)
*Mar  1 03:08:25.923: As34 IPCP: TIMEout: State REQsent
*Mar  1 03:08:25.923: As34 IPCP: O CONFREQ [REQsent] id 3 len 10
*Mar  1 03:08:25.923: As34 IPCP:    Address 1.1.1.1 (0x030601010101)
*Mar  1 03:08:27.939: As34 IPCP: TIMEout: State REQsent
*Mar  1 03:08:27.939: As34 IPCP: O CONFREQ [REQsent] id 4 len 10
*Mar  1 03:08:27.939: As34 IPCP:    Address 1.1.1.1 (0x030601010101)
*Mar  1 03:08:29.955: As34 IPCP: TIMEout: State REQsent
*Mar  1 03:08:29.955: As34 IPCP: O CONFREQ [REQsent] id 5 len 10
*Mar  1 03:08:29.955: As34 IPCP:    Address 1.1.1.1 (0x030601010101)
*Mar  1 03:08:31.971: As34 IPCP: TIMEout: State REQsent
*Mar  1 03:08:31.971: As34 IPCP: O CONFREQ [REQsent] id 6 len 10
*Mar  1 03:08:31.971: As34 IPCP:    Address 1.1.1.1 (0x030601010101)
..........................
и так до бесконечности
после успешной авторизации циска по интерфейсу чтото посылает, а в ответ ничего не приходит

Кто-нибудь может подсказать куда смотреть ?

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "не хочет работать callback"  
Сообщение от xeno email(??) on 20-Авг-08, 14:39 
Вот полный конфиг:

router#sh run
Building configuration...

Current configuration : 2270 bytes
!
! Last configuration change at 16:31:40 TMN Wed Aug 20 2008
! NVRAM config last updated at 21:44:58 TMN Mon Mar 1 1993
!
version 12.3
service exec-callback
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 <cenzored>
enable password 7 <cenzored>
!
username ppp password 7 <cenzored>
username nikitin callback-dialstring "" password 7 <cenzored>
username protasov callback-dialstring "" password 7 <cenzored>
clock timezone TMN 5
clock summer-time TMN recurring last Sun Mar 2:00 last Sun Oct 2:00
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ftp-server write-enable
async-bootp dns-server 192.168.1.1 192.168.1.11
!
chat-script offhook "" "ATH1" OK
chat-script clcp-script ABORT ERROR ABORT BUSY ABORT "NO CARRIER" ABORT "NO ANSWER" ABORT "NO DIALTONE" ABORT RING "" "ATZ" OK "ATH1" OK "ATDT \T" TIMEOUT 120  CONNECT \c
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.200.104 255.255.255.0
speed auto
full-duplex
no mop enabled
!
interface Serial0/0
no ip address
shutdown
no fair-queue
clockrate 2000000
!
interface FastEthernet0/1
ip address 192.168.1.45 255.255.255.0
duplex auto
speed auto
!
interface Group-Async1
ip unnumbered Loopback0
encapsulation ppp
dialer in-band
dialer idle-timeout 600
dialer-group 1
async mode interactive
peer default ip address pool DIALIN
ppp callback accept
ppp authentication pap callin callback
group-range 33 48
!
ip local pool DIALIN 192.168.1.251 192.168.1.254
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.11
ip http server
!
dialer-list 1 protocol ip permit
snmp-server community public RO
snmp-server enable traps tty
!
line con 0
line 33 48
script dialer offhook
script modem-off-hook offhook
script callback clcp-script
modem InOut
transport input all
autoselect during-login
autoselect ppp
callback forced-wait 10
line aux 0
line vty 0 4
password 7 <cenzored>
login
!
ntp clock-period 17180131
ntp source FastEthernet0/1
ntp master 15
ntp server 192.168.1.18 version 1 key 0 prefer
end


Если убрать строчку ppp callback accept с роутером модемами прекрасно соеденяемся, все работает.
А со включенным callback на экране вызывающего висит "Проверка имени и пароля" и все..
Если имя пароль неверные, то в соеденении отказывает правильно.

Гуру, посоветуйте хоть что-нибудь !

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "не хочет работать callback"  
Сообщение от xeno email(??) on 20-Авг-08, 14:47 
Вот лог:

router#sh debug
COMPRESS:
  COMPRESS debugging is on
Dial on demand:
  Dial on demand events debugging is on
Call Management:
  Call Management debugging is on
CSM Modem Management:
  Modem Management Call Switching Module debugging is on
PPP:
  PPP event debugging is on
  PPP detailed event debugging is on
  PPP protocol errors debugging is on
  PPP packet display debugging is on
  PPP Callback Control Protocol debugging is on


router#sh log
Syslog logging: enabled (0 messages dropped, 1 messages rate-limited, 0 flushes, 0 overruns, xml disabled)
    Console logging: level debugging, 3020 messages logged, xml disabled
    Monitor logging: level debugging, 0 messages logged, xml disabled
    Buffer logging: level debugging, 3020 messages logged, xml disabled
    Logging Exception size (4096 bytes)
    Count and timestamp logging messages: disabled
    Trap logging: level informational, 148 message lines logged

Log Buffer (4096 bytes):
21.675: Call Handle failed for Modem 1/1
Aug 20 10:40:23.819: As34 PPP: I pkt type 0xC021, datagramsize 27 link[ppp]
Aug 20 10:40:23.819: As34 PPP: I pkt type 0xC021, datagramsize 27 link[ppp]
Aug 20 10:40:23.819: As34 EVT: Packet 0 0x62069F50
Aug 20 10:40:23.819: As34 LCP: I CONFREQ [Closed] id 1 len 23
Aug 20 10:40:23.819: As34 LCP:    ACCM 0x00000000 (0x020600000000)
Aug 20 10:40:23.819: As34 LCP:    MagicNumber 0x0687261D (0x05060687261D)
Aug 20 10:40:23.819: As34 LCP:    PFC (0x0702)
Aug 20 10:40:23.819: As34 LCP:    ACFC (0x0802)
Aug 20 10:40:23.819: As34 LCP:    Callback 6  (0x0D0306)
Aug 20 10:40:23.819: As34 LCP: Lower layer not up, Fast Starting
Aug 20 10:40:23.819: As34 LCP: O CONFREQ [Listen] id 9 len 24
Aug 20 10:40:23.819: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Aug 20 10:40:23.819: As34 LCP:    AuthProto PAP (0x0304C023)
Aug 20 10:40:23.819: As34 LCP:    MagicNumber 0x1CD4ED78 (0x05061CD4ED78)
Aug 20 10:40:23.819: As34 LCP:    PFC (0x0702)
Aug 20 10:40:23.819: As34 LCP:    ACFC (0x0802)
Aug 20 10:40:23.819: As34 LCP: O CONFACK [Listen] id 1 len 23
Aug 20 10:40:23.819: As34 LCP:    ACCM 0x00000000 (0x020600000000)
Aug 20 10:40:23.819: As34 LCP:    MagicNumber 0x0687261D (0x05060687261D)
Aug 20 10:40:23.819: As34 LCP:    PFC (0x0702)
Aug 20 10:40:23.819: As34 LCP:    ACFC (0x0802)
Aug 20 10:40:23.819: As34 LCP:    Callback 6  (0x0D0306)
Aug 20 10:40:23.823: %LINK-3-UPDOWN: Interface Async34, changed state to up
Aug 20 10:40:23.823: As34 DDR: Dialer statechange to up
Aug 20 10:40:23.823: As34 DDR: Dialer received incoming call from <unknown>
Aug 20 10:40:23.951: As34 PPP: I pkt type 0xC021, datagramsize 28 link[ppp]
Aug 20 10:40:23.951: As34 PPP: I pkt type 0xC021, datagramsize 28 link[ppp]
Aug 20 10:40:23.951: As34 EVT: Packet 0 0x6206A24C
Aug 20 10:40:23.951: As34 LCP: I CONFACK [ACKsent] id 9 len 24
Aug 20 10:40:23.951: As34 LCP:    ACCM 0x000A0000 (0x0206000A0000)
Aug 20 10:40:23.951: As34 LCP:    AuthProto PAP (0x0304C023)
Aug 20 10:40:23.951: As34 LCP:    MagicNumber 0x1CD4ED78 (0x05061CD4ED78)
Aug 20 10:40:23.951: As34 LCP:    PFC (0x0702)
Aug 20 10:40:23.951: As34 LCP:    ACFC (0x0802)
Aug 20 10:40:23.967: As34 PPP: I pkt type 0xC021, datagramsize 20 link[ppp]
Aug 20 10:40:23.967: As34 PPP: I pkt type 0xC021, datagramsize 20 link[ppp]
Aug 20 10:40:23.967: As34 EVT: Packet 0 0x6181E1FC
Aug 20 10:40:23.967: As34 LCP: I IDENTIFY [Open] id 2 len 18 magic 0x0687261D MSRASV5.10
Aug 20 10:40:23.971: As34 PPP: I pkt type 0xC021, datagramsize 26 link[ppp]
Aug 20 10:40:23.971: As34 PPP: I pkt type 0xC021, datagramsize 26 link[ppp]
Aug 20 10:40:23.971: As34 EVT: Packet 0 0x6181DF00
Aug 20 10:40:23.971: As34 LCP: I IDENTIFY [Open] id 3 len 24 magic 0x0687261D MSRAS-0-COMPUTER
Aug 20 10:40:23.975: As34 PPP: I pkt type 0xC023, datagramsize 29 link[ppp]
Aug 20 10:40:23.975: As34 PPP: I pkt type 0xC023, datagramsize 29 link[ppp]
Aug 20 10:40:23.979: As34 EVT: Auth Packet 0 0x6181DC04
Aug 20 10:40:23.979: As34 PAP: I AUTH-REQ id 53 len 27 from "protasov"
Aug 20 10:40:23.979: As34 EVT: Hook 1 0x00000000
Aug 20 10:40:23.979: As34 EVT: Forwarded 0 0x00000000
Aug 20 10:40:23.979: As34 EVT: AAA Response 0 0x6222CEA4
Aug 20 10:40:23.979: As34 EVT: Hook 1 0x00000000
Aug 20 10:40:23.979: As34 EVT: Forwarded 0 0x00000000
Aug 20 10:40:23.979: As34 DDR: Remote name for protasov
Aug 20 10:40:23.979: As34 DDR: Authenticated host protasov with no matching dialer map
Aug 20 10:40:23.979: As34 EVT: AAA Response 0 0x622ABC00
Aug 20 10:40:23.979: As34 EVT: AAA Response 0 0x620BED68
Aug 20 10:40:23.979: As34 PAP: O AUTH-ACK id 53 len 5
Aug 20 10:40:23.979: As34 IPCP: O CONFREQ [Closed] id 1 len 10
Aug 20 10:40:23.979: As34 IPCP:    Address 1.1.1.1 (0x030601010101)
Aug 20 10:40:25.971: As34 IPCP: TIMEout: State REQsent
Aug 20 10:40:25.971: As34 IPCP: O CONFREQ [REQsent] id 2 len 10
Aug 20 10:40:25.971: As34 IPCP:    Address 1.1.1.1 (0x030601010101)
Aug 20 10:40:27.987: As34 IPCP: TIMEout: State REQsent
Aug 20 10:40:27.987: As34 IPCP: O CONFREQ [REQsent] id 3 len 10
Aug 20 10:40:27.987: As34 IPCP:    Address 1.1.1.1 (0x030601010101)

И на этом все заканчиваеться
А что такое dialer map ? может с этим связано ?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру