The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Настройка IPTV на Cisco1841"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]

"Настройка IPTV на Cisco1841"  +/
Сообщение от Agava80 email(ok) on 25-Янв-14, 23:05 
Уважаемые коллеги, добрый вечер.

Прошу вашей интеллектуальной помощи в следующей вопросе:
Имеется подключение к провайдеру CITYTELECOM.RU на тарифе с IPTV.
Провайдер предлагает смотреть это IPTV или через TV-приставку или с использованием VCL-плеера, путем скачивания со своего сайта плей-листа.
Имеется маршрутизатор Cisco 1841 с карточкой расширения HWIC-4ESW.
Интерфейс FA 0/0 смотрит на провайдера. Настройки получает от DHCP-провайдера.
Интерфейс FA 0/1 смотрит в "домашний" роутер (точнее в его свитч-часть, минуя WAN).

Цель: настроить трансляцию IPTV от провайдера на все интерфейсы (и на FA 0/1 и на все интерфейсы модуля HWIC-4ESW. Данные интерфейсы 1841 видит как FA 0/0/0, FA 0/0/1, FA 0/0/2, FA 0/0/3).

Увы, моих знаний не хватает, чтобы приблизиться к решению данной задачи.

Изучая вопрос, прочитал множество найденных статей. В центре внимания всех статей:
1) Включение "ip multicast-routing" в глобальной конфигурации.
2) Включение "ip pim sparse-dense-mode" на всех интерфейсах.
3) Включение "ip igmp helper-address", где в качестве конечного параметра, предлагается прописать "DEFAULT-GATEWAY" провайдера.

В процессе настройки, возникло несколько вопросов:
1) Как определить, в каком режиме провайдер транслирует IPTV. Или это не имеет значения?
2) Каким образом указать "ip igmp helper-address", если "DEFAULT-GATEWAY" провайдера меняется, то есть, он выдает адреса из разных пулов.

Все это мною было сделано. Увы. Результат отрицательный.
Самое обидное, что тот же самый "домашний" роутер TP-LINK без труда справляется с этой задачей. Также понимаю, что дело во мне, в отсутствии знаний. Но, тем не менее, хочется добиться результата именно с 1841.
Прошу не судить строго. Также, если не очень трудно, прошу писать развернутые ответы, с пояснениями, так как я новичок.

Заранее, спасибо.

С уважением, Дмитрий.

Конфигурация моего роутера Cisco 1841.

version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname TEST
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 *************************
!
no aaa new-model
!
clock timezone Russia 4 0
clock calendar-valid
dot11 syslog
ip source-route
!
!
ip dhcp excluded-address 192.168.253.1 192.168.253.100
!
ip dhcp pool TEST_DHCP_POOL_253
network 192.168.253.0 255.255.255.0
default-router 192.168.253.1
dns-server 192.168.253.1 62.152.51.2 62.152.42.2
domain-name TEST
lease 8
!
ip dhcp pool TEST_DHCP_POOL_254
network 192.168.254.0 255.255.255.0
default-router 192.168.254.1
dns-server 192.168.254.1 62.152.51.2 62.152.42.2
domain-name TEST
lease 8
!
!
!
ip cef
no ip domain lookup
ip domain name TEST
ip multicast-routing
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO1841 sn *********
username supervisor privilege 15 secret 5 ********************************
!
redundancy
!
!
ip ssh version 2
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
bandwidth 30000
ip address dhcp
no ip proxy-arp
ip pim sparse-dense-mode
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto

!
interface FastEthernet0/1
ip address 192.168.254.1 255.255.255.0
ip pim sparse-dense-mode
ip nat inside
ip virtual-reassembly in
ip igmp helper-address 31.28.3.1 \\ Данное значение, я подставил после получаения адреса от провайдера
duplex auto
speed auto
!
interface FastEthernet0/0/0
switchport access vlan 253
no ip address
spanning-tree portfast
!
interface FastEthernet0/0/1
switchport access vlan 253
no ip address
spanning-tree portfast
!
interface FastEthernet0/0/2
switchport access vlan 253
no ip address
spanning-tree portfast
!
interface FastEthernet0/0/3
switchport access vlan 253
no ip address
spanning-tree portfast
!
interface Vlan1
no ip address
shutdown
!
interface Vlan253
ip address 192.168.253.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source route-map INTERNET interface FastEthernet0/0 overload
!
ip access-list extended permitinternet
permit ip 192.168.253.0 0.0.0.255 any
permit ip 192.168.254.0 0.0.0.255 any
!
!
!
!
route-map INTERNET permit 10
match ip address permitinternet
!
!
!
control-plane
!
!
alias exec c conf t
alias exec s show run
!
line con 0
access-class INTERNET in
access-class INTERNET out
exec-timeout 30 0
logging synchronous
login local
line aux 0
line vty 0 4
access-class INTERNET in
access-class INTERNET out
exec-timeout 0 0
logging synchronous
login local
transport preferred ssh
transport input ssh
transport output ssh
line vty 5 15
access-class INTERNET in
access-class INTERNET out
exec-timeout 0 0
logging synchronous
login local
transport preferred ssh
transport input ssh
transport output ssh
!
scheduler allocate 20000 1000
end

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Настройка IPTV на Cisco1841"  +/
Сообщение от Agava80 email(ok) on 26-Янв-14, 19:52 
Доброго времени суток, уважаемые коллеги.

Проблема была решена следующим образом:

ip multicast-routing
!
interface FA0/0
  description WAN + IPTV
  ip pim sparse-dense-mode
!
interface FA0/1
  description LAN
  ip pim sparse-dense-mode
  ip igmp helper-address 31.28.3.1  <<-- IGMP router провайдера в сегменте, к которому я подключен... Он же - Default Gateway.
!
interface VLAN 253
  description VLAN for HWIC-4ESW (Switch Module)
  ip pim sparse-dense-mode
  ip igmp helper-address 31.28.3.1  <<-- IGMP router провайдера в сегменте, к которому я подключен... Он же - Default Gateway.
!
ip pim rp-address 31.28.3.1 override  <<-- Рандеву поинт, шлюз IP TV моего провайдера, он же - Default Gateway.

Всем спасибо.

С уважением, Дмитрий.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Настройка IPTV на Cisco1841"  +/
Сообщение от ShyLion (ok) on 27-Янв-14, 06:59 
>[оверквотинг удален]
> interface VLAN 253
>   description VLAN for HWIC-4ESW (Switch Module)
>   ip pim sparse-dense-mode
>   ip igmp helper-address 31.28.3.1  <<-- IGMP router провайдера в
> сегменте, к которому я подключен... Он же - Default Gateway.
> !
> ip pim rp-address 31.28.3.1 override  <<-- Рандеву поинт, шлюз IP TV
> моего провайдера, он же - Default Gateway.
> Всем спасибо.
> С уважением, Дмитрий.

Вот пример отличного участника форума. Сам разобрался и не поленился поделиться знанием.
Спасибо тебе!

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

5. "Настройка IPTV на Cisco1841"  +/
Сообщение от Guest (??) on 15-Июл-15, 12:41 
>[оверквотинг удален]
> interface VLAN 253
>   description VLAN for HWIC-4ESW (Switch Module)
>   ip pim sparse-dense-mode
>   ip igmp helper-address 31.28.3.1  <<-- IGMP router провайдера в
> сегменте, к которому я подключен... Он же - Default Gateway.
> !
> ip pim rp-address 31.28.3.1 override  <<-- Рандеву поинт, шлюз IP TV
> моего провайдера, он же - Default Gateway.
> Всем спасибо.
> С уважением, Дмитрий.

А как узнать этот самый ip pim rp-address провайдера?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

6. "Настройка IPTV на Cisco1841"  +/
Сообщение от ShyLion (??) on 16-Июл-15, 08:04 
>[оверквотинг удален]
>>   description VLAN for HWIC-4ESW (Switch Module)
>>   ip pim sparse-dense-mode
>>   ip igmp helper-address 31.28.3.1  <<-- IGMP router провайдера в
>> сегменте, к которому я подключен... Он же - Default Gateway.
>> !
>> ip pim rp-address 31.28.3.1 override  <<-- Рандеву поинт, шлюз IP TV
>> моего провайдера, он же - Default Gateway.
>> Всем спасибо.
>> С уважением, Дмитрий.
> А как узнать этот самый ip pim rp-address провайдера?

Вероятно это source адрес в мультикастовых пакетах. Могу ошибаться.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру