The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Ограничение скорости на 3750"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (ACL, фильтрация и ограничение трафика)
Изначальное сообщение [ Отслеживать ]

"Ограничение скорости на 3750"  +/
Сообщение от sas (??) on 05-Май-06, 11:28 
Есть элементарная потребность ограничить скорость клиентам (например на порту fa1/0/7). Имеется Catalyst 3750.
Пробовал 2я способами:
1.

mls qos
!
interface FastEthernet1/0/7
no switchport
ip address 10.0.0.1 255.255.255.0
rate-limit input 64000 1500 2000 conform-action transmit exceed-action drop
rate-limit output 64000 1500 2000 conform-action transmit exceed-action drop
!

подключился, проверил... нет результата

Попробовал другим:

mls qos
!
class-map match-all 100
  match access-group 70
!
!
policy-map 512
  class 100
    police 64000 8000 exceed-action drop
!
access-list 70 permit any
!
interface FastEthernet1/0/7
no switchport
ip address 10.0.0.1 255.255.255.0
service-policy input 512
!


в резльтате ничего.

поскажите пожалуйста что не так либо в 1м либо во 2м случае..a лучше в обоих :)

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Ограничение скорости на 3750"  +/
Сообщение от sas (??) on 05-Май-06, 17:59 
нашел друга по несчастью

http://puck.nether.net/pipermail/cisco-nsp/2005-March/018100...

та же история.. тот же коммутатор

ответов: 0


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Ограничение скорости на 3750"  +/
Сообщение от Wowa (??) on 05-Май-06, 18:03 
Исходящий из порта трафик на 3750 ограничить нельзя.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Ограничение скорости на 3750"  +/
Сообщение от sas (??) on 05-Май-06, 19:10 
>Исходящий из порта трафик на 3750 ограничить нельзя.

а через QoS через входящий других интерфейсов?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Ограничение скорости на 3750"  +/
Сообщение от sas (??) on 06-Май-06, 10:34 
>Исходящий из порта трафик на 3750 ограничить нельзя.

Насколько я разобрался, это не есть проблема, т.к. можно сделать шейпер на loopback, а для него это будет входящим трафиком. Но так и не смог разобраться как коректно все форвардить на loopback....

Подскажите пожалуйста... нужно fa1/0/1 и fa1/0/2 завернуть на loopback

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Ограничение скорости на 3750"  +/
Сообщение от mity on 06-Май-06, 11:27 

>!
>class-map match-all 100
>  match access-group 70
>!
>!
>policy-map 512
>  class 100
>    police 64000 8000 exceed-action drop
>!
>access-list 70 permit any
>!
>interface FastEthernet1/0/7
> no switchport
> ip address 10.0.0.1 255.255.255.0
> service-policy input 512
>!
>
>
>в резльтате ничего.
>
>поскажите пожалуйста что не так либо в 1м либо во 2м случае..a
>лучше в обоих :)

попробуйте 3 вариант, по типу...
mls qos aggregate-policer NAME 5000000 200000 exceed-action drop
mls qos


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Ограничение скорости на 3750"  +/
Сообщение от sas (??) on 06-Май-06, 11:36 
>
>>!
>>class-map match-all 100
>>  match access-group 70
>>!
>>!
>>policy-map 512
>>  class 100
>>    police 64000 8000 exceed-action drop
>>!
>>access-list 70 permit any
>>!
>>interface FastEthernet1/0/7
>> no switchport
>> ip address 10.0.0.1 255.255.255.0
>> service-policy input 512
>>!
>>
>>
>>в резльтате ничего.
>>
>>поскажите пожалуйста что не так либо в 1м либо во 2м случае..a
>>лучше в обоих :)
>
>попробуйте 3 вариант, по типу...
>mls qos aggregate-policer NAME 5000000 200000 exceed-action drop
>mls qos

и все же.. если даже получится, то только входящий.. уже в документации нашел... все сводится к завороту на лупбэк

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Ограничение скорости на 3750"  +/
Сообщение от Nailer (??) on 06-Май-06, 13:02 
>Есть элементарная потребность ограничить скорость клиентам (например на порту fa1/0/7). Имеется Catalyst
>3750.
>Пробовал 2я способами:
>1.
>
>mls qos
>!
>interface FastEthernet1/0/7
> no switchport
> ip address 10.0.0.1 255.255.255.0
> rate-limit input 64000 1500 2000 conform-action transmit exceed-action drop
> rate-limit output 64000 1500 2000 conform-action transmit exceed-action drop
>!
>
>подключился, проверил... нет результата
>
>Попробовал другим:
>
>mls qos
>!
>class-map match-all 100
>  match access-group 70
>!
>!
>policy-map 512
>  class 100
>    police 64000 8000 exceed-action drop
>!
>access-list 70 permit any
>!
>interface FastEthernet1/0/7
> no switchport
> ip address 10.0.0.1 255.255.255.0
> service-policy input 512
>!
>
>
>в резльтате ничего.
>
>поскажите пожалуйста что не так либо в 1м либо во 2м случае..a
>лучше в обоих :)


sh policy-map что говорит?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Ограничение скорости на 3750"  +/
Сообщение от sas (??) on 06-Май-06, 13:38 
>sh policy-map что говорит?

sh access-lists 70

Standard IP access list 70
    10 permit any (23 matches)


sh policy-map

  Policy Map 512
    Class 100
      police 64000 8000 exceed-action drop

sh policy-map interface fa1/0/7

FastEthernet1/0/7

  Service-policy input: 512

    Class-map: 100 (match-all)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: access-group 70

    Class-map: class-default (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
         rate 0 bps

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Ограничение скорости на 3750"  +/
Сообщение от sas (??) on 06-Май-06, 16:25 
> https://www.opennet.ru/base/cisco/loopback.txt.html
>> я плохо понимаю шейпер на loopback. что-то с
>> policy routing?

> Hу да. Допустим у меня есть кучка сериал-интерфейсов
> со скоростью в линии у каждого - 64к. Хочется, чтобы
> все они в сумме отожрали не больше 128к внешнего канала.
> Соответственно, на входном интерфейсе делаешь
> ip policy route-map с set interface loopback NN,
> а на этом loopback делаешь шейпер.

> С точки зрения массового обслуживания это выгоднее, чем
> узкая полоса на каждом из вышеупомянутых сериалов.


делаю

access-list 70 permit any

route-map divert permit 10
match ip address 70
set interface Loopback0

потом

int fa1/0/7
ip policy route-map divert
ip route-cache policy

смотрю sh run и этого ip policy route-map divert в опциях интерефейса нету :((((((((((((

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Ограничение скорости на 3750"  +/
Сообщение от sas (??) on 08-Май-06, 16:12 
>делаю
>
>access-list 70 permit any
>
>route-map divert permit 10
> match ip address 70
> set interface Loopback0
>
>потом
>
>int fa1/0/7
> ip policy route-map divert
> ip route-cache policy
>
>смотрю sh run и этого ip policy route-map divert в опциях интерефейса
>нету :((((((((((((


Прочитав от корки до корки официальную документацию на Catalyst 3750 выяснил следущее:

1. set interface <int_name> в route-map не поддерживается
2. ограничание по выходу (output rate) не поддерживается
3. In Cisco IOS Release 12.2(25)SE or later, you can only configure individual policers on an SVI.
4.

Следовательно шейпер на лупбэке отпадает. Согласно документации (по 3750 в частности, а не по IOS в общем) скорость (rate) можно ограничивать либо по микропотокам либо агрегировано.

Первый способ не подходит, т.к. имеется 2 внешних канала, к тому же он с успехом провалился. Остается 2й.

Продолжаю экспериментировать. Например нужно ограничить исходящую скорость для 10.10.10.10. Этого сделать невозможно на интерфейсе, к которому он подключен. Поэтому ее нужно ограничивать на входящих интерфейсах (fa1/0/1, fa1/0/3).

Делаем:

!
mls qos aggregate-policer test-police 512000 32000 exceed-action drop
mls qos
!
!
class-map match-all test-class
  match access-group 30
!
!
policy-map shaper0
  class test-class
    police aggregate test-police
!
!
access-list 30 permit 10.10.10.10
!
!
interface FastEthernet1/0/1
no switchport
ip address xx.xx.xx.xx 255.255.255.252
service-policy input shaper0
!
!
interface FastEthernet1/0/3
no switchport
ip address xx.xx.xx.xx 255.255.255.252
service-policy input shaper0
!

В результате снова ничего %(

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Ограничение скорости на 3750"  +/
Сообщение от mity on 10-Май-06, 15:12 
если устали думать,
поступите так:

mls qos aggregate-policer test-police 512000 32000 exceed-action drop
mls qos
!
!
mac access-list extended non-IP
permit any any
!
class-map match-all IP
  match access-group name IP
!
class-map match-all non-IP
  match access-group name non-IP
!
!
policy-map shaper0
  class IP
    police aggregate test-police
  class non-IP
    police aggregate test-police

!

interface FastEthernet1/0/1
no switchport
ip address xx.xx.xx.xx 255.255.255.252
service-policy input shaper0
!
!
interface FastEthernet1/0/3
no switchport
ip address xx.xx.xx.xx 255.255.255.252
service-policy input shaper0
!
access-list IP permit 10.10.10.10

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Ограничение скорости на 3750"  +/
Сообщение от sas (??) on 10-Май-06, 20:02 
>если устали думать,
>поступите так:

попробовал... ничего не получилось.. если оно работает как-то по одному, то и должно как-то по другому :-/

У меня почему-то все счетчики 0

unicorn#sh policy-map interface
FastEthernet1/0/1

  Service-policy input: shaper0

    Class-map: test-class (match-all)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: access-group 77

    Class-map: non-IP (match-all)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: access-group name non-IP

    Class-map: class-default (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
         rate 0 bps
FastEthernet1/0/3

  Service-policy input: shaper0

    Class-map: test-class (match-all)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: access-group 77

    Class-map: non-IP (match-all)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: access-group name non-IP

    Class-map: class-default (match-any)
      0 packets, 0 bytes
       offered rate 0 bps, drop rate 0 bps
      Match: any
        0 packets, 0 bytes
         rate 0 bps

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Ограничение скорости на 3750"  +/
Сообщение от Nailer (??) on 10-Май-06, 22:04 
>>если устали думать,
>>поступите так:
>
>попробовал... ничего не получилось.. если оно работает как-то по одному, то и
>должно как-то по другому :-/
>
>У меня почему-то все счетчики 0
>
>unicorn#sh policy-map interface
> FastEthernet1/0/1
>
>  Service-policy input: shaper0
>
>    Class-map: test-class (match-all)
>      0 packets, 0 bytes
>       offered rate 0 bps, drop
>rate 0 bps
>      Match: access-group 77
>
>    Class-map: non-IP (match-all)
>      0 packets, 0 bytes
>       offered rate 0 bps, drop
>rate 0 bps
>      Match: access-group name non-IP
>
>    Class-map: class-default (match-any)
>      0 packets, 0 bytes
>       offered rate 0 bps, drop
>rate 0 bps
>      Match: any
>        0 packets, 0 bytes
>
>         rate 0 bps
>
> FastEthernet1/0/3
>
>  Service-policy input: shaper0
>
>    Class-map: test-class (match-all)
>      0 packets, 0 bytes
>       offered rate 0 bps, drop
>rate 0 bps
>      Match: access-group 77
>
>    Class-map: non-IP (match-all)
>      0 packets, 0 bytes
>       offered rate 0 bps, drop
>rate 0 bps
>      Match: access-group name non-IP
>
>    Class-map: class-default (match-any)
>      0 packets, 0 bytes
>       offered rate 0 bps, drop
>rate 0 bps
>      Match: any
>        0 packets, 0 bytes
>
>         rate 0 bps
>

покажите (целиком!)

sh run
sh ver


Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Ограничение скорости на 3750"  +/
Сообщение от mity on 11-Май-06, 14:24 
>
>sh run
>sh ver

версия :
*    1   52     WS-C3750-48TS      12.2(25)SEE             C3750-IPSERVICESK9-M
не тo смотрите, типа так

sh mls qos interface statistics | inc Policer

поставьте в последнем акцес-листе
!
ip access-list extended IP
permit ip any any

и убедитесь по скажем ftp в работоспособности системы mls qos

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Ограничение скорости на 3750"  +/
Сообщение от sas (??) on 12-Май-06, 15:41 
>>
>>sh run
>>sh ver
>
>
>
>версия :
>*    1   52    
>WS-C3750-48TS      12.2(25)SEE    
>        C3750-IPSERVICESK9-M
>не тo смотрите, типа так
>
>sh mls qos interface statistics | inc Policer
>
>поставьте в последнем акцес-листе
>!
>ip access-list extended IP
> permit ip any any
>
>и убедитесь по скажем ftp в работоспособности системы mls qos


Спасибо, mity. Все работает. Нужно было использовать расширенные списки доступа вместо обычных, хотя в примере в документации обычные

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

16. "Ограничение скорости на 3750"  +/
Сообщение от Blade email on 29-Июн-06, 12:10 
>>>
>>>sh run
>>>sh ver
>>
>>
>>
>>версия :
>>*    1   52    
>>WS-C3750-48TS      12.2(25)SEE    
>>        C3750-IPSERVICESK9-M
>>не тo смотрите, типа так
>>
>>sh mls qos interface statistics | inc Policer
>>
>>поставьте в последнем акцес-листе
>>!
>>ip access-list extended IP
>> permit ip any any
>>
>>и убедитесь по скажем ftp в работоспособности системы mls qos
>
>
>Спасибо, mity. Все работает. Нужно было использовать расширенные списки доступа вместо обычных,
>хотя в примере в документации обычные

Несложно ли будет отправить рабочий конфиг на мыло, Затрагивающий ограничения скорости на 3750.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

17. "Ограничение скорости на 3750"  +/
Сообщение от vgray email(ok) on 30-Июн-06, 07:56 
>>Спасибо, mity. Все работает. Нужно было использовать расширенные списки доступа вместо обычных,
>>хотя в примере в документации обычные
>
> Несложно ли будет отправить рабочий конфиг на мыло, Затрагивающий ограничения скорости
>на 3750.

присоединяюсь к просьбе, отправь конфиг на почту plz

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

18. "Ограничение скорости на 3750"  +/
Сообщение от kazakh (??) on 30-Июн-06, 09:53 
>>>Спасибо, mity. Все работает. Нужно было использовать расширенные списки доступа вместо обычных,
>>>хотя в примере в документации обычные
>>
>> Несложно ли будет отправить рабочий конфиг на мыло, Затрагивающий ограничения скорости
>>на 3750.
>
>присоединяюсь к просьбе, отправь конфиг на почту plz


М ожно мне тоже batyr2003@yandex.ru  плизз

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

20. "Ограничение скорости на 3750"  +/
Сообщение от Татьяна email(??) on 14-Янв-09, 09:38 
Здравствуйте!
присоединяюсь к просьбе, отправьте, пожалуйста, конфиг, затрагивающий ограничения скорости
на Catalyst 3750, на почту taa@email.ru
>
>

Спасибо


Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

22. "Ограничение скорости на 3750"  +/
Сообщение от stal1n on 20-Окт-10, 10:40 
> Здравствуйте!
> присоединяюсь к просьбе, отправьте, пожалуйста, конфиг, затрагивающий ограничения скорости
> на Catalyst 3750, на почту taa@email.ru
>>
>>
> Спасибо

пожалуйста отправте конфиг и мне stal1n274@gmail.com
спасибо

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

23. "Ограничение скорости на 3750"  +/
Сообщение от wizmo email(ok) on 20-Янв-11, 10:40 
Отправьте мне тоже, если не сложно wizmo@mail.ru
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

24. "Ограничение скорости на 3750"  +/
Сообщение от 527 email on 19-Авг-11, 10:29 

> Спасибо, mity. Все работает. Нужно было использовать расширенные списки доступа вместо
> обычных, хотя в примере в документации обычные

Может сюда выложить образец конфига? Спасибо.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

21. "Ограничение скорости на 3750"  +/
Сообщение от kolotov (ok) on 26-Апр-10, 13:45 
>[оверквотинг удален]
>ip address xx.xx.xx.xx 255.255.255.252
>service-policy input shaper0
>!
>!
>interface FastEthernet1/0/3
>no switchport
>ip address xx.xx.xx.xx 255.255.255.252
>service-policy input shaper0
>!
>access-list IP permit 10.10.10.10

Этот конфиг ограничивает скорость на порту только исходящий траффик, а как сделать чтобы уменьшал скорость в двух направлениях на одном порту?

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

19. "Ограничение скорости на 3750"  +/
Сообщение от mici on 24-Июн-08, 11:24 
Немного не в тему, про cat6500, но очень любопытный документик на тему "почему на с7200 работает, а на каталистах нет" :)
http://www.cenic.net/operations/documentation/CENIC-QoS0604/...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

25. "Ограничение скорости на 3750"  +/
Сообщение от Вовасий (ok) on 15-Мрт-12, 15:59 
> Есть элементарная потребность ограничить скорость клиентам (например на порту fa1/0/7).
> Имеется Catalyst 3750.
> ...

Очень простой пример ограничения скорости всего исходящего трафика хоста, включенного в порт Fa1/0/1 коммутатора C3750, до 2,5Мб/сек:

conf t

policy-map RestrictSpeed
class class-default
  police 2500000 8000 exceed-action drop
  exit
exit

interface FastEthernet1/0/1
service-policy input RestrictSpeed
end


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру