The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Соединение транками двух каталлистов через маршрутизатор"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Соединение транками двух каталлистов через маршрутизатор"  
Сообщение от Dev email on 27-Апр-06, 13:43 
Добрый день!

Народ помогите! Чего-то не догоняю...
Не получается транками создать такую схему:

Каталист 3550(F0/1)---(F0/0)Циско 1841(F0/1)---(F0/1)Каталист 2950

Я просто не пойму, как настроить этот транк... Нужно прокинут от одного Каталиста к другому Виланы 2 и 40... Привожу куски конфигов:

Каталист 3550:
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2,40
switchport mode trunk
end
!
interface Vlan 2
ip address 172.16.0.13 255.255.252.0
!
interface Vlan 40
ip address 172.16.40.1 255.255.252.0
!
Интерфейс и Виланы в Up (и сами интерфейсы и протоколы)

Каталист 2950:
!
interface FastEthernet0/1
switchport trunk allowed vlan 2,40
switchport mode trunk
end
!
interface Vlan 2
ip address 172.16.0.28 255.255.252.0
!
interface Vlan 40
ip address 172.16.40.2 255.255.252.0
shutdown
!
Интерфейс и один из Виланов в Up (и сами интерфейсы и протоколы)

Циска 1841:

interface FastEthernet0/0.2
encapsulation dot1Q 2
!
interface FastEthernet0/0.40
encapsulation dot1Q 40
!
interface FastEthernet0/1.2
encapsulation dot1Q 2
!
interface FastEthernet0/1.40
encapsulation dot1Q 40
!
interface Vlan 2
ip address 172.16.0.29 255.255.252.0
!
interface Vlan 40
ip address 172.16.40.3 255.255.252.0
!

Интерфейсы ВСЕ в Up, а на Виланах ПРОТОКОЛЫ в Down
Соответственно пинги не ходят.
Я так предполагаю, что что-то забыл прописать на Циске, но что, нигде найти не могу...

Если делать через bridge-group (привязав ее к интерфейсу F0/X) и интерфейс BVI (с указанием айпи-адреса), то получается прокинуть, но так ведь "криво". Хочется именно через Виланы. Или так невозможно и надо именно через BVI?

Народ, подскажите что-где забыл или что не так сделал?!

С уважением, Дмитрий

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Соединение транками двух каталлистов через маршрутизатор"  
Сообщение от fantom (??) on 27-Апр-06, 13:48 
>Добрый день!
>
>Народ помогите! Чего-то не догоняю...
>Не получается транками создать такую схему:
>
>Каталист 3550(F0/1)---(F0/0)Циско 1841(F0/1)---(F0/1)Каталист 2950
>
>Я просто не пойму, как настроить этот транк... Нужно прокинут от одного
>Каталиста к другому Виланы 2 и 40... Привожу куски конфигов:
>
>Каталист 3550:
>!
>interface FastEthernet0/1
> switchport trunk encapsulation dot1q
> switchport trunk allowed vlan 2,40
> switchport mode trunk
>end
>!
>interface Vlan 2
> ip address 172.16.0.13 255.255.252.0
>!
>interface Vlan 40
> ip address 172.16.40.1 255.255.252.0
>!
>Интерфейс и Виланы в Up (и сами интерфейсы и протоколы)
>
>Каталист 2950:
>!
>interface FastEthernet0/1
> switchport trunk allowed vlan 2,40
> switchport mode trunk
>end
>!
>interface Vlan 2
> ip address 172.16.0.28 255.255.252.0
>!
>interface Vlan 40
> ip address 172.16.40.2 255.255.252.0
> shutdown
>!
>Интерфейс и один из Виланов в Up (и сами интерфейсы и протоколы)
>
>
>Циска 1841:
>
>interface FastEthernet0/0.2
> encapsulation dot1Q 2
>!
>interface FastEthernet0/0.40
> encapsulation dot1Q 40
>!
>interface FastEthernet0/1.2
> encapsulation dot1Q 2
>!
>interface FastEthernet0/1.40
> encapsulation dot1Q 40
>!
>interface Vlan 2
> ip address 172.16.0.29 255.255.252.0
>!
>interface Vlan 40
> ip address 172.16.40.3 255.255.252.0
>!
>
>Интерфейсы ВСЕ в Up, а на Виланах ПРОТОКОЛЫ в Down
>Соответственно пинги не ходят.
>Я так предполагаю, что что-то забыл прописать на Циске, но что, нигде
>найти не могу...
>
>Если делать через bridge-group (привязав ее к интерфейсу F0/X) и интерфейс BVI
>(с указанием айпи-адреса), то получается прокинуть, но так ведь "криво". Хочется
>именно через Виланы. Или так невозможно и надо именно через BVI?
>
>
>Народ, подскажите что-где забыл или что не так сделал?!
>
>С уважением, Дмитрий

1.
interface Vlan 40
ip address 172.16.40.2 255.255.252.0
shutdown
на 2950 ТОЛЬКО ОДИН ИНТЕРФЕЙС VLAN МОЖЕТ БЫТЬ В ПОДНЯТ!

2. 1841 - это всетаки маршрутизатор, а не каталист :)
там надо через bridge-group.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "Соединение транками двух каталлистов через маршрутизатор"  
Сообщение от Dev email on 27-Апр-06, 14:26 
>1.
>interface Vlan 40
> ip address 172.16.40.2 255.255.252.0
> shutdown
>на 2950 ТОЛЬКО ОДИН ИНТЕРФЕЙС VLAN МОЖЕТ БЫТЬ В ПОДНЯТ!
>

Это понятно

>2. 1841 - это всетаки маршрутизатор, а не каталист :)
>там надо через bridge-group.


А жаль... Думал может чего не нашел... Через группы все сделал, но так не очень хотелось бы... Но раз никак по-другому, значит так и оставим...

Спасибо за помощь. Если вдруг все-таки как-то можно, милости прошу совет

С уважением, Дмитрий

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "Соединение транками двух каталлистов через маршрутизатор"  
Сообщение от Nailer (??) on 27-Апр-06, 14:43 
>>1.
>>interface Vlan 40
>> ip address 172.16.40.2 255.255.252.0
>> shutdown
>>на 2950 ТОЛЬКО ОДИН ИНТЕРФЕЙС VLAN МОЖЕТ БЫТЬ В ПОДНЯТ!
>>
>
>Это понятно
>
>>2. 1841 - это всетаки маршрутизатор, а не каталист :)
>>там надо через bridge-group.
>
>
>А жаль... Думал может чего не нашел... Через группы все сделал, но
>так не очень хотелось бы... Но раз никак по-другому, значит так
>и оставим...
>
>Спасибо за помощь. Если вдруг все-таки как-то можно, милости прошу совет
>
>С уважением, Дмитрий


На 1800 циске:

vlan 2
exit
vlan 3
exit

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру