The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"2 prova PBR + nat"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"2 prova PBR + nat"  
Сообщение от andrey (??) on 19-Апр-06, 16:46 
Доброго времени суток .
тема возможна избитая... но ничего не получается.
имеются 2 adsl канала от 2-ух провайдеров и сisco 1841
задача банальна ... сделать бэкап.
Может подскажете что не правильно в настройках

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$YfD.$f/0VXL7U5zY3Yw1mNein9.
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
ip sla monitor 1
type echo protocol ipIcmpEcho x.x.x.x source-interface Dialer1
timeout 1000
threshold 2
frequency 3
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho y.y.y.y source-interface FastEthernet0/1
timeout 1000
threshold 2
frequency 3
ip sla monitor schedule 2 life forever start-time now
vpdn enable
!
!
!
!
!
!
!
track 123 rtr 1 reachability
!
track 124 rtr 2 reachability

interface FastEthernet0/0
description +++ ISP-1 +++
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
description +++ ISP-2 +++
ip address x.x.x.x 255.255.255.240
ip nat outside
ip virtual-reassembly
shutdown
duplex auto
speed auto
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
description +++ LAN +++
switchport access vlan 2

!
interface Vlan1
no ip address
!
interface Vlan2
ip address 192.168.1.4 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username user password 0 cisco
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
no ip http server
no ip http secure-server
ip nat inside source route-map ISP-2 interface FastEthernet0/1 overload
ip nat inside source route-map ISP-1 interface Dialer1 overload
!
access-list 10 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
route-map ISP-2 permit 10
match ip address 10
match interface FastEthernet0/1
!
route-map ISP-1 permit 10
match ip address 10
match interface Dialer1
!
!
!
control-plane
!
!

--More--

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

  • 2 prova PBR + nat, sh_, 12:22 , 20-Апр-06, (1)  
    • 2 prova PBR + nat, andrey, 12:32 , 20-Апр-06, (2)  
      • 2 prova PBR + nat, andrey, 14:43 , 20-Апр-06, (3)  
        • 2 prova PBR + nat, sh_, 16:39 , 20-Апр-06, (4)  
          • 2 prova PBR + nat, andrey, 16:48 , 20-Апр-06, (5)  
            • 2 prova PBR + nat, andrey, 17:07 , 20-Апр-06, (6)  
            • 2 prova PBR + nat, sh_, 17:09 , 20-Апр-06, (7)  
              • 2 prova PBR + nat, andrey, 17:22 , 20-Апр-06, (8)  
                • 2 prova PBR + nat, andrey, 17:25 , 20-Апр-06, (9)  
                  • 2 prova PBR + nat, andrey, 17:35 , 20-Апр-06, (10)  
                    • 2 prova PBR + nat, sh_, 18:22 , 20-Апр-06, (11)  
                      • 2 prova PBR + nat, andrey, 18:39 , 20-Апр-06, (12)  
                        • 2 prova PBR + nat, andrey, 12:15 , 26-Апр-06, (13)  
                        • 2 prova PBR + nat, sh_, 13:47 , 26-Апр-06, (14)  

Сообщения по теме [Сортировка по времени, UBB]


1. "2 prova PBR + nat"  
Сообщение от sh_ email(??) on 20-Апр-06, 12:22 
ip route 0.0.0.0 0.0.0.0 Dialer1 tra 123 10
ip route 0.0.0.0 0.0.0.0 x.x.x.x tra 124
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "2 prova PBR + nat"  
Сообщение от andrey (??) on 20-Апр-06, 12:32 
>ip route 0.0.0.0 0.0.0.0 Dialer1 tra 123 10
>ip route 0.0.0.0 0.0.0.0 x.x.x.x tra 124


ok, спасибо...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "2 prova PBR + nat"  
Сообщение от andrey (??) on 20-Апр-06, 14:43 
>>ip route 0.0.0.0 0.0.0.0 Dialer1 tra 123 10
>>ip route 0.0.0.0 0.0.0.0 x.x.x.x tra 124
>
>
>ok, спасибо...


Так вообще ничего не проходит

Ответ от 192.168.1.4: Заданный узел недоступен.
Ответ от 192.168.1.4: Заданный узел недоступен.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "2 prova PBR + nat"  
Сообщение от sh_ email(??) on 20-Апр-06, 16:39 
interface FastEthernet0/1
description +++ ISP-2 +++
ip address x.x.x.x 255.255.255.240
ip nat outside
ip virtual-reassembly
shutdown
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
duplex auto
speed auto


sh ip ro

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "2 prova PBR + nat"  
Сообщение от andrey (??) on 20-Апр-06, 16:48 
>interface FastEthernet0/1
>description +++ ISP-2 +++
>ip address x.x.x.x 255.255.255.240
>ip nat outside
>ip virtual-reassembly
>shutdown
>^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>duplex auto
>speed auto
>
>
>sh ip ro

shutdown - эт я его вырубал...  когда он в апе , все равно не работает

Gateway of last resort is x.x.x.y to network 0.0.0.0

     x.x.x.0/28 is subnetted, 1 subnets
C       x.x.x.x is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, Vlan2
S*   0.0.0.0/0 [1/0] via x.x.x.y
               is directly connected, Dialer1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "2 prova PBR + nat"  
Сообщение от andrey (??) on 20-Апр-06, 17:07 
>>interface FastEthernet0/1
>>description +++ ISP-2 +++
>>ip address x.x.x.x 255.255.255.240
>>ip nat outside
>>ip virtual-reassembly
>>shutdown
>>^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
>>duplex auto
>>speed auto
>>
>>
>>sh ip ro
>
>shutdown - эт я его вырубал...  когда он в апе ,
>все равно не работает
>
>Gateway of last resort is x.x.x.y to network 0.0.0.0
>
>     x.x.x.0/28 is subnetted, 1 subnets
>C       x.x.x.x is directly connected, FastEthernet0/1
>
>C    192.168.1.0/24 is directly connected, Vlan2
>S*   0.0.0.0/0 [1/0] via x.x.x.y
>            
>   is directly connected, Dialer1

это при том что руты были прописаны как в начальном конфиге

Gateway of last resort is x.x.x.y to network 0.0.0.0

     x.x.x.0/28 is subnetted, 1 subnets
C       x.x.x.x is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, Vlan2
S*   0.0.0.0/0 [1/0] via x.x.x.y
               is directly connected, Dialer1

а это появилось при изменении (как Вы написали) ip route 0.0.0.0.... track 123
  
x.x.x.0/28 is subnetted, 1 subnets
C       x.x.x.x is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, Vlan2

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "2 prova PBR + nat"  
Сообщение от sh_ email(??) on 20-Апр-06, 17:09 
1)А x.x.x.x и y.y.y.y пингуются?
2)Уберите match ip address 10 с route-map'ов.
3)Покажите конечный конфиг.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "2 prova PBR + nat"  
Сообщение от andrey (??) on 20-Апр-06, 17:22 
>1)А x.x.x.x и y.y.y.y пингуются?
>2)Уберите match ip address 10 с route-map'ов.
>3)Покажите конечный конфиг.


1. xxxx yyyyy пингуются
2. убрал - не помогло
3. version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$YfD.$f/0VXL7U5zY3Yw1mNein9.
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
ip sla monitor 1
type echo protocol ipIcmpEcho x.x.x.x source-interface Dialer1
timeout 1000
threshold 2
frequency 3
ip sla monitor schedule 1 life forever start-time now
ip sla monitor 2
type echo protocol ipIcmpEcho y.y.y.y source-interface FastEthernet0/1
timeout 1000
threshold 2
frequency 3
ip sla monitor schedule 2 life forever start-time now
vpdn enable
!
!
!
!
!
!
!
track 123 rtr 1 reachability
!
track 124 rtr 2 reachability

interface FastEthernet0/0
description +++ ISP-1 +++
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface FastEthernet0/1
description +++ ISP-2 +++
ip address x.x.x.x 255.255.255.240
ip nat outside
ip virtual-reassembly
shutdown
duplex auto
speed auto
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
description +++ LAN +++
switchport access vlan 2

!
interface Vlan1
no ip address
!
interface Vlan2
ip address 192.168.1.4 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username user password 0 cisco
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 123
ip route 0.0.0.0 0.0.0.0 x.x.x.y track 124
!
no ip http server
no ip http secure-server
ip nat inside source route-map ISP-2 interface FastEthernet0/1 overload
ip nat inside source route-map ISP-1 interface Dialer1 overload
!
access-list 10 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
route-map ISP-2 permit 10
match interface FastEthernet0/1
!
route-map ISP-1 permit 10
match interface Dialer1
!
!
!
control-plane
!
!

--More--

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "2 prova PBR + nat"  
Сообщение от andrey (??) on 20-Апр-06, 17:25 
>>1)А x.x.x.x и y.y.y.y пингуются?
>>2)Уберите match ip address 10 с route-map'ов.
>>3)Покажите конечный конфиг.
>
>
>1. xxxx yyyyy пингуются
>2. убрал - не помогло
>3. version 12.4
>service timestamps debug datetime msec
>service timestamps log datetime msec
>no service password-encryption
>!
>hostname Router
>!
>boot-start-marker
>boot-end-marker
>!
>enable secret 5 $1$YfD.$f/0VXL7U5zY3Yw1mNein9.
>!
>no aaa new-model
>!
>resource policy
>!
>mmi polling-interval 60
>no mmi auto-configure
>no mmi pvc
>mmi snmp-timeout 180
>ip subnet-zero
>ip cef
>!
>!
>!
>!
>ip sla monitor 1
>type echo protocol ipIcmpEcho x.x.x.x source-interface Dialer1
>timeout 1000
>threshold 2
>frequency 3
>ip sla monitor schedule 1 life forever start-time now
>ip sla monitor 2
>type echo protocol ipIcmpEcho y.y.y.y source-interface FastEthernet0/1
>timeout 1000
>threshold 2
>frequency 3
>ip sla monitor schedule 2 life forever start-time now
>vpdn enable
>!
>!
>!
>!
>!
>!
>!
>track 123 rtr 1 reachability
>!
>track 124 rtr 2 reachability
>
>interface FastEthernet0/0
>description +++ ISP-1 +++
>no ip address
>duplex auto
>speed auto
>pppoe enable
>pppoe-client dial-pool-number 1
>!
>interface FastEthernet0/1
>description +++ ISP-2 +++
>ip address x.x.x.x 255.255.255.240
>ip nat outside
>ip virtual-reassembly
>shutdown
>duplex auto
>speed auto
>!
>interface FastEthernet0/0/0
>!
>interface FastEthernet0/0/1
>!
>interface FastEthernet0/0/2
>!
>interface FastEthernet0/0/3
>description +++ LAN +++
>switchport access vlan 2
>
>!
>interface Vlan1
>no ip address
>!
>interface Vlan2
>ip address 192.168.1.4 255.255.255.0
>ip nat inside
>ip virtual-reassembly
>!
>interface Dialer1
>ip address negotiated
>ip mtu 1492
>ip nat outside
>ip virtual-reassembly
>encapsulation ppp
>no ip mroute-cache
>dialer pool 1
>dialer-group 1
>ppp authentication pap callin
>ppp pap sent-username user password 0 cisco
>!
>ip classless
>ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 123
>ip route 0.0.0.0 0.0.0.0 x.x.x.y track 124
>!
>no ip http server
>no ip http secure-server
>ip nat inside source route-map ISP-2 interface FastEthernet0/1 overload
>ip nat inside source route-map ISP-1 interface Dialer1 overload
>!
>access-list 10 permit 192.168.1.0 0.0.0.255
>dialer-list 1 protocol ip permit
>route-map ISP-2 permit 10
>match interface FastEthernet0/1
>!
>route-map ISP-1 permit 10
>match interface Dialer1
>!
>!
>!
>control-plane
>!
>!
>
>--More--


1. пардон не пингуются... пингуются только сами интерфейсы
fasteth 0/2 , dialer1

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "2 prova PBR + nat"  
Сообщение от andrey (??) on 20-Апр-06, 17:35 
Вот еще что показывает
outer#sh ip route track-table
ip route 0.0.0.0 0.0.0.0 Dialer1 10 track 123 state is [down]
ip route 0.0.0.0 0.0.0.0 x.x.x.y track 124 state is [down]
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "2 prova PBR + nat"  
Сообщение от sh_ email(??) on 20-Апр-06, 18:22 
Не... :) Так работать не будет... :)
Да что же вы все FastEthernet в shutdown опускаете... :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "2 prova PBR + nat"  
Сообщение от andrey (??) on 20-Апр-06, 18:39 
>Не... :) Так работать не будет... :)
>Да что же вы все FastEthernet в shutdown опускаете... :)


Shutdown - ето из прошлого куска осталось.

Вообщем ребут циски и все заработало.

P.S.
to  sh_ c спасибо за помощь.... с меня пива :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "2 prova PBR + nat"  
Сообщение от andrey (??) on 26-Апр-06, 12:15 
Господа, задача чуть усложнилась

требуется чтобы некоторые машины ходили в инет через 2 провайдера (скажем например 192,168,1,10-30).

Я так монимамаю нужно делать что-то типа

access-list 100 permit ip 192.168.1.0...

и потом к route-map привязывать?

route-map ISP2 permit 10
match ip address 100

подскажите в првильном направлении двигаюсь?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "2 prova PBR + nat"  
Сообщение от sh_ email(??) on 26-Апр-06, 13:47 
В сторону PBR и cisco.far.ru смотреть...
Лучше новый топик открывай. :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру