The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от opennews (??) on 08-Сен-14, 12:05 
Представлен (https://sourceware.org/ml/libc-alpha/2014-09/msg00088.html) релиз системной библиотеки GNU C Library (http://ftp.gnu.org/gnu/glibc/) (glibc) 2.20 (http://sourceware.org/glibc/wiki/Release/2.18), которая полностью следует требованиям стандартов ISO C11 и POSIX.1-2008. В подготовке нового выпуска использованы патчи от 69 разработчиков.


Новый выпуск ознаменовал собой завершение процесса слияния с проектом Eglibc (http://www.eglibc.org) (Embedded GLIBC), который развивался синхронно с Glibc и был полностью совместим с ней на уровне API и ABI, отличаясь (http://www.eglibc.org/faq) интеграцией некоторых дополнительных наработок для встраиваемых систем,  более низкими системными требованиями, возможностью гибкой настройки компонентов, улучшенной поддержкой кросс-компиляции и кросс-тестирования. Последние два года проекты двигались в сторону возвращения в Glibc наработок Eglibc, к моменту выхода Glibc 2.20 данный процесс завершился и отныне пользователям и разработчикам Eglibc рекомендовано вернуться на Glibc. Выпуск Eglibc 2.19 был последним, версия  Eglibc 2.20 не будет выпущена (http://www.eglibc.org/cgi-bin/viewvc.cgi/branches/). Ранее применявшие Eglibc дистрибутивы OpenWrt, Mandriva, Debian и Ubuntu уже наметили (https://www.opennet.ru/opennews/art.shtml?num=40033) возвращение на Glibc.

Из добавленных в Glibc 2.20 улучшений (http://sourceware.org/git/?p=glibc.git;a=blob_plain;f=NEWS;h...) можно отметить:


-  Требования к минимально поддерживаемому выпуску ядра Linux повышены до 2.6.32 (ранее поддерживались выпуски ядра, начиная с 2.6.16);

-  Для систем на основе ядра Linux добавлена поддержка блокировки на уровне описаний файлов (file descriptions, используется для обмена файловыми дескрипторами между процессами). Штатный интерфейс установки блокировок на файлы расширен средствами для блокировки на уровне описаний файлов (не путать с файловыми дескрипторами) с использованием опций F_OFD_GETLK, F_OFD_SETLK и F_OFD_SETLKW.  Блокировка на уровне описания файлов  ассоциируются с открытым файлом, а не процессом, т.е. корректно обрабатывает передачу открытого заблокированного файла другому процессу;

-  Реализация функции strchr оптимизирована для архитектуры AArch64;
-  Реализация функции strcmp оптимизирована для архитектуры ARMv7;

-  Изменена логика выполнения тестового набора - процесс тестирования больше не прерывается после первой ошибки и выполняется полностью. Лог всех выявленных при тестировании сбоев сохраняется в файл tests.sum. После завершения тестирования на экран выводится сводка проблем. Для возврата старого поведения следует запускать "make check stop-on-test-failure=y";
-  Прекращена поддержка порта am33, который находится в неработоспособном состоянии уже несколько лет;
-  Прекращена поддержка  макросов тестирования _BSD_SOURCE и _SVID_SOURCE, которые теперь действуют как _DEFAULT_SOURCE с выводом предупреждения;

-  Для архитектур s390 и s390x в реализации мьютексов pthread добавлена поддержка аппаратных механизмов проведения транзакций в памяти, определённых в составе набора расширений  TX (http://software.intel.com/en-us/blogs/2012/11/06/exploring-i...) (Transactional Extensions). Внесённое улучшение позволяет увеличить масштабируемость блокировок для существующих программ, при их запуске на системах, поддерживающих расширения TX;
-  Отменены изменения структур данных ABI, внесённые для архитектур s390 и s390x (в glibc 2.19 был увеличен размер структур ucontext и jmp_buf);
-  Все поддерживаемые архитектуры отныне используют основную директорию sysdeps из состава glibc вместо отдельных директорий в иерархии ports;
-  NPTL-реализация POSIXpthreads больше не позиционируется как дополнение и используется по умолчанию в конфигурациях, поддерживающих NPTL, независимо от включения опции "--enable-add-ons";

-  Реализация "ленивого" динамического связывания на архитектуре x86-64 приведена к совместимости с кодом приложений, в которых используются инструкции Intel MPX (состояние регистров MPX теперь сохраняется перед обращением к библиотеке);


-  Внесено  4 изменения, связанных с безопасностью:

-  Прекращена поддержка загружаемых модулей транслитерации gconv, которые не применяются уже более десяти лет. Поддержка обычных модулей преобразования gconv сохранена без изменений, в том числе возможно использовании транслитерации через опцию "//TRANSLIT" и применение спецификатора "//IGNORE".


Удаление кода связано с выявлением уязвимости CVE-2014-5119, первые сообщения о которой были опубликованы (https://www.sourceware.org/ml/libc-alpha/2005-12/msg00091.html) ещё в 2005 году. Уязвимость вызвана ошибкой, приводящей к перезаписи одного байта за границей буфера при обработке некорректных данных функцией "__gconv_translit_find()" (iconv/gconv_trans.c). В июле 2014 года проблема вновь  всплыла (https://sourceware.org/bugzilla/show_bug.cgi?id=17187) в системе отслеживания ошибок, но участники команды устранения уязвимостей из компании Red Hat скептически отнеслись к этой ошибке и заявили (http://www.openwall.com/lists/oss-security/2014/07/21/8), что она не подлежит эксплуатации, так как встроенные в реализацию malloc средства защиты должны блокировать проявление проблемы. Участники созданной компанией Google команды "Проект Zero (https://www.opennet.ru/opennews/art.shtml?num=40210)" показали, что поверхностный анализ потенциальных уязвимостей не всегда адекватен и подготовили (http://googleprojectzero.blogspot.ru/2014/08/the-poisoned-nu...)  рабочий эксплоит, который может быть применён для организации запуска кода атакующего.


* CVE-2014-0475 - добавлены дополнительные проверки на использование символов "/" и ".." в именах локалей, полученных через переменные окружения группы LC_*. Вызов setlocale при наличии таких имён отныне приводит к ошибке, а также при размещении очень длинных имён;

-  CVE-2014-4043 - проблема в реализации posix_spawn_file_actions_addopen, позволяла осуществить подмену аргумента с файловым путём, через разыменования связанной с ним ссылки через последующий вызов posix_spawn;

-  CVE-2014-6040 - ошибка в коде iconv, используемого для декодирования набора символов в кодировках IBM933, IBM935, IBM937, IBM939 и IBM1364, могла привести к чтению данных из области за пределами выделенного буфера;

-  Исправлено около 150 ошибок.

URL: https://sourceware.org/ml/libc-alpha/2014-09/msg00088.html
Новость: https://www.opennet.ru/opennews/art.shtml?num=40537

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +5 +/
Сообщение от Аноним (??) on 08-Сен-14, 12:05 
C11 threads ещё не добавили?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от Baz on 08-Сен-14, 12:07 
конвергенция во всей красе.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +2 +/
Сообщение от Журналовращатель on 08-Сен-14, 12:10 
Джва года ждал. Надеюсь на меньший зоопарк рантаймов, но тут внезапно выплыл musl.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

100. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –1 +/
Сообщение от Аноним (??) on 11-Сен-14, 02:26 
> но тут внезапно выплыл musl.

Да и буй с ним - он почти нигде не применяется.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

4. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от beerseller (ok) on 08-Сен-14, 12:34 
Интересно, много ли дистров перейдут на musl libc?
Есть же glibc хейтеры :-)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –11 +/
Сообщение от Аноним (??) on 08-Сен-14, 13:00 
* The minimum Linux kernel version that this version of the GNU C Library
  can be used with is 2.6.32.

Круто то как. Так держать! Какой там API/ABI compatibility? Шо це теке?

// b.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +12 +/
Сообщение от .... on 08-Сен-14, 13:13 
> * The minimum Linux kernel version that this version of the GNU
> C Library can be used with is 2.6.32.
> Круто то как. Так держать! Какой там API/ABI compatibility? Шо це теке?

2.6.32 - ядро, выпущенное в 2009м году. Нормальный compatibility. Получше чем у многих.

те кто все еще пользуется ведром 2006го года выпуска (2.6.16,ваше любимое) - ну, как нибудь уж, перетопчутся и предыдущей версией glibc.


Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

9. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –23 +/
Сообщение от Аноним (??) on 08-Сен-14, 13:25 
Лучше, чем у кого?

Я могу собрать MSVC 2013 программу и запустить её на Windows XP (2001 года выпуска).

И она, о чудо, не потребует ntdll.dll от Windows 8.1. Вообще ничего не потребует, кроме крошечного runtime.

Больные на голову опенсорцеры.

// b.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

10. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +13 +/
Сообщение от Аноним (??) on 08-Сен-14, 13:36 
совершенно разные подходы. В случае опенсорс-контингента нет смысла держать такое старье 2001 года - обновления и новые версии доступны свободно - бери и переходи на то, что поновее и лучше.

да и msvc 2013 компилирует под winxp-sp3, а это 2008 год, никак не 2001.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

15. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –18 +/
Сообщение от клоун on 08-Сен-14, 14:10 
> бери и переходи

= повторно заплати за программирование, тестирование и отладку.

Спасибо, спасибо... "Бесплатная" ОС она как бесплатный сыр...

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

16. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +7 +/
Сообщение от Аноним (??) on 08-Сен-14, 14:18 
1. Нет упоминания никакой бесплатной ОС. Есть свободной.

2. Как будто тестирование в новом окружении нужно проводить только в линукс. Или ты, скомпиляв под msvs2013 инсталлятор для winxp гордо пишешь в требованиях: "winxp"; без тестов

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

18. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +10 +/
Сообщение от Аноним (??) on 08-Сен-14, 14:25 
>скомпиляв под msvs2013 инсталлятор для winxp гордо пишешь в требованиях: "winxp"; без тестов

Вы только что раскрыли самый большой и страшный секрет индустрии по разработке коммерческого ПО.

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

21. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –2 +/
Сообщение от irinat (ok) on 08-Сен-14, 14:35 
> секрет индустрии по разработке коммерческого ПО.

Поправочка — любого ПО.

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

103. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от Аноним (??) on 11-Сен-14, 02:34 
> Поправочка — любого ПО.

А опенсорсникам нет смысла самих себя на...ть :). А то что комерсы заявляют системные требования нифига не тестировав это или тестировав по минимуму и потом зачастую лажа случается - "как доктор говорю". Ну не бывает у корпорасов ресурсов на нормальное тестирование всех задекларированных конфиг. И половина документации делается методом copy-paste с версии десятилетней давности, поэтому зачастую случаются годные плюхи, ибо читать 200 страниц копипасты мало кому втыкает :).

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

20. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –8 +/
Сообщение от клоун on 08-Сен-14, 14:29 
> Нет упоминания никакой бесплатной ОС. Есть свободной

Игра слов. Если продукт можно свободно забрать в магазине - разве это не делает его бесплатным?

В английском есть вариант использовать слово free вместо non-profit и GPL-based, чтобы искусственно создать неопределённость и потом долго объяснять где граница между profit, non-profit, GPL и GPL-based. Но в русском это оболванивание л-ов не прокатывает.

> тестирование в новом окружении нужно проводить только в линукс

Проверку работоспособности - да. Отличия от тестирования найдёте сами, назову лишь одно - это СИЛЬНО ДЕШЕВЛЕ.

Программирование, тестирование и отладку - нет.

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

23. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от Аноним (??) on 08-Сен-14, 14:41 
>Программирование, тестирование и отладку - нет.

Ну правильно, пишем под winxp no-sp, и не паримся на счет программирования и отладку с тестированием под другие окружения. Даже в вайне будет работать. Только разговор-то про программирование под новую платформу.

>Игра слов.

В извращеном сознании советского человека понятие собственности и законности искажено. Таким для понимания современных культурных и правовых норм и понятий требуется специальное обучение и подготовка, а главное - желание.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

68. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +2 +/
Сообщение от rshadow (ok) on 10-Сен-14, 01:58 
> Игра слов

Пичаль. Даже основ не знаешь. А все туда же...

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

33. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –3 +/
Сообщение от Аноним (??) on 08-Сен-14, 17:42 
> В случае опенсорс-контингента нет смысла держать такое старье 2001 года - обновления и новые версии доступны свободно - бери и переходи на то, что поновее и лучше.

Вы слово production никогда не слышали, да.

Когда у вас БД исчисляются терабайтами, когда час простоя равен сотням тысяч долларов - вперёд, обновляйтесь (точнее, увольняйтесь к чертям). Да, только озабоченные оперсорцеры будут менять работающие как часы системы, ради непонятным backward incompatible фишек.

Linux, конечно, используется в production. Только там знают одно слово: RHEL. Ваши плюшки никому не интересны.

// b.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

40. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +8 +/
Сообщение от arisu (ok) on 08-Сен-14, 19:10 
ага. то есть, обновляться мы не будем всё равно, но тем, что новая glibc не поддерживает наше старьё, таки недовольны.

рекомендую обратиться к специалисту по умственным расстройствам.

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

41. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от none_first (ok) on 08-Сен-14, 19:13 
>> В случае опенсорс-контингента нет смысла держать такое старье 2001 года - обновления и новые версии доступны свободно - бери и переходи на то, что поновее и лучше.
> Вы слово production никогда не слышали, да.
> Когда у вас БД исчисляются терабайтами, когда час простоя равен сотням тысяч
> долларов - вперёд, обновляйтесь (точнее, увольняйтесь к чертям). Да, только озабоченные
> оперсорцеры будут менять работающие как часы системы, ради непонятным backward incompatible
> фишек.

Продакшн не подразумевает установку без тестирование и МСпердулятор2013 этих проблем не решает. Затем вспомним что даже миграция между версиями МССкуль сопряжена с риском выпадений в БСОД (ну или теперь у него новое название :) ). А каких терабайтах речь...
Для систем от МС бесшовный апгрейд отсутствует как класс, для ч-л больше чем рабместо домохозяйки. Оно (как действо обновления) называется миграцией ;) - что в переводе - купи новую железку напиши скрипты переноса, оттестируй!, а потом попробуй запустить в продакшн (авось не ё..неца)

> Linux, конечно, используется в production. Только там знают одно слово: RHEL. Ваши
> плюшки никому не интересны.

"там" много слов знают и в больших инсталяциях используют собственные наработки
гугл, яндекс... врядли устроит штатный дистр, да и спецов там не меньше чем в шапке

> // b.

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

69. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от rshadow (ok) on 10-Сен-14, 02:05 
> Вы слово

Ниче ниче. С ростом компьютерной грамотности таких админов как вы станет меньше.

> Когда у вас БД исчисляются терабайтами,

Обновление через репликацию. Ах да, это слишком сложно для таких админов.

> менять работающие как часы системы

Жаль что бизнес мало понимает в технике и полагается на таких админов. Ваши терабайты информации давно уже слиты, либо слить их можно легко при надобности.
Но это жизнь. Вы просто сидите на попе ровно, получая свою зарплату. А если что-то и случится то "просто уволят". Как же рьяно можно защищать свой овощной образ жизни Неуловимого Джо.

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

70. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +3 +/
Сообщение от arisu (ok) on 10-Сен-14, 02:26 
да кому его локалхост нужен… «терабайтные БД» у него только во влажных мечтах, где он видит себя аж целым Начальником Отдела.
Ответить | Правка | ^ к родителю #69 | Наверх | Cообщить модератору

107. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от ваноним on 11-Сен-14, 03:51 
> Только там знают одно слово: RHEL

мсье из своего болтца на свет хоть раз выглядывал?

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

108. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Аноним (??) on 11-Сен-14, 05:55 
> Только там знают одно слово: RHEL. Ваши
> плюшки никому не интересны.

Наверное именно поэтому шапка в рхел7 даже systemd приволокли. Да и федора ими как беталаб будущего рхела используется, если кто не в курсе.

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

11. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +3 +/
Сообщение от Аноним (??) on 08-Сен-14, 13:40 
> Я могу собрать MSVC 2013 программу и запустить её на Windows XP (2001 года выпуска).
> …
> И она, о чудо, не потребует ntdll.dll от Windows 8.1. Вообще ничего не потребует, кроме крошечного runtime.

Передергиваешь, студент. Как же, сравнил среду разработки со стандартной библиотекой. А с "крошечным runtime" glibc сравнить слабо?

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

12. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от Аноним (??) on 08-Сен-14, 13:59 
Тогда почему сборки апача и модулей, скомпилированные VC11, не работают под XP и 2003 сервером? https://www.apachelounge.com/download/
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

14. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –3 +/
Сообщение от клоун on 08-Сен-14, 14:08 
Потому, что некоторые программы используют новые функции, не реализованные в старых версиях ОС.

Речь сейчас идёт о том, что если кто-то захочет собрать программу, использующую лишь возможности, имеющиеся в Windows 95, то она соберётся и запустится в Windows 95.

А вот программа для Линукс соберётся, но не заработает на дистрибутиве 20 летней давности и не факт что будет работать без необходимости лазить в код следующие 20 лет.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

22. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +4 +/
Сообщение от irinat (ok) on 08-Сен-14, 14:39 
> А вот программа для Линукс соберётся, но не заработает на дистрибутиве 20
> летней давности и не факт что будет работать без необходимости лазить
> в код следующие 20 лет.

Надо при связывании указывать версии символов: http://www.trevorpounds.com/blog/?p=103
По сути, это эквивалент выбора в Visual Studio сборки под старые версии ОС.


Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

24. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –4 +/
Сообщение от клоун on 08-Сен-14, 14:46 
Это в прошлое. Меня больше интересует будущее.

Если я пришёл к руководителю или фин. диру, то должен назвать конечную стоимость разработки ПО. Я не могу её назвать, т.к. знаю, что библиотеки, ядро, ОС - всё (!!!) может до неузнаваемости изменится с каждым релизом. И я не знаю, сколько денег потребуется на восстановление работоспособности. Ни один здравомыслящий руководитель не согласится на такое.

Отсюда: или ОС+ПО замораживается и никогда не обновляется (дыра в безопасности) или скриптовый язык, независящий от раз----йства Торвальдса и Ко.

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

25. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +3 +/
Сообщение от Аноним (??) on 08-Сен-14, 14:56 
да ты клоун
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

28. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +2 +/
Сообщение от Аноним (??) on 08-Сен-14, 15:15 
нет, он просто упоролся.
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

30. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +3 +/
Сообщение от ананим on 08-Сен-14, 15:41 
> Это в прошлое. Меня больше интересует будущее.

Во врёшь то!
Ты ж только что кричал на весь форум как будешь писать на вын8 и запускать на хп.
Что, новые вын-апи в хрюше автоматом появятся?
> Если я пришёл к руководителю или фин. диру, то должен назвать конечную стоимость разработки ПО.

Вот и берешь версии нужного ПО из lsb, прописываешь указанные выше версию глибц и всё.
Можешь компилять хоть со свежего среза генты.

И вообще, кто клоуна в офис фин.дира пустил?! Алё! Где служба безопасности?!

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

32. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –3 +/
Сообщение от клоун on 08-Сен-14, 17:24 
> прописываешь указанные выше версию глибц и всё

"Уважаемые покупатели. Мы приносим вам извинения за то, что драйвера для наших продуктов не работают с последней версией ядра ОС Линукс. Доводим до вашего сведения, что это явилось причиной удаления из ядра функций, необходимых для работы наших драйверов. Мы работаем над решением данной проблемы." (с) оф.сайт nVidia

И всё... Тут уж действительно всё...

Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

37. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от ананим on 08-Сен-14, 18:27 
Такое ощущение, что ты меня хочешь в чём-то убедить.
Ну несёшь ты эту пургу.. уже пару лет как.
Сразу после слива — чё там? с сырцами и фин.диром разобрались? будем считать, что слив засчитан.

Зыж
А ты не ставь новое ядро то.. Или не покупай невидию.
Делов то. Выбор у тебя есть.
В вантузе вон новое ядро надо с новой версией покупать, ты ж не визжишь по этому поводу? Вот и в линухе используй то ядро, что тебе с дистром поставил.
А то тебе и рыбку съесть, и на ... влезть.
Бери сравнение в аналогичных ситуациях, а не выковыривай из... откуда ты там выковыриваешь.

Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

90. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –2 +/
Сообщение от Аноним (??) on 10-Сен-14, 22:11 
>[оверквотинг удален]
> Зыж
> А ты не ставь новое ядро то.. Или не покупай невидию.
> Делов то. Выбор у тебя есть.
> В вантузе вон новое ядро надо с новой версией покупать, ты ж
> не визжишь по этому поводу? Вот и в линухе используй то
> ядро, что тебе с дистром поставил.
> А то тебе и рыбку съесть, и на ... влезть.
> Бери сравнение в аналогичных ситуациях, а не выковыривай из... откуда ты там
> выковыриваешь.
> А ты не ставь новое ядро то.. Или не покупай невидию.

Ах да, в лялихе шаг вправо и влево - расстрел, простите, неподдерживаемое оборудование.

А то, что поддерживается, работает часто через одно место. Через меня прошли десятки сетевых карт, причём некоторые "поддерживаются" так, что машину надо ребутить каждые полсуток, иначе скорость падает до 10Mbit и даже rmmod/modprobe/принудительно ethtool 1000 не помогают. Ещё были такие, которые отваливались полностью. Просто так - ping'и не идут. И это только сетевые. Я промолчу про Wi-Fi, карты телефонии, звуковые карты, 12309 и прочее.

Куда идти? Что делать?

// b.

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

91. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 10-Сен-14, 22:13 
> Куда идти? Что делать?

попробуй к хирургу. операция по пересадке рук из задницы в плечи — это, конечно, дорого и сложно, да и не всегда удаётся, но уж если получится…

Ответить | Правка | ^ к родителю #90 | Наверх | Cообщить модератору

109. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Аноним (??) on 11-Сен-14, 05:56 
> А то, что поддерживается, работает часто через одно место. Через меня прошли
> десятки сетевых карт, причём некоторые "поддерживаются" так, что машину надо ребутить

А винды до сих пор летают в бсод при обычном втыкании флешки. Казалось бы где там можно облажаться? Но этот баг живет наверное более декады и сдаваться не собирается.

Ответить | Правка | ^ к родителю #90 | Наверх | Cообщить модератору

71. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –2 +/
Сообщение от linvinus on 10-Сен-14, 12:20 
А ещё можно поправить бинарник ручками, главное чтобы все вызовы доступны в системе.
http://stackoverflow.com/questions/14879644/can-i-trick-libc... (5й ответ)
Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

72. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 10-Сен-14, 12:25 
сгинь, виндофил!
Ответить | Правка | ^ к родителю #71 | Наверх | Cообщить модератору

74. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от irinat (ok) on 10-Сен-14, 12:45 
На SO есть ссылки "share", которые указывают на конкретный ответ. И "5" это не номер. Их там вообще два всего.


Ответить | Правка | ^ к родителю #71 | Наверх | Cообщить модератору

29. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +4 +/
Сообщение от Аноним (??) on 08-Сен-14, 15:20 
> Речь сейчас идёт о том, что если кто-то захочет собрать программу, использующую лишь возможности, имеющиеся в Windows 95, то она соберётся и запустится в Windows 95.

Не запустится. Потому что кроме твоего hello world есть еще рантайм, который ни на какой Windows 95 не рассчитан.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

46. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –1 +/
Сообщение от Аноним (??) on 08-Сен-14, 20:30 
>> Речь сейчас идёт о том, что если кто-то захочет собрать программу, использующую лишь возможности, имеющиеся в Windows 95, то она соберётся и запустится в Windows 95.
> Не запустится. Потому что кроме твоего hello world есть еще рантайм, который
> ни на какой Windows 95 не рассчитан.

Открой для себя другие версии WinAPI.

Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

52. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от Аноним (??) on 08-Сен-14, 21:00 
> Открой для себя другие версии WinAPI.

Я-то для себя уже и открыл, и закрыл. А ты ну-ка расскажи, каким боком версии WinAPI относятся к CRT?

Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

110. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Аноним (??) on 11-Сен-14, 05:58 
> Открой для себя другие версии WinAPI.

Кроме версий винапи есть еще либы рантайма - у MSVC это обычно MSVC*.dll.

Что характерно - каждая студия использует разную версию рантайма. А вот по дефолту в той или иной системе есть далеко не любая версия этих либ и в результате зачастую приперев "да вот только что работало же?!" программу на новый комп мы получаем в физиономию диалог про отсутствие DLL, или просто тихую смерть программы.

Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

17. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –1 +/
Сообщение от Аноним (??) on 08-Сен-14, 14:21 
> Тогда почему сборки апача и модулей, скомпилированные VC11, не работают под XP
> и 2003 сервером? https://www.apachelounge.com/download/

гугли v110_xp Targeting

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

111. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Аноним (??) on 11-Сен-14, 05:59 
> гугли v110_xp Targeting

Сами и гуглите свой крап. Почему-то вы себе делаете феерического размера скидки, а другим так нельзя. Fsck double standards.

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

121. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от arisu (ok) on 11-Сен-14, 13:48 
> Почему-то вы себе делаете феерического размера скидки,
> а другим так нельзя.

ну дык если они станут играть честно, то их ещё на старте снимут. из жалости.

Ответить | Правка | ^ к родителю #111 | Наверх | Cообщить модератору

13. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +2 +/
Сообщение от Аноним (??) on 08-Сен-14, 14:01 
Ой ли?
Это набором v120_xp? Случаем не под SP3 она компилит, который в апреле 2008 вышел?
(К слову 12я студия только с Update1 стала это уметь делать, а до Update1 v110_xp не было, и получались "не приложения win32" на XP)
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

34. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –2 +/
Сообщение от Аноним (??) on 08-Сен-14, 17:45 
> Ой ли?
> Это набором v120_xp? Случаем не под SP3 она компилит, который в апреле
> 2008 вышел?
> (К слову 12я студия только с Update1 стала это уметь делать, а
> до Update1 v110_xp не было, и получались "не приложения win32" на
> XP)

SP0 vs SP3 - это вам не разница между Fedora 1 и Fedora 17. SP3 ставится молча спокойно и ничего не переворачивает с ног на голову.

Драйвера от SP0 отлично пашут в SP3 и даже в Windows 2003 R2. Покажите мне драйвера от Linux 2.6.0, которые соберутся в Linux 3.2.0. Хотя б один.

// b.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

39. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Аноним (??) on 08-Сен-14, 18:56 
Может для начала исходники всех виндодрайверов предоставишь?
Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

47. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –1 +/
Сообщение от Аноним (??) on 08-Сен-14, 20:31 
> Может для начала исходники всех виндодрайверов предоставишь?

Демагогия. Вы ж копытом в грудь себя бьете, что любой сорц по первому чиху. У M$ я что-то не припомню такого.

Ответить | Правка | ^ к родителю #39 | Наверх | Cообщить модератору

50. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 08-Сен-14, 20:39 
> Демагогия. Вы ж копытом в грудь себя бьете, что любой сорц по
> первому чиху. У M$ я что-то не припомню такого.

спасибо, что сразу явно обозначил свою демагогию.

Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

59. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от pavlinux (ok) on 09-Сен-14, 02:30 
> Покажите мне драйвера от Linux 2.6.0, которые соберутся в Linux 3.2.0. Хотя б один.

Все! Берёшь 3.2.0 и компилишь! И только тяфкни, что там нет этого драйвера.

Даже от 2.4.37 соберётся на 3.2.0

drivers/ide/ide-cd.с
drivers/pcmcia/yenta_socket.c

Был бы ты правильный троль, написал бы - "от 2.6 запустятся на 3.2", а не "соберутся".  :-P
Хотя...  

... не, для Анонимного говна и так много написал.

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

77. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –2 +/
Сообщение от Аноним (??) on 10-Сен-14, 21:45 
Павлуша, ты идиот.

Драйвера в исходниках, написанные изначально для 2.6.0, не соберутся для 3.0. Ни один в природе.

// b.

Ответить | Правка | ^ к родителю #59 | Наверх | Cообщить модератору

99. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от pavlinux (ok) on 11-Сен-14, 02:05 
> Павлуша, ты идиот.
> Драйвера в исходниках, написанные изначально для 2.6.0, не соберутся для 3.0. Ни
> один в природе.

Говно, ты сколько бабла заплатишь, чтоб я пред тобой тут отчитывался?  

Ответить | Правка | ^ к родителю #77 | Наверх | Cообщить модератору

112. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +2 +/
Сообщение от Аноним (??) on 11-Сен-14, 06:00 
> Ни один в природе.

А вот это совсем не факт.

Ответить | Правка | ^ к родителю #77 | Наверх | Cообщить модератору

73. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от anonymous (??) on 10-Сен-14, 12:34 
>SP3 ставится молча спокойно и ничего не переворачивает с ног на голову.

Угу, я видел сотни бсодов при апдейте лицензионной XP с SP0 на SP3 в обход SP1 и SP2

А так да, конечно...

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

78. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –1 +/
Сообщение от Аноним (??) on 10-Сен-14, 21:47 
>>SP3 ставится молча спокойно и ничего не переворачивает с ног на голову.
> Угу, я видел сотни бсодов при апдейте лицензионной XP с SP0 на
> SP3 в обход SP1 и SP2
> А так да, конечно...

SP2 - это требование для SP3. Я устанавливал SP0 -> SP1 -> SP2 -> SP3 на более, чем трёхстах компьютерах. Ноль БСОД'ов.

И, вообще, ваш высер не в тему.

Ответить | Правка | ^ к родителю #73 | Наверх | Cообщить модератору

19. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от .... on 08-Сен-14, 14:29 
> Лучше, чем у кого?

чем, думаю, у кого бы то ни было, кто еще не окуклился и не поддерживает совместимость только потому, что ничего и не делал десять лет.

> Я могу собрать MSVC 2013 программу и запустить её на Windows XP
> (2001 года выпуска).

и gcc можешь - с тем же примерно успехом. Ну то есть - помня о том что половина фич не работает, половина оставшейся половины - криво. hello world работать будет, да.

> И она, о чудо, не потребует ntdll.dll от Windows 8.1. Вообще ничего

и что?

В данном случае ты пытаешься зачем-то взгромоздить dll'и от windows 8.1 на XP. И обижаешься, что требуют хотя бы SP3. В понятных тебе аналогиях.
Я вот ума не приложу, зачем тебе это вообще может понадобиться, учитывая что большинство ограничений как раз в ядре, а не в самой библиотеке.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

35. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –1 +/
Сообщение от Аноним (??) on 08-Сен-14, 17:47 
Фичи либо работают, либо не работают вообще.

Microsoft, видите ли, заботится о compatibility. В лялихе и Open Source API могут менять как угодно - вызов один, а поведение различается, "Вы пересоберите всё, и всё будет отлично".

fopen() что в Windows 95, что в Windows 8.1, работает одинаково.

// b.


Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

42. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +/
Сообщение от arisu (ok) on 08-Сен-14, 19:13 
> Microsoft, видите ли, заботится о compatibility.

ага. старательно так заботится. радость считать страницы по запросу «не работает в семёрке» и «не работает в восьмёрке» оставлю тебе в качестве домашнего задания.

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

48. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –1 +/
Сообщение от Аноним (??) on 08-Сен-14, 20:33 
>> Microsoft, видите ли, заботится о compatibility.
> ага. старательно так заботится. радость считать страницы по запросу «не работает в
> семёрке» и «не работает в восьмёрке» оставлю тебе в качестве домашнего
> задания.

Это проблема не ОС, а прикладных прогеров.

И - да, в M$ тоже нет-нет чистят систему от устаревшего кода. Страницы "Не работает в Дебиан после обновления" предоставляю лично тебе найти. Дабы не трындел, что святее папы римского. В своем глазу бревна считайте. Вы ж всех шире-всех толще-всех-длиньше. Остальные просто дело делают, пока вы теологические споры за лицензии ведете, чья чище.

Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

49. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от arisu (ok) on 08-Сен-14, 20:38 
> Это проблема не ОС, а прикладных прогеров.

ух ты! действительно: если что-то не работает в новой версии винды — это программер того, что не работает, криворукий. а если в новой версии пингвинуса — это разработчики пингвинуса криворукие.

топорно ты свой досирак отрабатываешь.

Ответить | Правка | ^ к родителю #48 | Наверх | Cообщить модератору

60. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –1 +/
Сообщение от клоун on 09-Сен-14, 03:16 
Когда функция последние 5 лет obsolete, это на что-то намекает, правда?
Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

63. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +/
Сообщение от Аноним (??) on 09-Сен-14, 08:22 
> Когда функция последние 5 лет obsolete, это на что-то намекает, правда?

Когда функция объявляется устаревшей раньше, чем у неё заканчиваются параметры со статусом "reserved for future use", то это тоже на что-то намекает. И в WinAPI подобных параметров функций и полей структур чуть меньше, чем дофига.

Ответить | Правка | ^ к родителю #60 | Наверх | Cообщить модератору

113. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –1 +/
Сообщение от Аноним (??) on 11-Сен-14, 06:02 
> Когда функция последние 5 лет obsolete, это на что-то намекает, правда?

Да, это намекает на двойные стандарты. Когда у пингвина ядра пятилетней давности obsolete - это фи. А себе мы такую скидку сделами, да, зайцы-маздайцы?

Ответить | Правка | ^ к родителю #60 | Наверх | Cообщить модератору

26. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Аноним (??) on 08-Сен-14, 15:04 
600M
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

27. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +3 +/
Сообщение от Аноним (??) on 08-Сен-14, 15:12 
Правда чтоли? Блин, иди расскажи MS, а то клепают какие-то compatibility mode зачем-то.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

31. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Йух (??) on 08-Сен-14, 16:35 
MSVC Redistributable нифига не крошечный.
Конечно до какогонибуть дотнета ему далеко, не не маленький
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

36. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –2 +/
Сообщение от Аноним (??) on 08-Сен-14, 17:50 
> MSVC Redistributable нифига не крошечный.
> Конечно до какогонибуть дотнета ему далеко, не не маленький

vcredist_x64.exe - 6.9 MB
vcredist_x86.exe - 6.2 MB

Размер ядра или glibc сами посмотрите?

// b.

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

43. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от arisu (ok) on 08-Сен-14, 19:15 
> Размер ядра или glibc сами посмотрите?

без проблем.
-rw-r--r-- 1 root root 2413824 Oct 23  2012 /boot/vmlinuz
-rwxr-xr-x 1 root root 1831085 May  7 21:01 /lib/libc-2.19.so

обтекай.

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

44. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –3 +/
Сообщение от Аноним (??) on 08-Сен-14, 19:54 
Шутник.

/lib/modules/версия_ядра

+ не считая glibc-common:

/etc/gai.conf
/etc/ld.so.cache
/etc/ld.so.conf
/etc/ld.so.conf.d
/etc/localtime
/etc/nsswitch.conf
/etc/rpc
/lib/i686
/lib/i686/nosegneg
/lib/i686/nosegneg/libc-2.12.so
/lib/i686/nosegneg/libc.so.6
/lib/i686/nosegneg/libm-2.12.so
/lib/i686/nosegneg/libm.so.6
/lib/i686/nosegneg/libpthread-2.12.so
/lib/i686/nosegneg/libpthread.so.0
/lib/i686/nosegneg/librt-2.12.so
/lib/i686/nosegneg/librt.so.1
/lib/i686/nosegneg/libthread_db-1.0.so
/lib/i686/nosegneg/libthread_db.so.1
/lib/ld-2.12.so
/lib/ld-linux.so.2
/lib/libBrokenLocale-2.12.so
/lib/libBrokenLocale.so.1
/lib/libSegFault.so
/lib/libanl-2.12.so
/lib/libanl.so.1
/lib/libc-2.12.so
/lib/libc.so.6
/lib/libcidn-2.12.so
/lib/libcidn.so.1
/lib/libcrypt-2.12.so
/lib/libcrypt.so.1
/lib/libdl-2.12.so
/lib/libdl.so.2
/lib/libm-2.12.so
/lib/libm.so.6
/lib/libnsl-2.12.so
/lib/libnsl.so.1
/lib/libnss_compat-2.12.so
/lib/libnss_compat.so.2
/lib/libnss_dns-2.12.so
/lib/libnss_dns.so.2
/lib/libnss_files-2.12.so
/lib/libnss_files.so.2
/lib/libnss_hesiod-2.12.so
/lib/libnss_hesiod.so.2
/lib/libnss_nis-2.12.so
/lib/libnss_nis.so.2
/lib/libnss_nisplus-2.12.so
/lib/libnss_nisplus.so.2
/lib/libpthread-2.12.so
/lib/libpthread.so.0
/lib/libresolv-2.12.so
/lib/libresolv.so.2
/lib/librt-2.12.so
/lib/librt.so.1
/lib/libthread_db-1.0.so
/lib/libthread_db.so.1
/lib/libutil-2.12.so
/lib/libutil.so.1
/lib/rtkaio
/lib/rtkaio/i686
/lib/rtkaio/i686/nosegneg
/lib/rtkaio/i686/nosegneg/librt.so.1
/lib/rtkaio/i686/nosegneg/librtkaio-2.12.so
/lib/rtkaio/librt.so.1
/lib/rtkaio/librtkaio-2.12.so
/sbin/ldconfig
/sbin/sln
/usr/lib/gconv
/usr/lib/gconv/ANSI_X3.110.so
/usr/lib/gconv/ARMSCII-8.so
/usr/lib/gconv/ASMO_449.so
/usr/lib/gconv/BIG5.so
/usr/lib/gconv/BIG5HKSCS.so
/usr/lib/gconv/BRF.so
/usr/lib/gconv/CP10007.so
/usr/lib/gconv/CP1125.so
/usr/lib/gconv/CP1250.so
/usr/lib/gconv/CP1251.so
/usr/lib/gconv/CP1252.so
/usr/lib/gconv/CP1253.so
/usr/lib/gconv/CP1254.so
/usr/lib/gconv/CP1255.so
/usr/lib/gconv/CP1256.so
/usr/lib/gconv/CP1257.so
/usr/lib/gconv/CP1258.so
/usr/lib/gconv/CP737.so
/usr/lib/gconv/CP775.so
/usr/lib/gconv/CP932.so
/usr/lib/gconv/CSN_369103.so
/usr/lib/gconv/CWI.so
/usr/lib/gconv/DEC-MCS.so
/usr/lib/gconv/EBCDIC-AT-DE-A.so
/usr/lib/gconv/EBCDIC-AT-DE.so
/usr/lib/gconv/EBCDIC-CA-FR.so
/usr/lib/gconv/EBCDIC-DK-NO-A.so
/usr/lib/gconv/EBCDIC-DK-NO.so
/usr/lib/gconv/EBCDIC-ES-A.so
/usr/lib/gconv/EBCDIC-ES-S.so
/usr/lib/gconv/EBCDIC-ES.so
/usr/lib/gconv/EBCDIC-FI-SE-A.so
/usr/lib/gconv/EBCDIC-FI-SE.so
/usr/lib/gconv/EBCDIC-FR.so
/usr/lib/gconv/EBCDIC-IS-FRISS.so
/usr/lib/gconv/EBCDIC-IT.so
/usr/lib/gconv/EBCDIC-PT.so
/usr/lib/gconv/EBCDIC-UK.so
/usr/lib/gconv/EBCDIC-US.so
/usr/lib/gconv/ECMA-CYRILLIC.so
/usr/lib/gconv/EUC-CN.so
/usr/lib/gconv/EUC-JISX0213.so
/usr/lib/gconv/EUC-JP-MS.so
/usr/lib/gconv/EUC-JP.so
/usr/lib/gconv/EUC-KR.so
/usr/lib/gconv/EUC-TW.so
/usr/lib/gconv/GB18030.so
/usr/lib/gconv/GBBIG5.so
/usr/lib/gconv/GBGBK.so
/usr/lib/gconv/GBK.so
/usr/lib/gconv/GEORGIAN-ACADEMY.so
/usr/lib/gconv/GEORGIAN-PS.so
/usr/lib/gconv/GOST_19768-74.so
/usr/lib/gconv/GREEK-CCITT.so
/usr/lib/gconv/GREEK7-OLD.so
/usr/lib/gconv/GREEK7.so
/usr/lib/gconv/HP-GREEK8.so
/usr/lib/gconv/HP-ROMAN8.so
/usr/lib/gconv/HP-ROMAN9.so
/usr/lib/gconv/HP-THAI8.so
/usr/lib/gconv/HP-TURKISH8.so
/usr/lib/gconv/IBM037.so
/usr/lib/gconv/IBM038.so
/usr/lib/gconv/IBM1004.so
/usr/lib/gconv/IBM1008.so
/usr/lib/gconv/IBM1008_420.so
/usr/lib/gconv/IBM1025.so
/usr/lib/gconv/IBM1026.so
/usr/lib/gconv/IBM1046.so
/usr/lib/gconv/IBM1047.so
/usr/lib/gconv/IBM1097.so
/usr/lib/gconv/IBM1112.so
/usr/lib/gconv/IBM1122.so
/usr/lib/gconv/IBM1123.so
/usr/lib/gconv/IBM1124.so
/usr/lib/gconv/IBM1129.so
/usr/lib/gconv/IBM1130.so
/usr/lib/gconv/IBM1132.so
/usr/lib/gconv/IBM1133.so
/usr/lib/gconv/IBM1137.so
/usr/lib/gconv/IBM1140.so
/usr/lib/gconv/IBM1141.so
/usr/lib/gconv/IBM1142.so
/usr/lib/gconv/IBM1143.so
/usr/lib/gconv/IBM1144.so
/usr/lib/gconv/IBM1145.so
/usr/lib/gconv/IBM1146.so
/usr/lib/gconv/IBM1147.so
/usr/lib/gconv/IBM1148.so
/usr/lib/gconv/IBM1149.so
/usr/lib/gconv/IBM1153.so
/usr/lib/gconv/IBM1154.so
/usr/lib/gconv/IBM1155.so
/usr/lib/gconv/IBM1156.so
/usr/lib/gconv/IBM1157.so
/usr/lib/gconv/IBM1158.so
/usr/lib/gconv/IBM1160.so
/usr/lib/gconv/IBM1161.so
/usr/lib/gconv/IBM1162.so
/usr/lib/gconv/IBM1163.so
/usr/lib/gconv/IBM1164.so
/usr/lib/gconv/IBM1166.so
/usr/lib/gconv/IBM1167.so
/usr/lib/gconv/IBM12712.so
/usr/lib/gconv/IBM1364.so
/usr/lib/gconv/IBM1371.so
/usr/lib/gconv/IBM1388.so
/usr/lib/gconv/IBM1390.so
/usr/lib/gconv/IBM1399.so
/usr/lib/gconv/IBM16804.so
/usr/lib/gconv/IBM256.so
/usr/lib/gconv/IBM273.so
/usr/lib/gconv/IBM274.so
/usr/lib/gconv/IBM275.so
/usr/lib/gconv/IBM277.so
/usr/lib/gconv/IBM278.so
/usr/lib/gconv/IBM280.so
/usr/lib/gconv/IBM281.so
/usr/lib/gconv/IBM284.so
/usr/lib/gconv/IBM285.so
/usr/lib/gconv/IBM290.so
/usr/lib/gconv/IBM297.so
/usr/lib/gconv/IBM420.so
/usr/lib/gconv/IBM423.so
/usr/lib/gconv/IBM424.so
/usr/lib/gconv/IBM437.so
/usr/lib/gconv/IBM4517.so
/usr/lib/gconv/IBM4899.so
/usr/lib/gconv/IBM4909.so
/usr/lib/gconv/IBM4971.so
/usr/lib/gconv/IBM500.so
/usr/lib/gconv/IBM5347.so
/usr/lib/gconv/IBM803.so
/usr/lib/gconv/IBM850.so
/usr/lib/gconv/IBM851.so
/usr/lib/gconv/IBM852.so
/usr/lib/gconv/IBM855.so
/usr/lib/gconv/IBM856.so
/usr/lib/gconv/IBM857.so
/usr/lib/gconv/IBM860.so
/usr/lib/gconv/IBM861.so
/usr/lib/gconv/IBM862.so
/usr/lib/gconv/IBM863.so
/usr/lib/gconv/IBM864.so
/usr/lib/gconv/IBM865.so
/usr/lib/gconv/IBM866.so
/usr/lib/gconv/IBM866NAV.so
/usr/lib/gconv/IBM868.so
/usr/lib/gconv/IBM869.so
/usr/lib/gconv/IBM870.so
/usr/lib/gconv/IBM871.so
/usr/lib/gconv/IBM874.so
/usr/lib/gconv/IBM875.so
/usr/lib/gconv/IBM880.so
/usr/lib/gconv/IBM891.so
/usr/lib/gconv/IBM901.so
/usr/lib/gconv/IBM902.so
/usr/lib/gconv/IBM903.so
/usr/lib/gconv/IBM9030.so
/usr/lib/gconv/IBM904.so
/usr/lib/gconv/IBM905.so
/usr/lib/gconv/IBM9066.so
/usr/lib/gconv/IBM918.so
/usr/lib/gconv/IBM921.so
/usr/lib/gconv/IBM922.so
/usr/lib/gconv/IBM930.so
/usr/lib/gconv/IBM932.so
/usr/lib/gconv/IBM933.so
/usr/lib/gconv/IBM935.so
/usr/lib/gconv/IBM937.so
/usr/lib/gconv/IBM939.so
/usr/lib/gconv/IBM943.so
/usr/lib/gconv/IBM9448.so
/usr/lib/gconv/IEC_P27-1.so
/usr/lib/gconv/INIS-8.so
/usr/lib/gconv/INIS-CYRILLIC.so
/usr/lib/gconv/INIS.so
/usr/lib/gconv/ISIRI-3342.so
/usr/lib/gconv/ISO-2022-CN-EXT.so
/usr/lib/gconv/ISO-2022-CN.so
/usr/lib/gconv/ISO-2022-JP-3.so
/usr/lib/gconv/ISO-2022-JP.so
/usr/lib/gconv/ISO-2022-KR.so
/usr/lib/gconv/ISO-IR-197.so
/usr/lib/gconv/ISO-IR-209.so
/usr/lib/gconv/ISO646.so
/usr/lib/gconv/ISO8859-1.so
/usr/lib/gconv/ISO8859-10.so
/usr/lib/gconv/ISO8859-11.so
/usr/lib/gconv/ISO8859-13.so
/usr/lib/gconv/ISO8859-14.so
/usr/lib/gconv/ISO8859-15.so
/usr/lib/gconv/ISO8859-16.so
/usr/lib/gconv/ISO8859-2.so
/usr/lib/gconv/ISO8859-3.so
/usr/lib/gconv/ISO8859-4.so
/usr/lib/gconv/ISO8859-5.so
/usr/lib/gconv/ISO8859-6.so
/usr/lib/gconv/ISO8859-7.so
/usr/lib/gconv/ISO8859-8.so
/usr/lib/gconv/ISO8859-9.so
/usr/lib/gconv/ISO8859-9E.so
/usr/lib/gconv/ISO_10367-BOX.so
/usr/lib/gconv/ISO_11548-1.so
/usr/lib/gconv/ISO_2033.so
/usr/lib/gconv/ISO_5427-EXT.so
/usr/lib/gconv/ISO_5427.so
/usr/lib/gconv/ISO_5428.so
/usr/lib/gconv/ISO_6937-2.so
/usr/lib/gconv/ISO_6937.so
/usr/lib/gconv/JOHAB.so
/usr/lib/gconv/KOI-8.so
/usr/lib/gconv/KOI8-R.so
/usr/lib/gconv/KOI8-RU.so
/usr/lib/gconv/KOI8-T.so
/usr/lib/gconv/KOI8-U.so
/usr/lib/gconv/LATIN-GREEK-1.so
/usr/lib/gconv/LATIN-GREEK.so
/usr/lib/gconv/MAC-CENTRALEUROPE.so
/usr/lib/gconv/MAC-IS.so
/usr/lib/gconv/MAC-SAMI.so
/usr/lib/gconv/MAC-UK.so
/usr/lib/gconv/MACINTOSH.so
/usr/lib/gconv/MIK.so
/usr/lib/gconv/NATS-DANO.so
/usr/lib/gconv/NATS-SEFI.so
/usr/lib/gconv/PT154.so
/usr/lib/gconv/RK1048.so
/usr/lib/gconv/SAMI-WS2.so
/usr/lib/gconv/SHIFT_JISX0213.so
/usr/lib/gconv/SJIS.so
/usr/lib/gconv/T.61.so
/usr/lib/gconv/TCVN5712-1.so
/usr/lib/gconv/TIS-620.so
/usr/lib/gconv/TSCII.so
/usr/lib/gconv/UHC.so
/usr/lib/gconv/UNICODE.so
/usr/lib/gconv/UTF-16.so
/usr/lib/gconv/UTF-32.so
/usr/lib/gconv/UTF-7.so
/usr/lib/gconv/VISCII.so
/usr/lib/gconv/gconv-modules
/usr/lib/gconv/gconv-modules.cache
/usr/lib/gconv/libCNS.so
/usr/lib/gconv/libGB.so
/usr/lib/gconv/libISOIR165.so
/usr/lib/gconv/libJIS.so
/usr/lib/gconv/libJISX0213.so
/usr/lib/gconv/libKSC.so
/usr/lib/libmemusage.so
/usr/lib/libpcprofile.so
/usr/libexec/getconf
/usr/libexec/getconf/POSIX_V6_ILP32_OFF32
/usr/libexec/getconf/POSIX_V6_ILP32_OFFBIG
/usr/libexec/getconf/POSIX_V7_ILP32_OFF32
/usr/libexec/getconf/POSIX_V7_ILP32_OFFBIG
/usr/sbin/glibc_post_upgrade.i686
/usr/sbin/iconvconfig
/usr/sbin/iconvconfig.i686

Сколько же тут малолетних одарённых людей.

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

45. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от arisu (ok) on 08-Сен-14, 19:56 
молодец, хорошо обтёк. в следующий раз приходи, когда научишься правильно задавать вопросы, старолетний.
Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

88. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –3 +/
Сообщение от Аноним (??) on 10-Сен-14, 22:05 
> молодец, хорошо обтёк. в следующий раз приходи, когда научишься правильно задавать вопросы,
> старолетний.

Вопросы были чёткие. Размер пакетов glibc и ядра. Если вы особо одарённый, то извините. Попробуйте пообщаться с такими же. Палата номер 6, если что.

vmlinuz - это НЕ ядро.
libc.so - это НЕ glibc.

Это их маленькие составные части. В общем, вы неинтересны. Троллить не умеете. Заshitать лялих тоже. Удачи!

// b.

Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

92. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 10-Сен-14, 22:18 
> Вопросы были чёткие. Размер пакетов glibc и ядра.

внимательно поискал слово «пакет» в #36. не нашёл. но раз уж ты так хочешь именно пакеты, получай и это:
-rw-r--r-- 1 … users 2449028 May  7 21:03 glibc-solibs-2.19-i486–1.txz
-rw-r--r-- 1 … users  3868284 Aug 25 23:11 kernel-generic-smp-3.14.17_smp-i686–1.txz

и да: ты, конечно, можешь хоть разорваться, но vmlinuz — это таки ядро. а libc.so — это таки glibc.

не хотел обтекать молча — обтекай с позором, воля твоя.

Ответить | Правка | ^ к родителю #88 | Наверх | Cообщить модератору

114. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от Аноним (??) on 11-Сен-14, 06:06 
> vmlinuz - это НЕ ядро.

Да неужели? :)

> Это их маленькие составные части. В общем, вы неинтересны.

Я бы не сказал что vmlinuz - "маленькая составная часть". А мсовским дронам в методичке не рассказывают что ядро в лине можно при желании совсем без поддержки модулей сделать и вообще все впихать в само ядро?

Кроме всего прочего это удобно если например для старта системы надо какой-то особый драйвер. Его можно просто включить в ядро и если бутлоадер может прочитать и пнуть ядро правдами-неправдами - дальше система на взлет пойдет. А у MS по этому поводу весьма знатный кластерфак в плане нестандартных ситуаций вышел. Вплоть до бутлоадера-переростка который немного умеет предзагружать early boot дрова без которых система на взлет просто не может пойти чисто технически, т.к. если ядро не может подчитать бутовый носитель и ФС - это красивый такой тыдыщ с INACCESSIBLE_BOOT_DEVICE.

Ответить | Правка | ^ к родителю #88 | Наверх | Cообщить модератору

119. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от arisu (ok) on 11-Сен-14, 13:39 
> Я бы не сказал что vmlinuz - "маленькая составная часть". А мсовским
> дронам в методичке не рассказывают что ядро в лине можно при
> желании совсем без поддержки модулей сделать и вообще все впихать в
> само ядро?

конечно, нет. иначе он бы попросил предъявить ещё и initrd (и был бы где-то прав), а я бы его обломал сообщением, что не использую initrd.

Ответить | Правка | ^ к родителю #114 | Наверх | Cообщить модератору

122. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от Andrey Mitrofanov on 11-Сен-14, 14:25 
> конечно, нет. иначе он бы попросил предъявить ещё и initrd (и был

...и вычесть из него размер статически слинкомванного там в нём того libc, и прибавит его, размер, к размеру _этого libc, но только если это glibc, а не наоборот...

+++Где начало того конца, которым оканчивается начало?
---Опять они о терминах,- подумала Алиса. -И опять не договорятся.

Ответить | Правка | ^ к родителю #119 | Наверх | Cообщить модератору

124. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +/
Сообщение от Led (ok) on 12-Сен-14, 01:18 
>> Я бы не сказал что vmlinuz - "маленькая составная часть". А мсовским
>> дронам в методичке не рассказывают что ядро в лине можно при
>> желании совсем без поддержки модулей сделать и вообще все впихать в
>> само ядро?
> конечно, нет. иначе он бы попросил предъявить ещё и initrd (и был
> бы где-то прав), а я бы его обломал сообщением, что не
> использую initrd.

А что, можно и предъявить:

du -b /boot/initrd-3.15.10-led-ws-alt8.img
455028  /boot/initrd-3.15.10-led-ws-alt8.img

Ответить | Правка | ^ к родителю #119 | Наверх | Cообщить модератору

53. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от AlexAT (ok) on 08-Сен-14, 22:27 
Ну тогда и у винды весь system32 считай, и winsxs ещё.
Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

54. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 08-Сен-14, 22:39 
> Ну тогда и у винды весь system32 считай, и winsxs ещё.

спокойно, это малолетний одарённый человек, он ещё научится. лет через сорок.

Ответить | Правка | ^ к родителю #53 | Наверх | Cообщить модератору

79. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –3 +/
Сообщение от Аноним (??) on 10-Сен-14, 21:49 
> Ну тогда и у винды весь system32 считай, и winsxs ещё.

Оупенсорцеры не дружат с головой.

В лялихе невозможно (официально и нормально - идиоты, конечно, могут) обновить glibc, заменив один файл libc.so.

В Windows я ставлю MSVC redistributable и всё.

Мне не надо обновлять 500MB зависимостей для этого.

// b.

Ответить | Правка | ^ к родителю #53 | Наверх | Cообщить модератору

115. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от Аноним (??) on 11-Сен-14, 06:10 
> Мне не надо обновлять 500MB зависимостей для этого.

Для обновления libc качается один пакет, порядка 4Мб весом. Внезапно, правда? Ну подумаешь, MS-ботец соврал на 2 порядка :)

Ответить | Правка | ^ к родителю #79 | Наверх | Cообщить модератору

120. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 11-Сен-14, 13:41 
>> Мне не надо обновлять 500MB зависимостей для этого.
> Для обновления libc качается один пакет, порядка 4Мб весом. Внезапно, правда? Ну
> подумаешь, MS-ботец соврал на 2 порядка :)

он не соврал, он просто рассказал, как медленно и печально это происходит на винде. а поскольку винду писали Высоко Оплачиваемые Профессионалы и m$ её продаёт, то во всех остальных системах (особенно бесплатных) никак не может быть лучше.

Ответить | Правка | ^ к родителю #115 | Наверх | Cообщить модератору

75. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –2 +/
Сообщение от Аноним (??) on 10-Сен-14, 16:07 
>> Размер ядра или glibc сами посмотрите?
> без проблем.
> -rw-r--r-- 1 root root 2413824 Oct 23  2012 /boot/vmlinuz
> -rwxr-xr-x 1 root root 1831085 May  7 21:01 /lib/libc-2.19.so
> обтекай.

ядро двухлетней давности? о_О

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

80. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –2 +/
Сообщение от Аноним (??) on 10-Сен-14, 21:50 
>>> Размер ядра или glibc сами посмотрите?
>> без проблем.
>> -rw-r--r-- 1 root root 2413824 Oct 23  2012 /boot/vmlinuz
>> -rwxr-xr-x 1 root root 1831085 May  7 21:01 /lib/libc-2.19.so
>> обтекай.
> ядро двухлетней давности? о_О

Я лялихе нет дыр. Он лялих! Что вы к человеку придрались.

Ответить | Правка | ^ к родителю #75 | Наверх | Cообщить модератору

83. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от arisu (ok) on 10-Сен-14, 21:57 
> Я лялихе нет дыр. Он лялих! Что вы к человеку придрались.

эк тебя бомбит — даже пишешь от этого бред. любо смотреть.

Ответить | Правка | ^ к родителю #80 | Наверх | Cообщить модератору

82. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 10-Сен-14, 21:56 
> ядро двухлетней давности? о_О

даун, не умеющий собирать ядра под своё железо?

Ответить | Правка | ^ к родителю #75 | Наверх | Cообщить модератору

95. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –2 +/
Сообщение от Аноним (??) on 11-Сен-14, 00:32 
даун,сидящий два года на стухшем ядре и стухшем железе?
Ответить | Правка | ^ к родителю #82 | Наверх | Cообщить модератору

96. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 11-Сен-14, 00:40 
> даун,сидящий два года на стухшем ядре и стухшем железе?

тебе видней, конечно, какой ты даун, тут я гадать не буду.

Ответить | Правка | ^ к родителю #95 | Наверх | Cообщить модератору

97. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –2 +/
Сообщение от Аноним (??) on 11-Сен-14, 00:56 
пердак бомбануло, ретроградик? кстати, ты уже свой crt-моник выбросил на помойку или продолжаешь мучаться?
Ответить | Правка | ^ к родителю #96 | Наверх | Cообщить модератору

98. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от arisu (ok) on 11-Сен-14, 01:14 
Rasch abkochen, dann Vormarsch nach Sokal.
Ответить | Правка | ^ к родителю #97 | Наверх | Cообщить модератору

126. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +/
Сообщение от Аноним (??) on 12-Сен-14, 11:44 
> ядро двухлетней давности?

Напомнить, в каком году вышла самая распространённая версия винды?

Ответить | Правка | ^ к родителю #75 | Наверх | Cообщить модератору

64. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от Аноним (??) on 09-Сен-14, 08:39 
> Размер ядра или glibc сами посмотрите?

Да вот ведь незадача: в каждой отдельно взятой Linux-системе glibc одна, а рантайм MSVC под каждую версию свой, в результате чего в среднестатистической винде этих рантаймов стоит сразу несколько. А уж как разработчикам весело следить за тем, чтобы все (в том числе сторонние) компоненты их ПО использовали одну и ту же версию msvcrt...

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

81. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –3 +/
Сообщение от Аноним (??) on 10-Сен-14, 21:52 
>> Размер ядра или glibc сами посмотрите?
> Да вот ведь незадача: в каждой отдельно взятой Linux-системе glibc одна, а
> рантайм MSVC под каждую версию свой, в результате чего в среднестатистической
> винде этих рантаймов стоит сразу несколько. А уж как разработчикам весело
> следить за тем, чтобы все (в том числе сторонние) компоненты их
> ПО использовали одну и ту же версию msvcrt...
> а рантайм MSVC под каждую версию свой, в результате чего в среднестатистической винде этих рантаймов стоит сразу несколько.

И что? 2008, 2009, 2011, 2013 - четыре runtime'a не западло поставить. А вот в Линуксе _официально_ обновить отдельные программы и компоненты - хрен-с два. Пожалуйста, весь дистр обновите.

// b.

Ответить | Правка | ^ к родителю #64 | Наверх | Cообщить модератору

85. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 10-Сен-14, 21:58 
пожалуйста, расскажи, как в винде можно _официально_ обновить ядро, не обновляя весь виндовс. благодарю.
Ответить | Правка | ^ к родителю #81 | Наверх | Cообщить модератору

87. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  –2 +/
Сообщение от Аноним (??) on 10-Сен-14, 22:00 
> пожалуйста, расскажи, как в винде можно _официально_ обновить ядро, не обновляя весь
> виндовс. благодарю.

Зачем обновлять?! Вы особо одарённый? Речь шла про то, что XP можно расширить до новых библ, а лялих (официально) нельзя. Пожалуйста, весь дистр обновите.

Ответить | Правка | ^ к родителю #85 | Наверх | Cообщить модератору

93. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 10-Сен-14, 22:22 
>> пожалуйста, расскажи, как в винде можно _официально_ обновить ядро, не обновляя весь
>> виндовс. благодарю.
> Зачем обновлять?!

действительно. раз винда этого не умеет — это ненужно.

> а лялих (официально) нельзя

я не знаю, что такое «лялих», а вот свою GNU/Linux я спокойно обновляю отдельными пакетами с отдельными библиотеками. и ничего не отваливается. степерь рукожопости, необходимую для того, чтобы из-за одного пакета обновлять весь дистрибутив, я даже представить себе не могу.

Ответить | Правка | ^ к родителю #87 | Наверх | Cообщить модератору

102. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +1 +/
Сообщение от Аноним (??) on 11-Сен-14, 02:30 
> Зачем обновлять?! Вы особо одарённый? Речь шла про то, что XP можно
> расширить до новых библ,

Удачи в расширении до очередных секурити фиксов, которых теперь не будет, а без них это быстро станет рассадником вирья.

Ответить | Правка | ^ к родителю #87 | Наверх | Cообщить модератору

127. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +/
Сообщение от Аноним (??) on 12-Сен-14, 16:03 
Дык компиляция же! рулит и вполне официально в source-based дистрибутивах;)
Ответить | Правка | ^ к родителю #87 | Наверх | Cообщить модератору

128. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +/
Сообщение от arisu (ok) on 12-Сен-14, 16:07 
> Дык компиляция же! рулит и вполне официально в source-based дистрибутивах;)

и в остальных тоже, вообще-то.

Ответить | Правка | ^ к родителю #127 | Наверх | Cообщить модератору

125. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Аноним (??) on 12-Сен-14, 11:34 
> 2008, 2009, 2011, 2013 - четыре runtime'a не западло поставить

Ты про 2005 и 2012 забыл, а MSVS 2009 вообще не существует. И рантаймов этих куда больше четырёх: 2005, 2008, 2010, 2012, 2013, для каждой версии 32- и 64-битные сборки ставятся отдельно, в 2005 и 2008 из-за у*бищного WinSxS деление идёт ещё и по подверсиям/сервиспакам студии. Так что в системе запросто может оказаться десяток-другой рантаймов ОДНОВРЕМЕННО. *nix-оидам такое разве что в кошмарах присниться может.

Ответить | Правка | ^ к родителю #81 | Наверх | Cообщить модератору

65. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от Алексей Морозов (ok) on 09-Сен-14, 09:39 
Не можете, потому что часть сисколлов появилась только в XPsp2.

С уважением, Лёша, законный обладатель "буковских" Героев, которые не запускаются в Wine именно по причине не реализованности одного такого сисколла. При этом в системных требованиях у этих Героев, естественно, чуть ни Windows 98 стоит. С "Буковским" саппортом, так же естественно, не ругался, т.к. долго и муторно, а все виденные пиратки скомпилированы без этого сисколла. Если надо, могу посмотреть, в каком именно сисколле проблема.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

86. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –2 +/
Сообщение от Аноним (??) on 10-Сен-14, 21:59 
> Не можете, потому что часть сисколлов появилась только в XPsp2.
> С уважением, Лёша, законный обладатель "буковских" Героев, которые не запускаются в Wine
> именно по причине не реализованности одного такого сисколла. При этом в
> системных требованиях у этих Героев, естественно, чуть ни Windows 98 стоит.
> С "Буковским" саппортом, так же естественно, не ругался, т.к. долго и
> муторно, а все виденные пиратки скомпилированы без этого сисколла. Если надо,
> могу посмотреть, в каком именно сисколле проблема.

Все официальные английские версии HoMM3 (Original, SoD, AB) работают на XP SP0. Проверено.

То, что там Бука что-то намудила, нормальных людей не касается.

// b.

Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

116. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +2 +/
Сообщение от Аноним (??) on 11-Сен-14, 06:13 
> То, что там Бука что-то намудила, нормальных людей не касается.

Только почему-то Miranda IM после обновления XP до семерки перестала запускаться. Даже без сообщений вообще. В FAR работать стало геморно, ибо админ не администый и в половину дир его не пускают. А как он видит ФС - зависит от битности. В следующей версии наверное компьютер вообще лучше будет не включать.  

Ответить | Правка | ^ к родителю #86 | Наверх | Cообщить модератору

67. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от Клыкастый (ok) on 09-Сен-14, 17:58 
> Я могу собрать MSVC 2013 программу и запустить её на Windows XP (2001 года выпуска).

Недавно собрал последний астер на FreeBSD 8.x. И без проблем собрал бы на 7.x и 6.x. И на линуксе. С любым ядром. 64/32. Ну с arm/mips хвастать не буду, не пробовал, но результаты есть. Вся система в исходниках - это удобно. Но да, желающим бинарную блобятину таскать из года в год из системы в систему не так удобно, конечно.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

84. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –5 +/
Сообщение от Аноним (??) on 10-Сен-14, 21:57 
>> Я могу собрать MSVC 2013 программу и запустить её на Windows XP (2001 года выпуска).
> Недавно собрал последний астер на FreeBSD 8.x. И без проблем собрал бы
> на 7.x и 6.x. И на линуксе. С любым ядром. 64/32.
> Ну с arm/mips хвастать не буду, не пробовал, но результаты есть.
> Вся система в исходниках - это удобно. Но да, желающим бинарную
> блобятину таскать из года в год из системы в систему не
> так удобно, конечно.

Чем удобно? Тем, что вы гробите своё время на сборку? Что вам время своё не жалко? Что вы сексом с компьютером занимаетесь вместо того, чтобы наслаждаться жизнью? Чем вы гордитесь?

Программы для Windows собираются раз и работают на протяжении ... 13 лет различных систем.

Есть LibreOffice для Windows.

Так вот вы просто берёте и ставите его, начиная с XP и заканчивая Windows 9 Threshold. И ничего не собираете. Не думаете, что вам надо make install, apt-get install, yum install и прочее. Вы просто запускаете .exe

// b.

Ответить | Правка | ^ к родителю #67 | Наверх | Cообщить модератору

89. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший..."  +2 +/
Сообщение от arisu (ok) on 10-Сен-14, 22:10 
> Чем удобно? Тем, что вы гробите своё время на сборку?

нет, это только в винде принято вручную сишный код в машинный транслировать. у нас для этого давно особые инструменты есть: «компиляторы» называются.

> Что вы сексом с компьютером занимаетесь вместо
> того, чтобы наслаждаться жизнью?

опять проецируешь. из того, что лично ты криворукий и иначе не можешь, никак не следует, что все криворукие. хотя криворуким свойственно считать, что они самые умные, и уж если они-то не смогли, то все остальные тем более…

> Чем вы гордитесь?

только совсем альтернативно развитому могла прийти в голову идея гордиться инструментом вместо того, чтобы оный инструмент просто использовать.

> Программы для Windows собираются раз и работают на протяжении ... 13 лет
> различных систем.

да? ух, ты. запусти, пожалуйста, старую Magic:The Gathering, собраную для 95, под вистой, например. ну, это так, навскидку. за остальным можешь сам сходить в гугель, по запросу «не работает под <подставить любую версию винды>».

> Есть LibreOffice для Windows.
> Так вот вы просто берёте и ставите его, начиная с XP и
> заканчивая Windows 9 Threshold. И ничего не собираете. Не думаете, что
> вам надо make install, apt-get install, yum install и прочее. Вы
> просто запускаете .exe

качаю архивы с бинарниками с офсайта, распаковываю в /opt, запускаю. алгоритм отлично работает ещё с тех пор, как был только OO.o. лет эдак как минимум семь. но через пакетный менеджер, конечно, удобней. потому что «просто берёте и ставите» — это как раз apt-get install. а вот «идите на сайт, качайте .exe, запускайте» — это называется «геморрой».

ах, да. тебе опять об этом забыли рассказать, но у пакетного менеджера есть GUI. где софт рассортирован по разделам и имеется поиск. выбрал там Libre Office, тыцнул в кнопку «установить» — и всё. а теперь давай, расскажи, как пользователю намного удобней искать в гугле сайт для скачивания '.exe', внимательно следить, чтобы это был именно оффсайт, а не протрояненый фэйк, качать, запускать, клацать «дальше-дальше-якончел». очень интересно прочитать аргументы — почему именно это проще и лучше, чем использование одного универсального установщика, где надо только нажать кнопку «установить» и всё. мне действительно интересно: я вас коллекционирую.

Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

106. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Аноним (??) on 11-Сен-14, 02:59 
> Чем удобно? Тем, что вы гробите своё время на сборку? Что вам
> время своё не жалко? Что вы сексом с компьютером занимаетесь вместо
> того, чтобы наслаждаться жизнью? Чем вы гордитесь?

Ну мне вот например время на сборку жалко гробить. Поэтому я использую бинарные дистры. И собираю только то в чем лично заинтересован - версии которые в разработке, кастомные конфиги ядер под какую-то специфику и прочее. Но если этим кексам так хочется - наверное все таки не есть плохо что и я и они могут сделать себе удобно. Я их не понимаю в этом, но если им так хочется - вам так уж жалко чтоли?

И если мы о сборке: вкатить в бинарном лине либы и хидеры для сборки - буквально пара команд и пара минут (на скачку и распаковку). В винде подцепить либы и хидеры - весьма отдельный кластерфак. Вообще, в бинарных дистрах есть пакетные менеджеры. И этот ваш MSI installer - жалкая и невзрачная пародия на нормальный пакетный менеджер. Там и нормальная работа с зависимостями, и скачка недостающего на автомате, и обновление всей системы СО ВСЕМ СОФТОМ И ЛИБАМИ ИЗ РЕПОВ на предмет секурити, etc. Перейдя на линь я сэкономил себе туеву хучу времени на администрировании системы ;]. В том числе - я могу без особого гемора пересобрать например новую версию энной программы. Пакетный менеджер с удовольствием вкатит мне либы и хидеры в правильные локации где их ищет компилер за считанные минуты. А в винде это длииииииительный и геморный процесс.

> Программы для Windows собираются раз и работают на протяжении ... 13 лет
> различных систем.

Только при попытке кому-нибудь программы раздать - мы быстро знакомимся с тем фактом что MSVCRTшного рантайма есть полдюжины разных версий. И совсем не факт что в юзеровской системе есть именно тот который конкретно эта студия юзала. Поэтому у юзера или лезет сообщение что не найдена DLL или того веселее программа тихо не стартует.

> Есть LibreOffice для Windows.

Да и фиг с ним.

> просто запускаете .exe

И потом клацаете дурной сетап визард. Вместо того чтобы пакетный менеджер вкатил программу без моего участия. На секундочку, я могу поставить 20 программ из реп за 5 минут на полном автомате. Удачи такой номер в винде с "просто запускаю exe" сделать. Пакетный манагер как раз крутая штука, позволяющая и инсталлить софт без хвостов после сноса, и обновлять на предмет безопасности все и сразу. То-есть если в LibreOffice завтра найдут дыру, а еще в openssl и где там еще - ну я скачаю пакеты с либрой и пакеты с libssl. Они 1 командой или нажатием пары кнопок в гуятине вкатятся и на этом все закончится - система снова в заапдейченом состоянии без известных дыр. В винде же - сам ищи кто openssl юзал и сам проверяй - кто заапдейтился, кто нет, а кто вообще апдейтер поломался писать и надо самому дуть на сайт и качать обновление руками. В 20 раз больше долботни.

Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

117. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Клыкастый (ok) on 11-Сен-14, 13:34 
> Чем удобно? Тем, что вы гробите своё время на сборку? Что вам
> время своё не жалко? Что вы сексом с компьютером занимаетесь вместо
> того, чтобы наслаждаться жизнью? Чем вы гордитесь?

Моё время не тратится. Запустил - забрал результат. Напрягается компьютер. Если жалко времени на компиляцию, таки как относиться к антивирусу, который сношает комп ВСЁ время работы?

> Программы для Windows собираются раз и работают на протяжении ... 13 лет
> различных систем.

Или не работают. Или есть только в 32-битном варианте. Работают с уязвимостями, нефикшеными 13 лет.

> Есть LibreOffice для Windows.

Круто. Повезло вам.

> Так вот вы просто берёте и ставите его, начиная с XP и
> заканчивая Windows 9 Threshold. И ничего не собираете. Не думаете, что
> вам надо make install, apt-get install, yum install и прочее. Вы
> просто запускаете .exe

Врать нехорошо. Просто запускать exe получается далеко не всегда. Например, просто драйвера на интеловскую сетевуху: просто запускаешь exe. а оно просто вываливается. Оказывается нужен дотнет. Не ниже четвёртого. а его нет. Смешно же: то, что в лялихах просто работает из коробки, превращается в миниквест. Очень интересно натолкнуться на софт, который не хочет ставиться без IE 11-го. Интересно, как ты его поставишь на XP. Или вот интересная программа для безопасной передачи документов в налоговую. 4(!!!) компонента. ну, т.е. понимаешь, да? это четыре раза пошариться по "папкам" для запуска exe и много раз далее-далее-далее-далее-ок. Т.е. про зависимости люди не слышали. Компоненты можно ставить в произвольном порядке, но работать будет только если поставлены в определённом, правильном. НО КАК, ХОЛМС!?

Справедливости ради надо отметить, что у МС таки есть какая-то попытка унификации - msi. Но даже такой горячий фанат, как ты, написал "просто запускаете .exe", а не "просто запускаете .msi"

Но вернёмся к запуску бинарей vs исходники. Если запуск 32битного бинаря в 64битной системе ещё как-то решён, то как быть с остальным? 64битный бинарь запустить в xp32? а xp64 не покупали, есть 32. Про arm/mips вообще тухлый вопрос. Так что вопрос ставить надо не "тут просто запустил - тут надо перекомпилять", а "тут болт, а тут если надо - перекомпилял и заработало". Совсем другой коленкор, верно?

Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

130. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от bOOster email on 12-Сен-14, 21:57 
>[оверквотинг удален]
> время своё не жалко? Что вы сексом с компьютером занимаетесь вместо
> того, чтобы наслаждаться жизнью? Чем вы гордитесь?
> Программы для Windows собираются раз и работают на протяжении ... 13 лет
> различных систем.
> Есть LibreOffice для Windows.
> Так вот вы просто берёте и ставите его, начиная с XP и
> заканчивая Windows 9 Threshold. И ничего не собираете. Не думаете, что
> вам надо make install, apt-get install, yum install и прочее. Вы
> просто запускаете .exe
> // b.

Ну мы вообще видим что синим цветом это заканчивается, если что не так :)

Ответить | Правка | ^ к родителю #84 | Наверх | Cообщить модератору

131. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от AlexAT (ok) on 13-Сен-14, 00:11 
> Ну мы вообще видим что синим цветом это заканчивается, если что не
> так :)

Хуже. Это заканчивается годами не фикшенными дырами, типа дыр в GDI, DCOM-RPC или LSASS.

Ответить | Правка | ^ к родителю #130 | Наверх | Cообщить модератору

101. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +2 +/
Сообщение от Аноним (??) on 11-Сен-14, 02:29 
> Я могу собрать MSVC 2013 программу и запустить её на Windows XP
> (2001 года выпуска).

Я тоже могу собрать программу и запустить ее на линуксе 2001 года выпуска. С тамошним libc. Только нафига мне эта некромансия?

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

104. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +3 +/
Сообщение от Аноним (??) on 11-Сен-14, 02:37 
> И она, о чудо, не потребует ntdll.dll от Windows 8.1. Вообще ничего
> не потребует, кроме крошечного runtime.

Да, она при запуске скажет - DLL не найдена, кукуйте. И все, досвидания. А чтобы припереть рантайм - надо городить сетап (целый отдельный рокетсайнс) или рассказывать юзеру где взять и как подпихнуть либу рантайма. Или билдить статически.

У MS с MSVC*.dll вообще-то знатная идиотека и "просто скомпилить" программу конечно можно. Но если ее дать другим людям, без MSVS - можно узнать очень нового о наличии в WinXP 2001 года либ от VS 2013 года. Коих там нет. И это становится головняком програмера...

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

118. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от Клыкастый (ok) on 11-Сен-14, 13:36 
> Или билдить статически.

(сатанинский хохот) мечта "простозапускателейexe". только по-моему это голубая мечта.


Ответить | Правка | ^ к родителю #104 | Наверх | Cообщить модератору

129. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от bOOster email on 12-Сен-14, 21:53 
Ты ее на на windows CE запусти...
В большинстве случаев, если хочешь собрать чтото на опенсорце - даже на embedded платформах собирается и работает.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

8. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +1 +/
Сообщение от ананим on 08-Сен-14, 13:20 
> Какой там API/ABI compatibility?

Нормальный, а что?
Переход с 2.19 на 2.20 не потребует перекомпиляции прикладного ПО.
Не считая prelink.
> Шо це теке?

"Ах ты всё пела? Це же дело. Так иди же, поскачи"
Может хватит так своё невежество демонстрировать?

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

105. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  +/
Сообщение от Аноним (??) on 11-Сен-14, 02:39 
> Может хватит так своё невежество демонстрировать?

Ну мало ли, может этот виндузоид где-то откопал труп стюардессы^W^W ядро древнее 2.6.32. Вдруг он в музее древнего египта работает и в гробнице тутанхамона попались папирусы с распечатками :).

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

6. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –1 +/
Сообщение от eSyr email(ok) on 08-Сен-14, 13:08 
> Для архитектур s390 и s390x
> http://software.intel.com/en-us/blogs/2012/11/06/exploring-i...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

123. "Выпуск системной библиотеки Glibc 2.20, ознаменовавший слиян..."  –1 +/
Сообщение от Аноним (??) on 12-Сен-14, 00:41 
Патрик как в воду глядел!:)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру