The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от opennews on 09-Апр-12, 22:16 
Willy Tarreau, последние 6 лет занимающий пост мэйнтенера ветки ядра Linux 2.4, объявил (https://lkml.org/lkml/2012/4/9/127) о прекращении выпуска обновлений. Отмечается, что уже более года для ядра 2.4 не было представлено критических исправлений, поэтому больше нет смысла откладывать окончание поддержки старой ветки ядра. Для тех кто по тем или иным причинам не может мигрировать на современные версии ядра Linux оставлена Git-ветка, в которую возможно будут переноситься отдельные критические исправления, но без каких-либо гарантий. Напомним, что ядро 2.4.0 вышло в январе 2001 года, а 2.6.0 в декабре 2003 г.


URL: https://lkml.org/lkml/2012/4/9/127
Новость: https://www.opennet.ru/opennews/art.shtml?num=33565

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


2. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –1 +/
Сообщение от devcoder (ok) on 09-Апр-12, 22:23 
Отлично, прогресс,
всё вовремя,
пора все мелкодевайсы на 2.6 переводить,
с timerfd, epool, etc.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +1 +/
Сообщение от Аноним (??) on 09-Апр-12, 22:54 
> с timerfd, epool, etc.

С ext4, однако. Одна из немногих ФС хорошо работающих с мелкими девайсами как раз.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

22. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +1 +/
Сообщение от Andrey Mitrofanov on 10-Апр-12, 09:54 
> пора все мелкодевайсы на 2.6 переводить,

Переведи мне Asus WL-520GC ?

> с timerfd, epool, etc.

С драйвером-блобом для wifi, собирающимся _только с 2.4, и _4 Мб_ флэша (да, 2.6 туда не лезет --- без тебя никак!) ?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

23. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 09:56 
на WL-520GC openwrt упаришься пихать :)
Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

25. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Andrey Mitrofanov on 10-Апр-12, 10:13 
dd-wrt в сборке "micro". работает.
Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

28. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –1 +/
Сообщение от Аноним (??) on 10-Апр-12, 10:54 
Да и openwrt можно упихать при желании.
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

63. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 13-Апр-12, 12:33 
> на WL-520GC openwrt упаришься пихать :)

Не зря GC - garbage collector. Aka пылесос :)

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

66. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Andrey Mitrofanov on 13-Апр-12, 12:48 
Мои глаза, мои глаза! Он убил нас своим http://www.acronymfinder.com/GC.html круговзором! </tag>

> Aka пылесос :)

Нет, не пытайся сокращать vacuum cleaner.

Ответить | Правка | ^ к родителю #63 | Наверх | Cообщить модератору

36. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –1 +/
Сообщение от Аноним (??) on 10-Апр-12, 19:54 
> (да, 2.6 туда не лезет --- без тебя никак!) ?

Вообще-то openwrt спокойно лезет в 4 метра. Даже с 2.6, внезапно. Вот уж от кого такой криворукости и безапелляционности не ожидалось. Ты получаешь -1 к скиллу троллинга и -1 к пряморукости.

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

46. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Andrey Mitrofanov on 11-Апр-12, 09:54 
> Вообще-то openwrt спокойно лезет в 4 метра. Даже с 2.6, внезапно. Вот
> уж от кого такой криворукости и безапелляционности не ожидалось. Ты получаешь
> -1 к скиллу троллинга и -1 к пряморукости.

Ну да, ну да. [смахивает сскупую слезу] Поправим дедушку?

Флэша на самом _2 Мб_. И да. говорят, openwrt влезает, даже 2.6 влезает.

You can flash the openwrt-brcm-2.4-squashfs.trx file to your Asus WL-520GC device. The device has 192.168.4.1 as the default IP address.

It seems like the 2.4 version has some troubles accessing the flash and this will actually make the board hang after a while.

brcm47xx-2.6 does not have the same issue and works fine on this device. b43 will make the board reboot as soon as it is loaded.

Спишем на _кривую дешёвую железку (чего там про тп-линки?...) Раз b43 её ребутит, виновата не 2.6, не b43... Да никто ж не виноват!

ОпенВРТ с 3.0 ещё не?.. Не, ну правда!!?

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

49. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 11-Апр-12, 11:37 
> Флэша на самом _2 Мб_.

А, ну тогда ты сам себе злобный буратино если такое покупаешь. Ты купил максимально урезанный товар. Получи минимум возможностей, фигли.

> and this will actually make the board hang after a while.

Дядь, официальная позиция разработчиков опенврты: минимально требуется 4М флеш, 16М рамы. Все что менее того - совершенно официально относится к unsupported. Так что извини, но с своим хламом ты как-нибудь некрофильствуй сам. То что там какими-то извращениями можно и в 2М на грани фола втиснуться - если распереться то на 2.4 можно. Но никому не охота постоянно геморроиться, так что протестированность всего этого и прочая - ну ты понял.

> Спишем на _кривую дешёвую железку (чего там про тп-линки?...)

Спишем на убогую аппаратную конфигурацию, куда 2.4 еле-еле втискивается если все по максимуму обкромсать. У современных тп-линков сложно найти менее 4Мб флеша и 32 рамы...

> ОпенВРТ с 3.0 ещё не?.. Не, ну правда!!?

Не, на этом - дохлый номер. Unsupported. Сам с этим как-нибудь. Сиди с своим 2.4 или что там у тебя если хватает ума такое покупать. Ну или пинай саппорт производителя чтобы фиксили, etc. Сторонним разработчикам такое малоинтересно.

Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

51. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Andrey Mitrofanov on 11-Апр-12, 13:21 
>> Флэша на самом _2 Мб_.
> А, ну тогда ты сам себе злобный буратино если такое покупаешь. Ты

Это не ты там выше _хотел "все мелкодевайсы на 2.6 переводить"? Ай-ай, спутал же с кем-то.

>> Спишем на _кривую дешёвую железку (чего там про тп-линки?...)
> Спишем на убогую аппаратную конфигурацию,

b43 ребутит ядро 2.6 на этой железке из-за недостатка рамы или флэша? А-а-а, из-за того, что не Атерос-Тплинк.

>> ОпенВРТ с 3.0 ещё не?.. Не, ну правда!!?
> Не, на этом - дохлый номер. Unsupported. Сам с этим как-нибудь. Сиди
> с своим 2.4 или что там у тебя если хватает ума

Спасибо, внучек, порадовал дедушку!

> такое покупать. Ну или пинай саппорт производителя чтобы фиксили, etc. Сторонним
> разработчикам такое малоинтересно.

Не-не-не. Я буду пинать _идиотов, которые "все железки" _разом переводят на 2.6. Идиоты же! Пусть на LTS 3.0 уже?!

Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

52. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 11-Апр-12, 15:26 
>> А, ну тогда ты сам себе злобный буратино если такое покупаешь.
> Это не ты там выше _хотел "все мелкодевайсы на 2.6 переводить"? Ай-ай,
> спутал же с кем-то.

Ну тебе ли не знать что скупой платит дважды? Ну вот те кто купил максимально обкромсаное хардваре теперь будут или покупать новое или мириться с дырявостью и неподдерживаемостью, получая при случае сплойтами в бубен, etc.

>> Спишем на убогую аппаратную конфигурацию,
> b43 ребутит ядро 2.6 на этой железке из-за недостатка рамы или флэша?

Без понятия. У меня таких обкромсаных какашек под рукой нет. На wl500gp и подобных - никто никуда не ребуется, по крайней мере за несколько месяцев проблем ровно 0. Да, на 2.6 с открытым драйвером. Режим работы довольно типовой: WPA2-PSK.

> А-а-а, из-за того, что не Атерос-Тплинк.

Бэээ... что-то ты совсем скилл троллинга порастерял. Овощной какой-то троллинг, попробуй еще раз. Незачет.

Если туго доходит, у опенвртшников требование в 4М флеша было "по жизни", давным-давно и и даже с 2.4 версией. Все железки с менее чем - оптом заносятся в unsupported hardware и все. Дефолтный официальный образ тупо крупнее чем 2М и не ... :). То что на часть из огрызков как-то воодрузить останки опенврты можно - ничего не меняет: оно никогда не являлось официально поддерживаемой конфигурацией, поэтому дальше и долбитесь там сами.

>> Не, на этом - дохлый номер. Unsupported. Сам с этим как-нибудь. Сиди
>> с своим 2.4 или что там у тебя если хватает ума
> Спасибо, внучек, порадовал дедушку!

Ну дедушка сам дурак. Был бы ему нужен опенврт - он бы читал маны и знал системные требования. Если железка не пролезала под минимальные требования и раньше - странно полагать что кто-то будет всерьез париться с ее поддержкой. Иди вон у асуса саппорт требуй, в конце концов, дедушка ведь им денежку платил, правда? :)

>> такое покупать. Ну или пинай саппорт производителя чтобы фиксили, etc. Сторонним
>> разработчикам такое малоинтересно.
> Не-не-не. Я буду пинать _идиотов, которые "все железки" _разом переводят на 2.6.

Ну не переходи. Сиди на unsupported ядре которое никто не чинит и жди пока тебе прилетят сплойты. Благо железяк как раз чаще всего гейтвей-файрвол и выступает первой линией обороны, как раз получая из сети все что в принципе оттуда может прилететь первым номером.

> Идиоты же! Пусть на LTS 3.0 уже?!

Идиоты - это те кто покупает железки без будущего, у которых нет резерва под апдейт а потом натурально удивляется что они стали unsupported. Что для сетевой железки - чревато. Потому как в софте бывают баги а вот чинить их в unsupported барахлишке никто уже не будет и "you're on your own". Ну то-есть если к тебе прилетит сплойт и отспамится по жесткому так что пров стопнет выход в инет а айпи попадет в блеклисты - тебе никто не виноват. Минздрав честно предупредил. Если ты хочешь оставаться на корабле игнорируя тот факт что он тонет - твое право.

Ответить | Правка | ^ к родителю #51 | Наверх | Cообщить модератору

57. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от arisu (ok) on 12-Апр-12, 19:06 
> Флэша на самом _2 Мб_

слушай, ну не попей пива пару недель, купи уже что-нибудь поприличней. я сам не фанат бездумных апгрейдов, но тут уже… это как возмущаться, что третье ядро с btrfs и четвёртые кеды очень хреново помещаются на p90 с 32MB RAM.

Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

59. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 12-Апр-12, 21:14 
> что третье ядро с btrfs и четвёртые кеды очень хреново помещаются на p90 с 32MB RAM.

Что самое смешное - P90 и 32Мб рамы им самим по себе вполне хватит. А вот 2 метра - это хуже. Ну то-есть наверное и 2.6 можно обкастрировать, конечно, но что там от пингвина останется? Планировщик задач? :)))

Ответить | Правка | ^ к родителю #57 | Наверх | Cообщить модератору

44. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 20:19 
>> пора все мелкодевайсы на 2.6 переводить,
> Переведи мне Asus WL-520GC ?

Мсье не смог сам найти ссылку на образ на сайте опенврты. ПипецЪ :)

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

47. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Andrey Mitrofanov on 11-Апр-12, 09:58 
>образ на сайте опенврты. ПипецЪ :)

Ситуайен внизапно искал образ на сайте dd-wrt.

Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

50. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 11-Апр-12, 11:39 
> Ситуайен внизапно искал образ на сайте dd-wrt.

Ты про спеки прогнал. Не, с такими спеками кина не будет.

Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

54. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Andrey Mitrofanov on 11-Апр-12, 15:44 
>> пора все мелкодевайсы на 2.6 переводить,
> Переведи мне Asus WL-520GC ?

Да, теперь никто не понимает </сарказма>.

> С драйвером-блобом для wifi, собирающимся _только с 2.4, и

_2 Мб_ флэша //fixed

> (да, 2.6 туда не лезет --- без тебя никак!) ?

2.6 лезет, но wifi не едет. //facts unchecked

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

60. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –1 +/
Сообщение от Аноним (??) on 12-Апр-12, 21:16 
> _2 Мб_ флэша //fixed

Ну тады ой, ССЗБ. Сиди с 2.4 ядром и надейся что никто сплойтом не шарахнет или чини там дыры сам.

>> (да, 2.6 туда не лезет --- без тебя никак!) ?
> 2.6 лезет, но wifi не едет. //facts unchecked

В 2 метра 2.6 утрамбовывать... ну наверное если сильно захотеть то втиснуть то можно, но там будет отрезано вообще все. Ну и смысл? Это примерно как если тебе отрезать руки, ноги да еще и в кому положить. Но чисто номинально пациент вроде бы живой :)

Ответить | Правка | ^ к родителю #54 | Наверх | Cообщить модератору

4. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 09-Апр-12, 22:24 
А где 2.4 юзается, кроме прошивок для роутеров? Не троллинга ради, просто интересно.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +3 +/
Сообщение от wS on 09-Апр-12, 22:35 
а нас на работе:)
Старенький сервачёк:) 2.4 ядрошко:)
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –5 +/
Сообщение от Аноним (??) on 09-Апр-12, 22:53 
Айпишник скажите - пусть головастым хацкерам дармовый шеллбокс достанется :)
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

8. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +7 +/
Сообщение от filosofem (ok) on 09-Апр-12, 23:12 
10.0.0.66
вэлкам.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

10. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –1 +/
Сообщение от Аноним (??) on 09-Апр-12, 23:33 
> 10.0.0.66
> вэлкам.

Ну тогда и название конторы, чтоли.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

14. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –1 +/
Сообщение от tuxic (ok) on 10-Апр-12, 02:22 
10.0.0.66 - разве белый ip???
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

15. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –5 +/
Сообщение от Аноним (??) on 10-Апр-12, 02:24 
> 10.0.0.66 - разве белый ip???

Нет, конечно. И внешку этой конторы они зассут сказать, зуб даю. Потому что понимают чем чревато, но понтуются :)

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

19. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +8 +/
Сообщение от Какаянахренразница (ok) on 10-Апр-12, 05:42 
А кто сказал, что у того сервера есть внешний айпи? Кто сказал, что это вообще интернет-сервер? Может, это файл- и принт-сервер, который интернета в глаза не видел.

Главное, что железяка выполняет свои функции. Старый софт, который отлично работает, есть отличный софт, что бы ни говорили анонимусы.

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

24. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от an. on 10-Апр-12, 09:59 
Это да, но известные (и исправленные в новых версиях) уязвимости никто не отменял...
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

26. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –1 +/
Сообщение от mirr0r (ok) on 10-Апр-12, 10:29 
> пусть головастым хацкерам дармовый шеллбокс достанется

У меня почтовик на 2.4 шесть лет оттарабанил. Только в прошлом году переставил.
Старый такой сервачок HP E800.
Долбали, конечно. Но что-то я "головастых хацкеров" в логах не встречал.
Где они??? АУУУ?

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

27. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +1 +/
Сообщение от www2 (??) on 10-Апр-12, 10:43 
Они логи подчистили.
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

29. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –1 +/
Сообщение от mirr0r (ok) on 10-Апр-12, 11:41 
Прокладку они себе подчистили (между седалищем и сиденьем).
У меня логи на другой стервер ложатся,  в локалке, он из тырнета не виден.
Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

43. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 20:17 
> У меня логи на другой стервер ложатся,  

А может вы их еще и грамотно анализируете? :)

Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

48. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от www2 (??) on 11-Апр-12, 10:36 
А "сервер в локалке" - это такое непробиваемое средство защиты? Ты ещё скажи "у меня фаерволл на сервере настроен" - аргумент сравнимого качества.

Твой лог-сервер в локалке под Linux 2.4 взломали заодно с первым. И вообще, генерируя с левой машины в локалке UDP пакеты с нужным адресом отправителя, они тебе такие красивые логи рисовать будут - ты будешь спать спокойно.

Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

53. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 11-Апр-12, 15:27 
> А "сервер в локалке" - это такое непробиваемое средство защиты?

А у меня вот 2 компьютера вообще в сеть не подключено. 220 вольт. Фиг сломаете! :P :P //Mitrofanov trolling mode

Ответить | Правка | ^ к родителю #48 | Наверх | Cообщить модератору

55. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от XoRe (ok) on 12-Апр-12, 00:02 
> Твой лог-сервер в локалке под Linux 2.4 взломали заодно с первым. И
> вообще, генерируя с левой машины в локалке UDP пакеты с нужным
> адресом отправителя, они тебе такие красивые логи рисовать будут - ты
> будешь спать спокойно.

А кто говорил про UDP?)

Ответить | Правка | ^ к родителю #48 | Наверх | Cообщить модератору

37. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 19:57 
> Долбали, конечно. Но что-то я "головастых хацкеров" в логах не встречал.

Хм, вообще-то обнаруживают себя явным образом обычно лишь достаточно тупые хакеры. Которых в силу тупизны просто нейтрализовать. А профи просто втихаря делают черное дело. Даже если вы и узнаете что они вас посетили то как правило совссем не сразу и когда уже поздно жрать боржоми.

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

58. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от arisu (ok) on 12-Апр-12, 19:09 
ага-ага, прямо как истории про Чёрного Альпиниста.
Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

62. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от mirr0r (ok) on 13-Апр-12, 10:48 
Хоть и старый сабж, но не ответить не могу, язык прям чешется. :)
Вот прямо так и видно, что все, кто тут умничает, "головастых хацкеров"
на каждом повороте видят. Прям всех крикунов уже ломали, потом сообщали,
что ломали, потом ломали опять.

Я ф шоке, какой у нас тырнет страшный, на каждом шагу хацкеры, локалка вааще
ужо не гарантия ничего.

А ещё можно ложкой супа подавиться, не ешьте суп, желательно ничего не есть,
не пить, да и не жить тоже.

Хацкеры, блин.

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

65. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 13-Апр-12, 12:38 
> Я ф шоке, какой у нас тырнет страшный, на каждом шагу хацкеры,

Нормальный. Вон кернелорга сломал автоматический троянец вообще, просто умыкнув пароль. А потом оно не забыло повысить права и воткнуть руткит. Такой вот интернет - все кто щелкает клювом являют собой источник полезных ресурсов. Ну там бандвиза, цпу, ... :)

Ответить | Правка | ^ к родителю #62 | Наверх | Cообщить модератору

9. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 09-Апр-12, 23:25 
Это что, теперь выходит не будут исправляться уязвимости в прошивке для роутеров или как?
У меня просто openwrt на 2.4 стоит, на 2.6 не выйдет грейдиться, там какие-то проблемы есть с бинарными драйверами которые только на 2.4 работают =/
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

11. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 09-Апр-12, 23:46 
> Это что, теперь выходит не будут исправляться уязвимости в прошивке для роутеров или как?

Ядро 2.4 - официально похоронено апстримом. Так что вот так - никаких фиксов не будет.

> У меня просто openwrt на 2.4 стоит, на 2.6 не выйдет грейдиться,
> там какие-то проблемы есть с бинарными драйверами которые только на 2.4 работают =/

Да, бинарный драйвер для броадкома собран на 2.4, впрочем с 2.6 нынче довольно прилично работает опенсорсный b43, поэтому Kamikaze 10.03.1 был последней прошивкой поддерживающей 2.4 ядро (brcm-2.4). Теперь осталась только ветка с 2.6 и открытым драйвером. Уже давно рулят 2.6 и открытые дрова. Кончайте некрофилией страдать, на дворе 2012 год. И вообще, железка на атеросе с куда более резвым процом на 400МГц, нормально работающим юсб, мощным .n радио 2х2 и прочая стоит в районе 1000 рублей (~$30). Халява, сэр!

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

12. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –3 +/
Сообщение от Аноним (??) on 10-Апр-12, 01:44 
> стоит в районе 1000 рублей (~$30).

И сколько RAM у такой железки? 8mb? Оно, наверное, физически не потянет фильтрацию трафика при полной нагрузке в 300Gb/s. Об установке дополнительный программ можно даже не заикаться.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +4 +/
Сообщение от Michael Shigorin email(ok) on 10-Апр-12, 02:20 
> в 300Gb/s

Пожалуй.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

16. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 02:39 
>> стоит в районе 1000 рублей (~$30).
> И сколько RAM у такой железки? 8mb?

32 MB RAM, 4 или 8Mb flash, 400MHz CPU, 2x2 .n (в идеале до 300Mbit/sec), нормальный USB.

Кстати при желании все это еще и трамбуется в девайс порядка 4х4 сантиметра теперь - чипсеты довольно интегрированные нынче пошли. Так что теперь можно куда-нить донавесить прилично мозгов по цене грязи под ногами, спасибо китайцам за наше счастливое будущее.

> Оно, наверное, физически не потянет фильтрацию трафика при полной нагрузке в 300Gb/s.

300Gb/s? Я наверное чего-то пропустил. Это что-то для квантовых компьютеров? А то IEEE только еще пилит 100Gbit ethernet, панимаишь, для самых-самых core узлов интернета. А у вас уже 300. Если вы о мбитах, как минимум стольник в роутинге оно вполне осилит. А если скорость юсб сравнивать - то асуса на броадкоме оно обставит в несколько раз, например.

> Об установке дополнительный программ можно даже не заикаться.

Отставить пиндеж. Прекрасно поддерживается openwrt.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

17. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 03:54 
> 300Gb/s? Я наверное чего-то пропустил. Это что-то для квантовых компьютеров? А то
> IEEE только еще пилит 100Gbit ethernet, панимаишь, для самых-самых core узлов
> интернета. А у вас уже 300.

Любому понятно, что там речь о мегабитах.

> минимум стольник в роутинге оно вполне осилит.

Стольник? То-есть 1/3 от возможностей антенны?

> Отставить пиндеж. Прекрасно поддерживается openwrt.

Опять же, речь не о том, что openwrt не поставится, а о том, что железки не хватит для работы с дополнительными программами. Ее только на роутинг и хватает (хотя по вашим словам и на это не хватает).


Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

31. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +1 +/
Сообщение от Аноним (??) on 10-Апр-12, 12:51 
>> минимум стольник в роутинге оно вполне осилит.
> Стольник? То-есть 1/3 от возможностей антенны?

Изучаем табличку и делим примерно на 2.

http://linuxwireless.org/en/developers/Documentation/ieee802...

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

32. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 12:54 
>>> минимум стольник в роутинге оно вполне осилит.
>> Стольник? То-есть 1/3 от возможностей антенны?
> Изучаем табличку и делим примерно на 2.
> http://linuxwireless.org/en/developers/Documentation/ieee802...

И да, HT40 _ненасильно_ сейчас можно включить только в какой-нибудь глухой деревне.

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

38. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 20:00 
> Любому понятно, что там речь о мегабитах.

Не, даешь 300Гбит в массы! :)

>> минимум стольник в роутинге оно вполне осилит.
> Стольник? То-есть 1/3 от возможностей антенны?

Скорее, у антенны - 1.5 * возможности 100Мбит эзернета. В том плане что из 300 эфирных мегабитов в виде реального потока TCP/IP получится мегабитов ~150 примерно.

>> Отставить пиндеж. Прекрасно поддерживается openwrt.
> Опять же, речь не о том, что openwrt не поставится, а о
> том, что железки не хватит для работы с дополнительными программами.

Смотря какие программы использовать. Если апача и мускуля - да, с ними девайсу придется тяжко, хотя если своп подцепить то даже будет ползать. А так - сетевые сервисы в массе своей не особо прожорливы.

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

18. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  –2 +/
Сообщение от Аноним (??) on 10-Апр-12, 05:13 
>300Gb/s? Я наверное чего-то пропустил. Это что-то для квантовых компьютеров? А то IEEE только еще пилит 100Gbit ethernet, панимаишь, для самых-самых core узлов интернета. А у вас уже 300.

В 2009 году лаборатории Белла посредством мультиплексирования 155 каналов по 100 Гбит/с удалось передать данные со скоростью 15,5 Тбит/с на расстояние 7000 километров

Тащемта технологии магистральной связи давно уже такие скорости осилили.

И еще в квантовых компьютерах не используются биты/байты и прочие подобные единицы измерения. Там кубиты, которые с битами имеют весьма мало общего.

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

42. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 20:07 
> В 2009 году лаборатории Белла посредством мультиплексирования 155 каналов по 100 Гбит/с
> удалось передать данные со скоростью 15,5 Тбит/с на расстояние 7000 километров

Ну знаете, лабораторные эксперименты это круто. Если распереться - то и вайфай на 300 с гаком километров с лабораторным оборудованием и подготовкой прошибает. А теперь покажите то же самое с серийно выпускаемым оборудованием.

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

20. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 07:55 
Модель железяки озвучьте, пожалуйста. Как раз подбираю не дорогую с .n и под openwrt.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

30. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +1 +/
Сообщение от Аноним (??) on 10-Апр-12, 12:46 
Посмотрите в сторону TP-Link
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

34. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Dimez (ok) on 10-Апр-12, 15:50 
Не надо смотреть в сторону тплинка. Они не осилили засунуть аварийный tftpd в устройство. Чуть что - паять консольный кабель.
Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

35. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 16:17 
А вам за такую цену еще и консольный порт нужен?
Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

41. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 20:05 
> Не надо смотреть в сторону тплинка.

Предложите дешевле и лучше. Фигня вопрос. А аварийный tftp там есть, просто дебильный, активируется только через шнурок. Занафига вот так - только косоглазые и знают. Впрочем сорц бутлоадера есть, если кто ощущает себя крутым мачо и не боится дебрикинга, может и поработать над фиксом дебилизмов...

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

39. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 20:02 
> Модель железяки озвучьте, пожалуйста. Как раз подбираю не дорогую с .n и под openwrt.

Например тп-линки различные. Что у кого за железо можно посмотреть например там: http://wiki.openwrt.org/toh/start

Ценники можно посмотреть в прайс-листе любого магазина, желательно не очень наглого.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

21. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 09:03 
15 часов назад добавлен 21 коммит :)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

40. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от Аноним (??) on 10-Апр-12, 20:03 
> 15 часов назад добавлен 21 коммит :)

Посмертный дамп на камне? :)

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

56. "Объявлено о прекращении поддержки ветки ядра Linux 2.4.x"  +/
Сообщение от XoRe (ok) on 12-Апр-12, 00:05 
>> 15 часов назад добавлен 21 коммит :)
> Посмертный дамп на камне? :)

Все проще.
Очко!
=)

Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру