The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Новая версия интегрированной среды разработки приложений Cod..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [ Отслеживать ]

"Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от opennews (ok) on 04-Янв-10, 17:48 
Вышла (http://codelite.org/forum/viewtopic.php?f=9&t=713) версия 2.1 IDE Codelite (http://www.codelite.org/), кроссплатформенной интегрированной среды для разработки приложений на языках C/C++. CodeLite написана с использованием wxWidgets (http://www.wxwidgets.org/) и распространяется под лицензией GPLv2.


Из изменений в версии 2.1 стоит отметить:


-  Полностью переписан плагин для работы с svn
-  Поддержка глобального пространства в автодополнении кода, возможность задания директорий с заголовочными  файлами для каждого проекта в отдельности (для автодополнения)
-  Дополнительные опции рефакторинга
-  Обновлен статический анализатор CppCheck (http://sourceforge.net/apps/mediawiki/cppcheck/index.php?tit...) до версии 1.39


Основные возможности CodeLite:

- Поддержка SVN, интеграция с программами для поиска cscope (http://cscope.sourceforge.net/) и тестовым фреймворком UnitTest++ (http://unittest-cpp.sourceforge.net/);

-  Автодополнение кода, рефакторинг, под...

URL: http://codelite.org/forum/viewtopic.php?f=9&t=713
Новость: https://www.opennet.ru/opennews/art.shtml?num=24889

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от Карбофос (ok) on 04-Янв-10, 17:48 
надо будет сравнить с kdevelop...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от Аноним (??) on 04-Янв-10, 18:29 
Что-то в последнее время много инструментов для разработки выходит. Как бы намекают: всем - кодить! Может и правда пришла пора что ни будь написать.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от Iv945n (ok) on 04-Янв-10, 21:10 
>Что-то в последнее время много инструментов для разработки выходит. Как бы намекают:
>всем - кодить! Может и правда пришла пора что ни будь
>написать.

Как насчёт IDE?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Новая версия интегрированной среды разработки приложений Cod..."  +1 +/
Сообщение от Аноним (??) on 04-Янв-10, 21:39 
>Как насчёт IDE?

Это не круто. Лучше написать свой hello world с синхронизацией в svn, строками в XML, сборкой через Makefile, Web интерфейсом, описанием в Doxygen, импортированный из Visual Studio, отлаженный в GDB, проанализированный CppCheck.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Новая версия интегрированной среды разработки приложений Cod..."  +2 +/
Сообщение от Аноним (??) on 04-Янв-10, 18:51 
Может немного не по теме. Но с прочтения чего нужно начинать изучать программирование на С++ под Unix?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Новая версия интегрированной среды разработки приложений Cod..."  +1 +/
Сообщение от ЛеХа on 04-Янв-10, 18:57 
С прочтения "Руководства FreeBSD для разработчиков":
http://freebsd.org.ua/doc/ru_RU.KOI8-R/books/developers-hand...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Новая версия интегрированной среды разработки приложений Cod..."  –1 +/
Сообщение от User294 (ok) on 05-Янв-10, 02:25 
Уж послали так послали. "Не выиграл а проиграл, не в лотерею а в карты..."
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от DeadMustdie email(??) on 06-Янв-10, 22:02 
> Может немного не по теме. Но с прочтения чего нужно начинать изучать программирование на С++ под Unix?

http://www.parashift.com/c++-faq-lite/

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от Voviandr (??) on 04-Янв-10, 18:56 
попробовал установить, выдаёт
voviandr@voviandr-desktop:/usr/lib$ codelite
codelite: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/codelite/libcodeliteu.so)

первый раз такое вижу. никто не подскажет, как решить ? у меня убунту 9.04. установил из деба, скачанного с сайта.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от Voviandr (ok) on 05-Янв-10, 05:13 
>попробовал установить, выдаёт
> voviandr@voviandr-desktop:/usr/lib$ codelite
>codelite: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/codelite/libcodeliteu.so)
>
>первый раз такое вижу. никто не подскажет, как решить ? у меня
>убунту 9.04. установил из деба, скачанного с сайта.

уже решено. забил на деб, собрал из исходников.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от VarLog email(ok) on 04-Янв-10, 20:15 
А у меня и вовсе не собирается :(
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от Voviandr (??) on 05-Янв-10, 03:47 
>А у меня и вовсе не собирается :(

попробуйте перед сборкой поставить пакеты  libwxgtk2.8-dev libwxgtk2.8-dbg
я успешно собрал из исходников и установил после того, как потерпел неудачу с установкой из деба.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от VarLog email(ok) on 06-Янв-10, 08:50 
>>А у меня и вовсе не собирается :(
>
>попробуйте перед сборкой поставить пакеты  libwxgtk2.8-dev libwxgtk2.8-dbg
>я успешно собрал из исходников и установил после того, как потерпел неудачу
>с установкой из деба.

У меня собственная уютная, ламповая LFS. WxWidgets установлены. Не получается собрать именно из-за ошибок компиляции. Причём они порой довольно бредовые.
Написано в .cpp файле:
#include <unistd.h>
Но пока тупо не напишешь прототип:
extern read(int fd, void *buf, size_t count);
компилятор упорно будет утверждать, что функции с таким идентификатором (read) не найдено..

Пробовал и из svn, и из тарболов.. Хрень какая-то.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от del (??) on 06-Янв-10, 12:59 
Мммм, похоже на косяк скорее компилятора, чем исходников.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от VarLog email(ok) on 06-Янв-10, 18:49 
>Мммм, похоже на косяк скорее компилятора, чем исходников.

Ну не знаю..
g++ (GCC) 4.4.0
Ранее такого не наблюдалось.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от VarLog email(ok) on 06-Янв-10, 19:08 
>>Мммм, похоже на косяк скорее компилятора, чем исходников.

varlog:·> grep wxDrag_DefaultMove /usr/X11R6/include/wx-2.8/wx/dnd.h
    wxDrag_DefaultMove = 3  // the default operation is move, not copy
    // allowed, if it contains wxDrag_DefaultMove (which includes the previous
varlog:·> grep /usr/X11R6/include/wx-2.8/wx/dnd.h ./sdk/wxscintilla/include/wx/wxscintilla.h
#include "/usr/X11R6/include/wx-2.8/wx/dnd.h"

./sdk/wxscintilla/include/wx/wxscintilla.h: In member function ‘bool wxScintillaEvent::GetDragAllowMove()’:
./sdk/wxscintilla/include/wx/wxscintilla.h:3549: ошибка: нет декларации ‘wxDrag_DefaultMove’ в этой области видимости
make: *** [Release_gcc_unicode/PlatWX.o] Ошибка 1

Как это объяснить?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от Аноним (??) on 04-Янв-10, 20:57 
реально круче чем Visual studio
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Новая версия интегрированной среды разработки приложений Cod"  +/
Сообщение от Ursadon on 04-Янв-10, 22:13 
Он у меня ассоциируется с Code::Blocks. Да же значки приложений схожи. Миграция разработчиков?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от del (??) on 05-Янв-10, 00:55 
Не нашел на сайте вменяемого руководства.

В чем там выражается интеграция с SVN?

В интерфейсе там где эту интеграцию можно посмотреть?

Ну а так, приятная IDE. Ради интереса наваял там один внутренний проект на C - впечатления приятные.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от del (??) on 05-Янв-10, 20:58 
x86_64 deb не ставится на Debian testing:

$ sudo dpkg -i ./codelite_2.1.0.3584-ubuntu0_amd64.deb
(Reading database ... 165329 files and directories currently installed.)
Unpacking codelite (from .../codelite_2.1.0.3584-ubuntu0_amd64.deb) ...
dpkg-deb (subprocess): short read in buffer_copy (failed to write to pipe in copy)
dpkg-deb: subprocess paste returned error exit status 2
dpkg: error processing ./codelite_2.1.0.3584-ubuntu0_amd64.deb (--install):
short read in buffer_copy (backend dpkg-deb during `./usr/lib/codelite/libpluginu.so')
Processing triggers for desktop-file-utils ...
Processing triggers for menu ...
Errors were encountered while processing:
./codelite_2.1.0.3584-ubuntu0_amd64.deb


Собирать впадлу пока)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "Новая версия интегрированной среды разработки приложений Cod..."  +/
Сообщение от Карбофос (ok) on 06-Янв-10, 14:24 
кстати, сборку на мультипроцессорном компе можно ускорить:
make -j2
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру