The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Тематический каталог: Установка Apache-2.0.46 и PHP-4.3.2 ка..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [Проследить за развитием треда]

"Тематический каталог: Установка Apache-2.0.46 и PHP-4.3.2 ка..."  
Сообщение от auto_topic on 24-Окт-03, 06:15 
Обсуждение статьи тематического каталога: Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) модуля (php apache web install)

Ссылка на текст статьи: https://www.opennet.ru/base/dev/apache2_php.txt.html

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от digger3d email on 24-Окт-03, 06:15 
ну и не работает
апач работает а пхп нет
отдаёт пхп файл просто
чтото ещё надо в хттпд.конф
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от digger3d email on 24-Окт-03, 06:18 
и поставился не в /usr/local/apache2 а в /usr/local
правда Апач 2.0.47
неужели такая разница?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от DRiVE on 03-Ноя-03, 17:52 
Насчет того, что поставился не туда - у вас большой ККР(Коэффициент Кривизны Рук).
А чтобы заработало в хттпд.конф нужно вписать еще:
LoadModule php4_module libexec/libphp4.so
Прошу прощения за недосмотр.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от digger3d email on 06-Ноя-03, 16:29 
>Насчет того, что поставился не туда - у вас большой ККР(Коэффициент Кривизны
>Рук).
>А чтобы заработало в хттпд.конф нужно вписать еще:
>LoadModule php4_module libexec/libphp4.so
>Прошу прощения за недосмотр.

Видимо ещё один недосмотр был допущен в статье, цитирую:
>После этого конфигурируем сервер:
>Пример запуска скрипта configure:
>
>  # ./configure --prefix=/usr/local/ --enable-suexec

Именно изза этого ваш ККР несколько больше

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от УчеНИК email on 08-Ноя-03, 11:14 
По поводу строки "LoadModule php4_module libexec/libphp4.so", куда её вписать. Я просто в первые пытаюсь работать с apache+php, я дума мне должно это понравиться! заранее благодарен
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от digger3d email on 10-Ноя-03, 04:42 
У всех по разному,  может быть например в /usr/local/etc/apache2/httpd.conf
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от УчеНИК email on 12-Ноя-03, 12:21 
после запуска Apache мне выдало: [Wed Nov 12 14:15:12 2003] [warn] module php4_module is already loaded, skipping
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs-что это значит и как с этим бароться
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от digger email on 21-Ноя-03, 03:50 
>после запуска Apache мне выдало: [Wed Nov 12 14:15:12 2003] [warn] module
>php4_module is already loaded, skipping
>(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
>no listening sockets available, shutting down
>Unable to open logs-что это значит и как с этим бароться

Это вероятно означает что апач уже запущен, а если точнее это значит что 80 порт уже чемто занят.
Бороться с этим надо так:
1. Проверить запущен ли апач
http://127.0.0.1/
если всё работает - борьба окончена
если нет
2. Возможно чтото висит на этом порту - надо это отрубить или повесить на другой порт.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от Евгений on 02-Дек-03, 17:08 
Сделал все по этому сценарию. Действительно, с файлами .php все работают. Но php-вставки в html игнорируются браузером. Как исправить?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от rippy email on 10-Янв-04, 15:16 
Только если потребовать, чтобы и .html документы обрабатывались PHP, как и .php Только зачем? Чем они тогда будут отличаться? :)


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от УчеНИК email on 24-Янв-04, 20:55 
А если не стоит БД MYSQL то что делать
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

17. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от KLEVO (??) on 11-Май-04, 18:16 
Установить ...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Установка Apache-2.0.46 и PHP-4.3.2 как DSO, *** ЕСЛИ PHP ВС..."  
Сообщение от Sperling on 27-Янв-04, 17:09 
Если PHP все еще не работает, добавьте в httpd.conf строки:

<Files *.php>
  SetOutputFilter PHP
  SetInputFilter PHP
</Files>

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Установка Apache-2.0.46 и PHP-4.3.2 как DSO, *** ЕСЛИ PHP ВС..."  
Сообщение от wand email on 31-Мрт-04, 13:33 
поосторожнее с этими директивами - можете поламать UPLOAD файлов.
я имею в виду SetInputFilter PHP  - у меня выростал размер принятого файла, пока не закоментировал.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

35. "Установка Apache-2.0.46 и PHP-4.3.2 как DSO, *** ЕСЛИ PHP ВС..."  
Сообщение от зщш on 03-Янв-07, 02:50 
>поосторожнее с этими директивами - можете поламать UPLOAD файлов.
>я имею в виду SetInputFilter PHP  - у меня выростал размер
>принятого файла, пока не закоментировал.


так не плохо справляемся
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
LimitRequestBody 9524288
</Files>

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от Demimurych on 24-Мрт-04, 16:07 
Может кто скажет
Например http://127.0.0.1/test.php?text=mama
По логике скрипта должен мне вывести mama
Но ничего не выводит - более того путем несложных логических умозаключений пришел к выводу что вообще игнорируются все передаваемые переменные (в случае моего примера это переменная text)
В скрипте ошибки нет.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от andrew on 25-Мрт-04, 14:49 
>Может кто скажет
>Например http://127.0.0.1/test.php?text=mama
>По логике скрипта должен мне вывести mama
>Но ничего не выводит - более того путем несложных логических умозаключений пришел
>к выводу что вообще игнорируются все передаваемые переменные (в случае моего
>примера это переменная text)
>В скрипте ошибки нет.

Если в двух словах, то начаиная с версии 4.1(или 4.2, точно непомню), передача переменных в скрипт из строки запроса по-умолчанию отключена в целях безопасности. Что бы включить ее надо прописать в php.ini "register_globals = on"

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

20. "Установка Apache-2.0.46 и PHP-4.3.2 как (DSO) передача перем..."  
Сообщение от Sperling on 04-Июн-04, 22:32 
>>Может кто скажет
>>Например http://127.0.0.1/test.php?text=mama
>>По логике скрипта должен мне вывести mama
>>Но ничего не выводит - более того путем несложных логических умозаключений пришел
>>к выводу что вообще игнорируются все передаваемые переменные (в случае моего
>>примера это переменная text)
>>В скрипте ошибки нет.
>
>Если в двух словах, то начаиная с версии 4.1(или 4.2, точно непомню),
>передача переменных в скрипт из строки запроса по-умолчанию отключена в целях
>безопасности. Что бы включить ее надо прописать в php.ini "register_globals =
>on"

А еще лучше не использовать эту директиву, а поступать как советует manual, т.е. использовать переменные Сервера. Например вместо $text использовать $_POST['text'] или $_GET['text'] в зависимости от метода. Таким образом ваша программа станет более универсальной и будет работать на Серверах с разными настройками

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

18. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от APOX email on 26-Май-04, 15:53 
Во первых: конечно, для порядку лучше ставить в /usr/local/apache
во вторых: с ключом ./configure --with-mysql --with-apxs2 все встало сразу хорошо, даже не надо было LoadModule php4_module libexec/libphp4.so прописывать в httpd.conf. Я ставил Apache/2.0.49 (Unix) PHP/4.3.6  и в httpd.conf само прописалось:  LoadModule php4_module modules/libphp4.so
PHP вроде заработал, но переменные тоже не передаются, при этом php.ini нету :( Хде его искать, может создать нужно гдето и куда он делся? Нашел его только в каталоге устаноки, откуда устанавливал PHP. Что посоветуете?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от DRiVE (??) on 21-Июн-04, 21:10 
Почитайте документы, которые идут с РНР в дистрибутиве. Где-то там это указано...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от Насмерть тугой email on 03-Июн-04, 07:34 
Все это описано в доке по установке. Кроме одного у меня апач 2.0.40 в red Hat 9 ставился по умолчанию. Так вот у него нет APXS2 (его вообще нет в системе) - откуда брать?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

21. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от Acid email on 08-Июн-04, 01:41 
помогите начинающему юзеру в Линухе.... говорит что C compiler cannot create executebles
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

22. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от Acid email on 08-Июн-04, 01:58 
Можете не отвечать.... линух без компилятора. вот козды эти ALTLinuxовцы. Ни кто не скажет есть ли в Мандраке 10 апач?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

24. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от Horrible email on 02-Янв-05, 17:18 
Канешна есть ток из RPM лучше неставь он раскидает все по разным каталогам а удобно когда все в одном.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

25. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от DEVIL email on 18-Апр-05, 17:59 
Поставил дома APACHE 2.0.47, php работает виртуальный хост настроил - всё ОК, прищёл на работу, сделал всё идентично - APACHE запустился, сервис работает, но php не находит сервера (дома только локалка, на работе сеть с доменами и инетом) плиз, подскажите как настроить виртуальный хост.

Заранее спасибо!!!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

26. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от No_Spoon email on 14-Июн-05, 10:23 
Блин, ребят, замучался совсем. Помогите пжалста.
Ставлю апач (1.3.33 либо 2.хх - монопенисуально), конфигурю, мэйкю и мэйкинсталлю - все оки. httpd -l дает оба необходимых модуля (и core и so), после этого пытаюсь сконфигурить php 4 - ./configure --with-apxs2=/usr/local/apache2/bin/apxs - ну не хотит и все! Говорит, что не могет найти. но он физически есть. Выводит три долбаных ошибки - 1. А может у тебя Перлы нету?
2. А может у тя apxs нету?
3. А может у тя апачь не сконфигурен на загрузку динамических модулей?

Перлы у мя нету. Она нужна? (Новичек во FBSD)
Или поможите чем можите, люди добрые. Если не затруднит, замыльте, а? Заранее спасибо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

27. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от Asmund (ok) on 07-Ноя-05, 18:15 
Попутный вопрос. К той же статье.
Я до этого работал только с виндовой версией апача. Тепрь вот настраиваю на Linux. Apache 2.0.55, поставил индейца, поставил Php, но когда ссылаюсь на file.php мне выдается

Forbidden

You don't have permission to access /inf0.php on this server.
Apache/2.0.55 (Unix) PHP/4.4.1 Server at 192.168.0.3 Port 8080

Немогу понять в чем - тут дело, подскажите пожалуйста.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

29. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от D_Angel email(ok) on 31-Мрт-06, 14:28 
А файл file.php ты случаем не с виндового раздела брал?
Попробуй изменить права доступа к файлу, разрешить на чтение "для других"...
Мне в такихситуациях помогало...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

30. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от D_Angel email(ok) on 31-Мрт-06, 14:29 
А файл file.php ты случаем не с виндового раздела брал?
Попробуй изменить права доступа к файлу, разрешить на чтение "для других"...
Мне в такихситуациях помогало...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

28. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от Dima email(??) on 26-Дек-05, 09:30 
Привет! Ты решил свою проблему? У меня просто такая же и я тоже понять не могу, что делать?...

>Блин, ребят, замучался совсем. Помогите пжалста.
>Ставлю апач (1.3.33 либо 2.хх - монопенисуально), конфигурю, мэйкю и мэйкинсталлю -
>все оки. httpd -l дает оба необходимых модуля (и core и
>so), после этого пытаюсь сконфигурить php 4 - ./configure --with-apxs2=/usr/local/apache2/bin/apxs -
>ну не хотит и все! Говорит, что не могет найти. но
>он физически есть. Выводит три долбаных ошибки - 1. А может
>у тебя Перлы нету?
>2. А может у тя apxs нету?
>3. А может у тя апачь не сконфигурен на загрузку динамических модулей?
>
>
>Перлы у мя нету. Она нужна? (Новичек во FBSD)
>Или поможите чем можите, люди добрые. Если не затруднит, замыльте, а? Заранее
>спасибо.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

34. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от Фанис Мусин on 28-Июн-06, 19:59 
Это не 3 проблемы, а 3 возможных проблем, т.е. что-то из них у тебя не то.

В основном это происходит из-за не указанного точного пути к apxs возможно и perl не установлен, а может быть ты неправильно ./configurил apache - нужно конфигурить c параметрами --enable-so и --enable-suexec

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

31. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от D_Angel email(ok) on 31-Мрт-06, 14:34 
Если ты ставишь Apache 1.3.33 то нужно использовать --with-apxs= без двойки...
Попробуй. С версией 2.х с описаным конфигом у меня все работало и неоднократно...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

32. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от Антон email(??) on 02-Апр-06, 16:29 
Ситуация такая: у меня установлены Apach и PHP в директории C:\site , и я в редакторе HTML для страницы добавил ссылку на файл index.php. По идее должно быть как - php скрипт выполняется на сервере и результат выдается в браузер, но вместо этого - Error 404 file not found. Что за ботва... Но это ладно. Тестирую простейший скрипт - echo (вывод на экран) - и то же самое. В реадме описано то же, что я сделал еще когда ставил PHP как моодуль Apache. Скрипты PHP выполнятся вообще не хотят. Помогите кто чем может. Буду очень признателен.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

33. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от alex (??) on 31-Май-06, 00:29 
Спасибо. Всё поставилось нормльно.Можт кто знает подскажите как сдлать чтоб Апач 2 грузился при агрузке системы?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

36. "Установка Apache-2.0.46 и PHP-4.3.2 как динамического(DSO) м..."  
Сообщение от RHS email on 18-Янв-07, 09:49 
Та же схема, только для Apache_2.0.59 и  PHP_4.4.4. Связка работает без проблем!!! Установил и радуюсь)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру