The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

форумы  правила/FAQ  поиск  регистрация  вход/выход  слежка  RSS
"Прекращена поддержка дистрибутива openSUSE Leap 42.1"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от opennews on 18-Май-17, 00:15 
Разработчики openSUSE объявили (https://lists.opensuse.org/opensuse-announce/2017-05/msg0000...) о завершении цикла сопровождения релиза openSUSE Leap 42.1, обеспечиваемого компанией SUSE. Поддержка  релиза 42.1 теперь официально прекращена. За  18 месяцев существования openSUSE Leap 42.1 было выпущено 1442 обновления, из которых 507 импортированы из SUSE Linux Enterprise, а  935 подготовлены сообществом.  598 обновлений были связаны с устранением проблем с безопасностью, охватывающих в сумме 2434 уязвимости. Всем пользователям рекомендуется обновить свои системы до выпуска 42.2, обновлений для которого будут формироваться (https://en.opensuse.org/Lifetime) до второго квартала 2018 года.

URL: https://lists.opensuse.org/opensuse-announce/2017-05/msg0000...
Новость: https://www.opennet.ru/opennews/art.shtml?num=46564

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


2. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +2 +/
Сообщение от Аноним email(??) on 18-Май-17, 00:46 
Это что теперь каждый год обновляться?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

29. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +2 +/
Сообщение от пох on 18-Май-17, 09:36 
> Это что теперь каждый год обновляться?

что значит "теперь"? Каждые полтора, да.
оно примерно так было _всегда_.

Я тебе больше скажу - и с enterprise такая же точно фигня, только не полтора а два-с-половиной (какие-то у них энтерпрайзы-то однодневки ;-) за единственным исключением за все время существования проекта - 11.4 сделался таки вечно-живой (счастья это никому, кроме меня, надо заметить, не принесло - ты, полагаю, расстроишься, если заставить тебя с таким линуксом жить). То что новые версии там выпускаются под видом "сервис-пака" - это просто бизнес-модель такая ("сервиспаки" для заплативших - бесплатны, апргейд на новую major - за мешокденьгов). А на практике при установке этого "сервиспака" у тебя ведро прыгает на десяток версий вверх - 11.0 это 2.6 еще, 11.4 - 3.0.101, сам догадайся, что там в userspace происходит.

"мега-интерес" к проекту evergreen, собравшему аж пять (во времена расцвета) человек майнтейнеров и примерно ноль фидбэка (и продержавшемуся так долго только потому, что они могли невозбранно тырить пакеты из как раз sles11.4), как бе говорит о том, что оно и ненужно.

P.S. всего за 45 тысяч ржублей в год ты все еще можешь позволить себе SLES 11.4 - еще пару лет она будет поддерживаться (и потом еще лет пяток - за очень отдельные деньги)

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

39. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –2 +/
Сообщение от Ilya Indigo (ok) on 18-Май-17, 13:35 
Так оно изначально и задумывалось и так со SLES было всегда.
В Leap sudo zypper dup наконец-то починили, точнее grub2 и dracut, и прочую обвязку, и теперь обновляться можно легко, не боясь, что при апдейте перестанет работать загрузчик, как было 3 из 3 со старыми номерными версиями.
А также, есть прекрасная Tumbleweed, которую, хоть каждую неделю обновляй, и она становится всё стабильнее и стабильнее. Конфликт версий mpv и ffmpeg в ней уже починили и его больше не будет (кто-то сетовал на это, называя Tumbleweed недостаточно стабильной).
Единственное неудобство, на Amazon AWS EC2 поставить можно только Leap 42.2, а так с удовольствием вкатил бы и туда бы Tumbleweed.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

54. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от брат Граммара on 19-Май-17, 08:58 
Раз в год полностью обновляться самое оптимальное.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

3. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –9 +/
Сообщение от Аноним (??) on 18-Май-17, 01:03 
"Ухахахаха" над всеми кто не пользует Debian+rolling :-)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

18. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +9 +/
Сообщение от Аноним (??) on 18-Май-17, 07:04 
> "Ухахахаха" над всеми кто не пользует Debian+rolling :-)

про Tumbleweed не слышал что ли?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

30. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –10 +/
Сообщение от Аноним (??) on 18-Май-17, 10:07 
Rolling на rpm-based = "Dependency Hell во все поля".
Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

74. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от Michael Shigorin email(ok) on 22-Май-17, 13:39 
> Rolling на rpm-based = "Dependency Hell во все поля".

Недоуменно смотрю на свой многолетний сизиф и опять на тот бред, который Вы написали.  Может, удосужитесь снизойти и пояснить, при чём тут вообще менеджер _пакетов_, а не репозиторный?

Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

56. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от Anonimus (??) on 19-Май-17, 11:51 
rolling и debian далеко не самое лучшее сочетание
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

4. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –2 +/
Сообщение от Аноним (??) on 18-Май-17, 01:16 
Люблю openSUSE, но прекращать поддержку старого релиза за полгода до выпуска нового - маразм.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от aim (ok) on 18-Май-17, 01:51 
внимательно перечитайте новость - 42.2 будет поддерживаться ещё полгода. то есть он уже есть и ещё будет поддерживаться полгода.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

17. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от Аноним (??) on 18-Май-17, 07:00 
В новости про 42.3 ни слова. По ссылке видим такое

> Leap 42.2 - will be maintained until 6 months after 42.3 (EXPECTED Second Quarter of 2018)

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

59. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от ip (??) on 19-Май-17, 18:26 
> В новости про 42.3 ни слова. По ссылке видим такое
>> Leap 42.2 - will be maintained until 6 months after 42.3 (EXPECTED Second Quarter of 2018)

то что в новости ни слова, не значит, что нет планов
https://en.opensuse.org/openSUSE:Roadmap

Upcoming openSUSE Leap Release

Leap 42.3 is using a rolling development model without fixed mile stones. New snapshots are published according to automated testing results.

    April: integration of SLE sources
    May 21st: submission deadline for major version updates. Begin of polishing and testing phase
    June 6th: SLE goes RC, base system freeze
    June 25th: package freeze. Only bug fixes from here on.
    Last week of July: release

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

5. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –2 +/
Сообщение от th3m3 (ok) on 18-Май-17, 01:27 
Что-то совсем жесть. Не зря ушёл с openSUSE.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от alex (??) on 18-Май-17, 01:35 
Аналогично. Я ушёл ещё когда они в роллинг-релизе дефолтные приложения при каждом апдейте ставили, даже если я эти приложения удалил. На оф форуме сказали - "это не баг, а фича"
Но тут совсем ужас
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от grsec (ok) on 18-Май-17, 01:42 
Всем на gentoo. У нас всегда есть выбор во всем. Ну, или на ubuntu. Они тоже стараются.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

9. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –3 +/
Сообщение от адекват on 18-Май-17, 02:19 
Набор неотключаемых костылей в виде опенрс, питона и портажа? Нет, спасибо.
Лучше дебиана еще не придумали(девуан в бете). Ну или настоящих kiss дистров, crux например.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

20. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от Адекват (ok) on 18-Май-17, 07:17 
> Ну или настоящих kiss дистров, crux например.

В 2007ом примерно таким был Арч.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

41. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от Аноним (??) on 18-Май-17, 13:41 
Как раз в те времена пользовалься арчем. Но однажды я обновился и все сдохло. И тогда я понял что это всевышний администратор как бы намекает что арчем неху..ээ..рошо пользоваться.
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

21. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от Sluggard (ok) on 18-Май-17, 08:38 
Сменить дистр тебе проще, чем заблокировать пакеты? Силён.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

24. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от Аноним (??) on 18-Май-17, 09:04 
Надо не блокировать пакеты, а удалить мета-пакеты и поставить все необходимое явно. Все из-за тупости в виде zypper dup для обновления перекати-поля.
Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

25. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +2 +/
Сообщение от Sluggard (ok) on 18-Май-17, 09:19 
С каких пор тебе для обновления Tumbleweed понадобился dup? Он вообще нужен только для перехода между номерными версиями дистра или смены поставщика, при добавлении сторонних реп. Up'ом всё прекрасно обновляется.
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

77. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от Аноним (??) on 23-Май-17, 18:16 
поток личной информации выплеснутой в массы, а когда закроют этот ваш ОпенСусе?
Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

80. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от Sluggard (ok) on 28-Май-17, 22:02 
> а когда закроют этот ваш ОпенСусе?

Не раньше, чем родственники тебе оградку покрасят.

Ответить | Правка | ^ к родителю #77 | Наверх | Cообщить модератору

35. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +2 +/
Сообщение от Аноним (??) on 18-Май-17, 11:41 
> Надо не блокировать пакеты, а удалить мета-пакеты и поставить все необходимое явно.

А что, при удалении зависимостей мета-пакеты не удаляются автоматом? Как интересно...

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

44. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от Darth Revan (ok) on 18-Май-17, 17:38 
При удалении зависимостей удаляются, а при удалении рекомендаций – нет. Поэтому рекомендации и нужно блокировать.
Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

33. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –4 +/
Сообщение от alex (??) on 18-Май-17, 10:40 
Именно. Сначала при установке лезть в yast и блокировать, а потом при каждом апгрейде проверять, не подсунули чего-то нового. Нет, спасибо. Сменить дистр оказалось намного легче.
Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

34. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от th3m3 (ok) on 18-Май-17, 11:16 
Когда сидел на openSUSE, тоже постоянно мучался с этой проблемой.
Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

45. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +3 +/
Сообщение от Sluggard (ok) on 18-Май-17, 23:15 
> лезть в yast

zypper al
Но сменить дистр проще, чем осилить man пакетного менеджера, понимаю.

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

50. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от iPony on 19-Май-17, 07:24 
Ну типа да, проще.
Я тоже как-то тыкал палкой сие подделие. Ну при мирном обновлении насовало всяких флешей и прочего. Ну что это за виндовс вей или как это назвать даже не знаю.

Причем вроде толковые вещи бывают делают, а готовый продукт получается, что ужас.

Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

51. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +2 +/
Сообщение от Sluggard (ok) on 19-Май-17, 07:26 
> Ну типа да, проще.

Ну тебе-то, с твоим ником, несомненно, мог бы и не отписываться.

Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

78. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от Аноним (??) on 23-Май-17, 18:19 
>> Ну типа да, проще.
> Ну тебе-то, с твоим ником, несомненно, мог бы и не отписываться.

с вашим ником я б даже не решался, а не то что прям коменты писал.

Ответить | Правка | ^ к родителю #51 | Наверх | Cообщить модератору

81. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от Sluggard (ok) on 28-Май-17, 22:05 
> с вашим ником я б даже не решался, а не то что
> прям коменты писал.

Однако ж я вполне нормально использую openSUSE, не менее нормально использую zypper (и знаю нужные мне опции это пм), и пишу комменты. Именно потому, что с моим ником — я, а не ты.

Ответить | Правка | ^ к родителю #78 | Наверх | Cообщить модератору

42. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от Ilya Indigo (ok) on 18-Май-17, 13:44 
> Аналогично. Я ушёл ещё когда они в роллинг-релизе дефолтные приложения при каждом
> апдейте ставили, даже если я эти приложения удалил. На оф форуме
> сказали - "это не баг, а фича"
> Но тут совсем ужас

На русскоязычный форум лучше вообще не ходить, там одни идиоты сидят.
А так всего навсего нужно осилить конфиги zypper-а

sudo vim /eyc/zypp/zypper.conf
installRecommends = no

sudo vim /etc/zypp/zypp.conf
solver.cleandepsOnRemove = true

и потыкать мышкой в галочки yast-а в Software Manager.

Вот это же действительно невыполнимая задача, из-за которой следует уходить.
Ну что же - скатертью дорога!

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

52. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –2 +/
Сообщение от iPony on 19-Май-17, 07:28 
> Вот это же действительно невыполнимая задача, из-за которой следует уходить.

Задача не сложная. Но когда тебе приходится много крутить ручку, чтоб элементарно сделать по нормальному - тут смысл сомнителен.
Ну ты крути, Илюха, крути :)

Ответить | Правка | ^ к родителю #42 | Наверх | Cообщить модератору

11. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от Аноним (??) on 18-Май-17, 03:45 
Т.е. Leap 42.1 42.2 42.3 - это не как CentOS 7.1 7.2 7.3 ?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

12. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от leap42 (ok) on 18-Май-17, 04:59 
как раз так
Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

22. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –2 +/
Сообщение от Аноним (??) on 18-Май-17, 08:40 
А если так, в чем тогда проблема с обновлением на 42.2? На rhel и центосе в пределах мажорной версии обновления очень безболезненны. И особой поддержки версии 7.1, при наличии 7.2, нет - это просто срез репозитария и образ iso
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

31. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от Nemton on 18-Май-17, 10:21 
В пределах минорной версии у них теперь обновление ядра, прикладных программ, яста, DE. В целом, основная пакетная база остается той же.
PS Ушел с сюзи, как запилили KDE5 и до его стабилизации не вернусь точно.
Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

43. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от Ilya Indigo (ok) on 18-Май-17, 13:52 
> В пределах минорной версии у них теперь обновление ядра, прикладных программ, яста,
> DE. В целом, основная пакетная база остается той же.
> PS Ушел с сюзи, как запилили KDE5 и до его стабилизации не
> вернусь точно.

Я вот использую KDE4 на Tumbleweed и нормально, себя чувствую
Более того, мне известно только 2 дистрибутива, где можно использовать KDE4, это, собственно, openSUSE Tumbleweed и ROSA.
При этом в последнем на столько устарелая серверная и девелоперская части, что использовать её для работы просто невозможно, такой себе заплесневелый Desktop only.

Так на что Вы ушли?

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

48. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от kachsheev (ok) on 19-Май-17, 02:11 
Хоть Void и роллинг, но в репах до сих пор 4-е кеды.
Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

75. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –2 +/
Сообщение от Michael Shigorin email(ok) on 22-Май-17, 13:44 
> Более того, мне известно только 2 дистрибутива, где можно использовать KDE4,
> это, собственно, openSUSE Tumbleweed и ROSA.

Если что, в altlinux.org/starterkits вариант kde4 не отменяли (и скоро летние, как раз можно покрутить в руках и сказать, чего бы хотелось -- только лучше в альтовых новостях).

Ответить | Правка | ^ к родителю #43 | Наверх | Cообщить модератору

53. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –2 +/
Сообщение от iPony on 19-Май-17, 07:32 
> Ушел с сюзи, как запилили KDE5 и до его стабилизации не вернусь точно

Ну если это для тебе критерий, то можешь не возвращаться.
В ынтерпрайзной СУСИ KDE-шникам средний палец показали, тем самым намекнув что Gnome приоритетнее.

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

38. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от leap42 (ok) on 18-Май-17, 13:29 
а проблем с обновлением на 42.2 и нет, где вы их видели?
текущая версия 42.2, скоро выходит 42.3, вот 42.1 и перестаёт поддерживаться
Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

46. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от Аноним (??) on 18-Май-17, 23:15 
> На rhel и центосе в пределах мажорной версии обновления очень безболезненны.

Ага, конечно. Только какая-нибудь софтина обновится на пяток номеров и в ней что-нибудь сломается, или какую-нибудь библиотеку обновят с повышением soversion, и пакеты из EPEL или ELRepo окажутся поломанными, пока их не пересоберут... Очень безболезненно, ничего не скажешь.

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

36. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от PnDx (ok) on 18-Май-17, 12:21 
Как раз нет. Если сравнивать, то с какой-нибудь ubuntu lts. Но даже так — нет:
1. RHEL (Centos) держат ABI все 7 лет, и API/конфиги софта ±аналогично (пример: vsftpd, exim). Внутри мажорного релиза (весь жизненный цикл) новые фичи бэкпортируются без слома старых. Дорого, медленно (делать новые фичи), стабильно.
2. OpenSUSE — на каждом релизе 2-й цифры прыгает *всё*. Поэтому я, к примеру, каждый новый релиз себе ставлю с нуля (ну почти) и потяну такое в продакшен, только если(когда) крыша окончателтно съедет. (В SLES, по слухам, аналогично. Не было повода проверить.)
3. Ubuntu LTS: ядра прыгают на каждом релизе 3-й цифры, софт условно-плавно поднимается. Но без гарантии сломать конфигурацию на минорном апдейте (пример: samba, multipathd). Поддержка версий ядер внутри одного LTS кончается, когда майнтейнеры наиграются (а не через 5 лет). Использовать в продакшене можно, если зачем-то нужна дебиано-совместимость, при наличии собственных ресурсов для исправления критичных багов.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

37. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от leap42 (ok) on 18-Май-17, 13:28 
SUSE не держит ABI ядра, но это мало кому надо
обновление между минорными версиями всегда протестировано, работает хорошо и поддерживается официально
с недавних пор можно обновлять пропуская одну версию, например 42.1 -> 42.3
Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

40. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от пох on 18-Май-17, 13:38 
> Дорого, медленно (делать новые фичи), стабильно.

у них для этого есть fedora.  Собственно, для любителей все переставлять раз в пол-года, вполне себе выбор.

> В SLES, по слухам, аналогично.

в sles срок реальной жизни "сервиспака" был два с половиной года (то есть лучше, чем полтора, отводимые open). Но из ряда внезапно выбилась 11.4(_SP_4), которая уже здорово напоминает мумию вождя. Поскольку никакой "11.5" в природе не предусмотрено, если оно тебе подходит для продакшна - то и вперед, с песнями.

В общем-то, вполне известно, чего НЕ надо на ней делать - хранилки (нет ни одной работоспособной не write-only fs), light виртуализацию (старое ведро, да и юзерленд такой же) и openstack и его подобия.

Если твой прод не попадает ни в одну из этих категорий [зачеркнуто: то какого хрена он вообще кому-то нужен] - пользоваться вполне можно. Ну там пехепе посвежее вручную собрать, всех пяти потребных девелоперам версий, ключевые демоны позаменять (один хрен с местыми патчами) и живи себе.

А, нет, еще там, помнитсо, gcc был какой-то странной версии, тоже надо уже менять.

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

47. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от Аноним (??) on 18-Май-17, 23:18 
> 1. RHEL (Centos) держат ABI все 7 лет, и API/конфиги софта ±аналогично
> (пример: vsftpd, exim). Внутри мажорного релиза (весь жизненный цикл) новые фичи
> бэкпортируются без слома старых. Дорого, медленно (делать новые фичи), стабильно.

Это только в теории так должно быть.

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

55. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от PnDx (ok) on 19-Май-17, 11:41 
>> 1. RHEL (Centos) держат ABI все 7 лет, и API/конфиги софта ±аналогично
>> (пример: vsftpd, exim). Внутри мажорного релиза (весь жизненный цикл) новые фичи
>> бэкпортируются без слома старых. Дорого, медленно (делать новые фичи), стабильно.
> Это только в теории так должно быть.

Я, кажется, привёл практические примеры (для ППО).
exim: в очередном миноре (≈2010 г.) crl из файла превратили в каталог. У дебианщиков инсталляции сломались. У RH — "фичу" вырезали.
vsftpd: Не помню когда решили что в рут писать нельзя и добавили "allow_writable_root", сломав старое поведение. В RH появилось в 7.x, в 6.x — не будет (если сами не соберёте).

ABI подтвердить сложнее, но и опровержения у меня нет. Есть примеры со сломанными заголовками ядра (e.g. изменение аргументов макроса), но вот это, увы, никто не гарантирует.

Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

57. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от Аноним (??) on 19-Май-17, 16:22 
> exim: в очередном миноре (≈2010 г.) crl из файла превратили в каталог. У дебианщиков инсталляции сломались.

Где сломались, в stable? Рассказывай, ага.
https://bugs.debian.org/cgi-bin/pkgreport.cgi?archive=both;i...
Где баг? Нету бага.
К сведению, в Debian обновления между мажорными версиями проходят более гладко, чем в шапке между минорными. А как в шапке мажорную версию обновляют, расскажи-ка нам? Где в ейном yum спрятали zypper dup?

Ответить | Правка | ^ к родителю #55 | Наверх | Cообщить модератору

58. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от Аноним (??) on 19-Май-17, 16:36 
> ABI подтвердить сложнее, но и опровержения у меня нет.

В 2015 в 7-ке обновили libical, например, с 0 на 1. Это из того, что сходу удалось найти. А вообще подход к пакетированию библиотек в федоре/шапке едва ли не самый раздолбайский из всех бинарных дистрибутивов. В большинстве остальных можно установить несколько версий библиотеки одновременно, а у них — только для избранных библиотек.

Ответить | Правка | ^ к родителю #55 | Наверх | Cообщить модератору

49. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от Аноним (??) on 19-Май-17, 04:58 
Один из немногих нормальных дистрибутивов запланированно прекращает поддержку устаревшей версии и всё, караул.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

60. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от vin email on 19-Май-17, 20:28 
А в 42,2 сейчас при установки какое ядро стоит? А то эти амд драйвера на сусе сейчас работают только в 42,1 и в Tumbleweed. а 42,2 когда пробовал ставить она так и не запускалась.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

65. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от leap42 (ok) on 20-Май-17, 02:19 
> А в 42,2 сейчас при установки какое ядро стоит?

4.4.62-18.6.1

> амд драйвера на сусе сейчас работают только в 42,1 и в Tumbleweed

какой драйвер, какая карта?

Ответить | Правка | ^ к родителю #60 | Наверх | Cообщить модератору

70. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от vinn1 email on 20-Май-17, 16:09 
Встроенное видео в процессор AMD Richland A10-6800K
AMD Radeon HD8670D  я опен сусе люблю но поставить 42,2 так и не получается.
Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

72. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от leap42 (ok) on 21-Май-17, 08:15 
карточка должна "просто работать", драйвер давно в ядре
какие именно проблемы испытываете?
Ответить | Правка | ^ к родителю #70 | Наверх | Cообщить модератору

73. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +1 +/
Сообщение от vin email on 22-Май-17, 08:01 
Система устанавливается но после перезагрузки не загружается.
Ответить | Правка | ^ к родителю #72 | Наверх | Cообщить модератору

76. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от leap42 (ok) on 23-Май-17, 02:11 
> Система устанавливается но после перезагрузки не загружается.

ого, пилите бегрепорт, даже если не хочется - оно надо

не загружается, это как именно выглядит? если добавить single к параметрам ядра или nomodeset тоже не грузится?

Ответить | Правка | ^ к родителю #73 | Наверх | Cообщить модератору

79. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  –1 +/
Сообщение от vin email on 24-Май-17, 12:20 
После установки перезагружается и при загрузки монитор тухнет и все. Черный экран бездействия.
Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

82. "Прекращена поддержка дистрибутива openSUSE Leap 42.1"  +/
Сообщение от vin email on 30-Май-17, 13:38 
А вот geckolinux сборка с гномом опенсусе 42,2 встал без проблем. Так только установщик другой.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема



  Закладки на сайте
  Проследить за страницей
Created 1996-2017 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor