The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от opennews on 18-Сен-15, 09:29 
Компания Google анонсировала (http://googleonlinesecurity.blogspot.ru/2015/09/disabling-ss...) скорое прекращение поддержки протокола SSLv3 и алгоритма RC4, которые не отвечают современным требованиям безопасности и подвержены нескольким видам атак. На первом этапе поддержка  SSLv3 и RC4 будет отключена на фронтэнд-серверах, после чего отключение распространится на все продукты Google, включая Chrome (SSLv3 в Chrome уже отключен, в очереди на отключение RC4), Android, поисковые боты и SMTP-серверы. По статистике SSL Pulse (https://www.trustworthyinternet.org/ssl-pulse/) из 200 тысяч крупнейших HTTPS-сайтов 42% уже отключили RC4 и 65% отключили SSLv3.

Кроме того, планируется повысить требования к параметрам установки соединения HTTPS, например, для работы с сайтами Google по защищённому каналу связи на стороне клиента станет обязательной поддержка TLS 1.2, наличие расширения SNI (https://en.wikipedia.org/wiki/Server_Name_Indication) (Server Name Indication) и присутствие набора шифров TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256. Доверие будет ограничено корневыми сертификтами из списка pki.google.com/roots.pem (https://pki.google.com/roots.pem), при обработке сертификатов обязательной будет поддержка  DNS SAN (https://en.wikipedia.org/wiki/SubjectAltName) (Subject Alternative Names). Для тестирования соответствия клиентского ПО новым требованиям Google подготовлена страница cert-test.sandbox.google.com (https://cert-test.sandbox.google.com/).


URL: http://googleonlinesecurity.blogspot.ru/2015/09/disabling-ss...
Новость: https://www.opennet.ru/opennews/art.shtml?num=42982

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от iPony on 18-Сен-15, 09:29 
> Для тестирования соответствия клиентского ПО новым требованиям Google подготовлена страница

Проверял разные браузеры на разных ОС.
IE11 на вындовз 7 не проходит.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от анончег on 18-Сен-15, 09:39 
IE11 на Win10 проходит
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Аноним (??) on 18-Сен-15, 10:53 
Надеюсь это была шутка? =)
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

4. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Анонимус_б6_выпуск_3 on 18-Сен-15, 10:55 
нет, не шутка
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

6. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от daemontux on 18-Сен-15, 11:24 
> нет, не шутка

Подтверждаю. На 11 ишаке не работает.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

8. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от iZEN (ok) on 18-Сен-15, 11:50 
> IE11 на вындовз 7 не проходит.

Не обновляется, видимо - пламенный привет от Windows 10 устаревшим системам.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

10. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от sadsad on 18-Сен-15, 12:31 
Win7 ещё поддерживается.
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

12. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от iPony on 18-Сен-15, 13:21 
Да, но фаза основной поддержки закончилась, щас на расширенной.
Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

15. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +2 +/
Сообщение от Аноним (??) on 18-Сен-15, 14:18 
> IE11 на вындовз 7 не проходит.

Открывал в vimb, xombrero и прочей маргинальщине на webkit-gtk2
> Client test successful.

Интересно, как клоуны, ксении и другие, идейные или проплаченные пиарщики  "качества" проприетарщины, собираются опять впарить "когда вас за ваши же деньги еще и ... " за фичу :)

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

42. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от username (??) on 20-Сен-15, 11:06 
Ты попутал немного, веб страницы нужно открывать веб браузером, осел к ним не относится.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

5. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  –5 +/
Сообщение от Аноним (??) on 18-Сен-15, 11:19 
>TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256

Почему именно этот а не более безопасный GOST?
Совпадение? Не думаю.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +2 +/
Сообщение от Аноним (??) on 18-Сен-15, 12:23 
GOST содержит уязвимости.
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

11. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  –1 +/
Сообщение от Аноним (??) on 18-Сен-15, 12:47 
gost содержит (родные) уязвимости!

Еще проще получить данные подав заявку в ФСБ на расшифровку

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

14. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Аноним (??) on 18-Сен-15, 14:11 
Сам GOST как алгоритм уязвимости не содержит, иначе бы его не стандартизовали и не использовали. Там проблема в возможных настройках алгоритма.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

16. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от pavlinux (ok) on 18-Сен-15, 14:22 
> Сам GOST как алгоритм уязвимости не содержит,

Доказательства есть?

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

20. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Аноним (??) on 18-Сен-15, 14:44 
>> Сам GOST как алгоритм уязвимости не содержит,
> Доказательства есть?

Докажи что содержит

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

26. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  –1 +/
Сообщение от pavlinux (ok) on 18-Сен-15, 15:20 
>>> Сам GOST как алгоритм уязвимости не содержит,
>> Доказательства есть?
> Докажи что содержит

Стрелки не переводи.  Ты заявил - ты доказывай.


Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

39. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Аноним (??) on 18-Сен-15, 21:35 
в гугле забанили? не так давно даже тут пробегала статья о оценке криптостойкости ГОСТ 28147.
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

40. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Аноним (??) on 18-Сен-15, 21:47 
Сам не переводи, читай всё обсуждение, а не только последнее сообщение.
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

36. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Аноним (??) on 18-Сен-15, 19:31 
> Почему именно этот а не более безопасный GOST?

Наверное, потому что никто не собирается гадать какие таблицы замены хорошие, а какие нет. Да и вообще, потомки DES'а нынче не в моде.

> Совпадение? Не думаю.

Ты умеешь думать?

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

41. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Аноним (??) on 18-Сен-15, 21:49 
>> Почему именно этот а не более безопасный GOST?
> Наверное, потому что никто не собирается гадать какие таблицы замены хорошие, а
> какие нет.

Вроде их собирались тоже добавить в стандарт, не сделано пока?

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

7. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +1 +/
Сообщение от iZEN (ok) on 18-Сен-15, 11:48 
https://cert-test.sandbox.google.com/
Firefox 40.0.3, IE 11.0.10240.16431, Edge 20.10240.16384.0 - Client test successful.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

38. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Аноним (??) on 18-Сен-15, 20:05 
Opera
Версия:
12.17
Сборка:
1863
Платформа:
x64
Система:
Windows 7

Безопасное подключение: критическая ошибка (49) с сервера

https://cert-test.sandbox.google.com/

Сертификат правильный, но доступ запрещен.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

13. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  –1 +/
Сообщение от Аноним (??) on 18-Сен-15, 13:48 
**присутствие** набора шифров TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 ? видать какой-то из компонентов легко проламывается и какбы не эти хвалёные EC.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

37. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Аноним (??) on 18-Сен-15, 19:33 
> **присутствие** набора шифров TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256 ? видать какой-то
> из компонентов легко проламывается и какбы не эти хвалёные EC.

Учитывая что там именно NIST'овские кривые, а не 25519 например - вот это может быть.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

17. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от Аноним (??) on 18-Сен-15, 14:29 
>> для работы с сайтами Google по защищённому каналу связи на стороне клиента станет обязательной ... наличие расширения SNI

я правильно понимаю, что это блокирует устройствам на Android 2.x доступ к серверам Google?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

18. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от pavlinux (ok) on 18-Сен-15, 14:37 
Links 2.8, SSL Error
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

22. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +1 +/
Сообщение от An2 on 18-Сен-15, 14:53 
links 2.11
client test successful
Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

19. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от pavlinux (ok) on 18-Сен-15, 14:39 
Да они долб....ы. Thunderbird, The Bat!,... стали банить (если работать по IMAPs/POP3s/SSMTP)  
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

21. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от iPony on 18-Сен-15, 14:49 
> Thunderbird стали банить

Врёшь же.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

23. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от pavlinux (ok) on 18-Сен-15, 15:00 
>> Thunderbird стали банить
> Врёшь же.

https://www.google.com/settings/security/lesssecureapps
https://support.google.com/accounts/answer/6010255?hl=ru

> "Как разрешить ненадежным приложениям доступ к аккаунту
> Google может блокировать приложения и устройства, которые пытаются
> получить доступ к вашему аккаунту и при этом не отвечают современным
>стандартам безопасности. Это позволяет нам защитить ваш аккаунт.
> Вот некоторые примеры таких приложений и устройств:
> почтовый клиент для iPad на платформе iOS 6 и ниже;
> почтовый клиент для телефонов на платформе Windows ниже версии 8.1;
> отдельные почтовые программы для компьютеров, например Microsoft Outlook или Mozilla Thunderbird..."

Неделю-две назад видимо переключили в режим по-умолчанию.


Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

24. "Google прекращает поддержку SSLv3 и RC4 и повышает требовани..."  +/
Сообщение от iPony on 18-Сен-15, 15:03 
https://www.mozilla.org/en-US/thunderbird/38.0beta/releasenotes/

GMail supports OAuth2 authentication, removing the need to manually select "allow less secure applications" in Google options for the account.

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру