The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  вход/выход  слежка  RSS
"centos7 & php-ldap & libsasl2.so"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Системное и пользовательское ПО)
Изначальное сообщение [ Отслеживать ]

"centos7 & php-ldap & libsasl2.so"  –2 +/
Сообщение от Антоним (ok) on 29-Июн-16, 09:15 
В centos7 libsasl2.so.2 была заменена на libsasl2.so.3.
Понадобилось установить php-ldap , но он требует libsasl2.so.2

#yum install php-ldap
Resolving Dependencies
--> Running transaction check
---> Package php-ldap.x86_64 0:7.0.8-1.el6.remi will be installed
--> Processing Dependency: libsasl2.so.2()(64bit) for package: php-ldap-7.0.8-1.el6.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php-ldap-7.0.8-1.el6.remi.x86_64 (remi-php70)
           Requires: libsasl2.so.2()(64bit)

Симлинк не помог.
#ln -s /usr/lib64/libsasl2.so.3.0.0 /usr/lib64/libsasl2.so.2
Диагностика таже.

Что можно предпринять?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "centos7 & php-ldap & libsasl2.so"  +1 +/
Сообщение от Led (ok) on 29-Июн-16, 09:21 
> Что можно предпринять?

Выгнать ссаными тряпками "заменяльщика" и нанять хотя бы студента.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "centos7 & php-ldap & libsasl2.so"  –1 +/
Сообщение от Антоним (ok) on 29-Июн-16, 10:45 
>> Что можно предпринять?
> Выгнать ссаными тряпками "заменяльщика" и нанять хотя бы студента.

В СентОС 6 использовали 2-ю версию а в СентОС 7 3-ю
кого выгорять?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "centos7 & php-ldap & libsasl2.so"  +1 +/
Сообщение от admin (??) on 30-Июн-16, 04:10 
>>> Что можно предпринять?
>> Выгнать ссаными тряпками "заменяльщика" и нанять хотя бы студента.
> В СентОС 6 использовали 2-ю версию а в СентОС 7 3-ю
> кого выгорять?
> В centos7 libsasl2.so.2 была заменена на libsasl2.so.3.

нужно заменять не для всей системы а для конкретного приложения. эти либы если вы заметили имеют разные имена и не пересекаются.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "centos7 & php-ldap & libsasl2.so"  –1 +/
Сообщение от Антоним (ok) on 30-Июн-16, 05:42 
Все оказалось проще.
Из-за невнимательности прописал репозитории для centos6.
Тема закрыта.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "centos7 & php-ldap & libsasl2.so"  +/
Сообщение от erera22 (ok) on 01-Июл-16, 18:22 
> Все оказалось проще.
> Из-за невнимательности прописал репозитории для centos6.
> Тема закрыта.

А так-то LD_PRELOAD

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor