The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Ошибки при компиляции пакета linux-f10-flashplugin11"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Видео, изображения, потоковое вещание / FreeBSD)
Изначальное сообщение [ Отслеживать ]

"Ошибки при компиляции пакета linux-f10-flashplugin11"  –2 +/
Сообщение от qqq email(??) on 24-Апр-16, 22:12 
Всем привет!
Решил сегодня на свеже установленой freebsd 10.3 устоновить flash.
И ни застрял на установке пакета linux-f10-flashplugin11.
Ни как не проходит make этого пакета.
Помогите пожалуйста очень нужно!  Вот что в ответ говорит система
1 problem(s) in the installed packages found.
=> Please update your ports tree and try again.
=> Note: Vulnerable ports are marked as such even if there is no update available.
=> If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/linux-f10-flashplugin11
*** Error code 1

Stop.
Попытался установить с помощью pkg install linux-f10-flashplugin11
Updating FreeBSD repository catalogue...
FreeBSD repository is up-to-date.
All repositories are up-to-date.
pkg: No packages available to install matching 'linux-f10-flashplugin11' have been found in the repositories

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от BarS_Mutabor (ok) on 25-Апр-16, 07:35 
Тут кроме как посоветовать перевести сообщение и сказать то нечего....
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 25-Апр-16, 09:35 
> Всем привет!
> Решил сегодня на свеже установленой freebsd 10.3 устоновить flash.
> И ни застрял на установке пакета linux-f10-flashplugin11.
> Ни как не проходит make этого пакета.
> Помогите пожалуйста очень нужно!  Вот что в ответ говорит система
> 1 problem(s) in the installed packages found.
> => Please update your ports tree and try again.

Пожалуйста проапдейтите Ваше дерево портов и попробуйте снова
(portsnap fetch extract)

> => Note: Vulnerable ports are marked as such even if there is
> no update available.

Порт помечен как опасный...

> => If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'

Если хотите проигнорировать, пересоберите порт следующим образом

# make DISABLE_VULNERABILITIES=yes

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Ошибки при компиляции пакета linux-f10-flashplugin11"  –2 +/
Сообщение от qqq email(??) on 25-Апр-16, 09:41 
>[оверквотинг удален]
>> 1 problem(s) in the installed packages found.
>> => Please update your ports tree and try again.
> Пожалуйста проапдейтите Ваше дерево портов и попробуйте снова
> (portsnap fetch extract)
>> => Note: Vulnerable ports are marked as such even if there is
>> no update available.
> Порт помечен как опасный...
>> => If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
> Если хотите проигнорировать, пересоберите порт следующим образом
> # make DISABLE_VULNERABILITIES=yes

Я давал такую команду
# make DISABLE_VULNERABILITIES=yes но это то же не помогало. Вылетало с ошибками.
А можно как нибудь обойти этот порт? Что совсем не хочется ради флеша обновлять парты.
Я попытался установить из пакетов. А пакета такого нет. Может подскажите как еще флеш настроить на фришке?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +1 +/
Сообщение от bagas email(ok) on 25-Апр-16, 09:49 
>[оверквотинг удален]
>> Порт помечен как опасный...
>>> => If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
>> Если хотите проигнорировать, пересоберите порт следующим образом
>> # make DISABLE_VULNERABILITIES=yes
> Я давал такую команду
> # make DISABLE_VULNERABILITIES=yes но это то же не помогало. Вылетало с ошибками.
> А можно как нибудь обойти этот порт? Что совсем не хочется ради
> флеша обновлять парты.
> Я попытался установить из пакетов. А пакета такого нет. Может подскажите как
> еще флеш настроить на фришке?

Обновляй порты, не компостируй мозг!!!

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Сергей (??) on 25-Апр-16, 10:29 
>>[оверквотинг удален]
>>> Порт помечен как опасный...

Посмотрите может в /var/db/pkg валяется файлик типа vuln.xml или подобный, то переместите его и попробуйте синсталлировать порт снова...


Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 25-Апр-16, 12:33 
>[оверквотинг удален]
>> Пожалуйста проапдейтите Ваше дерево портов и попробуйте снова
>> (portsnap fetch extract)
>>> => Note: Vulnerable ports are marked as such even if there is
>>> no update available.
>> Порт помечен как опасный...
>>> => If you wish to ignore this vulnerability rebuild with 'make DISABLE_VULNERABILITIES=yes'
>> Если хотите проигнорировать, пересоберите порт следующим образом
>> # make DISABLE_VULNERABILITIES=yes
> Я давал такую команду
> # make DISABLE_VULNERABILITIES=yes но это то же не помогало. Вылетало с ошибками.

с какими? вероятно с другими?

# echo "linux_enable=\"YES\" >> /etc/rc.conf
# make DISABLE_VULNERABILITIES=yes BATCH=yes

И да, этот порт устарел:
https://www.freebsd.org/doc/en/books/handbook/desktop-browse...

linux-c6-flashplugin11

> А можно как нибудь обойти этот порт? Что совсем не хочется ради
> флеша обновлять парты.

требуется linuxolator (linux emulation)

> Я попытался установить из пакетов. А пакета такого нет. Может подскажите как
> еще флеш настроить на фришке?

в пакетах нет по причине лицензионности, сами скачиваете и подтвержаете
использование лицензии в личных целях.

Если не хотите обновляться, смотрите версию FreeBSD и того что у Вас установлено:
- linuxolator

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

7. "Ошибки при компиляции пакета linux-f10-flashplugin11"  –2 +/
Сообщение от qqq email(??) on 25-Апр-16, 12:44 
>[оверквотинг удален]
>> А можно как нибудь обойти этот порт? Что совсем не хочется ради
>> флеша обновлять парты.
> требуется linuxolator (linux emulation)
>> Я попытался установить из пакетов. А пакета такого нет. Может подскажите как
>> еще флеш настроить на фришке?
> в пакетах нет по причине лицензионности, сами скачиваете и подтвержаете
> использование лицензии в личных целях.
> Если не хотите обновляться, смотрите версию FreeBSD и того что у Вас
> установлено:
> - linuxolator

linux_enable="YES" >> /etc/rc.conf естественно имеется строчка.
Я ставил и linux-c6-flashplugin11 linux-f10-flashplugin11 и стаалкивался с одной и той же ошибкой
make DISABLE_VULNERABILITIES=yes я давал вот ту команду но не помоglo
Все понятно вообщем похоже проще поставить линух чем.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +1 +/
Сообщение от Аноним (??) on 25-Апр-16, 15:59 
> Все понятно вообщем похоже проще поставить линух чем.

можно psbsd попробовать, а виндоус поставить ещё леgче чем

но настоящие джедаи не ищут лёгких путей, не разочаровывай

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 25-Апр-16, 17:51 
>> Все понятно вообщем похоже проще поставить линух чем.
> можно psbsd попробовать, а виндоус поставить ещё леgче чем
> но настоящие джедаи не ищут лёгких путей, не разочаровывай

psbsd у меня стоит переодически, но он переодически после моих экспериметнов падает и не отжимается по этому приходится переодически переустанавливать.
Я просто подумал что если установлю фрибсд то он не будет так часто падать.
Но похоже что проще установить psbсd чем самому настраивать фрибсд до рабочего десктопа

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Аноним (??) on 25-Апр-16, 18:36 
>>> Все понятно вообщем похоже проще поставить линух чем.
>> можно psbsd попробовать, а виндоус поставить ещё леgче чем
>> но настоящие джедаи не ищут лёгких путей, не разочаровывай
> psbsd у меня стоит переодически, но он переодически после моих экспериметнов падает
> и не отжимается по этому приходится переодически переустанавливать.
> Я просто подумал что если установлю фрибсд то он не будет так
> часто падать.
> Но похоже что проще установить psbсd чем самому настраивать фрибсд до рабочего
> десктопа

да, возможно
типа в pcBSD многое работае прям сразу "искаропки", то, что в FreeBSD нужно допиливать

ну и в чём дело? нужно таки взять и "в конце - доработать напильником"
в этом весь хардкор

странно, что pcBSD "падает", вроде это не виндоус
попробуйте яблоко, может понравится - и консоль есть, и флеш
но хакинтош не для слабонервных :)

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 25-Апр-16, 19:01 
>[оверквотинг удален]
>> десктопа
> да, возможно
> типа в pcBSD многое работае прям сразу "искаропки", то, что в FreeBSD
> нужно допиливать
> ну и в чём дело? нужно таки взять и "в конце -
> доработать напильником"
> в этом весь хардкор
> странно, что pcBSD "падает", вроде это не виндоус
> попробуйте яблоко, может понравится - и консоль есть, и флеш
> но хакинтош не для слабонервных :)

Я не знаю что там падает в pcbsd но падает!
Обычно после того как я поставлю wine и попытаюсь что нибудь из виндузовых программ поставить. После этого virtualbox точнее его ядро перестает запускаться!
Яблоко хочу поставить но получается. Единственное что получается скачать образ и раскатать его диск. Или на виртуалке запускать.
Вообщем для экспериментов остается все меньше времени и нужно ставить в продакшин сервер.
Была идея очень простая! Поставить фрибсд ее использовать в качестве сервера и на нем поднять X в иксах ставить virtualbox и в нем уже крутить виртуалки!
Ну вообщем прихожу к мысли что сервер это сервер а десктоп это десктоп. И скрещивать их не стоит! Сервер работал более 5 лет на фрибсд не скрещеный с десктопом пусть и работает.
А десктоп на фрибсд это издевательство

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 26-Апр-16, 08:31 
>[оверквотинг удален]
> его диск. Или на виртуалке запускать.
> Вообщем для экспериментов остается все меньше времени и нужно ставить в продакшин
> сервер.
> Была идея очень простая! Поставить фрибсд ее использовать в качестве сервера и
> на нем поднять X в иксах ставить virtualbox и в нем
> уже крутить виртуалки!
> Ну вообщем прихожу к мысли что сервер это сервер а десктоп это
> десктоп. И скрещивать их не стоит! Сервер работал более 5 лет
> на фрибсд не скрещеный с десктопом пусть и работает.
> А десктоп на фрибсд это издевательство

издевательство - это подход в стиле я-ля Windoze.
Установка VirtualBox не требует Xorg, а установка flash plugin от Linux -
не требует сборки, ну разве что nspluginwrapper.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

14. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 08:47 
>[оверквотинг удален]
>> Была идея очень простая! Поставить фрибсд ее использовать в качестве сервера и
>> на нем поднять X в иксах ставить virtualbox и в нем
>> уже крутить виртуалки!
>> Ну вообщем прихожу к мысли что сервер это сервер а десктоп это
>> десктоп. И скрещивать их не стоит! Сервер работал более 5 лет
>> на фрибсд не скрещеный с десктопом пусть и работает.
>> А десктоп на фрибсд это издевательство
> издевательство - это подход в стиле я-ля Windoze.
> Установка VirtualBox не требует Xorg, а установка flash plugin от Linux -
> не требует сборки, ну разве что nspluginwrapper.

Вот как раз nspluginwrapper ставится из пакетов. И нет проблем с ним!
Я знаю что VirtualBox не требует Xorg.
Пожалуйста не пинайте ногами больно а помогите с установкой linux-f10-flashplugin11.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

16. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Сергей (??) on 26-Апр-16, 09:25 
>>[оверквотинг удален]
>>> Была идея очень простая! Поставить фрибсд ее использовать в качестве сервера и
>>> на нем поднять X в иксах ставить virtualbox и в нем
>>> уже крутить виртуалки!
> Я знаю что VirtualBox не требует Xorg.
> Пожалуйста не пинайте ногами больно а помогите с установкой linux-f10-flashplugin11.

ну так поставь xorg-minimal + twm + xterm, как самое легковесное... Ну и естественно нужные драйвера из xorg-drivers, а то в xorg-minimal только vesa поставится...
Просто обьясни, каким боком флеш нужен для виртуалбокса?


Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

17. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 09:35 
>>>[оверквотинг удален]
>>>> Была идея очень простая! Поставить фрибсд ее использовать в качестве сервера и
>>>> на нем поднять X в иксах ставить virtualbox и в нем
>>>> уже крутить виртуалки!
>> Я знаю что VirtualBox не требует Xorg.
>> Пожалуйста не пинайте ногами больно а помогите с установкой linux-f10-flashplugin11.
>  ну так поставь xorg-minimal + twm + xterm, как самое легковесное...
> Ну и естественно нужные драйвера из xorg-drivers, а то в xorg-minimal
> только vesa поставится...
>  Просто обьясни, каким боком флеш нужен для виртуалбокса?

Это я все поставил и оно работает а теперь нужен для проверки моей непосредственной работы флеш проигрователь

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

18. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 26-Апр-16, 10:52 
>>  Просто обьясни, каким боком флеш нужен для виртуалбокса?
> Это я все поставил и оно работает а теперь нужен для проверки
> моей непосредственной работы флеш проигрователь

который как бэ можно установить на любой клиентской машине для демонстрации
чего-либо.

Странный подход к демонстрации работы.

ps. Больше 20'ти лет использую FreeBSD как десктоп, не имел и не имею проблем.

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

19. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 10:59 
>>>  Просто обьясни, каким боком флеш нужен для виртуалбокса?
>> Это я все поставил и оно работает а теперь нужен для проверки
>> моей непосредственной работы флеш проигрователь
> который как бэ можно установить на любой клиентской машине для демонстрации
> чего-либо.
> Странный подход к демонстрации работы.
> ps. Больше 20'ти лет использую FreeBSD как десктоп, не имел и не
> имею проблем.

Так все таки как его установить? Помогите пожалуйста! Поделитесь опытом, пожалуйста

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

20. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 26-Апр-16, 12:06 
>>>>  Просто обьясни, каким боком флеш нужен для виртуалбокса?
>>> Это я все поставил и оно работает а теперь нужен для проверки
>>> моей непосредственной работы флеш проигрователь
>> который как бэ можно установить на любой клиентской машине для демонстрации
>> чего-либо.
>> Странный подход к демонстрации работы.
>> ps. Больше 20'ти лет использую FreeBSD как десктоп, не имел и не
>> имею проблем.
> Так все таки как его установить? Помогите пожалуйста! Поделитесь опытом, пожалуйста

дык все по handbook'у. Если старый релиз, нужно посмотреть емуляцию linux
и порт flash плагина.

Вот пример с 10.1R:

[joker]~ > uname -r
10.1-RELEASE-p19
[joker]~ > pkg info | egrep '(^firefox|flash)'
firefox-38.0.6,1               Web browser based on the browser portion of Mozilla
firefox-i18n-38.0.6            Localized interface for Firefox
linux-c6-flashplugin-11.2r202.481 Adobe Flash Player NPAPI Plugin
[joker]~ >
[joker]~ > sysctl -a | grep ^compat.linux
compat.linux.osname: Linux
compat.linux.osrelease: 2.6.18
compat.linux.oss_version: 198144
compat.linux32.maxdsiz: 536870912
compat.linux32.maxssiz: 67108864
compat.linux32.maxvmem: 0
[joker]~ >

бывали заморочки, но они всегда носили временный характер.

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

21. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 12:22 
>[оверквотинг удален]
> [joker]~ >
> [joker]~ > sysctl -a | grep ^compat.linux
> compat.linux.osname: Linux
> compat.linux.osrelease: 2.6.18
> compat.linux.oss_version: 198144
> compat.linux32.maxdsiz: 536870912
> compat.linux32.maxssiz: 67108864
> compat.linux32.maxvmem: 0
> [joker]~ >
> бывали заморочки, но они всегда носили временный характер.

Покажите пожалуйста оригинал!

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

22. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 26-Апр-16, 12:34 
>[оверквотинг удален]
>> [joker]~ > sysctl -a | grep ^compat.linux
>> compat.linux.osname: Linux
>> compat.linux.osrelease: 2.6.18
>> compat.linux.oss_version: 198144
>> compat.linux32.maxdsiz: 536870912
>> compat.linux32.maxssiz: 67108864
>> compat.linux32.maxvmem: 0
>> [joker]~ >
>> бывали заморочки, но они всегда носили временный характер.
> Покажите пожалуйста оригинал!

переведите или объясните что хотите увидеть.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

24. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 12:42 
>[оверквотинг удален]
>>> compat.linux.osname: Linux
>>> compat.linux.osrelease: 2.6.18
>>> compat.linux.oss_version: 198144
>>> compat.linux32.maxdsiz: 536870912
>>> compat.linux32.maxssiz: 67108864
>>> compat.linux32.maxvmem: 0
>>> [joker]~ >
>>> бывали заморочки, но они всегда носили временный характер.
>> Покажите пожалуйста оригинал!
> переведите или объясните что хотите увидеть.

Еще раз все с начала объясняю. Нужно для моей непосредственной работы флеш плеер!
Для этого я попытался для начала с помощью pkg install установить пакет
linux-f10-flashplugin11! Но это не удалось система такой пакет не нашла.
Ну думаю фиг с тобой золотая рыбка пойдем другим путем. Попытался установить из коллекции портов. Опять не получается. При команде make получаю ошибки.
То же самое получаю при попытке установки linux-c6-flashplugin11.
Что я делаю не так?

Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

23. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 12:34 
>[оверквотинг удален]
> [joker]~ >
> [joker]~ > sysctl -a | grep ^compat.linux
> compat.linux.osname: Linux
> compat.linux.osrelease: 2.6.18
> compat.linux.oss_version: 198144
> compat.linux32.maxdsiz: 536870912
> compat.linux32.maxssiz: 67108864
> compat.linux32.maxvmem: 0
> [joker]~ >
> бывали заморочки, но они всегда носили временный характер.

Если бы этот пакет  linux-c6-flashplugin-11 ставился бы то и не задавал бы я тут вопросов. А так он и не компилится и не ставится! Система самая последняя freebsd 10.3

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

31. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 26-Апр-16, 15:09 
>[оверквотинг удален]
>> compat.linux.osrelease: 2.6.18
>> compat.linux.oss_version: 198144
>> compat.linux32.maxdsiz: 536870912
>> compat.linux32.maxssiz: 67108864
>> compat.linux32.maxvmem: 0
>> [joker]~ >
>> бывали заморочки, но они всегда носили временный характер.
> Если бы этот пакет  linux-c6-flashplugin-11 ставился бы то и не задавал
> бы я тут вопросов. А так он и не компилится и
> не ставится! Система самая последняя freebsd 10.3

Еще раз для тех кто не желает читать то что рекомендуется в Handbook:
- новый эмулятор linux
- для него советую новый linux_base
- при использовании верхнего, все собирается by default без всяких бубнов,
танцев и шаманства

можно и вовсе все необходимое установить из пакетов и останется установить
из портов лишь linux-c6-flashplugin11

хочется linux-f10-flashplugin11, можно аналогично все установить из пакетов,
останется установить из портов: linux-f10-flashplugin11 и собрать-установить
nspluginwrapper

Не поленился, на своей тухлой WKS: core2 6300 с RAM=3GB, установил 10.3R,
в ней Xorg, jwm, firefox, linux_base-f10, inux-f10-flashplugin11, nspluginwrapper:

http://unix1.jinr.ru/~lavr/bsd103.png

флеш работает.

Что у Вас не собирается, известно только Вам и только по Вашим словам.

Вам нужна была конкретика, см ссылку, на рисунке все наглядно.

Ответить | Правка | ^ к родителю #23 | Наверх | Cообщить модератору

32. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 17:25 
>[оверквотинг удален]
> хочется linux-f10-flashplugin11, можно аналогично все установить из пакетов,
> останется установить из портов: linux-f10-flashplugin11 и собрать-установить
> nspluginwrapper
> Не поленился, на своей тухлой WKS: core2 6300 с RAM=3GB, установил 10.3R,
> в ней Xorg, jwm, firefox, linux_base-f10, inux-f10-flashplugin11, nspluginwrapper:
> http://unix1.jinr.ru/~lavr/bsd103.png
> флеш работает.
> Что у Вас не собирается, известно только Вам и только по Вашим
> словам.
> Вам нужна была конкретика, см ссылку, на рисунке все наглядно.

Так этот порт и не устанавливается linux-f10-flashplugin11. С какими опциями вы его компилите? Я правильно делаю сначала перехожу в директорию linux-f10-flashplugin11 и там в ней делаю команду make? Правильно? Покажите как вы компилите! Может я где напортачил?
Дайте ссылку на то где этот процесс описывается!

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

33. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 26-Апр-16, 19:05 
>[оверквотинг удален]
>> http://unix1.jinr.ru/~lavr/bsd103.png
>> флеш работает.
>> Что у Вас не собирается, известно только Вам и только по Вашим
>> словам.
>> Вам нужна была конкретика, см ссылку, на рисунке все наглядно.
> Так этот порт и не устанавливается linux-f10-flashplugin11. С какими опциями вы его
> компилите? Я правильно делаю сначала перехожу в директорию linux-f10-flashplugin11 и там
> в ней делаю команду make? Правильно? Покажите как вы компилите! Может
> я где напортачил?
> Дайте ссылку на то где этот процесс описывается!

этот порт НЕкомпилится, разворачивается бинарник и устанавливается в систему:

root@bsd103:~ # date
Tue Apr 26 18:57:05 MSK 2016
root@bsd103:~ # uname -a
FreeBSD bsd103.jinr.ru 10.3-RELEASE FreeBSD 10.3-RELEASE #0 r297264: Fri Mar 25 02:10:02 UTC 2016     root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC  amd64
root@bsd103:~ # kldstat
Id Refs Address            Size     Name
1   26 0xffffffff80200000 17bc680  kernel
2    1 0xffffffff81a11000 563c     linsysfs.ko
3    4 0xffffffff81a17000 683b     linux_common.ko
4    1 0xffffffff81a1e000 9faf     linprocfs.ko
5    1 0xffffffff81a28000 26b76    vboxguest.ko
6    1 0xffffffff81a4f000 114db    ipfw.ko
7    1 0xffffffff81a61000 3d118    linux.ko
8    1 0xffffffff81a9f000 37ae5    linux64.ko
root@bsd103:~ #
root@bsd103:~ # pkg info | grep linux
linux-f10-atk-1.24.0_1         Accessibility Toolkit, Linux/i386 binary (Linux Fedora 10)
linux-f10-cairo-1.8.0_3        Vector graphics library Cairo (Linux Fedora 10)
linux-f10-curl-7.19.6_1        Command line tool for transferring files with URL syntax (Linux Fedora 10)
linux-f10-cyrus-sasl2-2.1.22_3 RFC 2222 SASL (Simple Authentication and Security Layer) (Linux Fedora 10)
linux-f10-expat-2.0.1_1        Linux/i386 binary port of Expat XML-parsing library (Linux Fedora 10)
linux-f10-flashplugin-11.2r202.559 Adobe Flash Player NPAPI Plugin
linux-f10-fontconfig-2.6.0_1   XML-based font configuration API for X Windows (Linux Fedora 10)
linux-f10-gtk2-2.14.7_5        GTK+ library, version 2.X (Linux Fedora 10)
linux-f10-jpeg-6b              RPM of the JPEG lib (Linux Fedora 10)
linux-f10-libssh2-0.18_1       Library implementing the SSH2 protocol (Linux Fedora 10)
linux-f10-nspr-4.7.6_1         Netscape Portable Runtime (Linux Fedora 10)
linux-f10-nss-3.12.3.99.3_2    Network Security Services (Linux Fedora 10)
linux-f10-openldap-2.4.12_2    Lightweight Directory Access Protocol libraries (Linux Fedora 10)
linux-f10-openssl-0.9.8g_1     OpenSSL toolkit (Linux Fedora 10)
linux-f10-pango-1.28.3_1       Pango library (Linux Fedora 10)
linux-f10-png-1.2.37_2         RPM of the PNG lib (Linux Fedora 10)
linux-f10-sqlite3-3.5.9_2      Library that implements an embeddable SQL database engine (Linux Fedora 10)
linux-f10-tiff-3.8.2           TIFF library, Linux/i386 binary (Linux Fedora 10)
linux-f10-xorg-libs-7.4_1      Xorg libraries (Linux Fedora 10)
linux_base-f10-10_9            Base set of packages needed in Linux mode for i386/amd64 (Linux Fedora 10)
root@bsd103:~ # pkg info | grep nsplugin
nspluginwrapper-1.4.4_4        Compatibility plugin for Mozilla NPAPI plugins
root@bsd103:~ #

удаляем ранее установленные:
root@bsd103:~ # pkg delete -y nspluginwrapper
Updating database digests format: 100%
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
        nspluginwrapper-1.4.4_4
[1/1] Deinstalling nspluginwrapper-1.4.4_4...
[1/1] Deleting files for nspluginwrapper-1.4.4_4: 100%
root@bsd103:~ #
root@bsd103:~ # pkg delete -y linux-f10-flashplugin
Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
        linux-f10-flashplugin-11.2r202.559

The operation will free 17 MiB.
[1/1] Deinstalling linux-f10-flashplugin-11.2r202.559...
[1/1] Deleting files for linux-f10-flashplugin-11.2r202.559: 100%
root@bsd103:~ #

порты от установлены вместе с 10.3R:

root@bsd103:~ # cat /usr/ports/www/linux-f10-flashplugin11/Makefile
# Created by: Naoki Tsurutani
# $FreeBSD: tags/RELEASE_10_3_0/www/linux-f10-flashplugin11/Makefile 409078 2016-02-18 00:13:34Z des $

DISTFILES:=     install_flash_player_11_linux.i386.tar.gz:plugin
USE_LINUX=              f10
ALSA_RUN_DEPENDS=       linux-${USE_LINUX}-alsa-lib>=1.0.21_5:${PORTSDIR}/audio/linux-f10-alsa-lib
USE_LINUX_APPS=         curl cyrus-sasl2 gtk2 libssh2 nspr nss openldap
MASTERDIR=              ${.CURDIR}/../linux-c6-flashplugin11
LINUX_RPM_ARCH=         i686

.include "${MASTERDIR}/Makefile"
root@bsd103:~ #

ставим:
root@bsd103:~ # make -C /usr/ports/www/linux-f10-flashplugin11 install
===>  Found saved configuration for linux-f10-flashplugin-11.2r202.559
===>   linux-f10-flashplugin-11.2r202.559 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by linux-f10-flashplugin-11.2r202.559 for building
===>  Extracting for linux-f10-flashplugin-11.2r202.559
=> SHA256 Checksum OK for flashplugin/11.2r202.559/install_flash_player_11_linux.i386.tar.gz.
=> SHA256 Checksum OK for flashplugin/11.2r202.559/linux-f10-flashsupport-9.0.1.i386.tar.gz.
===>  Patching for linux-f10-flashplugin-11.2r202.559
===>   linux-f10-flashplugin-11.2r202.559 depends on executable: update-desktop-database - found
===>  Configuring for linux-f10-flashplugin-11.2r202.559
===>  Staging for linux-f10-flashplugin-11.2r202.559
===>   linux-f10-flashplugin-11.2r202.559 depends on executable: update-desktop-database - found
===>   linux-f10-flashplugin-11.2r202.559 depends on file: /compat/linux/bin/sh - found
===>   linux-f10-flashplugin-11.2r202.559 depends on file: /compat/linux/usr/lib/libatk-1.0.so.0.2409.1 - found
...
...
...
===>  Installing for linux-f10-flashplugin-11.2r202.559
===>  Checking if linux-f10-flashplugin already installed
===>   Registering installation for linux-f10-flashplugin-11.2r202.559
Installing linux-f10-flashplugin-11.2r202.559...
If this is your first time installing flash each user must run:

        nspluginwrapper -v -a -i

If you are updating flash each user must run:

        nspluginwrapper -v -a -u

===> SECURITY REPORT:
      This port has installed the following files which may act as network
      servers and may therefore pose a remote security risk to the system.
/usr/local/lib/browser_plugins/linux-f10-flashplugin/libflashplayer.so

      If there are vulnerabilities in these programs there may be a security
      risk to the system. FreeBSD makes no guarantee about the security of
      ports included in the Ports Collection. Please type 'make deinstall'
      to deinstall the port if this is a concern.

      For more information, and contact details about the security
      status of this software, see the following webpage:
http://www.adobe.com/
root@bsd103:~ #
root@bsd103:~ # pkg info | grep linux-f10-flashplugin
linux-f10-flashplugin-11.2r202.559 Adobe Flash Player NPAPI Plugin
root@bsd103:~ #


Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

34. "Ошибки при компиляции пакета linux-f10-flashplugin11"  –1 +/
Сообщение от qqq email(??) on 26-Апр-16, 19:50 
>[оверквотинг удален]
> is a concern.
>       For more information, and contact details
> about the security
>       status of this software, see the
> following webpage:
> http://www.adobe.com/
> root@bsd103:~ #
> root@bsd103:~ # pkg info | grep linux-f10-flashplugin
> linux-f10-flashplugin-11.2r202.559 Adobe Flash Player NPAPI Plugin
> root@bsd103:~ #

Я понял почему у меня этот порт не компилится так как не может скачать install_flash_player_11_linux.i386.tar.gz
Я его скачал разархивировал файлы из него положил по директориям но это не помогает

Ответить | Правка | ^ к родителю #33 | Наверх | Cообщить модератору

35. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 26-Апр-16, 20:17 
>[оверквотинг удален]
>> following webpage:
>> http://www.adobe.com/
>> root@bsd103:~ #
>> root@bsd103:~ # pkg info | grep linux-f10-flashplugin
>> linux-f10-flashplugin-11.2r202.559 Adobe Flash Player NPAPI Plugin
>> root@bsd103:~ #
> Я понял почему у меня этот порт не компилится так как не
> может скачать install_flash_player_11_linux.i386.tar.gz
> Я его скачал разархивировал файлы из него положил по директориям но это
> не помогает

Мне не понятно что Вы делаете, а телепатировать я пока не научился...

Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

36. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 20:24 
>[оверквотинг удален]
>>> http://www.adobe.com/
>>> root@bsd103:~ #
>>> root@bsd103:~ # pkg info | grep linux-f10-flashplugin
>>> linux-f10-flashplugin-11.2r202.559 Adobe Flash Player NPAPI Plugin
>>> root@bsd103:~ #
>> Я понял почему у меня этот порт не компилится так как не
>> может скачать install_flash_player_11_linux.i386.tar.gz
>> Я его скачал разархивировал файлы из него положил по директориям но это
>> не помогает
> Мне не понятно что Вы делаете, а телепатировать я пока не научился...

При компиляции linux-f10-flashplugin11 с опцией make DISABLE_VULNERABILITIES=yes выскакивает
что ему нужен пакет linux-f10-flashplugin-11.2r202.559 и он его не может скачать.
Я скачал его открыл но это не помогло.
Ладно хрен  с ним видимо я где то напартачил.
Я больше не могу злоупотреблять вашим временем.
Поставлю линуху

Ответить | Правка | ^ к родителю #35 | Наверх | Cообщить модератору

37. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 26-Апр-16, 21:00 
> что ему нужен пакет linux-f10-flashplugin-11.2r202.559 и он его не может скачать.
> Я скачал его открыл но это не помогло.
> Ладно хрен  с ним видимо я где то напартачил.
> Я больше не могу злоупотреблять вашим временем.
> Поставлю линуху

хозяин-барин

На будующее, научитесь показывать логи того что Вы делаете и решать проблемы
будет проще, "на пальцах" - Вам никто разбираться ситуацию не будет.

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

38. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 21:12 
>> что ему нужен пакет linux-f10-flashplugin-11.2r202.559 и он его не может скачать.
>> Я скачал его открыл но это не помогло.
>> Ладно хрен  с ним видимо я где то напартачил.
>> Я больше не могу злоупотреблять вашим временем.
>> Поставлю линуху
> хозяин-барин
> На будующее, научитесь показывать логи того что Вы делаете и решать проблемы
> будет проще, "на пальцах" - Вам никто разбираться ситуацию не будет.

логи чего?
Я показал все логи которые у меня есть. Ошибка из за того что нет файла.
===>  Found saved configuration for linux-f10-flashplugin-11.2r202.491
===>   linux-f10-flashplugin-11.2r202.491 depends on file: /usr/local/sbin/pkg - found
=> install_flash_player_11_linux.i386.tar.gz doesn't seem to exist in /usr/ports/distfiles/flashplugin/11.2r202.491.
=> Attempting to fetch http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.20...
fetch: http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.20...: Not Found
=> Attempting to fetch http://distcache.FreeBSD.org/ports-distfiles/flashplugin/11....
fetch: http://distcache.FreeBSD.org/ports-distfiles/flashplugin/11....: Not Found
=> Couldn't fetch it - please try to retrieve this
=> port manually into /usr/ports/distfiles/flashplugin/11.2r202.491 and try again.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/www/linux-f10-flashplugin11
*** Error code 1

Stop.
make: stopped in /usr/ports/www/linux-f10-flashplugin11
Я скачал gz распакавал но это не помогает! Что мне дальше делвть?

Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

39. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 26-Апр-16, 21:23 
>[оверквотинг удален]
> Not Found
> => Couldn't fetch it - please try to retrieve this
> => port manually into /usr/ports/distfiles/flashplugin/11.2r202.491 and try again.
> *** Error code 1
> Stop.
> make[1]: stopped in /usr/ports/www/linux-f10-flashplugin11
> *** Error code 1
> Stop.
> make: stopped in /usr/ports/www/linux-f10-flashplugin11
> Я скачал gz распакавал но это не помогает! Что мне дальше делвть?

# ls -la /usr/ports/www/linux-f10-flashplugin11
# ls -laR /usr/ports/distfiles/flashplugin/
# uname -rm
# grep tag /usr/ports/Makefile
# ls -la /usr/ports/ | egrep '( CHAN| UPD)'
# cat /etc/make.conf
# cat /etc/sysctl.conf

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

40. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Сергей (??) on 26-Апр-16, 23:10 
>>[оверквотинг удален]
> что ему нужен пакет linux-f10-flashplugin-11.2r202.559 и он его не может скачать.
> Я скачал его открыл но это не помогло.

Зачем распаковывать то, просто положить в /usr/ports/distfiles религия не позволяет...
> Ладно хрен  с ним видимо я где то напартачил.
> Я больше не могу злоупотреблять вашим временем.
> Поставлю линуху

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

41. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 23:18 
>>>[оверквотинг удален]
>> что ему нужен пакет linux-f10-flashplugin-11.2r202.559 и он его не может скачать.
>> Я скачал его открыл но это не помогло.
>  Зачем распаковывать то, просто положить в /usr/ports/distfiles религия не позволяет...
>> Ладно хрен  с ним видимо я где то напартачил.
>> Я больше не могу злоупотреблять вашим временем.
>> Поставлю линуху

Клал это не помогло.

Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

44. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Аноним (??) on 28-Апр-16, 03:16 
> Клал это не помогло.

поправочка
нужно "класть" не просто в /usr/ports/distfiles/ а конкретно в /usr/ports/distfiles/flashplugin/11.2r202.491/

ведь сказано же install_flash_player_11_linux.i386.tar.gz doesn't seem to exist in /usr/ports/distfiles/flashplugin/11.2r202.491

перевожу ))

install_flash_player_11_linux.i386.tar.gz кажется не существует в /usr/ports/distfiles/flashplugin/11.2r202.491

вы главное не сдавайтесь, дорогу осилит идущий
нам всем очень интересно, чем закончится эта великая эпопея

да кто сильнее? вы или какой-то там гр*баный флешь?

Ответить | Правка | ^ к родителю #41 | Наверх | Cообщить модератору

45. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 28-Апр-16, 07:58 
>> Клал это не помогло.
> поправочка
> нужно "класть" не просто в /usr/ports/distfiles/ а конкретно в /usr/ports/distfiles/flashplugin/11.2r202.491/
> ведь сказано же install_flash_player_11_linux.i386.tar.gz doesn't seem to exist in /usr/ports/distfiles/flashplugin/11.2r202.491
> перевожу ))
> install_flash_player_11_linux.i386.tar.gz кажется не существует в /usr/ports/distfiles/flashplugin/11.2r202.491
> вы главное не сдавайтесь, дорогу осилит идущий
> нам всем очень интересно, чем закончится эта великая эпопея
> да кто сильнее? вы или какой-то там гр*баный флешь?

Я клал его и туда туда но все при постройки порта программа пытается его скачать.
Как запретить ей это файл скачать? И как это файл установить? Ведь на сколько я понимаю это исходное который тоже нужно собирать. Хотя внутри там нет make. Помогите. Спасите. Ради Христа очень нужно

Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

46. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Аноним (??) on 28-Апр-16, 08:02 
тогда приведите вывод команд из поста 39 лавра
Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

47. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 28-Апр-16, 08:20 
> тогда приведите вывод команд из поста 39 лавра

Так как под тяжестью моих экспериментов система рухнула вчера!
То сегодня буду ее заново ставить. И тогда буду уже экспериментировать снова.

Ответить | Правка | ^ к родителю #46 | Наверх | Cообщить модератору

48. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 28-Апр-16, 08:53 
>> тогда приведите вывод команд из поста 39 лавра
> Так как под тяжестью моих экспериментов система рухнула вчера!
> То сегодня буду ее заново ставить. И тогда буду уже экспериментировать снова.

Я затратил около часа на своем дохлом десктопе на:

- установку свежей системы в VirtualBox
- установку и настройку Xorg из пакетов
- установку firefox из пакетов

- установка плагина с текущим linux_base == linux-c6 не требует ну
никаких дополнительных телодвижений:

# make -C /usr/ports/www/linux-c6-flashplugin11 install BATCH=yes

собственно все ставиться из коробки кроме flash плагина, nspluginwrapper тоже
ставится из пакетов и вытягивает все зависимости для linuxolator'а, после чего
остается установить лишь флеш плагин из портов.

ps. Как нужно экспериментировать, чтобы убить систему на пустом месте, ума
не приложу.

Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

49. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Сергей (??) on 28-Апр-16, 10:16 
>> тогда приведите вывод команд из поста 39 лавра
> Так как под тяжестью моих экспериментов система рухнула вчера!
> То сегодня буду ее заново ставить. И тогда буду уже экспериментировать снова.

Ну вот и добрая весть появилась... Если вам потребуется помощь, то вы немножко более полно расскажите что делали и что ставили. А то я у меня к примеру даже после всех экспериментов система была живая...


Ответить | Правка | ^ к родителю #47 | Наверх | Cообщить модератору

50. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 28-Апр-16, 10:27 
>>> тогда приведите вывод команд из поста 39 лавра
>> Так как под тяжестью моих экспериментов система рухнула вчера!
>> То сегодня буду ее заново ставить. И тогда буду уже экспериментировать снова.
>  Ну вот и добрая весть появилась... Если вам потребуется помощь, то
> вы немножко более полно расскажите что делали и что ставили. А
> то я у меня к примеру даже после всех экспериментов система
> была живая...

ТАк как офиицального руководства по установке флеша я не  нашел
то устанавливаю прямо вот по этому руководству.
http://i-notes.org/ustanavlivaem-adobe-flash-player-dlya-ope.../
В данный момент на 10 часов 24 минуты после установки
freebsd 10.2 учсстановки хоrg, xfce и firefox нахожусь на этапе установки
linux_base-f10

Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

51. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 28-Апр-16, 10:52 
>>>> тогда приведите вывод команд из поста 39 лавра
>>> Так как под тяжестью моих экспериментов система рухнула вчера!
>>> То сегодня буду ее заново ставить. И тогда буду уже экспериментировать снова.
>>  Ну вот и добрая весть появилась... Если вам потребуется помощь, то
>> вы немножко более полно расскажите что делали и что ставили. А
>> то я у меня к примеру даже после всех экспериментов система
>> была живая...
> ТАк как офиицального руководства по установке флеша я не  нашел
> то устанавливаю прямо вот по этому руководству.
> http://i-notes.org/ustanavlivaem-adobe-flash-player-dlya-ope.../

мб тогда нужно установить FreeBSD 8.2R ?

> В данный момент на 10 часов 24 минуты после установки
> freebsd 10.2 учсстановки хоrg, xfce и firefox нахожусь на этапе установки
> linux_base-f10

https://www.freebsd.org/doc/en/books/handbook/desktop-browse...
https://www.freebsd.org/doc/en/books/handbook/linuxemu-lbc-i...

для свежих 10.2/3 ничего в /etc/sysctl.conf прописывать не нужно.

Вам какая инструкция нужна? По установке пакетов, портов?
Их более 20000, было бы глупо писать инструкции даже к одной десятой этого
количества, да и не нужны они, есть инструкции в самих ПО.

http://www.freshports.org/www/linux-c6-flashplugin11
http://daemon-notes.com/articles/desktop/firefox
http://www.bsdportal.ru/viewtopic.php?f=58&t=27488

инструкция по установке bash, инструкция по установке mc, инструкция по
установке и настройке Xorg, firefox, затем инструкции по их использованию...

Прям с детского сада можно изучать Unix по таким инструкциям, даже
школа не нужна, про институт даже не заикаюсь :)

Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

52. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 28-Апр-16, 11:00 
>[оверквотинг удален]
> Их более 20000, было бы глупо писать инструкции даже к одной десятой
> этого
> количества, да и не нужны они, есть инструкции в самих ПО.
> http://www.freshports.org/www/linux-c6-flashplugin11
> http://daemon-notes.com/articles/desktop/firefox
> http://www.bsdportal.ru/viewtopic.php?f=58&t=27488
> инструкция по установке bash, инструкция по установке mc, инструкция по
> установке и настройке Xorg, firefox, затем инструкции по их использованию...
>  Прям с детского сада можно изучать Unix по таким инструкциям, даже
> школа не нужна, про институт даже не заикаюсь :)

Я положил пакет install_flash_player_11_linux.i386.tar.gz в /usr/ports/distfiles/flashplugin/11.2r202.491
Но это не дает ни какого результата.
Он все равно его пытается скачать. Как make запретить скачивать?
После того как make вылетает с ошибкой то в директоррии
/usr/ports/distfiles/flashplugin/11.2r202.491 появляется вот этот файл.
linux-f10-flashsupport-9.0.1.i386.tar.gz
Как системе запретить удалять нужный файл?

Ответить | Правка | ^ к родителю #51 | Наверх | Cообщить модератору

54. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 28-Апр-16, 12:10 
>[оверквотинг удален]
>> установке и настройке Xorg, firefox, затем инструкции по их использованию...
>>  Прям с детского сада можно изучать Unix по таким инструкциям, даже
>> школа не нужна, про институт даже не заикаюсь :)
> Я положил пакет install_flash_player_11_linux.i386.tar.gz в /usr/ports/distfiles/flashplugin/11.2r202.491
> Но это не дает ни какого результата.
> Он все равно его пытается скачать. Как make запретить скачивать?
> После того как make вылетает с ошибкой то в директоррии
> /usr/ports/distfiles/flashplugin/11.2r202.491 появляется вот этот файл.
> linux-f10-flashsupport-9.0.1.i386.tar.gz
> Как системе запретить удалять нужный файл?

дохтур, у мине эта...

Телепатов нема.

Откуда у Вас дерево портов?
какой в конце концов порт Вы ставите?
И что у Вас для данного порта в:
# cat distinfo.*

Sorry, на пальцах, продолжения не будет:

чисто ради понимания на примере устаревшего linux_base-f10:

# make fetch - стянуть то что в distinfo в хранилище /usr/ports/distfiles

root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # make fetch DISABLE_VULNERABILITIES=yes
===>  Found saved configuration for linux-f10-flashplugin-11.2r202.559
===>   linux-f10-flashplugin-11.2r202.559 depends on file: /usr/local/sbin/pkg - found
=> install_flash_player_11_linux.i386.tar.gz doesn't seem to exist in /usr/ports/distfiles/flashplugin/11.2r202.559.
=> Attempting to fetch http://fpdownload.macromedia.com/get/flashplayer/pdc/11.2.20...
install_flash_player_11_linux.i386.tar.gz     100% of 6802 kB 2774 kBps 00m03s
=> linux-f10-flashsupport-9.0.1.i386.tar.gz doesn't seem to exist in /usr/ports/distfiles/flashplugin/11.2r202.559.
=> Attempting to fetch http://distcache.FreeBSD.org/local-distfiles/nox/linux-f10-f...
linux-f10-flashsupport-9.0.1.i386.tar.gz      100% of 3455  B 2219 kBps 00m00s
===> Fetching all distfiles required by linux-f10-flashplugin-11.2r202.559 for building
root@bsd103:/usr/ports/www/linux-f10-flashplugin11 #

из верхнего видно что содержимое distinfo скачивается в хранилище /usr/ports/distfiles,
конкретно в:

"doesn't seem to exist in /usr/ports/distfiles/flashplugin/11.2r202.559"

root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # ls -la /usr/ports/distfiles/flashplugin/
total 12
drwxr-xr-x  3 root  wheel  512 Apr 28 11:52 .
drwxr-xr-x  4 root  wheel  512 Apr 28 11:52 ..
drwxr-xr-x  2 root  wheel  512 Apr 28 11:52 11.2r202.559
root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # ls -la /usr/ports/distfiles/flashplugin/11.2r202.559/
total 6860
drwxr-xr-x  2 root  wheel      512 Apr 28 11:52 .
drwxr-xr-x  3 root  wheel      512 Apr 28 11:52 ..
-rw-r--r--  1 root  wheel  6965297 Dec 24 09:07 install_flash_player_11_linux.i386.tar.gz
-rw-r--r--  1 root  wheel     3455 Jun 26  2009 linux-f10-flashsupport-9.0.1.i386.tar.gz
root@bsd103:/usr/ports/www/linux-f10-flashplugin11 #

# make extract - разворачивает sources в рабочую директорию work

root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # ls -la
total 72
drwxr-xr-x     2 root  wheel    512 Apr 28 11:51 .
drwxr-xr-x  2395 root  wheel  64000 Mar 25 04:12 ..
-rw-r--r--     1 root  wheel    474 Mar 25 04:11 Makefile
root@bsd103:/usr/ports/www/linux-f10-flashplugin11 #

distinfo отсутствует, смотрим Makefile

root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # less Makefile
# Created by: Naoki Tsurutani
# $FreeBSD: tags/RELEASE_10_3_0/www/linux-f10-flashplugin11/Makefile 409078 2016-02-18 00:13:34Z des $

DISTFILES:=     install_flash_player_11_linux.i386.tar.gz:plugin
USE_LINUX=              f10
ALSA_RUN_DEPENDS=       linux-${USE_LINUX}-alsa-lib>=1.0.21_5:${PORTSDIR}/audio/linux-f10-alsa-lib
USE_LINUX_APPS=         curl cyrus-sasl2 gtk2 libssh2 nspr nss openldap
MASTERDIR=              ${.CURDIR}/../linux-c6-flashplugin11
LINUX_RPM_ARCH=         i686

.include "${MASTERDIR}/Makefile"

видим что этот порт использует в реалии:
MASTERDIR=              ${.CURDIR}/../linux-c6-flashplugin11
...
-> .include "${MASTERDIR}/Makefile"

смотрим distinfo

root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # ls -la ../linux-c6-flashplugin11/dist*
-rw-r--r--  1 root  wheel  449 Mar 25 04:11 ../linux-c6-flashplugin11/distinfo.i686
-rw-r--r--  1 root  wheel  453 Mar 25 04:11 ../linux-c6-flashplugin11/distinfo.x86_64
root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # grep SIZE ../linux-c6-flashplugin11/dist*
../linux-c6-flashplugin11/distinfo.i686:SIZE (flashplugin/11.2r202.559/install_flash_player_11_linux.i386.tar.gz) = 6965297
../linux-c6-flashplugin11/distinfo.i686:SIZE (flashplugin/11.2r202.559/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 3455
../linux-c6-flashplugin11/distinfo.x86_64:SIZE (flashplugin/11.2r202.559/install_flash_player_11_linux.x86_64.tar.gz) = 7275447
../linux-c6-flashplugin11/distinfo.x86_64:SIZE (flashplugin/11.2r202.559/linux-f10-flashsupport-9.0.1.i386.tar.gz) = 3455
root@bsd103:/usr/ports/www/linux-f10-flashplugin11 #

порт скачивает в /usr/ports/distfiles в flashplugin/11.2r202.559
размером install_flash_player_11_linux.i386.tar.gz = 6965297
размером linux-f10-flashsupport-9.0.1.i386.tar.gz = 3455

- make checksum (проверяем не подсунули ли нам кота в мешке)

root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # make checksum DISABLE_VULNERABILITIES=yes
===>  Found saved configuration for linux-f10-flashplugin-11.2r202.559
===>   linux-f10-flashplugin-11.2r202.559 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by linux-f10-flashplugin-11.2r202.559 for building
=> SHA256 Checksum OK for flashplugin/11.2r202.559/install_flash_player_11_linux.i386.tar.gz.
=> SHA256 Checksum OK for flashplugin/11.2r202.559/linux-f10-flashsupport-9.0.1.i386.tar.gz.
root@bsd103:/usr/ports/www/linux-f10-flashplugin11 #

- make extract - разворачиваем

root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # make extract DISABLE_VULNERABILITIES=yes
===>  Found saved configuration for linux-f10-flashplugin-11.2r202.559
===>   linux-f10-flashplugin-11.2r202.559 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by linux-f10-flashplugin-11.2r202.559 for building
===>  Extracting for linux-f10-flashplugin-11.2r202.559
=> SHA256 Checksum OK for flashplugin/11.2r202.559/install_flash_player_11_linux.i386.tar.gz.
=> SHA256 Checksum OK for flashplugin/11.2r202.559/linux-f10-flashsupport-9.0.1.i386.tar.gz.
root@bsd103:/usr/ports/www/linux-f10-flashplugin11 #

root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # ls -la
total 76
drwxr-xr-x     3 root  wheel    512 Apr 28 12:08 .
drwxr-xr-x  2395 root  wheel  64000 Mar 25 04:12 ..
-rw-r--r--     1 root  wheel    474 Mar 25 04:11 Makefile
drwxr-xr-x     3 root  wheel    512 Apr 28 12:08 work
root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # ls -la work/
total 12
drwxr-xr-x  3 root  wheel  512 Apr 28 12:08 .
drwxr-xr-x  3 root  wheel  512 Apr 28 12:08 ..
-rw-r--r--  1 root  wheel    0 Apr 28 12:08 .extract_done.flashplugin._usr_local
drwxr-xr-x  4 root  wheel  512 Apr 28 12:08 linux-f10-flashplugin-11.2r202.559
root@bsd103:/usr/ports/www/linux-f10-flashplugin11 #

далее устанавливаем:

root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # make install DISABLE_VULNERABILITIES=yes

Ответить | Правка | ^ к родителю #52 | Наверх | Cообщить модератору

55. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 28-Апр-16, 12:25 
>[оверквотинг удален]
> root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # ls -la work/
> total 12
> drwxr-xr-x  3 root  wheel  512 Apr 28 12:08 .
> drwxr-xr-x  3 root  wheel  512 Apr 28 12:08 ..
> -rw-r--r--  1 root  wheel    0 Apr 28
> 12:08 .extract_done.flashplugin._usr_local
> drwxr-xr-x  4 root  wheel  512 Apr 28 12:08 linux-f10-flashplugin-11.2r202.559
> root@bsd103:/usr/ports/www/linux-f10-flashplugin11 #
> далее устанавливаем:
> root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # make install DISABLE_VULNERABILITIES=yes

Объясняю для непонятливых еще раз
Ставлю порт из /usr/ports/www/linux-f10-flashplugin11
Перехожу в директорию /usr/ports/www/linux-f10-flashplugin11
Даю там команду make. Получаю что нужно make запускать вот так
make extract DISABLE_VULNERABILITIES=yes
в итоге получаю что он не может скачать так как не находит /install_flash_player_11_linux.i386.tar.gz
Я этот файл скачал и положил в /usr/ports/distfiles/flashplugin/11.2r202.491
и /usr/ports/distfiles/flashplugin
И все равно система этот файл удаляет и пытается скачать. Что я делаю не так?

Ответить | Правка | ^ к родителю #54 | Наверх | Cообщить модератору

56. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от lavr email(ok) on 28-Апр-16, 12:55 
>[оверквотинг удален]
>> root@bsd103:/usr/ports/www/linux-f10-flashplugin11 # make install DISABLE_VULNERABILITIES=yes
> Объясняю для непонятливых еще раз
> Ставлю порт из /usr/ports/www/linux-f10-flashplugin11
> Перехожу в директорию /usr/ports/www/linux-f10-flashplugin11
> Даю там команду make. Получаю что нужно make запускать вот так
> make extract DISABLE_VULNERABILITIES=yes
> в итоге получаю что он не может скачать так как не находит
> /install_flash_player_11_linux.i386.tar.gz
> Я этот файл скачал и положил в /usr/ports/distfiles/flashplugin/11.2r202.491
> и /usr/ports/distfiles/flashplugin

Вам все расписано и разжевано, с примерами и объяснением,
и если Вы "понятливый" должны были сделать все еще вчера,
если НЕ понимаете, должны были привести вывод того что было указано

> И все равно система этот файл удаляет и пытается скачать. Что я
> делаю не так?

Это к Кашпировскому, или логи в студию.

Ответить | Правка | ^ к родителю #55 | Наверх | Cообщить модератору

53. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 28-Апр-16, 11:16 
>[оверквотинг удален]
> Их более 20000, было бы глупо писать инструкции даже к одной десятой
> этого
> количества, да и не нужны они, есть инструкции в самих ПО.
> http://www.freshports.org/www/linux-c6-flashplugin11
> http://daemon-notes.com/articles/desktop/firefox
> http://www.bsdportal.ru/viewtopic.php?f=58&t=27488
> инструкция по установке bash, инструкция по установке mc, инструкция по
> установке и настройке Xorg, firefox, затем инструкции по их использованию...
>  Прям с детского сада можно изучать Unix по таким инструкциям, даже
> школа не нужна, про институт даже не заикаюсь :)

Ну не компилится у меня этот порт!
Можно ли как то обойти эту ошибку

Ответить | Правка | ^ к родителю #51 | Наверх | Cообщить модератору

13. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Аноним (??) on 26-Апр-16, 08:39 
>[оверквотинг удален]
> его диск. Или на виртуалке запускать.
> Вообщем для экспериментов остается все меньше времени и нужно ставить в продакшин
> сервер.
> Была идея очень простая! Поставить фрибсд ее использовать в качестве сервера и
> на нем поднять X в иксах ставить virtualbox и в нем
> уже крутить виртуалки!
> Ну вообщем прихожу к мысли что сервер это сервер а десктоп это
> десктоп. И скрещивать их не стоит! Сервер работал более 5 лет
> на фрибсд не скрещеный с десктопом пусть и работает.
> А десктоп на фрибсд это издевательство

прямые руки, интеловское железо, исошник (на рутрекере в разделе хакинтош) и будет замечательное яблочко на побаловаться ;)
а эксперементы устраивать в цейтноте категорически не советую,
лучше ставить проверенное и знакомое - сбережёте время и нервы и себе, и окружающим

мысли про сервер и десктоп поддерживаю
серверу - серверово и не надо пихать в него что попало :)

а вот насчет десктопа на фри не согласен - ты просто не умеешь его готовить

не сдавайся, а то, ну поставишь ты linux и что?
у соседа слева, справа тоже linux, а сверху и снизу так и вообще, страшно сказать, windows 10
ну чем ты отличаться будешь? такой же как и все "чоткий пацанчик у себя на раёне"

а прикинь, ты так небрежно, как бы между прочим, говоришь - а у мну BSD! и ниип*т!

это как в бородатом анекдоте про нового русского, барабан и Страдивари, ну ты понял, да?

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

15. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 09:00 
>[оверквотинг удален]
> умеешь его готовить
> не сдавайся, а то, ну поставишь ты linux и что?
> у соседа слева, справа тоже linux, а сверху и снизу так и
> вообще, страшно сказать, windows 10
> ну чем ты отличаться будешь? такой же как и все "чоткий пацанчик
> у себя на раёне"
> а прикинь, ты так небрежно, как бы между прочим, говоришь - а
> у мну BSD! и ниип*т!
> это как в бородатом анекдоте про нового русского, барабан и Страдивари, ну
> ты понял, да?

Так мысль про то что сервер на freebsd в аптайме около 5 лет и дала надежду что десктоп столько же будет работать.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

25. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Сергей (??) on 26-Апр-16, 13:08 
>[оверквотинг удален]
>> у соседа слева, справа тоже linux, а сверху и снизу так и
>> вообще, страшно сказать, windows 10
>> ну чем ты отличаться будешь? такой же как и все "чоткий пацанчик
>> у себя на раёне"
>> а прикинь, ты так небрежно, как бы между прочим, говоришь - а
>> у мну BSD! и ниип*т!
>> это как в бородатом анекдоте про нового русского, барабан и Страдивари, ну
>> ты понял, да?
> Так мысль про то что сервер на freebsd в аптайме около 5
> лет и дала надежду что десктоп столько же будет работать.

Вам флеш в файерфоксе нужен?

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

26. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от qqq email(??) on 26-Апр-16, 13:11 
>[оверквотинг удален]
>>> вообще, страшно сказать, windows 10
>>> ну чем ты отличаться будешь? такой же как и все "чоткий пацанчик
>>> у себя на раёне"
>>> а прикинь, ты так небрежно, как бы между прочим, говоришь - а
>>> у мну BSD! и ниип*т!
>>> это как в бородатом анекдоте про нового русского, барабан и Страдивари, ну
>>> ты понял, да?
>> Так мысль про то что сервер на freebsd в аптайме около 5
>> лет и дала надежду что десктоп столько же будет работать.
>  Вам флеш в файерфоксе нужен?

Для начала да

Ответить | Правка | ^ к родителю #25 | Наверх | Cообщить модератору

27. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Сергей (??) on 26-Апр-16, 13:26 
>[оверквотинг удален]
>>>> ну чем ты отличаться будешь? такой же как и все "чоткий пацанчик
>>>> у себя на раёне"
>>>> а прикинь, ты так небрежно, как бы между прочим, говоришь - а
>>>> у мну BSD! и ниип*т!
>>>> это как в бородатом анекдоте про нового русского, барабан и Страдивари, ну
>>>> ты понял, да?
>>> Так мысль про то что сервер на freebsd в аптайме около 5
>>> лет и дала надежду что десктоп столько же будет работать.
>>  Вам флеш в файерфоксе нужен?
> Для начала да

Странно все это, у меня на 10.2 linux-f10-flashplugin11 ставится и без вопросов...
Сейчас попробую обновить порты, хотя они 2-х недельной давности...

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

28. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Сергей (??) on 26-Апр-16, 13:30 
>  Странно все это, у меня на 10.2 linux-f10-flashplugin11 ставится и без
> вопросов...
>  Сейчас попробую обновить порты, хотя они 2-х недельной давности...

Обновил и все без проблем, линуксатор то какой стоит?


Ответить | Правка | ^ к родителю #27 | Наверх | Cообщить модератору

29. "Ошибки при компиляции пакета linux-f10-flashplugin11"  –1 +/
Сообщение от qqq email(??) on 26-Апр-16, 13:42 
>>  Странно все это, у меня на 10.2 linux-f10-flashplugin11 ставится и без
>> вопросов...
>>  Сейчас попробую обновить порты, хотя они 2-х недельной давности...
>  Обновил и все без проблем, линуксатор то какой стоит?

Если под линуксатором понимается эмулятор то вот этот  linux_base-f10
Правда ставился пакетом! То есть с помощью pkg install.
В rc.conf имеется строчка linux_enable="YES"
А все таки можно ли этот мой злополучный порт поставить пакетом?

Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

30. "Ошибки при компиляции пакета linux-f10-flashplugin11"  +/
Сообщение от Сергей (??) on 26-Апр-16, 13:58 
>>>  Странно все это, у меня на 10.2 linux-f10-flashplugin11 ставится и без
>>> вопросов...
>>>  Сейчас попробую обновить порты, хотя они 2-х недельной давности...
>>  Обновил и все без проблем, линуксатор то какой стоит?
> Если под линуксатором понимается эмулятор то вот этот  linux_base-f10
> Правда ставился пакетом! То есть с помощью pkg install.
> В rc.conf имеется строчка linux_enable="YES"
> А все таки можно ли этот мой злополучный порт поставить пакетом?

Насколько я помню его в репозитариях никогда не было, может у вас что-то с системой?

Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру