The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Проект Qt объявил о смене лицензии и изменении соглашения с KDE

13.01.2016 21:25

Ларс Кнолл (Lars Knoll), создатель движка KHTML, руководитель проекта Qt Project и директор по развитию фреймворка Qt в компании Digia, анонсировал серию важных изменений в лицензировании Qt. Отныне Qt, кроме коммерческой лицензии, будет поставляться только под лицензиями LGPLv3 и GPLv2, вместо ранее предлагаемых LGPLv2.1, LGPLv3 и GPLv2. Инструменты и приложения Qt для разработчиков, такие как Qt Creator и qmake, будут поставляться под лицензией GPLv3. Таким образом, теперь все компоненты Qt доступны под лицензиями, совместимыми с GPLv3 при сохранении совместимости Qt с GPLv2. Изменение вступит в силу начиная с релиза Qt 5.7.

В отличие от LGPLv2.1, LGPLv3 предоставляет защиту от патентных претензий при поставке продуктов под данной лицензией и обеспечивает защиту от тивоизации. С практической стороны, прекращение поставки под LGPLv2.1 ограничит разработчиков, связывающих Qt с проприетарными продуктами, которые должны будут отказаться от привязки прошивок к устройствам или воспользоваться вариантом Qt под GPLv2, но в этом случае обязаны открыть код связываемых с Qt компонентов, либо воспользоваться коммерческой версией Qt

Вторым важным изменением является открытие исходных текстов ряда дополнений, которые ранее поставлялись только под коммерческой лицензией:

Коммерческие дополнения будут открыты под лицензией GPLv3, что связано с необходимостью использования внешних зависимостей под лицензией Apache. Ранее уже открытые дополнения, как и Qt, будут поставляться под LGPLv3 и GPLv2. Исключение сделано только для Qt WebEngine, который из-за использования стороннего кода от проекта Chromium будет доступен и под LGPLv2.1.

Третьим изменением является расширение соглашения с организацией KDE Free Qt Foundation, созданной для защиты сообщества от возможного изменения политики в отношении поставки Qt как свободного продукта. Заключённое в 1998 году соглашение между KDE Free Qt Foundation и Trolltech, распространяющееся на всех будущих владельцев Qt, предоставляет проекту KDE право перелицензировать код Qt под любой открытой лицензией и продолжить разработку своими силами, в случае ужесточения лицензионной политики, банкротства владельца или прекращения развития проекта.

В обновлённым варианте соглашения компания Qt Company (подразделение Digia) расширила действие документа на все редакции Qt (в том числе для продуктов Microsoft и Apple), а не только на версии для X11 и Android. Более того, соглашение теперь распространяется на весь публично опубликованный код компании Qt Company, а не только входящий в поставку Qt. Данное изменение особенно актуально в свете развития протокола Wayland.

  1. Главная ссылка к новости (https://dot.kde.org/2016/01/13...)
  2. OpenNews: Digia создаёт отдельную компанию для Qt и унифицирует свободную и коммерческую версии
  3. OpenNews: Компания Digia вошла в число основных покровителей проекта KDE
  4. OpenNews: Проект KDE обозначил свою позицию в отношении будущего Qt и указал на недопустимость форка
  5. OpenNews: Nokia переводит Qt на более открытую модель разработки
  6. OpenNews: Qt переходит на лицензию LGPLv3 вместо GPLv3, что позволит заимствовать код Qt в KDE
Лицензия: CC-BY
Тип: Интересно / К сведению
Ключевые слова: kde, qt
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (78) Ajax | 1 уровень | Линейный | Раскрыть всё | RSS
  • 1.1, A.Stahl (ok), 22:04, 13/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +32 +/
    Ну вот. Пачка хороших новостей. Даже поныть не о чем. О! Вот об этом и буду ныть: что-то у них там всё подозрительно хорошо и адекватно. Они что-то скрывают. Усыпляют бдительность!
     
     
  • 2.5, fail (?), 22:15, 13/01/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    угу,
    u 14.04, штатное Qt, вроде 5.2, QWidget::showMaximized() (save/restore geo)
    седня убито парy чacoв вpeмeни..
     
     
  • 3.34, KOT040188 (?), 05:09, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Не скажу точную версию, но точно не пятый Qt.
     
     
  • 4.76, fail (?), 14:07, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Не скажу точную версию, но точно не пятый Qt.

    пятерка, причем не из bpo,
    вот выжимка лога aппликyxи
    ...
    2016.01.13 15:57:10 [def] [INF:APP] Compiled options:
    2016.01.13 15:57:10 [def] [INF:APP] Compiled with OS: Linux 3.13.0-52-generic i686
    2016.01.13 15:57:10 [def] [INF:APP] Compiled with Qt: 5.2.1
    2016.01.13 15:57:10 [def] [INF:APP] OS detected: u14 Linux 3.13.0-74-generic i686 #118-Ubuntu SMP Thu Dec 17 22:52:02 UTC 2015
    2016.01.13 15:57:11 [def] [INF:APP] Qt detected: 5.2.1
    2016.01.13 15:57:11 [def] [INF:APP] User profile dir: def
    ...

     
     
  • 5.77, KOT040188 (?), 16:55, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Наглая ложь:
    kot@kot-MS-7930:~$ kde4-config --version
    Qt: 4.8.6
    KDE: 4.13.3
    kde4-config: 1.0
     
     
  • 6.78, clopomor (??), 17:09, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А при чём тут версия с которой _собран_ кде ?
    4.8 есть для совместимости и непереведённых на 5 проэктов ,  а так 5.2
     
     
  • 7.86, KOT040188 (?), 23:53, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Я не программист, вот тут разработчики пишут, Qt протух, им думаю виднее: http://photoqt.org/down?popup=ubuntu
    >>For Ubuntu 14.04 or earlier, some manual work is required to install PhotoQt. This is due to the fact, that Ubuntu 14.04 still ships a very old version of Qt, too old for PhotoQt to work with.
     
     
  • 8.89, fail (?), 11:18, 15/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    лучше смотреть что-то более официальное а не мнение разрабов одной аппликухи, ... текст свёрнут, показать
     
  • 2.6, Омский линуксоид (ok), 22:20, 13/01/2016 [^] [^^] [^^^] [ответить]  
  • –5 +/
    Ну... Они опасны... Trolltech же. Троллололтехнологии.
     
  • 2.7, Michael Shigorin (ok), 22:23, 13/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    :-]

    PS: и клавиатурка русский умеет, тоже хорошо...

     
  • 2.11, Роман (??), 23:09, 13/01/2016 [^] [^^] [^^^] [ответить]  
  • –6 +/
    Ох ешкин кот) Как будто лицензия чтото значит)
     
     
  • 3.13, A.Stahl (ok), 23:12, 13/01/2016 [^] [^^] [^^^] [ответить]  
  • +6 +/
    Эх, жёваный хомяк! Ещё как значит!
     
     
  • 4.14, Роман (??), 23:17, 13/01/2016 [^] [^^] [^^^] [ответить]  
  • –7 +/
    Ну бабло попилить можно конечно) я имел в виду обычный народ..
     
  • 4.25, некто никто (?), 01:25, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Жеваный крот же
    и братская щука
     
  • 4.50, Andrey Mitrofanov (?), 10:57, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >

    Расскажите подробнее! Про продажу проприертарных лицензий Qt, гарантию релиза под BSDL/MITL... Кто там нынче Хозяин и баболосополучатель, и он занят всё тем же? Меняет лицензии, юр,лица и путает следы?


     

  • 1.2, lucentcode (ok), 22:12, 13/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Хорошие новости.
     
  • 1.3, dimqua (ok), 22:13, 13/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +7 +/
    > ограничит разработчиков, связывающих Qt с проприетарными продуктами

    Отлично!

     
     
  • 2.51, Andrey Mitrofanov (?), 11:13, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> ограничит разработчиков, связывающих Qt с проприетарными продуктами
    > Отлично!

    Тивоизаторы приглашены забашлять?  Одни проприертарщики за-bait&switch-или других проприертарщиков и продвинули свободу им.Столмана [для проприертарщиков и частью их пользователей, "если поймают", как обычно] с v2.1 до v3.1?

    Санта-Барбара какая-то. Проприертарщическая. Пользователи GPLv2+ смотрят на них с удивлением. //Финансирование разработки? Не не слыхал...

     
  • 2.88, Наркоман (?), 09:07, 15/01/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Ещё один ни разу не писавший код за деньги человек.
     
     
  • 3.91, dimqua (ok), 19:11, 15/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    GPL не мешает писать код за деньги, она обязывает открывать исходники.
     

  • 1.4, AnotherAnonymous (?), 22:14, 13/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Хм, а на самих продуктах:
    ..."commercial only" (Clang static analyzer)
     
     
  • 2.10, Sinot (ok), 23:01, 13/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Изменение ВСТУПИТ в силу начиная с релиза Qt 5.7.
    > ...дополнения БУДУТ открыты под лицензией...

    Все будет, потерпите.

     

  • 1.8, Аноним (-), 22:40, 13/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Перелицензировать всё на GPLv3. Зачем такие сложности с двойным-тройным лицензированием?
     
     
  • 2.9, Аноним (-), 22:59, 13/01/2016 [^] [^^] [^^^] [ответить]  
  • –8 +/
    Иначе сложно продавать воздух.
     
     
  • 3.33, Вареник (?), 04:56, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    Ты разработай "воздух", сравнимый с Qt. По аналогии - "воздух" должен быть совместим с кучей планет с разной биосферой на протяжении нескольких геологических эпох.
     
     
  • 4.37, Аноним (-), 06:21, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    вам смешать азот и кислород? Да и вопрос совместимости мягко говоря не уместен. Воздух продают людям, а не планетам.
     
     
  • 5.79, Вареник (?), 17:36, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    А если на планете он замерзает до снегообразного состояния, а в ТЗ требование - "чтобы гуиманоиды свободно дышали"?
     
     
  • 6.83, Вареник (?), 21:38, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Qt под LGPL это прекрасно, но без коммерческого направления развитие Qt загнется, а это будет потерей для всех.
     
  • 2.35, Тот_Самый_Анонимус (?), 05:42, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >Зачем такие сложности с двойным-тройным лицензированием?

    Думают о пользователях. Не все идеализируют ГПЛ.

     
     
  • 3.54, Andrey Mitrofanov (?), 11:20, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >>Зачем такие сложности с двойным-тройным лицензированием?

    Сидят на двух стульях. Замануха для проприерасов на убо^Wдля стрижки, и "дружба" с оперсорсиком.

    > Думают о пользователях. Не все идеализируют ГПЛ.

    Думают о проприертарщиках. Стрегут купоны с нелюбви, спасибо Стив!, к GPL.

    Или ты купил проп.лицензию на Qt для своей убунточки, лишь бы не _пользоваться_ ей под GPL?? Не все ж "любят", да?  Но не настолько, чтобы не пользоваться нашару, нет?

     

  • 1.12, Аноним (-), 23:10, 13/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >LGPLv3 и GPLv2

    Таки с какой целью отсутствует GPLv3?

     
     
  • 2.16, Michael Shigorin (ok), 23:49, 13/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >>LGPLv3 и GPLv2
    > Таки с какой целью отсутствует GPLv3?

    Видимо, этих вариантов им достаточно.

     
     
  • 3.55, Andrey Mitrofanov (?), 11:29, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    >>>LGPLv3 и GPLv2
    >> Таки с какой целью отсутствует GPLv3?

    Она там есть, Вы не заметили!

    В самой LGPLv3 явно прописано двойное лицензирование и под GPLv3.

    > Видимо, этих вариантов им достаточно.

    Ай-яй-яй? :)

     
  • 2.23, Crazy Alex (ok), 00:33, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Потому что для Qt она не подходит - есть масса проприетарщины, которая использует Qt и логично, что снижать популярность тулкита они не хотят. Уже за то, что LGPLv2 выкнули - спасибо, как и на GPLv3 на тулзы.
     
  • 2.40, Аноним (-), 07:47, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >Таки с какой целью отсутствует GPLv3?

    LGPLv3 полностью совместима с GPLv3. Ты можешь скомпоновать код Qt с кодом под GPLv3.

     
  • 2.47, iPony (?), 10:11, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Потому что GPLv3 ни кому не нужна, кроме совсем экстремистских фанатиков.
     
     
  • 3.56, Andrey Mitrofanov (?), 11:30, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Потому что GPLv3 ни кому не нужна, кроме совсем экстремистских фанатиков.

    Прочитай уже наконец лицензию, о которой бредишь. Обе.  Пять раз на ночь.

     
     
  • 4.66, iPony (?), 13:00, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Всё уже прочитано за нас http://go2.pt/-yVFYc
     

  • 1.17, Аноним (-), 23:51, 13/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –11 +/
    А ещё кто-то пишет десктопные приложения?
     
     
  • 2.18, Michael Shigorin (ok), 23:54, 13/01/2016 [^] [^^] [^^^] [ответить]  
  • +10 +/
    > А ещё кто-то пишет десктопные приложения?

    Надо ж кому-то работать, а не тыкать немытым пальцОм в три дюймы.

     
     
  • 3.19, Аноним (-), 00:09, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Это был намёк на веб.
     
     
  • 4.20, Michael Shigorin (ok), 00:11, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Это был намёк на веб.

    И что с ним делать в офлайне прикажете?

     
     
  • 5.21, A.Stahl (ok), 00:14, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Дисковод не выбросили? Вот смахнёте пыль с дискетки с интернетом и всё будет хорошо.
     
     
  • 6.61, Michael Shigorin (ok), 12:40, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Дисковод не выбросили? Вот смахнёте пыль с дискетки с интернетом

    Вы вот ёрничаете, а я вчера смахивал пыль с DVD-привода (вечером) и, отвечая человеку на вопрос о том, как изучал линукс, упомянул флоппинет не то что интернетов -- fido7.ru.linux, причём over FTN@приятель (днём)...

     
  • 5.22, Аноним (-), 00:22, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Отдыхать.
     
  • 5.87, _KUL (ok), 06:32, 15/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Сейчас веб-интерфейс для локальных демонов не редкость. Очень удобно, с любого браузера, с любого устройства, просто html отдал юзеру/боту по tcp и готово.
     
     
  • 6.90, Аноним (-), 17:04, 15/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Тот же CUPS так делает годами.
     
  • 4.45, Аноним (-), 09:35, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Один IBM-овский "суперсервер" дороже условно бесплатных(нужны и под другие задачи) 1000-пк. в конторе
     
  • 4.62, Аноним (-), 12:53, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    А вы ваш веб в консоли смотрите? Да и кому нахрен нужен веб при наличии десктопных аналогов приложений.
     
     
  • 5.70, Чаёвник (?), 13:15, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Зато веб-приложения умеют тормозить, терять данные, глючить и расползаться сразу везде, без перекомпиляции и инсталла =)
     
  • 2.24, Crazy Alex (ok), 00:34, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Вон, Scribus  в соседней новости.
     
  • 2.26, rob pike (?), 02:50, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    И не только на Qt.
    http://x3270.bgp.nu/
     
     
  • 3.58, Andrey Mitrofanov (?), 11:52, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > И не только на Qt.

    ..."also runs natively on Windows."   Сочувствуем Вашей озабоченности!

     
     
  • 4.80, . (?), 18:59, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ну взрослый же дядя уже, а всё ... :)

    Если народ озаботился мультиплатформенностью, и мало того - ослил еЯ, то им только респект и уважуха, это сразу показывает уровень недоступный шкоLOLте не за какие коврижки!

    Это я не тебе объясняю, ты то и так знаешь, это я тем кого ещё можно спасти :)

     

  • 1.27, Аноним (-), 03:08, 14/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    Особого смысла нет, ведь когда Столлман дойдёт до ответов на вопросы, которые мучили человечество многие тысячелетия и сотворит новую версию GPL, окажется, что GPL версии 3 содержала далеко не все необходимые и реальные свободы, да вообще больше похожа на лепет ребёнка.

    Но через эту стадию GNU и GPL всё равно обязательно придётся пройти на пути своего идеологического взросления.

    А позже, в течение десяти лет после ухода Столлмана, всё станет ещё сложнее и в целом даже хуже, это течение расколется на 2 крупных противоборствующих лагеря и ещё n-е количество мелких "богoмерзких" "сект".

    Победит сильнейший, в нашем случае - подлейший.

     
     
  • 2.29, Аноним (-), 03:30, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Прежде всего, борьба поколений Первое течение Консерваторы, которые чтут свой ... текст свёрнут, показать
     
     
  • 3.30, Аноним (-), 03:57, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Всегда было смешно видеть как люди пытаются подкрепить свою точку зрения  надуманными аргументами. Придумал сферического коня в вакууме, молодец. А программисты из реального мира выбирают MIT. А GPL3 нужна только для того что бы конкуренты не смогли сделать закрытый продукт, превосходящий во всем открытый аналог. Но исторических примеров таких ходов я не припомню.
     
     
  • 4.31, Аноним (-), 04:17, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Вы видимо имели ввиду BSD, а не MIT.

    С таким же успехом можно использовать Public Domain, можно сказать, что они обе являются её испорченным, усложнённым и менее удобным вариантом по своей сути, хотя юридически это не так.

    Адекватные программисты подбирают лицензию не по названию и не потому что им Firefox нравится, программисты выбирают конкретную лицензию для конкретных целей и для конкретного проекта или его части.


    И тут нет никакого коня, голая логика, статистика и здравый смысл.

     
  • 4.57, Andrey Mitrofanov (?), 11:48, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Всегда было смешно видеть как люди пытаются подкрепить свою точку зрения  
    > надуманными аргументами.

    И сам же и продолжил:

    >А программисты из реального мира выбирают

    Смех был настолько заразителен?

    > А GPL3 нужна только для того
    > что бы конкуренты не смогли сделать закрытый продукт, превосходящий во всем

    Во-первых, не только -- читать Столмана. Во-второых, я практически уверен, что и под проданной конкурентам "правильной" проприертарной лицензией они им, конкурентам, тоже ничего такого не разрешают. С использованием лицензированного же, да, если речь почему-то про GPLv3? То же относится и к GPLv2. Вас Стив укусил или Линус? -- GPLv3 пугает весьма отдельно, но  необъяснимо.  В-третьих,  конкуренты _вольны_ сделать конкурирующий СПО-продукт под GPL/LGPL. Но, пожалуй да, не смогут -- жаба, слабость в коленках и пр.  А не, не то, Вы ж о проблемах конкурирования проприертарщиков?    omfg....

    > открытый аналог. Но исторических примеров таких ходов я не припомню.

     
     
  • 5.73, Аноним (-), 13:58, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Я представляю какая у тебя каша в голове если ты так свои мысли излагаешь. Я даже дискутировать не буду, это без толку.
     
  • 3.63, Michael Shigorin (ok), 12:54, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Прежде всего, борьба поколений.

    Вы перепутали "отцов и детей" со свободной волей и рассудком (вспомните Иосифа Аримафейского, ап. Павла; ну и тот синедрион знал, [I]что[/I] делает).  Есть и другие логические и фактические ошибки, но предложенный аргумент неверен ни "изнутри", ни применительно к обсуждаемому.

    И сразу по #30: неверность аргумента из #29 не делает верным Ваш; своему склерозу можете сходу напомнить про какой-нить NetApp (если бы не неверная посылка про MIT License, которая появилась вообще ситуативно -- может, сами бы и сообразили).

     
  • 3.93, Аноним (-), 08:04, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • +1 +/
    опять хомячье с двоичным мышлением…
    компьютеры виноваты что ли?
     
  • 2.36, Какаянахренразница (ok), 06:10, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +3 +/
    > Столлман дойдёт до ответов на вопросы, которые мучили человечество
    > многие тысячелетия и сотворит новую версию GPL

    GPLv42

     
  • 2.84, Вареник (?), 21:42, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    > Особого смысла нет, ведь когда Столлман дойдёт до ответов на вопросы, которые
    > мучили человечество многие тысячелетия и сотворит новую версию GPL, окажется, что
    > GPL версии 3 содержала далеко не все необходимые и реальные свободы,
    > да вообще больше похожа на лепет ребёнка.
    > Но через эту стадию GNU и GPL всё равно обязательно придётся пройти
    > на пути своего идеологического взросления.
    > А позже, в течение десяти лет после ухода Столлмана, всё станет ещё
    > сложнее и в целом даже хуже, это течение расколется на 2
    > крупных противоборствующих лагеря и ещё n-е количество мелких "богoмерзких" "сект".
    > Победит сильнейший, в нашем случае - подлейший.

    И будет великая война киборгов за победу самой истинно верной лицензии прошивки.

     

  • 1.41, anonymous (??), 08:20, 14/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Посмотрел тут на совместимость между лицензиями: http://www.gnu.org/licenses/gpl-faq.html#AllCompatibility

    Получается, что если у меня программа "только GPLv2", то применять библиотеку под LGPLv3 нельзя. А если закрытый блоб, то можно. Что курили составители этой таблицы?

     
     
  • 2.42, IMHO (?), 08:32, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    это и есть свобода
     
     
  • 3.75, Аноним (-), 14:02, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Ага, а еще свобода когда пишешь на форуме, а твой коммент удаляют.
     
     
  • 4.81, . (?), 19:10, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Я вот иногда даже не трезвый сюда пишу :) А удалили только те __немногие__ сообщения где я по расслабленности "дал волю и излил" так сказать :)
    И ничё - мир не перевернулся, да и я не в претензии.

    Подумай над тем что у тебя внутри (и что ты сюда изливаешь) - если это постоянно вытирают ... может твою проблему лучше всего видно в зеркало?

     
  • 2.46, Аноним (-), 09:36, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Это попил огромного количества зелёноденег на игре словами и докапывании к мелочам, нахождение дырок в законах, текст которых в принципе не может быть идеальным и без ошибок. А ещё многие думают, что закон - это нечто важное и значимое, когда это лишь попытка описания словами и в удобном виде кому то урезанных свобод, которые вам подарило государство - законодательный монополист, да ещё часто и проплаченная некоторыми заинтересованными элитарными кругами, чтобы их карманы отвисали ещё больше.
     
  • 2.49, Аноним (-), 10:36, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    Если ты пишешь программу сам, и имеешь право выбирать её лицензию, то использовать библиотеку под LGPLv3 можно. Неважно, блоб это, или GPL2, или ещё что. Просто допиши к лицензии разрешение на использование этой библиотеки, и всё. Если же программа чужая, то тебе придётся учитывать не только условия распространения библиотеки, но и программы. Да, к чужой GPL2-программе LGPL3-библиотеку не привяжешь. Но и к чужому блобу тем более.
     
     
  • 3.94, anonymous (??), 12:16, 16/01/2016 [^] [^^] [^^^] [ответить]  
  • –1 +/
    Что значит "чужая" программа? Ты GPL вообще читал?
     
  • 2.59, Andrey Mitrofanov (?), 11:56, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Получается, что если у меня программа "только GPLv2", то применять библиотеку под
    > LGPLv3 нельзя. А если закрытый блоб, то можно. Что курили составители
    > этой таблицы?

    Курили применятели GPLv2-ровно-и-только (Линус, да, в их числе), а не составвители какие-то.  Нарушение инструкции по эксплуатации же.  Что ещё Вас удивляет? Поделитесь с нами.

     
     
  • 3.67, Аноним (-), 13:02, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Курили применятели GPLv2-ровно-и-только (Линус, да, в их числе), а не составвители какие-то.

    Я бы сказал, курят как раз те, которые лицензируют код под еще несуществующей лицензией.

     
     
  • 4.71, Andrey Mitrofanov (?), 13:33, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> Курили применятели GPLv2-ровно-и-только (Линус, да, в их числе), а не составвители какие-то.
    > Я бы сказал, курят как раз те, которые лицензируют код под еще
    > несуществующей лицензией.

    Digia, или то был Qt proj? или кто?, решил эту проблему: гарантия релиза кода под MIT "в случае если $кое-где-порой". И текушие релизы под GPLvM=. (И пере-релиз под v$(++M) во время жатвы).   //Я ещё раз спрошу: юристы в зале есть? Оно, "гарантия" [см.wikipwdia~], ещё актуальна? И кто отец нынче?

     
  • 4.72, Andrey Mitrofanov (?), 13:43, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >> Курили применятели GPLv2-ровно-и-только (Линус, да, в их числе), а не составвители какие-то.

    Ладно, хоть составителей "галочек" оправдали.

    *>> Нарушение инструкции по эксплуатации же.  

    > Я бы сказал, курят как раз те, которые лицензируют код под еще
    > несуществующей лицензией.

    Вкус фломастеров. Зависит, от Т.З.  В частности от того, кого обвинитель в "курении" противной стороны, _сам_ эксплуатирует.  Или ближе к телу, в случае форумных бездельников, т.е. нас с Вами, к какому из двух(ч/б же да!) эксплуатирующих лагерей оный бездельник заявляет само-идентификацию.  Столман-Торвальдс-то такого бреда, как выше, не писали.  Форумные кидания необоснованными субъективными оценочными суждениями. === Полное отсутствие предмета.

     
  • 2.95, Аноним (-), 16:57, 17/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    >Получается, что если у меня программа "только GPLv2", то применять библиотеку под LGPLv3 нельзя. А если закрытый блоб, то можно. Что курили составители этой таблицы?

    Это лицензия GPLv2 не позволит линковаться с библиотекой под LGPLv3. Но если ты владеешь правами на весь код программы под GPLv2, то можешь написать исключение, позволяющее это сделать.

     

  • 1.69, Чаёвник (?), 13:13, 14/01/2016 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    > QML Profiler
    > Clang static analyzer
    > Qt Test Integration

    Вот где был весь этот торт раньше? /* плакать кровавыми слезами от безысходности */

     
     
  • 2.82, BlackRaven86 (ok), 20:02, 14/01/2016 [^] [^^] [^^^] [ответить]  
  • +/
    В коммерческой версии.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    MIRhosting
    Inferno Solutions
    Hosting by Ihor
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2019 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру